Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику mut ::: Спасибо сказали: 26 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
11.11.19, 16:22 Создание счета на сайте, средставми 1С
По идее всё возможно. Сервер на котором крутится сайт должен сформировать и отправить запрос, правильнее POST-запрос, со всеми нужными параметрами в 1С. Соответственно в 1С должен быть сконфигурирован хттп-сервис, который сделает всё остальное. При выполнении запроса сервер авторизуется в 1С, ну и т.к. это всё на стороне сервера, то вполне безопасно, покупатель который жмет кнопку никаких паролей не увидит и что там будет происходить не узнает.
awp,
03.10.19, 17:02 Как изменить дату на месяц? 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 17:53 * ,

Если сейчас у нас дата в переменной ТекДата, то гарантированно попасть на конец следующего месяца можно так:

СледующаяДата = КонМесяца(КонМесяца(ТекДата)+1);
ZUBR,
18.09.19, 12:26 Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 0:28 * ,

Представь результат выборки запроса в виде таблицы, потом эту таблицу свернули по полям, указанным в Группировка а по формулам Функция вычислили значения для этих группировок. Потом оператором Запрос.Группировка() мы перемещаемся по значениям группировок.
"Без Групп" работает для значений типа "Справочник", исключает из выборки элементы - группы, потому как по умолчанию если группировка делается по справочнику, то система собирает в выборку все элементы с иерархией и вычисляет функции и для групп, т.е. при переборе Запрос.Группировка() будем получать группу, элемент и т.д. Если нам группы не нужны, пишем "Без групп".
ZUBR,
16.09.19, 11:07 В чем ошибка условия? 1С 7.70.003 торговля склад для Украины?
Подсчет делается внутри перебора элементов справочника, нет смысла писать сотрудника в таблицу и потом сравнивать с таблицей.
Нужно сделать выборку накладных по текущему элементу справочника, потом добавить все в строку таблицы.

Спр.ВыбратьЭлементы();
      Пока Спр.ПолучитьЭлемент()=1 Цикл
            
          К = 0;
           Расх.ВыбратьДокументы(НачДата,КонДата);
          
      Пока Расх.ПолучитьДокумент()=1 Цикл
          
          Если Спр.ТекущийЭлемент() = Расх.Инженер Тогда
                К=К+1;
              КонецЕсли;
              
            КонецЦикла;

         ТЗ.НоваяСтрока();
          ТЗ.Сотрудник = Спр.Наименование;
      ТЗ.КолСис = К;

    КонецЦикла;
ZUBR,
02.09.19, 20:03 Как создать отчет с суммой по отдельной позиции табличной части расходных накладных в 1С 7.70.003 торговля склад для Украины
Цитата(ZUBR @ 02.09.19, 19:55) *
Если подскажете пример запроса


ТекстЗапроса = 
    "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |Товар = Документ.РасходнаяНакладная.Товар;
    |СуммаСНДС = Документ.РасходнаяНакладная.СуммаСНДС;
    |Функция Сум = Сумма(СуммаСНДС);
    |Группировка Товар Без Групп;
    |Условие (Товар = НужныйТовар);";
    Запрос.Выполнить(ТекстЗапроса);
    Пока Запрос.Группировка(1) = 1 Цикл
        СуммаУслуг = Запрос.Сум;
    КонецЦикла;


ваши параметры - НачДата, КонДата, НужныйТовар (это элемент справочника, услуга, по которой нужно отобрать)

результат в переменной СуммаУслуг
ZUBR,
02.09.19, 10:43 Не подсвечивается цветом ТЗ в 1С 7.70.003 торговля склад для Украины?
Цитата(ZUBR @ 31.08.19, 22:13) *
раскрашивать цветом строки этой таблицы.

раскрашивать табличный документ нельзя
нужно в макете табличного документа сделать несколько секций, с одинаковым содержимым, но раскрашенные в разные цвета и при построении таблицы выводить нужные секции (с нужной раскраской)
ZUBR,
02.09.19, 10:39 Как создать отчет с суммой по отдельной позиции табличной части расходных накладных в 1С 7.70.003 торговля склад для Украины
Конечно запросом, что тут думать?! Запрос по документам за период с отбором по номенклатуре, отбор нужно делать по элементу справочника, а не по названию. Если покажете структуру документа, могу подсказать пример запроса smile.gif
ZUBR,
07.08.19, 13:06 Загрузка курсов валют НБУ для 1с 8
Цитата(Lyti @ 06.08.19, 16:55) *
Нажаль, доступа до модуля обробки немає

Доречі, отримати курси з сайта НБУ дуже просто, якщо трохи програмуєте в 1С, то зробіть самі smile.gif
Все що потрібно - зробити запит на адресу https://bank.gov.ua/NBUStatService/v1/statd...190807&json
Замість 20190807 вставляємо потрібну дату. У відповідь приходить JSON з масивом даних по валютах. Залишається тільки перебрати масив з отбором по нужних валютах.

Все просто smile.gif
Badger1C,
04.08.19, 22:13 Не подсвечивается цветом ТЗ в 1С 7.70.003 торговля склад для Украины?
Колонка Цвет должна быть первой слева и можно сделать ее невидимой. Раскраска работает слева направо начиная от столбца со служебной строкой.
ZUBR,
30.07.19, 20:41 Как сохранить текущее значение переменной в 1С 7.70.003 торговля склад для Украины?
1Cv77 @ Сегодня, 21:18 * ,
Цитата(1Cv77 @ 30.07.19, 21:18) *
Хотя, можно, без объявления константы, просто, в процедуре ВводНового() прописать


а если кто-то сохранит последний акт в предыдущем месяце? smile.gif

если так то нужно перебирать все документы в периоде нумерации и искать максимальный номер
ZUBR,
15.07.19, 11:54 Как создать таблицу значений. Пример. 1с 7.7 конф 7.7.003
Судя по описанию нужен Справочник. Реквизиты справочника (поля таблицы) могут ссылаться на другие справочники. Нужно изучить доку про объект метаданных "Справочник"
ZUBR,
14.06.19, 9:36 Переход с 7.7 на 8
Цитата(Filin2991 @ 13.06.19, 15:41) *
Фактически нужно разработать с нуля с дальнейшей технической поддержкой. Идеальный вариант-если вы сотрудничаете (или в штате) с компаний-разработчиком интернет-магазинов.

Да, если у вас конфигурация модифицированная, то придется делать практически с нуля. С моей стороны возможна только часть в 1С, с разработкой сайта не помогу.
Filin2991,
16.05.19, 9:24 Будет ли отличаться работа 1С на Exppress от работы на полной SQL?
NAGor4ik @ Вчера, 12:53 * ,
Если база 1-3 Гб, обычный комп в качестве сервера, то экспресс вполне подойдет
NAGor4ik,
24.04.19, 17:57 Сохранить реквизит на форме в обход запрета изменения данных
Constantus @ Сегодня, 13:45 * ,
Лучше всего эти статусы записывать в отдельном регистре сведений на который права не будут ограничены, а для редактирования прикрутить отдельную форму, открывать отдельной командой, отображать в списке документов и на форме.
awp, Егор Динин,
26.03.19, 19:44 Получение данных с сайта POST запросом API из 1с7.7
programm.ist @ Сегодня, 15:01 * ,
Например простой заменой, вот список символов (код из восьмерки, так что для 77 нужно переделать, но смысл понятен)
    СписокСимволов = Новый СписокЗначений;
    СписокСимволов.Добавить("\u0430", "а");
    СписокСимволов.Добавить("\u0431", "б");
    СписокСимволов.Добавить("\u0432", "в");
    СписокСимволов.Добавить("\u0433", "г");
    СписокСимволов.Добавить("\u0434", "д");
    СписокСимволов.Добавить("\u0435", "е");
    СписокСимволов.Добавить("\u0451", "ё");
    СписокСимволов.Добавить("\u0436", "ж");
    СписокСимволов.Добавить("\u0437", "з");
    СписокСимволов.Добавить("\u0438", "и");
    СписокСимволов.Добавить("\u0439", "й");
    СписокСимволов.Добавить("\u043a", "к");
    СписокСимволов.Добавить("\u043b", "л");
    СписокСимволов.Добавить("\u043c", "м");
    СписокСимволов.Добавить("\u043d", "н");
    СписокСимволов.Добавить("\u043e", "о");
    СписокСимволов.Добавить("\u043f", "п");
    СписокСимволов.Добавить("\u0440", "р");
    СписокСимволов.Добавить("\u0441", "с");
    СписокСимволов.Добавить("\u0442", "т");
    СписокСимволов.Добавить("\u0443", "у");
    СписокСимволов.Добавить("\u0444", "ф");
    СписокСимволов.Добавить("\u0445", "х");
    СписокСимволов.Добавить("\u0446", "ц");
    СписокСимволов.Добавить("\u0447", "ч");
    СписокСимволов.Добавить("\u0448", "ш");
    СписокСимволов.Добавить("\u0448", "щ");
    СписокСимволов.Добавить("\u044a", "ъ");
    СписокСимволов.Добавить("\u044b", "ы");
    СписокСимволов.Добавить("\u044c", "ь");
    СписокСимволов.Добавить("\u044d", "э");
    СписокСимволов.Добавить("\u044e", "ю");
    СписокСимволов.Добавить("\u044f", "я");
    
    СписокСимволов.Добавить("\u0410", "А");
    СписокСимволов.Добавить("\u0411", "Б");
    СписокСимволов.Добавить("\u0412", "В");
    СписокСимволов.Добавить("\u0413", "Г");
    СписокСимволов.Добавить("\u0414", "Д");
    СписокСимволов.Добавить("\u0415", "Е");
    СписокСимволов.Добавить("\u0401", "Ё");
    СписокСимволов.Добавить("\u0416", "Ж");
    СписокСимволов.Добавить("\u0417", "З");
    СписокСимволов.Добавить("\u0418", "И");
    СписокСимволов.Добавить("\u0419", "Й");
    СписокСимволов.Добавить("\u041a", "К");
    СписокСимволов.Добавить("\u041b", "Л");
    СписокСимволов.Добавить("\u041c", "М");
    СписокСимволов.Добавить("\u041d", "Н");
    СписокСимволов.Добавить("\u041e", "О");
    СписокСимволов.Добавить("\u041f", "П");
    СписокСимволов.Добавить("\u0420", "Р");
    СписокСимволов.Добавить("\u0421", "С");
    СписокСимволов.Добавить("\u0422", "Т");
    СписокСимволов.Добавить("\u0423", "У");
    СписокСимволов.Добавить("\u0424", "Ф");
    СписокСимволов.Добавить("\u0425", "Х");
    СписокСимволов.Добавить("\u0426", "Ц");
    СписокСимволов.Добавить("\u0427", "Ч");
    СписокСимволов.Добавить("\u0428", "Ш");
    СписокСимволов.Добавить("\u0428", "Щ");
    СписокСимволов.Добавить("\u042a", "Ъ");
    СписокСимволов.Добавить("\u042b", "Ы");
    СписокСимволов.Добавить("\u042c", "Ь");
    СписокСимволов.Добавить("\u042d", "Э");
    СписокСимволов.Добавить("\u042e", "Ю");
    СписокСимволов.Добавить("\u042f", "Я");
programm.ist,
17.03.19, 22:54 Добавить и получить настройку пользователя
Цитата(avel1976 @ 15.03.19, 19:43) *
НастройкаСсылка = ПланыВидовХарактеристик.НастройкиПользователей[Настройка];

Этот кусок кода говорит о том, что поиск производится по имени предопределенных данных а не по наименованию настройки. Надо добавить в предопределенные данные.
avel1976,
12.03.19, 20:46 Мобильное приложение для работы с базой 1С - "Помощник"
Цитата(Vofka @ 11.03.19, 21:09) *
Я не пойму как это приложение может отобразить и организовать ввод произвольного документа?

Вводится не произвольный документ, а предусмотреный в сервисе, в 1С. Приложению сообщается перечень доступных видов документов. В приложении можно открыть список например Приходных накладных, добавить новый - откроется экран где можно добавлять товары из справочника товаров. Потом даем команду сохранить. Как-то так.

Цитата(Alegzander @ 12.03.19, 13:26) *
Интересно посмотреть реализацию самого сервиса. Можно пример конфигураци?

Конфигурация урезанная, но часть с сервисами на месте, смотреть HTTPСервисы - RemoteConnector: link
Alegzander,
19.10.18, 19:57 Прикручиваем магнитный ридер к 1С
Прикручиваю ридеры через старый АТОЛ-овский драйвер, который бесплатный. Там всё как со сканером штрихкода, только название источника другое. Думаю и этот будет работать.
SeverinPasha,
25.08.18, 13:22 Запускалка для 1С
Небольшая программка делает одну оеперацию - стартует сеанс и вызывает процедуру из глобального модуля.
Была написана для избавления от проблем при запуске по расписанию из командной строки. Например - не может стартануть т.к. нужно переиндексировать файлы, соответственно висит окно и ждет нажатия кнопки ОК.
В этой программе при любых ошибках исполнения происходит выход из сеанса 1С и корректное завершение самой программы.
Использую для запуска заданий по расписанию на терминальных серверах.

Программа на Java, т.е. на компьютере должна стоять JRE.

[attachment=1108:mobilefiles.zip]

Цитата
Комплект поставки:
mobilefiles.jar
mobilefiles.cmd
jawin.jar
jawin.dll
mobilefiles.settings
mobilefiles.errors

Установка:
Проверить/установить Java. Тестировалось на jre_8_181.
Все файлы скопировать в одну директорию.
Файл jawin.dll скопировать в подкаталог bin каталога установки jre.
В файле mobilefiles.settings прописать параметры запуска 1С: путь к базе, имя и пароль пользователя.

Запуск программы:

[JAVA_PATH]java -jar [M_PATH]mobilefiles.jar

JAVA_PATH - путь установки jre, если он не прописан в системной PATH
M_PATH - путь к файлу mobilefiles.jar

При запуске, программа пытается создать ОЛЕ объект V77.Application и запускает его с параметрами, прописанными в файле mobilefiles.settings, ключ "path".
Если запуск успешен, вызывается процедура глобального модуля MobileFiles().
В случае возникновения ошибок лог записывается в файл mobilefiles.errors.
Gleef,
23.08.18, 12:44 VBA + V77.Application: Ошибка при доступе к справочнику
AntAlex @ Сегодня, 11:49 * ,

Не знаю точно, но вроде создавать объекты надо примерно так:
Set Товар = trade.EvalExpr("CreateObject(""Справочник.Товары"")")


Попробуйте wink.gif


 ! 

Правила: 1
 
AntAlex,
15.08.18, 18:31 Доступ к базе через Http сервис
Цитата(Sonador @ 15.08.18, 8:48) *
Можете поделиться опытом (инструкцией) как собрать такое чудо?


Как-то вот так, написал тут:
ссылка
Alegzander, Sonador,
15.08.18, 12:04 Проблема обработки пустого значения типа Дата (1с 8.2.19.106)
andrew76 @ Сегодня, 12:21 * ,
Процедура сработает если поле изменится. Т.е. когда туда ничего не вводят, то и процедура не вызывается. По феньшую надо проверку ставить в модуль, в ОбработкаПроверкиЗаполнения()
andrew76,
15.08.18, 7:21 Получение бухгалтерских итогов
chel_iz_naroda @ Сегодня, 7:52 * ,
C помощью метода ИспользоватьСубконто, перед вызовом запроса, например:

Ит.ИспользоватьСубконто(ВидыСубконто.ВидыЗатрат,ВыбСтатьяЗатрат,1,1);
chel_iz_naroda,
07.02.17, 10:14 пароль на конфу снял, автор и текст заставки запаролены все равно
altaykniga @ Сегодня, 9:25 * ,
как это - сайт написан а связаться нет возможности?! smile.gif
напишите на support(a)programmer.com.ua, пришлю пароль
zanna1967,

RSS Текстовая версия Сейчас: 11.12.19, 13:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!