Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



474 страниц V   1 2 3 > » 

>  ВебЧек:ПРРО Программный регистратор расчетных операций
Vofka
Отправлено: Вчера, 8:54


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Цитата(sergoff @ 27.09.20, 13:33) *
В У.Т 3.2 слишком устаревший механизм работы с торговым оборудованием

sergoff, 3.2 это самая новая wink.gif
  Форум: 1С:Предприятие 8 · Просмотр сообщения: #166835 · Ответов: 5 · Просмотров: 2271
 

>  Объединение виртуальных таблиц.
Vofka
Отправлено: 25.09.20, 9:12


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Цитата(Bon Jovi @ 25.09.20, 10:09) *
И о таком методе как вы предложили я знаю, не подходит

В смысле не подходит? Код выше обхъдиняет временные таблицы.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166767 · Ответов: 4 · Просмотров: 110
 

>  Сроки окончания поддержки УТП и обязательный переход на КУП
Vofka
Отправлено: 24.09.20, 11:17


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Salex, у меня под рукой этого нету, так что посмотреть сейчас не могу. Я видел реаально индусский код в 1С, даже работал с таким долго (причем писали его не индусы, а наши соотечественники; на украинском языке, кстати), но мне не верится, что в типовой код выглядит так. Или вы имеете ввиду, что дело не в оформлении кода, а что его понять сложно? Если так, то это, возможно, беда с теми людьми, которые ставят задачи. Как сказали, так и пишут. 44000000.gif
  Форум: BAS Комплексное управление предприятием · Просмотр сообщения: #166727 · Ответов: 9 · Просмотров: 224
 

>  Сроки окончания поддержки УТП и обязательный переход на КУП
Vofka
Отправлено: 23.09.20, 8:34


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Цитата(Salex @ 22.09.20, 20:06) *
у вендора спецы как раз по 7.7 и 8.2 поэтому такие проблемы с качеством кода в ERP/КУП

А что не так с качеством кода там?
  Форум: BAS Комплексное управление предприятием · Просмотр сообщения: #166692 · Ответов: 9 · Просмотров: 224
 

>  Получить признак отказа при проведении документа
Vofka
Отправлено: 21.09.20, 15:35


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Обернуть в Попытку строку

ПеремещениеТМЦ.Записать(РежимЗаписиДокумента.Проведение);


Попытка
   ПеремещениеТМЦ.Записать(РежимЗаписиДокумента.Проведение);
Исключение
   Возврат;
КонецПопытки;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166630 · Ответов: 2 · Просмотров: 76
 

>  Как можно при отключённом NumLock вызвать форму которая показала что его надо включить обратно?
Vofka
Отправлено: 19.09.20, 18:13


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Средствами 1С вряд ли.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166584 · Ответов: 2 · Просмотров: 145
 

>  Запись элементов справочника через СериализаторXDTO в формат json
Vofka
Отправлено: 16.09.20, 13:08


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


ЗаписьJSON.ОткрытьФайл("E:\Odecom\test.json, , , ПараметрыJSON");

Это как?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166482 · Ответов: 2 · Просмотров: 128
 

>  Нужен список всех городов России с почтовыми индексами
Vofka
Отправлено: 11.09.20, 9:00


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Вот, например
Город Почтовый индекс
Абакан (Республика Хакасия) 655017
Апрелевка (Московская область) 143362
Адлер (Краснодарский край) 354340
Александров (Владимирская область) 601657
Алексин (Тульская область) 301360
Альметьевск (Республика Татарстан) 423450
Анапа (Краснодарский край) 353440
Армавир (Краснодарский край) 352900
Архангельск (Архангельская область) 163000
Асбест (Свердловская область) 624260
Астрахань (Астраханская область) 414000
Балабаново (Калужская область) 249000
Балаково (Саратовская область) 413840
Балашиха(Московская область) 143900
Барнаул (Алтайский край) 656000
Белгород (Белгородская область) 308000
Бийск (Алтайский край) 659300
Бронницы(Московская область) 140170
Братск (Иркутская область) 665700
Брянск (Брянская область) 241000
Буденновск (Ставропольский край) 356800
Бузулук (Оренбургская область) 461040
Великие Луки (Псковская область) 182100
Верея (Московская область) 140153
Великий Новгород (Новгородская область) 173000
Владикавказ (Респ. Северная Осетия-Алания) 362000
Владимир (Владимирская область) 600000
Волгоград (Волгоградская область) 400000
Волгодонск (Ростовская область) 347340
Высоковск (Московская область) 141650
Воскресенск (Московская область) 140200
Волоколамск(Московская область) 143600
Видное (Московская область) 142700
Волжск (Республика Марий Эл) 425000
Волжский (Волгоградская область) 404100
Вологда (Вологодская область) 160000
Воронеж (Воронежская область) 394000
Воткинск (Удмуртская Республика) 427430
Вышний Волочек (Тверская Область) 171151
Выборг (Ленинградская область) 188800
Вязьма (Смоленская область) 215100
Глазов (Удмуртская Республика) 427620
Голицыно (Московская область) 143040
Горно-Алтайск (Республика Алтай) 649000
Грозный (Чеченская республика) 364000
Гусь Хрустальный (Владимирская область) 601501
Гороховец (Владимирская область) 601480
Губкин (Белгородская область) 309180
Дзержинск (Нижегородская область) 606000
Дзержинский (Московская область) 140090
Дмитров (Московская область) 141800
Долгопрудный (Московская область) 141707
Дубна (Московская область) 141980
Домодедово (Московская область) 142000
Дрезна (Московская область) 142660
Димитровград (Ульяновская область) 433500
Дедовск (Московская область) 143530
Дятьково (Брянская область) 242600
Ейск (Краснодарский край) 353680
Екатеринбург (Свердловская область) 620109
Егорьевск (Московская область) 140300
Елабуга (Республика татарстан) 423600
Елец (Липецкая область) 399770
Емва (Республика Коми) 169200
Ессентуки (Ставропольский край) 357601
Ефремов (Тульская область) 301840
Железнодорожный (Московская область) 143980
Жуковский (Московская область) 140180
Железногорск (Красноярский край) 662970
Железногорск (Курская область) 307170
Железноводск (Ставропольский край) 357400
Жешарт (Республика Коми) 169044
Жигулевск (Самарская область) 445350
Жирновск (Волгоградская область) 403790
Зарайск (Московская область) 140600
Зеленоград (Московская область) 124460
Звенигород (Московская область) 143180
Заволжье (Нижегородская область) 606520
Заинск (Республика Татарстан) 423520
Заринск (Алтайский край) 659100
Зеленодольск (Республика Татарстан) 422540
Златоуст (Челябинская область) 456200
Ивантеевка (Московская область) 141280
Истра (Московская область) 143500
Иваново (Ивановская область) 153000
Ижевск (Удмуртская Республика) 426000
Илек (Оренбургская область) 461350
Ирбит (Свердловская область) 623856
Иркутск (Иркутская область) 644000
Ишим (Тюменская область) 627750
Кашира (Московская область) 142900
Климовск (Московская область) 142180
Клин (Московская область) 141601
Коломна (Московская область) 140400
Королев (Московская область) 141070
Котельники (Московская область) 140053
Красноармейск (Московская область) 141292
Красногорск (Московская область) 143400
Краснозаводск (Московская область) 141321
Куровское (Московская область) 142621
Казань (Республика Татарстан) 420000
Калуга (Калужская область) 248000
Кемерово (Кемеровская область) 650000
Кириши (Ленинградская область) 187110
Киров (Кировская область) 610000
Кострома (Костромская область) 156000
Краснодар (Краснодарский край) 350000
Красноярск (Красноярский край) 660000
Курган (Курганская область) 640000
Курск (Курская область) 305000
Ликино-Дулево(Московская область) 142670
Лосино-Петровский(Московская область) 141150
Луховицы (Московская область) 140500
Лыткарино (Московская область) 140080
Люберцы (Московская область) 140000
Лобня (Московская область) 141730
Лабинск (Краснодарский край) 352500
Лебедянь (Липецкая область) 399610
Ливны (Орловская область) 303850
Липецк (Липецкая область) 398000
Лиски (Воронежская область) +397900
Лысьва (Пермская область) 618900
Можайск (Московская область) 143200
Московский (Московская область) 142784
Мытищи (Московская область) 141000
Магнитогорск (Челябинская область) 455000
Майкоп (Республика Адыгея) 385000
Махачкала (Республтка Дагестан) 367000
Минеральные Воды (Ставропольский край) 357200
Мураши (Кировская область) 613710
Мурманск (Мурманская область) 183038
Муром (Владимирская область) 602200
Наро-Фоминск (Московская область) 143301
Ногинск (Московская область) 142400
Набережные Челны (Республика Татарстан) 423800
Нальчик (Кабардино-Балкарская республика) 360000
Нефтекамск (Республика Башкортостан) 452680
Нефтеюганск (Ханты-Мансийский авт. округ) 628300
Невинномысск (Ставропольский край) 357100
Нижний Новгород (Нижегородская область) 603000
Нижневартовск (Ханты-Мансийский авт. округ) 628600
Нижнекамск (республтка Татарстан) 423570
Нижний Тагил (Свердловская область) 622000
Новороссийкс (Краснодарский край) 353900
Новосибирск (Новосибирская область) 630000
Новый Уренгой (Ямало-Ненецкий авт. Округ) 629300
Новый Оскол (Белгородская область) 309640
Новокузнецк (Кемеровская область) 654000
Новокуйбышевск (Самарская область) 446200
Новочеркасск (Ростовская область) 346400
Новочебоксарск (Чувашская республика) 4299950
Новотроицк (Оренбургская область) 462351
Новошахтинск (Ростовская область ) 346900
Ноябрьск (Ямало-Ненецкий авт. округ) 629800
Нягань (Ханты-Мансийский авт. округ) 628181
Орехово-Зуево (Московская область) 142600
Одинцово (Московская область) 143000
Ожерелье(Московская область) 142921
Озеры (Московская область) 140560
Омск (Омская область) 644000
Орел (Орловская область) 302000
Оренбург (Оренбургская область) 460000
Орск (Оренбургская область) 462400
Обнинск (Калужская область) 249030
Октябрьский (Республика Башкортостан) 452600
Озерск (Закрытый) 456780
Павловский Посад (Московская область) 142500
Павловская Слобода (Московская область) 143581
Пересвет (Московская область) 141320
Подольск (Московская область) 142100
Протвино (Московская область) 142280
Пушкино (Московская область) 141200
Пущино (Московская область) 142290
Пенза (Пензенская область) 440000
Первоуральск (Свердловская область) 623100
Пермь (Пермская область) 614000
Петрозаводск (Республика Карелия) 185000
Петушки (Владимирская область) 601144
Приморск (Ленинградская область) 188910
Прокопьевск (Кемеровская область) 653000
Псков (Псковская область) 180000
Пурпе (Ямало Ненецкий авт. округ) 629840
Пятигорск (Ставропольский край) 357500
Рошаль (Московская область) 140730
Раменское (Московская область) 140100
Реутов (Московская область) 143960
Руза(Московская область) 143100
Ржев (Тверская область) 172380
Рославль (Смоленская область) 216500
Россошь (Воронежская область) 396650
Ростов-на-Дону (Ростовская область) 344000
Рубцовск (Алтайский край) 658200
Рыбинск (Ярославская область) 152900
Рязань (Рязанская область) 3390000
Сергиев Посад (Московская область) 141300
Серпухов (Московская область) 142200
Солнечногорск (Московская область) 141501
Старая Купавна (Московская область) 142450
Ступино (Московская область) 142800
Салават (республика Башкортостан) 453250
Самара (Самарская область) 443000
Санкт-Петербург 190000
Саранск (Республика Мордовия) 430000
Сарапул (Удмуртская Республика) 427960
Саратов (Саратовская область) 410000
Серов (Свердловская область) 624000
Серпухов (Московская область) 142200
Смоленск (Смоленская область) 214000
Снежинск (Челябинская область) 456770
Сочи (Краснодарский край) 354000
Ставрополь (Ставропольский край) 355000
Старый Оскол (Белгородская область) 309500
Стерлитамак (Республика Башкортостан) 453100
Сургут (Ханты-Мансийский авт.округ) 628400
Суздаль (Владимирская область) 601293
Сызрань (Самарская область) 446000
Сыктывкар (Республика Коми) 167000
Талдом (Московская область) 141900
Троицк (Московская область) 457100
Таганрог (Ростовская область) 347900
Тамбов (Тамбовская область) 392000
Тверь (Тверская область) 170000
Тимашевск (Краснодарский край) 3527000
Тобольск (Тюменская область) 626150
Тольятти (Самарская область) 445000
Томск (Томская область) 634000
Троицк (Челябинская область) 457100
Тула (Тульская область) 300000
Туапсе (Краснодарский край) 352800
Тюмень (Тюменская область) 625000
Улан-Удэ (Республика Бурятия) 670000
Ульяновск (Ульяновская область) 432000
Уренгой (Ямало-Ненецкий авт. округ) 629860
Усть-Кут (Иркутская область) 666780
Уфа (Республика Башкортостан) 450000
Ухта (Республика Коми) 169300
Фрязино (Московская область) 141190
Фролово (Волгоградская область) 403530
Химки (Московская область) 141400
Хотьково (Московская оласть) 141371
Хабаровск (Хабаровский край) 680000
Ханты-Мансийск (Ханты-Мансийский авт. округ) 628000
Черноголовка (Московская оласть) 142432
Чехов (Московская оласть) 142300
Чагода (Вологодская область) 162401
Чебоксары (Чувашская Республика) 428000
Челябинск (Челябинская область) 454000
Череповец (Вологодская область) 162600
Черкесск (Карачаево-Черкесская Республика) 369000
Чита (Читинская область) 672000
Шатура(Московская область) 140700
Шахты (Ростовская область) 346500
Щелково (Московская область) 141101
Щербинка (Московская область) 142171
Электросталь (Московская область) 144000
Электрогорск (Московская область) 142530
Электроугли (Московская область) 142455
Энгельс (Саратовская область) 413100
Элиста (Республика Калмыкия) 358000
Юбилейный (Московская область) 141090
Юрга (Кемеровская область) 652050
Южноуральск (Челябинская область) 457040
Яхрома (Московская область) 141840
Ярославль (Ярославская область) 150000
Якутск (Республика Саха(Якутия)) 677000


ПС. Или это какой-то новый вид спама?
  Форум: Офф-топик · Просмотр сообщения: #166348 · Ответов: 1 · Просмотров: 126
 

>  Расширения для конфигураций серии BAS
Vofka
Отправлено: 07.09.20, 15:20


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


andreydv87, "Каталог разработок" - это свои платные разработки.
  Форум: 1С:Предприятие 8 · Просмотр сообщения: #166249 · Ответов: 9 · Просмотров: 298
 

>  Расширения для конфигураций серии BAS
Vofka
Отправлено: 04.09.20, 14:12


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


29a, вставляйте картинки, как указано тут https://pro1c.org.ua/index.php?act=announce...p;f=36&id=2 в пункте 8. В следующий раз просто удалю.
  Форум: 1С:Предприятие 8 · Просмотр сообщения: #166185 · Ответов: 9 · Просмотров: 298
 

>  POST запрос до серверу податкової
Vofka
Отправлено: 28.08.20, 14:18


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


volodya1122, вы бы сразу написали, что делаете конкретный запрос, получаете конкретный ответ. faceoff.gif
Я не проверял, но если верить тому, что написано в описании АПИ, то в вашем коде следующие ошибки:
1. Вы делаете GET запрос Ответ = Соединение.Получить(Запрос), надо POST;
2. kodPdvList и token вы вставляете в заголовок, хотя они должны быть в теле запрос в виде json;
3. Не уверен, но мне кажется, что токен должен быть не тот, который в примере указан, а свой.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165994 · Ответов: 6 · Просмотров: 298
 

>  POST запрос до серверу податкової
Vofka
Отправлено: 28.08.20, 9:18


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Вот, например https://pro1c.org.ua/topic/rabota-s-http-za...primerah-61211/
Если по этим примерам непонятно, гуглите 1с 8 http post запрос
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165988 · Ответов: 6 · Просмотров: 298
 

>  Работа с http-запросами (get и post) в языке 1С 8.3, 8.2 (в примерах)
Vofka
Отправлено: 28.08.20, 9:17


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


/// Как получить страницу сайта через http-запрос
/// из 1с 8.3, 8.2

&НаКлиенте
Процедура КакПолучитьСтраницуСайтаЧерезHttpЗапросНаКлиенте()

    // В сети есть сайт http://example.com
    // Запросим содержимое его главной страницы.

    // Подключаемся к сайту.
    Соединение = Новый HTTPСоединение(
        "example.com", // сервер (хост)
        80, // порт, по умолчанию для http используется 80, для https 443
        , // пользователь для доступа к серверу (если он есть)
        , // пароль для доступа к серверу (если он есть)
        , // здесь указывается прокси, если он есть
        , // таймаут в секундах, 0 или пусто - не устанавливать
          // защищенное соединение, если используется https
    );

    // Получаем текст корневой страницы через GET-запрос.
    Запрос = Новый HTTPЗапрос("/");
    // Если бы нужна была другая страница, мы бы указали,
    // например, "/about" или "/news".

    Результат = Соединение.Получить(Запрос);

    Сообщить("Нам вернули код: " + Результат.КодСостояния);
    // Что примерно означают коды результата запроса:
    // [100, 299] - хороший код возврата
    // [300, 399] - нас перенаправляют на другую страницу,
    //              причём 302 - код постоянного перенаправления
    // [400, 499] - ошибка запроса
    // [500, 599] - ошибка сервера

    // в теле результата запроса - текст обычной html страницы
    Сообщить("Тело результата: " + Результат.ПолучитьТелоКакСтроку());  

КонецПроцедуры

/// Как обработать перенаправление в http-запросе
/// из 1с 8.3, 8.2

&НаКлиенте
Процедура КакОбработатьПеренаправлениеВHttpЗапросеНаКлиенте()

    // Предположим, что мы хотим отправить поисковый http запрос
    // гуглу и получить от него страницу с результатами нашего
    // запроса.

    // К примеру, будем искать по строке "работа программистом 1с в моём городе".

    Соединение = Новый HTTPСоединение("www.google.com", 80);

    Запрос = Новый HTTPЗапрос("/search?q=работа программистом 1с в моём городе");
    Результат = Соединение.Получить(Запрос);

    Сообщить("Нам вернули код " + Результат.КодСостояния);

    Если Результат.КодСостояния = 302 Тогда
        Сообщить("Нас перенаправили на другую страницу.");
        Сообщить("Адрес этой страницы находится в заголовке результата Location.");
        Сообщить("Вот он: " + Результат.Заголовки.Получить("Location"));

        // Воспользуемся вспомогательной функцией СтруктураURI, которая
        // сама вытаскивает из адреса имя хоста, порт и путь к ресурсу.

        URI = СтруктураURI(Результат.Заголовки.Получить("Location"));

        // Делаем новое подключение и get запрос.

        Соединение = Новый HTTPСоединение(URI.Хост, URI.Порт);
        Запрос = Новый HTTPЗапрос(URI.ПутьНаСервере);
        Результат =  Соединение.Получить(Запрос);

        Сообщить("Нам вернули код " + Результат.КодСостояния);

        // Сохраним тело ответа (это и есть наша страница с результатами
        // поиска) в виде htm файла и тут же покажем его пользователю.

        КаталогДляЭкспериментов = КаталогДокументов() + "\helpme1c.ru";
        СоздатьКаталог(КаталогДляЭкспериментов);
        ФайлРезультатов = КаталогДляЭкспериментов + "\test.htm";

        Текст = Новый ЗаписьТекста(ФайлРезультатов, КодировкаТекста.UTF8);
        Текст.Записать(Результат.ПолучитьТелоКакСтроку());
        Текст.Закрыть();

        Сообщить("Результаты поиска сохранены в " + ФайлРезультатов);

        ЗапуститьПриложение(ФайлРезультатов);
    КонецЕсли;

КонецПроцедуры

/// Как сохранить картинку с сайта через http-запрос
/// из 1с 8.3, 8.2

&НаКлиенте
Процедура КакСохранитьКартинкуСайтаЧерезHttpЗапросНаКлиенте()

    // Запрашивать через http можно не только html-страницы,
    // но и другие объекты, доступные нам через http,
    // например, картинки.

    // Сохраним на диск и покажем пользователю картинку, которая
    // размещена в интернете по адресу:
    // thumb7.shutterstock.com/display_pic_with_logo/1014806/270790184/
    // stock-photo-summer-holidays-background-sea-background-270790184.jpg

    Соединение = Новый HTTPСоединение("thumb7.shutterstock.com", 80);

    // Get-запрос к ресурсу на сервере.
    Запрос = Новый HTTPЗапрос("/display_pic_with_logo/1014806/270790184/" +
        "stock-photo-summer-holidays-background-sea-background-270790184.jpg");
    Результат = Соединение.Получить(Запрос);

    Сообщить("Нам вернули код " + Результат.КодСостояния);

    // Сама картинка - уже в теле ответа, осталось
    // только записать её в файл на диск в виде двоичных данных.

    КаталогДляЭкспериментов = КаталогДокументов() + "\helpme1c.ru";
    СоздатьКаталог(КаталогДляЭкспериментов);
    ФайлКартинки = КаталогДляЭкспериментов + "\test.jpg";

    // Записываем картинку на диск.
    Результат.ПолучитьТелоКакДвоичныеДанные().Записать(ФайлКартинки);

    Сообщить("Сохранили картинку по адресу " + ФайлКартинки);

    // Покажем картинку пользователю.
    ЗапуститьПриложение(ФайлКартинки);    

КонецПроцедуры

/// Как послать защищенный https запрос к серверу из 1с 8.3, 8.2

&НаКлиенте
Процедура КакПослатьЗащищенныйHttpsЗапросКСерверуНаКлиенте()

    // Получим код страницы https://ya.ru
    // Так как для доступа к ней используется защищенный
    // протокол https - нам нужно заполнить последний
    // параметр при соединении с сервером.

    Соединение = Новый HTTPСоединение(
        "ya.ru", // сервер (хост)
        443, // порт, по умолчанию для http используется 80, для https 443
        , // пользователь для доступа к серверу (если он есть)
        , // пароль для доступа к серверу (если он есть)
        , // здесь указывается прокси, если он есть
        , // таймаут в секундах, 0 или пусто - не устанавливать
       Новый ЗащищенноеСоединениеOpenSSL()
    );

    // Получаем текст корневой страницы через GET-запрос.
    Запрос = Новый HTTPЗапрос("/");
    // Если бы нужна была другая страница, мы бы указали,
    // например, "/about" или "/news".

    Результат = Соединение.Получить(Запрос);
    Сообщить(Результат.КодСостояния);
    Сообщить(Результат.ПолучитьТелоКакСтроку());

КонецПроцедуры

/// Как установить заголовки http-запроса из 1с 8.3, 8.2

&НаКлиенте
Процедура КакУстановитьЗаголовкиHttpЗапросаНаКлиенте()

   // Возьмём чисто гипотетический пример.

   // Нам нужно послать запрос к http://example.com/,
   // передав ему в куках (cookie) session=231.
   // Также мы будем передадим в запросе поле keep-alive,
   // чтобы сервер не закрывал наше соединений к нему
   // для повторых запросов.

   // За всё это отвечают заголовки запроса.

   Заголовки = Новый Соответствие;
   Заголовки.Вставить("Cookie", "session=231");
   Заголовки.Вставить("Connection", "keep-alive");

    // Подключаемся к сайту.
    Соединение = Новый HTTPСоединение("example.com");

    // Получаем текст корневой страницы через GET-запрос.
    Запрос = Новый HTTPЗапрос("/", Заголовки);
    // Если бы нужна была другая страница, мы бы указали,
    // например, "/about" или "/news".

    Результат = Соединение.Получить(Запрос);

КонецПроцедуры

/// Как указать прокси для http-запроса из 1с 8.3, 8.2

&НаКлиенте
Процедура КакУказатьПроксиДляHttpЗапросаНаКлиенте()

   // Если для соединения с интернетом используется прокси,
   // его нужно указывать так.

    ПроксиСервер = Новый ИнтернетПрокси;
    // авторизация
    ПроксиСервер.Пользователь = "Vova";
    ПроксиСервер.Пароль = "123";
    // прокси сервер прописывается для каждого протокола отдельно
    ПроксиСервер.Установить("http", "192.168.0.1", "8080");
    ПроксиСервер.Установить("https", "192.168.0.1", "6547");

    // Созданный объект указываем при http соединении.

    Соединение = Новый HTTPСоединение("example.com",,,, ПроксиСервер);

КонецПроцедуры

/// Как послать post-запрос через http из 1с 8.3, 8.2

&НаКлиенте
Процедура КакПослатьPostЗапросНаКлиенте()

    // Post-запрос отличается от Get-запроса только наличием
    // тела запроса.

    // То есть этот тот же самый HTTPЗапрос, но у которого
    // вызыван метод УстановитьТелоИзСтроки.
    // И это тело уже может быть и просто текстом, и текстом
    // в формате xml, json, soap и так далее.

    // В качестве большого примера рассмотрим фрагмент
    // авторизации на сайте 1с, там используются и get
    // и post запросы.

    // Откуда мы узнали как и когда посылать какие запросы?
    // Мы подсмотрели их у браузера (в Хроме нажмите F12, вкладка Network),
    // а также использовали беплатный инструмент Fiddler
    // для отладки и мониторинга http запросов.

    // Если бы мы писали рабочий код - нам понадобилось
    // всего несколько соединений с сервером, которые
    // мы бы не закрывали. Но в учебных целях будем
    // писать максимально просто ("тупо").

    // 1. Первым делом - посылаем get-запрос к
    // https://releases.1c.ru/total

    Соединение = Новый HTTPСоединение("releases.1c.ru",,,,,,
        Новый ЗащищенноеСоединениеOpenSSL());        
    Запрос = Новый HTTPЗапрос("/total");
    Результат = Соединение.Получить(Запрос);

    // В куках нам должны вернуть идентификатор сессии.
    Куки = Результат.Заголовки.Получить("Set-Cookie");
    // Он идёт первым параметром и отделён от остальных
    // частей точкой с запятой.
    Куки = СтрЗаменить(Куки, ";", Символы.ПС);
    ИдентификаторСессии1 = СтрПолучитьСтроку(Куки, 1);    

    Сообщить(ИдентификаторСессии1);

    // 2. В результате первого запроса нас перенаправили
    // на другую страницу, перейдём на неё новым get-запросом.
    Перенаправление = Результат.Заголовки.Получить("Location");

    Сообщить("Код возврата " + Результат.КодСостояния);
    Сообщить("Нас перенаправили на " + Перенаправление);

    // При помощи служебной функции СтруктураURI разберём
    // новый адрес на части.

    URI = СтруктураURI(Перенаправление);

    Соединение = Новый HTTPСоединение(URI.Хост, URI.Порт,,,,,
        Новый ЗащищенноеСоединениеOpenSSL());
    Запрос = Новый HTTPЗапрос(URI.ПутьНаСервере);    
    Результат =  Соединение.Получить(Запрос);

    // В куках нам вернули второй идентификатор.
    Куки = Результат.Заголовки.Получить("Set-Cookie");
    Куки = СтрЗаменить(Куки, ";", Символы.ПС);
    ИдентификаторСессии2 = СтрПолучитьСтроку(Куки, 1);

    Сообщить(ИдентификаторСессии2);    

    // 3. В результате предыдущего Get-запроса в теле нам вернули
    // страницу авторизации, вытащим из формы авторизации значения
    // параметров name="lt", name="execution" и name="_eventId",
    // чтобы затем сформировать код приглашения на сайт.

    ltValue = "";
    executionValue = "";
    _eventIdValue = "";

    Текст = Новый ТекстовыйДокумент;
    Текст.УстановитьТекст(Результат.ПолучитьТелоКакСтроку());
    Для Индекс = 0 По Текст.КоличествоСтрок() Цикл
        Строка = Текст.ПолучитьСТроку(Индекс);
        Если Найти(Строка, "name=""lt""") > 0 Тогда
            ltValue = ВытащитьЗначениеИзСтроки(Строка);
        ИначеЕсли Найти(Строка, "name=""execution""") > 0 Тогда
            executionValue = ВытащитьЗначениеИзСтроки(Строка);
        ИначеЕсли Найти(Строка, "name=""_eventId""") > 0 Тогда
            _eventIdValue = ВытащитьЗначениеИзСтроки(Строка);
        КонецЕсли;
    КонецЦикла;

    Сообщить(ltValue);
    Сообщить(executionValue);
    Сообщить(_eventIdValue);    

    // Для формирования кода приглашения нам понадобится
    // наш логин и пароль от ИТС.    

    ЛогинИТС = "";
    ПарольИТС = "";

    Если ЛогинИТС = "" Или ПарольИТС = "" Тогда
        Сообщить("Для продолжения укажите в коде логин и пароль от ИТС.");
        Возврат;
    КонецЕсли;

    КодПриглашения = "inviteCode=" +
        "&lt=" + ltValue +
        "&execution=" + executionValue +
        "&_eventId=" + _eventIdValue +
        "&username=" + ЛогинИТС +
        "&password=" + ПарольИТС;    

    // 4. Наконец, посылаем Post-запрос, вкладывая в тело запроса
    // код приглашения, а куках указыаем второй идентификатор сессии.    

    Ресурс =
        "/login;" +
        ИдентификаторСессии2 +
        "?service=https%3A%2F%2Fusers.v8.1c.ru%2Fdistribution%2Fpublic%2Fsecurity_check%3B" +
        ИдентификаторСессии1;

    Соединение = Новый HTTPСоединение("login.1c.ru",,,,,,
        Новый ЗащищенноеСоединениеOpenSSL());

    Заголовки = Новый Соответствие;    
    Заголовки.Вставить("Cookie", ИдентификаторСессии2);
    Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded;");    

    Запрос = Новый HTTPЗапрос(Ресурс, Заголовки);
    Запрос.УстановитьТелоИзСтроки(КодПриглашения);

    Результат = Соединение.ОтправитьДляОбработки(Запрос);

    Сообщить("Нам вернули код " + Результат.КодСостояния);
    Перенаправление = Результат.Заголовки.Получить("Location");
    Сообщить("И перенаправили на " + Перенаправление);

    // 5. В завершении авторизации переходим на следующую
    // страницу, используя первый идентификатор сессии.

    URI = СтруктураURI(Перенаправление);

    Соединение = Новый HTTPСоединение(URI.Хост, URI.Порт,,,,,
        Новый ЗащищенноеСоединениеOpenSSL());

    Заголовки = Новый Соответствие;    
    Заголовки.Вставить("Cookie", ИдентификаторСессии1);    

    Запрос = Новый HTTPЗапрос(URI.ПутьНаСервере, Заголовки);
    Результат =  Соединение.Получить(Запрос);    

    Сообщить("Нам вернули " + Результат.КодСостояния);
    Перенаправление = Результат.Заголовки.Получить("Location");
    Сообщить("И окончательно перенаправили на " + Перенаправление);        

    // Авторизация окончена, теперь можем запрашивать любые
    // страницы сайта, используя первый идентификатор сессии.

КонецПроцедуры

&НаКлиенте
Функция СтруктураURI(Знач СтрокаURI) Экспорт

    СтрокаURI = СокрЛП(СтрокаURI);

    // схема
    Схема = "";
    Позиция = Найти(СтрокаURI, "://");
    Если Позиция > 0 Тогда
        Схема = НРег(Лев(СтрокаURI, Позиция - 1));
        СтрокаURI = Сред(СтрокаURI, Позиция + 3);
    КонецЕсли;

    // строка соединения и путь на сервере
    СтрокаСоединения = СтрокаURI;
    ПутьНаСервере = "";
    Позиция = Найти(СтрокаСоединения, "/");
    Если Позиция > 0 Тогда
        ПутьНаСервере = Сред(СтрокаСоединения, Позиция + 1);
        СтрокаСоединения = Лев(СтрокаСоединения, Позиция - 1);
    КонецЕсли;

    // информация пользователя и имя сервера
    СтрокаАвторизации = "";
    ИмяСервера = СтрокаСоединения;
    Позиция = Найти(СтрокаСоединения, "@");
    Если Позиция > 0 Тогда
        СтрокаАвторизации = Лев(СтрокаСоединения, Позиция - 1);
        ИмяСервера = Сред(СтрокаСоединения, Позиция + 1);
    КонецЕсли;

    // логин и пароль
    Логин = СтрокаАвторизации;
    Пароль = "";
    Позиция = Найти(СтрокаАвторизации, ":");
    Если Позиция > 0 Тогда
        Логин = Лев(СтрокаАвторизации, Позиция - 1);
        Пароль = Сред(СтрокаАвторизации, Позиция + 1);
    КонецЕсли;

    // хост и порт
    Хост = ИмяСервера;
    Порт = "";
    Позиция = Найти(ИмяСервера, ":");
    Если Позиция > 0 Тогда
        Хост = Лев(ИмяСервера, Позиция - 1);
        Порт = Сред(ИмяСервера, Позиция + 1);
    КонецЕсли;

    Результат = Новый Структура;
    Результат.Вставить("Схема", Схема);
    Результат.Вставить("Логин", Логин);
    Результат.Вставить("Пароль", Пароль);
    Результат.Вставить("ИмяСервера", ИмяСервера);
    Результат.Вставить("Хост", Хост);
    Результат.Вставить("Порт", ?(Порт <> "", Число(Порт), Неопределено));
    Результат.Вставить("ПутьНаСервере", ПутьНаСервере);

    Возврат Результат;

КонецФункции

&НаКлиенте
Функция ВытащитьЗначениеИзСтроки(Строка)

    Позиция2 = СтрДлина(Строка);
    Пока Позиция2 > 1 Цикл
        Если Сред(Строка, Позиция2, 1) = """" Тогда
            Прервать;
        КонецЕсли;
        Позиция2 = Позиция2 - 1;
    КонецЦикла;

    Позиция1 = Позиция2 - 1;
    Пока Позиция1 > 1 Цикл
        Если Сред(Строка, Позиция1, 1) = """" Тогда
            Прервать;
        КонецЕсли;
        Позиция1 = Позиция1 - 1;
    КонецЦикла;

    Возврат Сред(Строка, Позиция1 + 1, Позиция2 - Позиция1 - 1);

КонецФункции


отсюда
  Форум: 1С:Предприятие 8.3 · Просмотр сообщения: #165987 · Ответов: 0 · Просмотров: 185
 

>  Выборка документов по доп. характеристике номенклатуры
Vofka
Отправлено: 25.08.20, 10:12


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


stajer, было бы не плохо, если бы вы показали запрос.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165890 · Ответов: 4 · Просмотров: 234
 

>  Не отображает колонку НДС и сумма НДС
Vofka
Отправлено: 25.08.20, 8:31


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Цитата(Наталья КУ @ 14.08.20, 13:03) *
Большое спасибо, сама бы не догадалась.

Для спасибо у нас специальная кнопочка есть.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #165886 · Ответов: 16 · Просмотров: 18233
 

>  Универсальная выгрузка в Dbf из 1С 8 любого документа, включая все табличные части
Vofka
Отправлено: 25.08.20, 8:26


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Gotthard, у меня нету, но можно попробовать сконвертировать под 8.3
  Форум: Отчеты / Обработки · Просмотр сообщения: #165885 · Ответов: 15 · Просмотров: 23628
 

>  Проблема с выводом на печать реестра документов 1с 8 редакция 2
Vofka
Отправлено: 25.08.20, 8:23


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Верните настройки как на скриншоте. upset.gif
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #165884 · Ответов: 1 · Просмотров: 139
 

>  Номенклатура и её родители
Vofka
Отправлено: 04.08.20, 15:10


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Обычно уровень вложенности номенклатуры заранее известный, поэтому можно в запросе сразу выбрать всех родителей и сделать соответствующее условие.

|ВЫБРАТЬ
|   Номенклатура.Ссылка
|   Номенклатура.Родитель,
|   Номенклатура.Родитель.Родитель,
|   Номенклатура.Родитель.Родитель.Родитель
|ГДЕ
|   Номенклатура.Родитель.МойПризнак = 1
|   ИЛИ Номенклатура.Родитель.Родитель.МойПризнак = 1
|   ИЛИ Номенклатура.Родитель.Родитель.Родитель.МойПризнак = 1


Если хочется универсально, можно программно узнать сколько уровней вложенности может быть в справочнике и сгенерировать текст запроса программно.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165315 · Ответов: 5 · Просмотров: 315
 

>  Получение присоединенного файла для дальнейшей отсылки его по почте
Vofka
Отправлено: 03.08.20, 16:57


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


lelelada, в вашем случае есть 2 варианта. Либо вы платите деньги и кто-то вам это делает, либо вы все таки опишете с кодом что именно вы делаете и что именно не получается.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165286 · Ответов: 3 · Просмотров: 188
 

>  Получение присоединенного файла для дальнейшей отсылки его по почте
Vofka
Отправлено: 03.08.20, 15:18


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


lelelada, что именно не получается?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165282 · Ответов: 3 · Просмотров: 188
 

>  Обработка XML большого объема
Vofka
Отправлено: 28.07.20, 16:48


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Vond, а какой именно файл пытаетесь обработать?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165123 · Ответов: 19 · Просмотров: 582
 

>  При переходе с БУ 1.2 на BAS КОРП система заблокировала старые документы
Vofka
Отправлено: 28.07.20, 10:16


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Andriy11111,

 ! 

Правила: 6
 
  Форум: BAS Комплексное управление предприятием · Просмотр сообщения: #165112 · Ответов: 5 · Просмотров: 253
 

>  Объеденение приходных накаладных
Vofka
Отправлено: 28.07.20, 8:45


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1



 ! 

Правила: 3, 7
 
  Форум: Платформа 8 · Просмотр сообщения: #165107 · Ответов: 4 · Просмотров: 289
 

>  Типы штрихкодов BAF УТ редакция 3.2
Vofka
Отправлено: 27.07.20, 16:11


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


Sergowa, так в чем беда была?
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #165067 · Ответов: 2 · Просмотров: 203
 

>  Перебор таблицы значений из реквизита формы
Vofka
Отправлено: 27.07.20, 15:32


У нас здесь своя атмосфера...
***********

Группа: Основатель
Сообщений: 13332
Регистрация: 02.02.09
Из: Киев
Пользователь №: 1


pablo, если вы сопоставляете таблицы по индексу, то это скорее всего проблема. Индекс может поменяться, если таблица есть на форме и строки в ней могут двигать. Я для таких вещей делаю идентификационное строковое поле, в которое пишу УИД.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #165065 · Ответов: 12 · Просмотров: 380
 

474 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 29.09.20, 16:58
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!