Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

2 страниц V   1 2 >

>  Как вывести значение булево(да или нет) в колонку Формы списка документа
jojojoba2
Отправлено: 13.09.19, 16:04


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый деннь!
1С8.3 УПП

Подскажите подалуйста, как вывести значение булево(да или нет) в колонку Формы списка(обычную) документа.
Я создал реквизит типа булево. На форме списка создал колонку,подвязал реквизит к колонке. Выводит в строках формы значение - "Нет".

Как сделать чтобы при определенных условиях(если в структуре подчиненных документов есть НалоговаяНакладная) выводилось значение "Да".

Я в событии формы списка при открытии Создал процедуру :

Процедура ПриОткрытии(ОформленияСтрок)    
    МасЗаказы = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        ДанныеСтроки = Стр.ДанныеСтроки;
        МасЗаказы.Добавить(ДанныеСтроки.Ссылка);
    КонецЦикла;
    //
    зЗапрос = Новый Запрос;
    Запрос.Текст =

          "ВЫБРАТЬ
          |    СвязанныеДокументы.Ссылка
          |ИЗ
          |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СвязанныеДокументы";
    
          Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока);
                                                                
    Результат = Запрос.Выполнить();  
    
  
    Для Каждого Стр Из ОформленияСтрок Цикл
        тд = Стр.ДанныеСтроки;        
        Выборка.Сбросить();
        Если Выборка.НайтиСледующий(тд.Ссылка, "НалоговаяНакладная") Тогда


   ОформлениеСтроки.Ячейки.Флаг = Истина;     как правильно написать эту строку ???????????????? Выдает ошибку :


Документ.ЗаказПокупателя.Форма.ФормаСписка.Форма(104)}: Значення не є значенням об`єктного типу (Ячейки)

Подскажите пожалуйста как правильно написать код : если значение запроса = нужное значение то в строке напротив документа поставить значение "ДА"

Спасибо за любую помощь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155609 · Ответов: 1 · Просмотров: 59
 

>  Вывести флажок в поле формы списка
jojojoba2
Отправлено: 13.09.19, 11:48


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


sava1 @ Сегодня, 12:29 * ,

Спасибо огромное!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155600 · Ответов: 6 · Просмотров: 78
 

>  Вывести флажок в поле формы списка
jojojoba2
Отправлено: 13.09.19, 11:23


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


sava1 @ Сегодня, 11:12 * ,
8.3 УПП

sava1 @ Сегодня, 11:12 * ,
Обычная форма

fly @ Сегодня, 11:36 * ,
Спасибо! Буду разбираться.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155597 · Ответов: 6 · Просмотров: 78
 

>  Вывести флажок в поле формы списка
jojojoba2
Отправлено: 13.09.19, 10:04


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Есть задача - необходимо в документе ЗаказПокупателя в поле ввода колонки формы списка вывести флажок напротив документа если в структуре подчиненных документов, есть Реализация и Налоговая накладная.

Подскажите каким методом, запросом это возможно сделать?
Как правильно настроить колонку в свойствах?
В каком событии лучше писать процедуру?

Если есть пример кода буду благодарен.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155592 · Ответов: 6 · Просмотров: 78
 

>  Вывод структуры подчиненности в заказах покупателя
jojojoba2
Отправлено: 30.08.19, 11:41


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


sava1 @ Сегодня, 12:08 * ,

Спасибо! Буду пробовать.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155162 · Ответов: 3 · Просмотров: 131
 

>  Вывод структуры подчиненности в заказах покупателя
jojojoba2
Отправлено: 30.08.19, 10:53


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!
Может кто-то знает как вывести структуры подчиненности в заказах покупателя. То есть чтобы на форме списка рядом со строками справа при активизации строки появлялась структура подчиненных документов.

Сделать типа так:


Какой элемент управления вставить в форму списка для отображения формы структуры подчиненных документов? В каких событиях запускать вывод этой формы при активизации строки?

Буду благодарен за любую помощь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155158 · Ответов: 3 · Просмотров: 131
 

>  Заполнение формы списка данными Документов и реквизитами на основании другого документа
jojojoba2
Отправлено: 28.08.19, 15:40


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 16:26 * ,

Спасибо
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155094 · Ответов: 5 · Просмотров: 128
 

>  Заполнение формы списка данными Документов и реквизитами на основании другого документа
jojojoba2
Отправлено: 28.08.19, 14:57


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 12:24 * ,
более подробно на примерах, там, Док1 с Реквиз1, Реквиз2 и ТЧ1 перенести данные в Док2 с Реквиз1, Реквиз2 и ТЧ1+еще значения реквизитов нужно обработать с помощью формул(Сумма С НДС, Без НДС)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155092 · Ответов: 5 · Просмотров: 128
 

>  Заполнение формы списка данными Документов и реквизитами на основании другого документа
jojojoba2
Отправлено: 28.08.19, 11:08


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите советом,как можно вывести список (определенных отбором) документов и их реквизитов+реквизитов табличных частей в форму списка из одного объекта конфигурации(документа) в другой объект.
Я копировал документ(объект_конфигурации) с которого нужно выводить данные и в нем менял в реквизитах формы путь к документу, с которого нужно выводить данные. Дальше в форме списка добавлял реквизиты. Это решение правильно не заработало(((.
Я находил похожие решения с заполнением документа на основании но информация разбросана. Я запутался(((.

Пожалуйста,подскажите правильный метод (алгоритм) решения такого задания,что за чем выполнять и в каких модулях прописывать код.

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155086 · Ответов: 5 · Просмотров: 128
 

>  Как значение из реквизита таб. части документа вывести в форму списка
jojojoba2
Отправлено: 23.08.19, 11:20


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


pablo @ Сегодня, 12:12 * ,

Это обычный режим. А в нем как можно?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154959 · Ответов: 4 · Просмотров: 130
 

>  Как значение из реквизита таб. части документа вывести в форму списка
jojojoba2
Отправлено: 23.08.19, 10:36


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!
Есть документ ПлатежноеПоручениеВходящее. Я создал копированием другой документ Докум1 и в форму списка переношу данные из документов ПлатежноеПоручениеВходящее. Подскажите пожалуйста, как в форме списка созданного документа в колонку ЗаказыПокупателя вывести данные из табличной части РасшифровкаПлатежа из реквизита Сделка.

Я создал процедуру и функцию

Код
Функция ПолучитьДанныеИзРС(РасшифровкаПлатежа)
                                             
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТекущийДокумент", ЭтаФорма.СсылкаНаОбъект);
Запрос.Текст =  "ВЫБРАТЬ
                |    ПлатежноеПоручениеВходящееРасшифровкаПлатежа.Сделка
                |ИЗ
                |    Документ.ПлатежноеПоручениеВходящее.РасшифровкаПлатежа КАК ПлатежноеПоручениеВходящееРасшифровкаПлатежа
                |ГДЕ
    |    ПлатежноеПоручениеВходящее.Ссылка = &ТекущийДокумент";
               // получение данных по конкретному ОС

Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();

Возврат Выборка.Сделка;

КонецФункции


Процедура ПриОткрытии()

дк=Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Поступления от продажи товаров, работ, услуг / внешние");


ЭтаФорма.ДокументСписок.Отбор.СтатьяДвиженияДенежныхСредств.Использование = Истина;
ЭтаФорма.ДокументСписок.Отбор.СтатьяДвиженияДенежныхСредств.ВидСравнения =  ВидСравнения.Равно;
ЭтаФорма.ДокументСписок.Отбор.СтатьяДвиженияДенежныхСредств.Значение = дк;

ЗаказПокупателя = ПолучитьДанныеИзРС(Сделка);    

КонецПроцедуры


Почему-то не заработало.

Может можно как-то в колонке полю ввода напрямую подставить ссылочный реквизит табличной части?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154957 · Ответов: 4 · Просмотров: 130
 

>  Вывод диапазона значений(определенные строки) в поле формы из плана счетов
jojojoba2
Отправлено: 18.07.19, 16:47


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Подскажите пожалуйста новичку каким образом можно в поле формы вывести строки(чтобы выводился не весь список,а всего 5 счетов которые я укажу) плана счетов хозрасчетный. То есть в отчете при определенной роли должно в поле формы счет выводится 5 счетов.
Я пытаюсь в конфигураторе в модуле формы отчета в процедуре ПриОткрытии() дописать код

если РольДоступна("Роль1") Тогда

Счет = заданный список счетов

Может есть специальные методы или функции? Может запросом вывести(отфильтровать) этот список в поле?

Если можете выложите пример кода.


Заранее спасибо.
  Форум: Корзина · Просмотр сообщения: #153926 · Ответов: 3 · Просмотров: 177
 

>  План счетов (ограничение вывода счетов из списка для роли пользователя)
jojojoba2
Отправлено: 18.07.19, 13:35


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день.

Подскажите пожалуйста, как можно в ОборотноСальдоваяВедомостьПоСчету(в форме отчета при выборе счета) сделать список из 5-ти нужных счетов(чтобы все счета не выводились) или из общего списка были доступны только 5 и при этом только для определенной роли. Возможно RLS, но если можно пример запроса RLS.
Может есть какие-то стандартные решения(например в конфигураторе заполнить в поле счета ,которые будут видны для опреденной роли).Куда копать?


Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153921 · Ответов: 1 · Просмотров: 118
 

>  Ссылка на Документ основание
jojojoba2
Отправлено: 27.06.19, 9:42


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


pablo @ Сегодня, 9:38 * ,


Спасибо!
Получилось!

Выкладываю код.


Процедура СкопироватьТовары2(ТабличнаяЧасть,ДокументОснование) 

ДокументОснование = Сделка;
ДатаОстатков = ОбщегоНазначения.ПолучитьДатуОстатков(ЭтотОбъект);

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДокументОснование", ДокументОснование);
Запрос.УстановитьПараметр("ПустойСклад", Справочники.Склады.ПустаяСсылка());
Запрос.УстановитьПараметр("ДатаОстатков", ДатаОстатков);

Запрос.Текст ="ВЫБРАТЬ
|    Товары.НомерСтроки,
|    Товары.Номенклатура,
|    Товары.Количество,
|    Товары.ЕдиницаИзмерения,
|    Товары.Коэффициент,
|    Товары.Цена,
|    Товары.ПроцентСкидкиНаценки,
|    Товары.Сумма
|ИЗ
|    Документ.ЗаказПокупателя.Товары КАК Товары
|ГДЕ
|    Товары.Ссылка = &ДокументОснование";

РезультатЗапроса = Запрос.Выполнить();



ДобавленКомплект = Ложь;
Выборка = РезультатЗапроса.Выбрать();

Пока Выборка.Следующий() Цикл


НоваяСтрока = Товары.Добавить();
НоваяСтрока.Номенклатура = Выборка.НомерСтроки;
НоваяСтрока.Номенклатура = Выборка.Номенклатура;
НоваяСтрока.Количество = Выборка.Количество;    
НоваяСтрока.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
НоваяСтрока.Коэффициент = Выборка.Коэффициент;
НоваяСтрока.Цена = Выборка.Цена;
НоваяСтрока.ПроцентСкидкиНаценки = Выборка.ПроцентСкидкиНаценки;    
НоваяСтрока.Сумма = Выборка.Сумма;

КонецЦикла;

КонецПроцедуры


Всем спасибо!


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153400 · Ответов: 4 · Просмотров: 252
 

>  Ссылка на Документ основание
jojojoba2
Отправлено: 27.06.19, 8:28


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


takefive @ Вчера, 17:44 * ,
Почему то выдает ошибку

Ошибка при выполнении обработчика - 'ОбработкаЗаполнения'
по причине:
{Документ.РеализацияТоваровУслуг.МодульОбъекта(5086)}: Ошибка при вызове метода контекста (Выполнить)

по причине:
{(12, 19)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
неограниченной длины и поля несовместимых типов.
Товары.Ссылка <<?>>= &Ссылка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153398 · Ответов: 4 · Просмотров: 252
 

>  Ссылка на Документ основание
jojojoba2
Отправлено: 26.06.19, 16:00


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

В 8.3 УПП в документе РеализацияТоваровИУслуг необходимо скопировать данные из табличной части ТОВАРЫ документа основания Заказ Покупателя. Написал запрос но не знаю как в запросе сослатся на данные каторые есть в документе основании (на товары каторые есть в табличной части Заказ Покупателя).

Процедура СкопироватьТовары2(ТабличнаяЧасть,ДокументОснование) 
    
        Если ТабличнаяЧасть = Товары   Тогда
    
    
        ДатаОстатков = ОбщегоНазначения.ПолучитьДатуОстатков(ЭтотОбъект);
              
        Запрос = Новый Запрос;
        
            Запрос.УстановитьПараметр("ДокументОснование", ДокументОснование);
        Запрос.УстановитьПараметр("ПустойСклад", Справочники.Склады.ПустаяСсылка());
        Запрос.УстановитьПараметр("ДатаОстатков", ДатаОстатков);
        
        Запрос.Текст ="ВЫБРАТЬ
                      |    Товары.НомерСтроки,
                      |    Товары.Номенклатура,
                      |    Товары.Количество,
                      |    Товары.ЕдиницаИзмерения,
                      |    Товары.Коэффициент,
                      |    Товары.Цена,
                      |    Товары.ПроцентСкидкиНаценки,
                      |    Товары.Сумма
                      |ИЗ
                      |    Документ.РеализацияТоваровУслуг.Товары КАК Товары   ";
                
        
        РезультатЗапроса = Запрос.Выполнить();
        
        Если РезультатЗапроса.Пустой() Тогда
            Возврат;
        КонецЕсли;
        
        ДобавленКомплект = Ложь;
        Выборка          = РезультатЗапроса.Выбрать();
        
        Пока Выборка.Следующий() Цикл
                        
                        
            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.Номенклатура                        = Выборка.НомерСтроки;
            НоваяСтрока.Номенклатура                        = Выборка.Номенклатура;
            НоваяСтрока.Количество                          = Выборка.Количество;        
            НоваяСтрока.ЕдиницаИзмерения                    = Выборка.ЕдиницаИзмерения;
            НоваяСтрока.Коэффициент                         = Выборка.Коэффициент;
            НоваяСтрока.Цена                       = Выборка.Цена;
            НоваяСтрока.ПроцентСкидкиНаценки                = Выборка.ПроцентСкидкиНаценки;            
            НоваяСтрока.Сумма =      Выборка.Сумма;
                        
                                    
                        
                                
            
            НоваяСтрока.ЗаказПокупателя              = Сделка;

            ДобавленКомплект                         = Истина;
        КонецЦикла;
КонецЕсли;


КонецПроцедуры



 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #153373 · Ответов: 4 · Просмотров: 252
 

>  Не копируется документ Покупка-Продажа валюты( УПП)
jojojoba2
Отправлено: 28.05.19, 10:40


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


pablo @ Сегодня, 10:39 * ,
В модуле объекта данного документа нету процедуры ПриКопировании
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152565 · Ответов: 3 · Просмотров: 228
 

>  Не копируется документ Покупка-Продажа валюты( УПП)
jojojoba2
Отправлено: 28.05.19, 9:30


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Столкнулся с проблемой копирования документа. Документ Покупка-Продажа валюты при копировании переносит не всю информацию(не все поля переносятся в новый документ). Это происходит через раз. Подскажите, кто-то может сталкивался с такой проблемой?
Похоже на глюк 1С -ки. Может RLS тупит. Куда копать?

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152561 · Ответов: 3 · Просмотров: 228
 

>  ГТД по импорту в поле налоги подставить значение 20%
jojojoba2
Отправлено: 23.05.19, 15:14


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите пожалуйста с задачей. В УПП для Украины в документе ГТД по импорту на вкладке параметры взаиморасчетов в поле налоги нужно подставить значение по умолчанию 20%. В конфигураторе смотрю на форму и там нет поля налоги. Есть НДССубконто1, НДССубконто2, НДССубконто3. Тоесть 3 поля. Как появляется поле налоги в документе? И как туда подставить по умолчанию значение(20%).

Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152452 · Ответов: 0 · Просмотров: 164
 

>  Сравнение значения реквизита Табличной части
jojojoba2
Отправлено: 22.05.19, 15:32


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 11:24 * ,
Спасибо, все заработало.

Но все же уже, чисто, интересно как сделать сравнение реквизита Табличной Части с другим значением с помощью менеджера :

@@ Если Документы.ПеремещениеТоваров.Товары.СчетУчетаБУ = "023" то запрос 2, иначе запрос 1.@@ Товары-это ТАБЛИЧНАЯ ЧАСТЬ, СчетУчетаБУ- это реквизит табличной табличной части.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152420 · Ответов: 3 · Просмотров: 262
 

>  Сравнение значения реквизита Табличной части
jojojoba2
Отправлено: 22.05.19, 8:55


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Конфигурация УПП для Украины. Есть документ ПеремещениеТоваров. Я для него исправляю типичную форму с вывод суммы для товара. Данные взял с регистра Бухгалтерии Хозрасчетный( ХозрасчетныйОбороты). Форма работает ,но при выборе 023 счета пишет "индекс находится за границами массива".Я разобрался, В запросе при выборе ХозрасчетныйОбороты.КорСубконто1 попадает значение NULL :
|ВЫБРАТЬ
|    ХозрасчетныйОбороты.КорСубконто1,
|    ХозрасчетныйОбороты.СуммаОборотДт
|ИЗ
|    РегистрБухгалтерии.Хозрасчетный.Обороты(, , Регистратор, , , , , ) КАК ХозрасчетныйОбороты
|ГДЕ
|    ХозрасчетныйОбороты.Регистратор = &Ссылка



Для Счета 023 нужно использовать запрос :

|ВЫБРАТЬ
|    ХозрасчетныйОбороты.КорСубконто2,
|    ХозрасчетныйОбороты.СуммаОборотДт
|ИЗ
|    РегистрБухгалтерии.Хозрасчетный.Обороты(, , Регистратор, , , , , ) КАК ХозрасчетныйОбороты
|ГДЕ
|    ХозрасчетныйОбороты.Регистратор = &Ссылка


и форма по 023 работает норм.Но другие тогда не пашут.

Подскажите пожалуйста начинающему програмисту, как сделать правильно выбор между запросами. Я хочу сравнить Значение поля табличной части с 023 счетом:


@@ Если Документы.ПеремещениеТоваров.Товары.СчетУчетаБУ = "023" то запрос 2, иначе запрос 1.@@ Товары-это ТАБЛИЧНАЯ ЧАСТЬ, СчетУчетаБУ- это реквизит табличной табличной части.

Как вытащить значение из СчетУчетаБУ с сылкой на товар в документе? Можете сбросить подобный пример.

Спасибо!


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152408 · Ответов: 3 · Просмотров: 262
 

>  Заполнение поля из свойства другого объекта
jojojoba2
Отправлено: 17.05.19, 13:28


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Всем спасибо!
Вставляю рабочий код, может кому то пригодиться

Функция ПолучитьДанныеИзРС(ОС) 

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ОС",ОС);
Запрос.УстановитьПараметр("Дата",Дата);
Запрос.Текст = "ВЫБРАТЬ
|    МестонахождениеОСБухгалтерскийУчет.МОЛ
|ИЗ
| РегистрСведений.МестонахождениеОСБухгалтерскийУчет.СрезПоследних(&Дата,ОсновноеСредство = &ОС) КАК МестонахождениеОСБухгалтерскийУчет";

// получение данных по конкретному ОС

Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();

Возврат Выборка.МОЛ;

КонецФункции

Процедура ОСОсновноеСредствоПриИзменении(Элемент)

СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.М = ПолучитьДанныеИзРС(СтрокаТабличнойЧасти.ОсновноеСредство);

КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152295 · Ответов: 11 · Просмотров: 407
 

>  Заполнение поля из свойства другого объекта
jojojoba2
Отправлено: 16.05.19, 15:50


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Vofka @ Сегодня, 16:03 * ,

Да, нужно подставить в созданное поле на ком числится основное средство. Как подтянуть данные из регистра.Я пробую запросом но данные не вставляются:

Функция ПолучитьДанныеИзРС(ОС)

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ОС",ОС);
Запрос.Текст =  "ВЫБРАТЬ
              
               |    МестонахождениеОС.МОЛ
               |ИЗ
               |    РегистрСведений.МестонахождениеОС КАК МестонахождениеОС ";
              
              
               // получение данных по конкретному ОС

Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();



КонецФункции



Процедура ОСОсновноеСредствоПриИзменении(Элемент)
    
СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.М = ПолучитьДанныеИзРС(СтрокаТабличнойЧасти.ОС);


КонецПроцедуры


jojojoba2 @ Сегодня, 16:36 * ,
Написал код, вставляет значение в мое созданное поле но значение одно и тоже для всех основных средств


 ! 

Правила: 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152275 · Ответов: 11 · Просмотров: 407
 

>  Заполнение поля из свойства другого объекта
jojojoba2
Отправлено: 16.05.19, 14:32


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Acid @ Сегодня, 14:11 * ,

Подскажите пожалуйста книгу
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152270 · Ответов: 11 · Просмотров: 407
 

>  Заполнение поля из свойства другого объекта
jojojoba2
Отправлено: 16.05.19, 12:44


Общительный
**

Группа: Пользователи
Сообщений: 32
Регистрация: 18.02.19
Пользователь №: 64372


Добрый день!

Помогите начинающему разработчику 1С. Есть документ Перемещение ОС. В нем нужно добавить поле с вожможностью вода данных ,на ком или какому складе(МОЛ) принадлежит ОС(Тоесть чтобы было поле "Тот кто здал" и "Тот кто принял". При создании нового документа Перемещение ОС, при добавлении Основного средства необходимо чтобы данные на ком(на каком складе) оно числится добавлялись в созданное поле автоматически.

Подскажите метод или пример кода автоматического заполнения. Я Пытаюсь через обработку формы при изменении документа "Перемещение ОС"
подставить в новое поле (созданное мною "на ком числиться") данные из документа "Основные Средства" вкладка "бух учет" из поля "МОЛБУ",но это не реквизит , а переменная в Процедура ЗаполнитьОписания() формы элемента. Как сделать ссылку на конкретный элемент формы другого документа.

Процедура ОСОсновноеСредствоПриИзменении(Элемент)
    
СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.м =Справочники.ОсновныеСредства.ФормаЭлемента. ???????????

КонецПроцедуры


Направте на путь истинный.

Спасибо.


 ! 

Правила: 4, 9
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #152266 · Ответов: 11 · Просмотров: 407
 

2 страниц V   1 2 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 15.09.19, 10:17
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!