Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



5 страниц V   1 2 3 > » 

>  Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю.
inna.innainna84
Отправлено: 24.03.17, 16:36


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Огромное спасибо. Все отлично срабатывает.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #124703 · Ответов: 8 · Просмотров: 2071
 

>  Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю.
inna.innainna84
Отправлено: 24.03.17, 15:12


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


09000000.gif 09000000.gif 09000000.gif
10 раз переделыааю код и все равно возвращаюсь в начало
Процедура ЗаполняемПЛраб() 
          
          тз.выбратьстроки();
          Пока ТЗ.ПолучитьСтроку()=1 Цикл                     
              //================создаем новый!=====================          
              ДокМ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");                 
              ДокМ.Новый();      
              глЗаполнитьШапку(ДокМ);
              ДокМ.ДатаДок = ТЗ.ДатаДок;  
              ДокМ.Автомобиль = ТЗ.Автомобиль.ТекущийЭлемент();         
              Докм.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
              Докм.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
              Докм.ПробегGPS=ТЗ.GPS;
              Докм.ПробегНорма=ТЗ.Км;
              Докм.СуммаЗаправки=ТЗ.ПоступилоСумма;
              Докм.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
              Докм.Автор=глПользователь;
              
              //================создаем новый!=======================================================      
              
              
              //=========================проверям на наличие уже созданного пл=======================    
              ДокПЛ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");    
              ДокПЛ.ВыбратьДокументы(Дата1,Дата2);
              Пока ДокПл.ПолучитьДокумент()=1 Цикл
                  Если ДокПЛ.ПометкаУдаления() = 0 Тогда // (ДокПЛ.Проведен() = 0) И                  
                      
                      //================находим документ и редактируем его!=====================           
                      Если (ДокПЛ.Автомобиль=ДокМ.Автомобиль) и (ДокПЛ.ДатаДок=ДокМ.ДатаДок) Тогда                  
                          Если Вопрос("ПЛ № "+ДокПЛ+" уже записан (№ "+ДокПЛ.Номердок+"). РЕДАКТИРОВАТЬ?", "Да+Нет") =  "Да" Тогда  
                              
                              ДокМ=ДокПЛ;
                              
                              Если ДокМ.Проведен()=1 Тогда                        
                                  ДокМ.СделатьНеПроведенным();
                                  
                              КонецЕсли;                      
                          КонецЕсли;                      
                          Докм.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
                          Докм.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
                          Докм.ПробегGPS=ТЗ.GPS;
                          Докм.ПробегНорма=ТЗ.Км;
                          Докм.СуммаЗаправки=ТЗ.ПоступилоСумма;
                          Докм.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
                          Докм.Автор=глПользователь;
                          ДокМ.Записать();        
                          Сообщить("Редактирован! "+ДокМ.ТекущийДокумент());                          
                          
                      КонецЕсли;                      
                      //================находим документ и редактируем его!=====================         
                  КонецЕсли;             
              КонецЦикла;  
              Попытка
                  ДокМ.Записать();
                  Сообщить("Создан новый ПЛ "+ ДокМ);    
              Исключение
              КонецПопытки;
              //===========================================================
          КонецЦикла;                      
          
          сообщить("Ок.");    
      КонецПроцедуры

создаю новый
сообщает:
Создан новый ПЛ ПутевойЛистГрузовой ЗЕ-0000001 (04.01.17)
Создан новый ПЛ ПутевойЛистГрузовой ЗЕ-0000002 (05.01.17)
Создан новый ПЛ ПутевойЛистГрузовой ЗЕ-0000003 (06.01.17)
Ок.
Здесь все хорошо.


теперь провераю на наличие дока и редактирую его
сообщает:
Редактирован! ПутевойЛистГрузовой ЗЕ-0000001 (04.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000002 (05.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000003 (06.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000002 (05.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000003 (06.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000003 (06.01.17)
Ок.
************************************************************************
Редактирован! ПутевойЛистГрузовой ЗЕ-0000002 (05.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000003 (06.01.17)
Редактирован! ПутевойЛистГрузовой ЗЕ-0000003 (06.01.17)
Почему 2 строчка задваеветься, а 3 вовсе троит?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #124697 · Ответов: 8 · Просмотров: 2071
 

>  Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю.
inna.innainna84
Отправлено: 24.03.17, 10:51


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Этот код не верно сработает.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #124674 · Ответов: 8 · Просмотров: 2071
 

>  Создание нового документа и проверка на наличие уже созданого. Подскажите пожалуйста что не так я делаю.
inna.innainna84
Отправлено: 24.03.17, 10:29


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Код
Процедура СоздаемПЛ() 
    
    тз.выбратьстроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл                     
        //================создаем новый!=====================          
        ДокМ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");                 
        ДокМ.Новый();          
        глЗаполнитьШапку(ДокМ);
        ДокМ.ДатаДок = ТЗ.ДатаДок;  
        ДокМ.Автомобиль = ТЗ.Автомобиль.ТекущийЭлемент();         
        Докм.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
        Докм.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
        Докм.ПробегGPS=ТЗ.GPS;
        Докм.ПробегНорма=ТЗ.Км;
        Докм.СуммаЗаправки=ТЗ.ПоступилоСумма;
        Докм.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
        Докм.Автор=глПользователь;
        //================создаем новый!=====================             
        
        //=========================проверям на наличие уже созданного пл=======================    
        ДокПЛ=СоздатьОбъект("Документ.ПутевойЛистГрузовой");    
        ДокПЛ.ВыбратьДокументы(Дата1,Дата2);
        Пока ДокПл.ПолучитьДокумент()=1 Цикл
                       Если ДокПЛ.ПометкаУдаления() = 0 Тогда // проверяем все кроме помеченных!!
                
                //================находим документ и редактируем его!=====================           
                Если (ДокПЛ.Автомобиль=ДокМ.Автомобиль) и (ДокПЛ.ДатаДок=ДокМ.ДатаДок) Тогда                  
                    Если Вопрос("ПЛ № "+ДокПЛ+" уже записан (№ "+ДокПЛ.Номердок+"). РЕДАКТИРОВАТЬ?", "Да+Нет") =  "Да" Тогда  
                        
                        ДокМ=ДокПЛ;
                        
                        Если ДокМ.Проведен()=1 Тогда                            
                            ДокМ.СделатьНеПроведенным();                             
                        КонецЕсли;
                    КонецЕсли;
                    Докм.Автор=глПользователь;
                    ДокМ.ПоказанияСпидометраНаНачало=ТЗ.КоличествоНачПокСпид;
                    ДокМ.ПоказанияСпидометраНаКонец=ТЗ.КоличествоКонПокСпид;
                    ДокМ.ПробегGPS=ТЗ.GPS;
                    ДокМ.ПробегНорма=ТЗ.Км;
                    ДокМ.СуммаЗаправки=ТЗ.ПоступилоСумма;
                    ДокМ.ПоступилоГСМ=ТЗ.ПоступилоЛитр;
                    ДокМ.Записать();        
                    Сообщить("Редактирован! "+ДокМ.ТекущийДокумент());                     
                КонецЕсли;                   
                //================находим документ и редактируем его!=====================         
            КонецЕсли;             
        КонецЦикла;  
        
        //===========================================================
    КонецЦикла;                                        
    
    Попытка
        ДокМ.Записать();
        Сообщить("№2 "+ ДокМ);    
    Исключение
    КонецПопытки;
    
    сообщить("Ок.");    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #124669 · Ответов: 8 · Просмотров: 2071
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 04.12.16, 14:34


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Спасибо за "спасибо". С первым меня "Спасибо." XBrut @ Сегодня, 9:18 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120158 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 03.12.16, 16:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


                  //----4----//  
            
//=========================не трогать====================================================================
    Если ДокРН.Итог("СуммаСНДС")<ДокРН.СуммаДокНал  Тогда//   **начало
        сообщить ("Не хватает товара!!");  
    иначе
        
        //правим суммы    
        Ном = ДокРН.КоличествоСтрок();
        Если Ном > 0 Тогда   //**1
            Пока  Ном > 0 Цикл
                ДокРН.ПолучитьСтрокуПоНомеру(Ном);
                Если ДокРН.Итог("СуммаСНДС")>ДокРН.СуммаДокНал  Тогда //**2                 
                    Дельта2=    ДокРН.Итог("СуммаСНДС")-ДокРН.СуммаДокНал;
                ДокРН.СуммаСНДС=ДокРН.Суммасндс-Дельта2;
                    
                    Если ДокРН.СуммаСНДС=0 Тогда
                        ДокРН.Удалитьстроку();
                    КонецЕсли;
                    
                    //**выбрает вессой или штучный товар и правим кво с условием                 
                    Если ДокРН.ТМЦ.Весовой = 0 тогда                          
                        ДокРН.Кво=Окр(ДокРН.СуммаСНДС/ДокРН.ЦенаСНДС);                         
                    иначе
                        ДокРН.Кво=ДокРН.СуммаСНДС/ДокРН.ЦенаСНДС;                             
                    КонецЕсли;//**выбрала
                    
                    ДокРН.ЦенаСНДС= ДокРН.СуммаСНДС/ДокРН.Кво;      
        
                    ДокРН.СуммаБезНДС=Формат(ДокРН.СуммаСНДС/1.2,"Ч12.2");                         
                    ДокРН.НДС= Формат(ДокРН.СуммаСНДС-ДокРН.СуммаБезНДС,"Ч12.2");
                    ДокРН.СуммаБезСкидки=ДокРН.СуммаБезНДС;                     
                КонецЕсли; //**2
                Ном = Ном-1;
                
            КонецЦикла;
        КонецЕсли; //**1         
    КонецЕсли; //*** начало

алгоритм подбора кол-ва и подгонка суммы в документе на согласно указанной ДокРН.СуммаДокНал (СуммаДокНал-это сумма переплаты по покупателю)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120137 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 03.12.16, 13:24


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


У меня получилось. Я это сделала!:32542460: 32542460.gif 32542460.gif inna.innainna84 @ Вчера, 13:36 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120136 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 02.12.16, 13:36


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Может нужно создать еще третью ТЗ и выгрузить туда Долги по клиенту и Остатки по ТМЦ? Может кто-то такое уже делал подскажите пожалуйста наглядный код.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120102 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 01.12.16, 20:22


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


не трогать писала я. Это мой код.XBrut @ Сегодня, 19:48 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120033 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 01.12.16, 11:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


После того как я загрузила из ТЗОстатков в РН мне необходимо пробежаться по строках в документе снизу в вверх и убрать лишние суммы и расчитать ТекКво= если ТМЦ.БазЕдиница "шт". то ОКР, если "кг" оставляем как есть ("помогите расчитать нужное колво!!!!"); чтобы расзницу по кво вернуть обратно в ТЗОстатки.
Acid @ Сегодня, 10:48 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120008 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 01.12.16, 10:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Процедура СоздатьДокРН()
  //=========================не трогать====================================================================        
                           //---1---//
//==========создаем расходныйе накладный по выбраным контрагентам==========  
                                         
        ТЗКлиенты.ВыбратьСтроки();
        Пока ТЗКлиенты.ПолучитьСтроку()=1 Цикл//1  начало
        докРН = СоздатьОбъект("Документ.РасходнаяНакладная");
        докРН.Новый();
        докРН.Фирма =          глВосстановитьЗначение(,"БазФирма");
        докРН.Валюта =         Константа.ОсновнаяВалюта;  
        докРН.Курс =           докРН.Валюта.Курс.Получить(докРН.ДатаДок);        
        докРН.ВидНДС =         докРН.Фирма.СтавкаНДС;
        докРН.ДатаДок =        ТекущаяДата();         
        докРН.Контрагент =        ТЗКлиенты.Контрагент;
        докРН.СуммаДокНал=     ТЗКлиенты.Долг;
        докРН.ВидТорговли =    докРН.Контрагент.ВидТорговли;    
        докРН.СчетКонтрагента =СчетПоКоду("361");
        докРН.МестоХранения =  ВыбСклад;    
//=========================не трогать====================================================================        
                     //----2----//
//==========создаем список ТМЦ в расходных накладных по выбраным контрагентам====  
        ТЗОстатки.ВыбратьСтроки();
        Пока ТЗОстатки.ПолучитьСтроку()=1 Цикл //2 начало
        докРН.НоваяСтрока();
        докРН.ТМЦ =         ТЗОстатки.ТМЦ;      
        докРН.Ед =          ТЗОстатки.Ед;
        докРН.Коэффициент = ТЗОстатки.Коэффициент;
        докРН.Кво =         ТЗОстатки.СписатьКво;        
        докРН.ЦенаСНДС =    ТЗОстатки.ЦенаСНДС;         
        докРН.СуммаСНДС =   докРН.Кво* докРН.ЦенаСНДС;
//=========================не трогать====================================================================
                      //----3----//
         Если докРН.СуммаДокНал>ТЗОстатки.Итог("СписатьКво") Тогда
          Сообщить (ТЗОстатки.Итог("СписатьКво"));    
          Сообщить ("Нехватает товара!!!");  
          возврат;      
         КонецЕсли;  
//=========================не трогать====================================================================                    
        
        
        

                      //----4----//
//    как расчитать сколько нужно списать колва в РН !!!!!!!!!!!  
        Если докРН.СуммаДокНал<докРН.Итог("СуммаСНДС") Тогда  
    
        докРН.ВыбратьСтроки();
        Пока докРН.ПолучитьСтроку()=1 Цикл //3
    
        ИзлишекСуммы=докРН.СуммаДокНал-докРН.Итог("СуммаСНДС");    
        сообщить("излишек"+    ИзлишекСуммы);
        // не обходимо пробежаться по строках в документе и убрать лишее!!!!!!    
        текКолСтрокРН = ТЗОстатки.КоличествоСтрок();
        Для ы = 1 По текКолСтрокРН Цикл      
           
        ТекКво= ОКР("помогите расчитать нужное колво!!!!");
        докРН.Кво =         ТекКво;        
        докРН.ЦенаСНДС =    ТЗОстатки.ЦенаСНДС;         
        докРН.СуммаСНДС =   докРН.Кво* докРН.ЦенаСНДС;
        
       КонецЦикла;        
       КонецЦикла;
       КонецЕсли;

                //----5----//
// возращаяю в таблицу ТЗОстатки-лишее кол-во товара из РН                
                
        докРН.ВыбратьСтроки();
        Пока докРН.ПолучитьСтроку()=1 Цикл //3                 
        
        ТЗОстатки.НоваяСтрока();          
        ТЗОстатки.СписатьКво=ТЗОстатки.СписатьКво-докРН.Кво;
        ТЗОстатки.СписатьЦенаСНДС= ТЗОстатки.ЦенаСНДС;
        ТЗОстатки.СписатьСумма= ТЗОстатки.СписатьКво*ТЗОстатки.СписатьЦенаСНДС;
        КонецЦикла;
        
                        
    
    
    
//=========================не трогать====================================================================    
        
        КонецЦикла;//2 конец     
        Сообщить(докРН.Контрагент);
        Сообщить("Итого"+докРН.Итог("СуммаСНДС"));           
    
    
    //=========================не трогать====================================================================        
        докРН.Записать();
        Сообщить(докРН.ТекущийДокумент()+"Создан!");
        Если флПроводить=1  Тогда
        докРН.Провести();
        Сообщить(докРН.ТекущийДокумент()+"Проведен!");                  
        КонецЕсли;  
    //====================================================================================================        
        КонецЦикла; //1 конец        
    КонецПроцедуры  
    
    //=====================================================================
    Процедура Удалить()
        Если ТЗОстатки.СписатьКво<=0 Тогда
            ТЗОстатки.УдалитьСтроку(ТЗОстатки.НомерСтроки);
        КонецЕсли;
    КонецПроцедуры


Немного изменила.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120005 · Ответов: 11 · Просмотров: 2059
 

>  Пересчет необходимого колва и суммы ТМЦ в РН (создаю программно!))
inna.innainna84
Отправлено: 01.12.16, 2:41


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Добрый вечер. Очень давно хотела обработку по Формированию РН из ТЗОстатков. Как смогла так и настряпала. Прошу не ругать меня.
1.Сначала я выбрала в ТЗКлиенты данные по контрагентам по 361 счету с отрицательным долгом
2.Набрала ВыбДок (это излишки по остаткам ТМЦ между Бух.базой и Складом и загрузила их в Расходную накладную по продажной цене)
3.Выгрузила эти излишки в ТЗОстатки
4.СоздатьОбъект("Документ.РасходнаяНакладная") и загружаю в ТЗОстатки
5. Необходимо их обработать
а)Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда
Сообщить ("Нехватает товара!!!");
прерываю!!!!!!!
б) Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда
и начинается самое ТРУДНОЕ 09000000.gif как расчитать ТекКво= если ТМЦ.БазЕдиница "шт". то ОКР, если "кг" оставляем как есть ("помогите расчитать нужное колво!!!!");
Я понимаю, что нужно пробежаться по строках в документе и убрать лишнее кво и вернуть его в ТЗОстатки для создания следующей РН !!!!!! 09000000.gif help.gif help.gif
Если не трудно подскажите
Процедура СоздатьДокРН()
  //=========================не трогать====================================================================        
                           //---1---//
//==========создаем расходныйе накладный по выбраным контрагентам==========  
                                         
        ТЗКлиенты.ВыбратьСтроки();
        Пока ТЗКлиенты.ПолучитьСтроку()=1 Цикл//1  начало
        докРН = СоздатьОбъект("Документ.РасходнаяНакладная");
        докРН.Новый();
        докРН.Фирма =          глВосстановитьЗначение(,"БазФирма");
        докРН.Валюта =         Константа.ОсновнаяВалюта;  
        докРН.Курс =           докРН.Валюта.Курс.Получить(докРН.ДатаДок);        
        докРН.ВидНДС =         докРН.Фирма.СтавкаНДС;
        докРН.ДатаДок =        ТекущаяДата();         
        докРН.Контрагент =        ТЗКлиенты.Контрагент;
        докРН.СуммаДокНал=     ТЗКлиенты.Долг;
        докРН.ВидТорговли =    докРН.Контрагент.ВидТорговли;    
        докРН.СчетКонтрагента =СчетПоКоду("361");
        докРН.МестоХранения =  ВыбСклад;    
//=========================не трогать====================================================================        
                     //----2----//
//==========создаем список ТМЦ в расходных накладных по выбраным контрагентам====  
        ТЗОстатки.ВыбратьСтроки();
        Пока ТЗОстатки.ПолучитьСтроку()=1 Цикл //2 начало
        докРН.НоваяСтрока();
        докРН.ТМЦ =         ТЗОстатки.ТМЦ;      
        докРН.Ед =          ТЗОстатки.Ед;
        докРН.Коэффициент = ТЗОстатки.Коэффициент;
        докРН.Кво =         ТЗОстатки.СписатьКво;        
        докРН.ЦенаСНДС =    ТЗОстатки.ЦенаСНДС;         
        докРН.СуммаСНДС =   докРН.Кво* докРН.ЦенаСНДС;
//=========================не трогать====================================================================
                      //----3----//
         Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда
          Сообщить ("Нехватает товара!!!");  
          возврат;      
         КонецЕсли;  
//=========================не трогать====================================================================                    
        
        
        

                      //----4----//
//    как расчитать сколько нужно списать колва в РН !!!!!!!!!!!  
        Если докРН.СуммаДокНал>докРН.Итог("СуммаСНДС") Тогда  
    
        докРН.ВыбратьСтроки();
        Пока докРН.ПолучитьСтроку()=1 Цикл //3
    
        ИзлишекСуммы=докРН.СуммаДокНал-докРН.Итог("СуммаСНДС");    
        сообщить("излишек"+    ИзлишекСуммы);
        // не обходимо пробежаться по строках в документе и убрать лишее!!!!!!    
              текКолСтрокРН = ТЗОстатки.КоличествоСтрок();
        Для ы = 1 По текКолСтрокРН Цикл      
           
            ТекКво= если ТМЦ.БазЕдиница "шт". то ОКР, если "кг" оставляем как есть ("помогите расчитать нужное колво!!!!");     
        докРН.Кво =         ТекКво;        
        докРН.ЦенаСНДС =    ТЗОстатки.ЦенаСНДС;         
        докРН.СуммаСНДС =   докРН.Кво* докРН.ЦенаСНДС;
        
       КонецЦикла;        
       КонецЦикла;
       КонецЕсли;

                //----5----//
// возращаяю в таблицу ТЗОстатки-лишее кол-во товара из РН                
                
           докРН.ВыбратьСтроки();
            Пока докРН.ПолучитьСтроку()=1 Цикл //3                 
        
            ТЗОстатки.НоваяСтрока();          
        ТЗОстатки.СписатьКво=ТЗОстатки.СписатьКво-докРН.Кво;
        ТЗОстатки.СписатьЦенаСНДС= ТЗОстатки.ЦенаСНДС;
        ТЗОстатки.СписатьСумма= ТЗОстатки.СписатьКво*ТЗОстатки.СписатьЦенаСНДС;
        КонецЦикла;
        
                        
    
    
    
//=========================не трогать====================================================================    
        
        КонецЦикла;//2 конец     
        Сообщить(докРН.Контрагент);
        Сообщить("Итого"+докРН.Итог("СуммаСНДС"));           
    
    
    //=========================не трогать====================================================================        
        докРН.Записать();
        Сообщить(докРН.ТекущийДокумент()+"Создан!");
        Если флПроводить=1  Тогда
        докРН.Провести();
        Сообщить(докРН.ТекущийДокумент()+"Проведен!");                  
        КонецЕсли;  
    //====================================================================================================        
        КонецЦикла; //1 конец        
    КонецПроцедуры  
    
    //=====================================================================
    Процедура Удалить()
        Если ТЗОстатки.СписатьКво<=0 Тогда
            ТЗОстатки.УдалитьСтроку(ТЗОстатки.НомерСтроки);
        КонецЕсли;
    КонецПроцедуры



//=========================не трогать==================================================================== Это я пишу для себя пометки, люблю сначала все поломать,а потом 3 часа вспоминать.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #120002 · Ответов: 11 · Просмотров: 2059
 

>  Функция счетчик не срабатывает в первом коде
inna.innainna84
Отправлено: 25.11.16, 18:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Посчитать количество Контрагентов которые приобрели данную категорию товара.Acid @ Сегодня, 17:36 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119766 · Ответов: 9 · Просмотров: 3180
 

>  Функция счетчик не срабатывает в первом коде
inna.innainna84
Отправлено: 25.11.16, 17:21


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Убала закоммет.контрагента Счеткик все также считает колво строк документе Acid @ Сегодня, 17:07 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119764 · Ответов: 9 · Просмотров: 3180
 

>  Функция счетчик не срабатывает в первом коде
inna.innainna84
Отправлено: 25.11.16, 16:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


нет есть только ниже |Контрагент= Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент,Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент; Acid @ Сегодня, 16:05 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119760 · Ответов: 9 · Просмотров: 3180
 

>  Функция счетчик не срабатывает в первом коде
inna.innainna84
Отправлено: 25.11.16, 15:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Процедура ПечатьПоКатегориям()     
    Перем Запрос,ТекстЗапроса, Таб;  

    Времяначало= ТекущееВремя();  
    
    СписокТоваров=СоздатьОбъект("СписокЗначений");
    СписокКлиентов=СоздатьОбъект("СписокЗначений");    
    СС=СоздатьОбъект("СписокЗначений");
    ФормированиеСписка(СписокТоваров,"Номенклатура","КатегорииТоваров",ВыбТовар,КатТоваров,МФВыбТовары,МФКатТоваров);
    ФормированиеСписка(СписокКлиентов,"Контрагенты","КатегорииКонтрагентов",ВыбКлиент,КатКлиентов,МФВыбКлиенты,МФКатКлиентов);
    
    
    Запрос = СоздатьОбъект("Запрос");       
    ТекстПеременных =       
    "//{{ЗАПРОС(Сформировать)      
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Фирма =             Регистр.ПартииТоваров.Фирма;
    |Товар =             Регистр.ПартииТоваров.Товар;
    |Категория =         Регистр.ПартииТоваров.Товар.КатегорияДляГруппировки;
    |Вес =               Регистр.ПартииТоваров.Товар.Вес;
    |Нетто =             Регистр.ПартииТоваров.Товар.Нетто;
    |ТекДокумент =       Регистр.ПартииТоваров.ТекущийДокумент;
    //|Контрагент=         Регистр.ПартииТоваров.Контрагент;
    |Контрагент=         Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент,Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент;
    |Количество =        Регистр.ПартииТоваров.ОстатокТовара;
    |Оборот =            Регистр.ПартииТоваров.Оборот;
    |КодОперации=        Регистр.ПартииТоваров.КодОперации;
    |";                  
    
    ТекстГруппировок = "      
    |Группировка Категория  без групп упорядочить по Категория.Наименование;  
    |Группировка Контрагент  без групп упорядочить по Контрагент.Наименование;
    |";  
    ТекстФункций = "                  
    |Функция КолРасход =   Расход(Количество);
    |Функция Сумма =       Сумма(Оборот);            
    |Функция ВесРасход =   Сумма(Запрос.КолРасход * Вес + Количество - Количество);
    |Функция НеттоРасход = Сумма(Запрос.КолРасход * Нетто + Количество - Количество);
    |Функция КолТТ = Счётчик(Контрагент);
    |";
    ТекстУсловий = "
    |Условие (Фирма = ВыбФирма);
    |Условие (ПустоеЗначение(Контрагент)=0);    
    //    |Условие (Оборот<>0);  
    |Условие (КодОперации В КодыОперацийПродажи);
    |Условие (Товар в СписокТоваров);
    |Условие (Контрагент в СписокКлиентов);
    |"//}}ЗАПРОС                      
;                       
    
    
    ТекстЗапроса = ТекстПеременных+РазделительСтрок+ТекстФункций+РазделительСтрок+ТекстГруппировок+РазделительСтрок+ТекстУсловий;
    
    Если глФильтрПоСправочнику("Номенклатура",0,0,КатТоваров,0,0,СписокТоваров,ТекстЗапроса,0,0,"Товар,,,СписокТоваров,,,,,")=0 Тогда
        Возврат;
    КонецЕсли;
    
    Если глФильтрПоСправочнику("Контрагенты",0,0,КатКлиентов,0,0,СписокКлиентов,ТекстЗапроса,0,0,"Контрагент,,,СписокКлиентов,,,,,")=0 Тогда
        Возврат;
    КонецЕсли;    
    
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;    
    
    
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);

    Запрос.ВНачалоВыборки();
    Пока Запрос.Группировка(1) = 1 Цикл    
          Таб.ВывестиСекцию("КатегорияТовара");         
    КонецЦикла;  
    

    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);  
    
    Таб.Показать("Сформировать по категории товара", "");
    
КонецПроцедуры


На печате Ставлю Запрос.КолТТ
Добрый подскажите пожалуйста как просчитать колвоТТ по выбраной категории товаров и почему Счетчик считает колво документов, если ему указано просчитать Контрагентов?
Во втором коде счетчик считает верно. Что я делаю не так?

ЗапросКлиенты= СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Считалочка)  
    |Клиент = Справочник.Контрагенты.ТекущийЭлемент;    
    |Группировка Клиент без групп упорядочить по Клиент.Наименование;
    |Условие(Клиент в ВыбКлиент);
    |Условие(Клиент в МФВыбКлиенты);
    |Функция Колвокл = Счётчик (Клиент);
    |"//}}ЗАПРОС
;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119757 · Ответов: 9 · Просмотров: 3180
 

>  Выборка данных из необходимых документов
inna.innainna84
Отправлено: 16.11.16, 23:47


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Да я согласна с вами опыта у меня нет. Коректировать регистр мне поможет знакомый специалист по 1с. (Правда к нему очень трудно достучатся). Все что я делаю я сначала тестирую на копии. Спасибо огромное вам за поучения. Sharzem @ Сегодня, 15:41 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119345 · Ответов: 17 · Просмотров: 4410
 

>  Выборка данных из необходимых документов
inna.innainna84
Отправлено: 16.11.16, 1:52


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Serg_XX @ 14.11.16, 15:09 * ,
Sharzem @ 14.11.16, 0:25 * ,
Я посмотрела, что пишет в регистры партии товара,
1)записи дублирует фирма-пусто и фирма с данными
2)контрагент и поставщик сюда записывает только поставщика который поставлял проданный товар в этой накладной. он не записывает контрагента в этом документе. Вот почему у меня не получалось правильно сформировать данные
Срабатывало только так:
|Контрагент= Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент,Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент;
3)Если уж так придираться мне вообще не стоило брать из регистра партии данные для отчета,
Возникла идея Дописать и откоректировать Регистр ОборотПродаж
1) в расходной, поставить условие , что вид документа=0 тогда данные из возврата поставщику сюда не подтянутся.
2) в приходной, поставить условие , что вид документа=1 тогда данные из возврата покупателя сюда не подтянутся.
3)Провести все документы за нужный период.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119299 · Ответов: 17 · Просмотров: 4410
 

>  Выборка данных из необходимых документов
inna.innainna84
Отправлено: 13.11.16, 22:24


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


1.Регистр.ПартииТоваров.Фирма пусто ! Используйте Фирма = Регистр.ПартииТоваров.ТекущийДокумент.Фирма если изменить вытягивает не понятные данные
2.Добавила через КодОперации все отлично работает быстрее прежнего приблизительно на 00:00;17, но Контрагент нужно указать через нужные документы иначе суммы не верны.
Запрос = СоздатьОбъект("Запрос");       
    ТекстПеременных =       
    "//{{ЗАПРОС(Сформировать)      
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Фирма =             Регистр.ПартииТоваров.Фирма;
    |Товар =             Регистр.ПартииТоваров.Товар;
    |Категория =         Регистр.ПартииТоваров.Товар.КатегорияДляГруппировки;
    |Вес =               Регистр.ПартииТоваров.Товар.Вес;
    |Нетто =             Регистр.ПартииТоваров.Товар.Нетто;
    |ТекДокумент =       Регистр.ПартииТоваров.ТекущийДокумент;    
    |Контрагент=         Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент,Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент;
    |Количество =        Регистр.ПартииТоваров.ОстатокТовара;
    |Оборот =            Регистр.ПартииТоваров.Оборот;
    |КодОперации=        Регистр.ПартииТоваров.КодОперации;
    |";                  
    
    ТекстГруппировок = "      
    |Группировка Категория  без групп упорядочить по Категория.Наименование;  
    |";  
    ТекстФункций = "                  
    |Функция КолРасход =   Расход(Количество);
    |Функция Сумма =       Сумма(Оборот);            
       |Функция ВесРасход =   Сумма(Запрос.КолРасход * Вес + Количество - Количество);
    |Функция НеттоРасход = Сумма(Запрос.КолРасход * Нетто + Количество - Количество);
    |";
    ТекстУсловий = "
    |Условие (Фирма = ВыбФирма);
    |Условие (ПустоеЗначение(Контрагент)=0);    
//    |Условие (Оборот<>0);  
    |Условие (КодОперации В СписКодыОпераций);
    |Условие (Товар в СписокТоваров);
    |Условие (Контрагент в СписокКлиентов);
    |"//}}ЗАПРОС                      
;

sava1 @ Вчера, 20:31 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119150 · Ответов: 17 · Просмотров: 4410
 

>  Выборка данных из необходимых документов
inna.innainna84
Отправлено: 12.11.16, 12:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Если я не укажу Оборот>0 или Оборот<0 тогда вытягиваются возвраты. Вы имеете в виду
|Оборот = Регистр.ПартииТоваров.Оборот; исправить?
Если вам не тяжело можете привести пример.
igmig65 @ Сегодня, 7:03 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119116 · Ответов: 17 · Просмотров: 4410
 

>  Выборка данных из необходимых документов
inna.innainna84
Отправлено: 12.11.16, 2:21


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Все. Исключила не нужные документы.(Сумма(Оборот) когда ((Оборот>0) и (ТекДокумент.Вид() = ""РасходнаяНакладная"")или(Оборот<0) и (ТекДокумент.Вид() = ""ПриходнаяНакладная""))wink.gif Единственное хотелось бы чтобы быстрее формировался. Можно ли что-то подправить?
Запрос = СоздатьОбъект("Запрос");       
    ТекстПеременных =       
    "//{{ЗАПРОС(Сформировать)      
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Фирма =          Регистр.ПартииТоваров.Фирма;
    |Товар =           Регистр.ПартииТоваров.Товар;    
    |Контрагент=    Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент,Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент;
    |ТекДокумент = Регистр.ПартииТоваров.ТекущийДокумент;
    |Вес =               Регистр.ПартииТоваров.Товар.Вес;
    |Нетто =            Регистр.ПартииТоваров.Товар.Нетто;
    |Категория =     Регистр.ПартииТоваров.Товар.КатегорияДляГруппировки;
    |Количество =    Регистр.ПартииТоваров.ОстатокТовара;
    |Оборот =         Регистр.ПартииТоваров.Оборот;
    |";                  
    
    ТекстГруппировок = "      
    |Группировка Категория  без групп упорядочить по Категория.Наименование;  
    |";  
    ТекстФункций = "                  
    |Функция КолРасход =   Расход(Количество);
    |Функция Сумма =       Сумма(Оборот) когда ((Оборот>0) и (ТекДокумент.Вид() = ""РасходнаяНакладная"")или(Оборот<0) и (ТекДокумент.Вид() = ""ПриходнаяНакладная""));              
       |Функция ВесРасход =   Сумма(Запрос.КолРасход * Вес + Количество - Количество);
    |Функция НеттоРасход = Сумма(Запрос.КолРасход * Нетто + Количество - Количество);
    |";
    ТекстУсловий = "
    |Условие(Фирма = ВыбФирма);
    |Условие(ПустоеЗначение(Контрагент)=0);
    |Условие(Товар в СписокТоваров);
    |Условие(Контрагент в СписокКлиентов);
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119113 · Ответов: 17 · Просмотров: 4410
 

>  Выборка данных из необходимых документов
inna.innainna84
Отправлено: 11.11.16, 23:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


//************************************   

Процедура ПечатьПоКатегориям()
    Перем Запрос,ТекстЗапроса, Таб;
    Времяначало= ТекущееВремя();
    СписокТоваров=СоздатьОбъект("СписокЗначений");
    СписокКлиентов=СоздатьОбъект("СписокЗначений");
    
    СС=СоздатьОбъект("СписокЗначений");
    ФормированиеСписка(СписокТоваров,"Номенклатура","КатегорииТоваров",ВыбТовар,КатТоваров,МФВыбТовары,МФКатТоваров);
    ФормированиеСписка(СписокКлиентов,"Контрагенты","КатегорииКонтрагентов",ВыбКлиент,КатКлиентов,МФВыбКлиенты,МФКатКлиентов);

    
            
    
    Запрос = СоздатьОбъект("Запрос");       
    ТекстПеременных =       
    "//{{ЗАПРОС(Сформировать)      
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Фирма =             Регистр.ПартииТоваров.Фирма;
    |Товар =             Регистр.ПартииТоваров.Товар;  
    |Контрагент=         Регистр.ПартииТоваров.Контрагент;
    |ТекДокумент =       Регистр.ПартииТоваров.ТекущийДокумент;
    |Вес =               Регистр.ПартииТоваров.Товар.Вес;
    |Нетто =             Регистр.ПартииТоваров.Товар.Нетто;
    |Категория =         Регистр.ПартииТоваров.Товар.КатегорияДляГруппировки;
    |Количество =        Регистр.ПартииТоваров.ОстатокТовара;
    |Оборот =            Регистр.ПартииТоваров.Оборот;  
    |";
                    
    ТекстФункций = "                  
    |Функция КолРасход =   Расход(Количество);                  
    |Функция Сумма =       Сумма(Оборот);                              
    |Функция ВесРасход =   Сумма(Запрос.КолРасход * Вес + Количество - Количество);
    |Функция НеттоРасход = Сумма(Запрос.КолРасход * Нетто + Количество - Количество);
    |";
    
    ТекстГруппировок = "      
    |Группировка Категория  без групп упорядочить по Категория.Наименование;  
    |";  
            
    ТекстУсловий = "
    |Условие(Фирма = ВыбФирма);
    |Условие(Товар в СписокТоваров);
    |Условие(Контрагент в СписокКлиентов) ;
    |Условие(ПустоеЗначение(Контрагент)=0);      
    |"//}}ЗАПРОС                      
;                       

    ТекстЗапроса = ТекстПеременных+РазделительСтрок+ТекстФункций+РазделительСтрок+ТекстГруппировок+РазделительСтрок+ТекстУсловий;

    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;         
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("проба");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    // посщитаем кол-во клиентов  
    
    
            
    Запрос.ВНачалоВыборки();  
    Пока Запрос.Группировка(1) = 1 Цикл
        
        Док=Запрос.ТекДокумент;  
        
        Если Док.Вид()="РасходнаяНакладная" Тогда         
            Если Док.ВидОперации=0 Тогда          

            КонецЕсли;
        КонецЕсли;
        
                    
                        
         Если Док.Вид()="ПриходнаяНакладная" Тогда
                    Если Док.ВидОперации=1 Тогда                   
        КонецЕсли;
    КонецЕсли;

    
        Таб.ВывестиСекцию("КатегорияТовара");         
    КонецЦикла;
    
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);  
    
    Таб.Показать("Сформировать по категории товара", "");
    
КонецПроцедуры  

//****************************************************************

Мне нужно выбрать сумму и колворасход из расходной накладной без возврата поставщику и из приходной без возврата покупателя, так как форма док едина. Я уже не знаю, что делать. Вариант указать Док.ВидОперации, но что-то по незнанию не получается. Подскажите пожалуйста.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #119090 · Ответов: 17 · Просмотров: 4410
 

>  Не правильно формирует вес
inna.innainna84
Отправлено: 07.11.16, 15:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Да, вы очень помогли. Спасибо. Функция ВесРасход = Сумма(Запрос.КолРасход * Вес + Количество - Количество).
Контрагента выбираю через Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент, Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент
и создала на каждую группировку -Печать1() Печать2() и тд. теперь формирует очень быстро. И поставила |Условие (ПустоеЗначение(Контрагент)=0); тогда убирает поставщиков из приходки.

Sharzem @ Сегодня, 10:51 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #118773 · Ответов: 23 · Просмотров: 3493
 

>  Не правильно формирует вес
inna.innainna84
Отправлено: 06.11.16, 23:50


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Я понимаю, что это не правильно. Чтобы быстрее формировались данные можно не сколько видов печати?
печать 1 -группирует только категория товара
печать 2 -группирует категория+контрагент
печать 3 -группирует категория+контрагент+товар
печать 4 -группирует категория+контрагент+товар+текдок
печать 5 -группирует категория+товар
засекала время группирует категорию товара -по сформировать по всем группировкам с выборкой только категория товара-1 минута 5 сек,
а при печать (1) - 19 секунд.


inna.innainna84 @ Сегодня, 20:35 * ,


Еще вариант
|ТекДок = Регистр.ПартииТоваров.ТекущийДокумент; // это оставляю !!!!!!!!
а
|Контрагент= Регистр.ПартииТоваров.ТекущийДокумент.РасходнаяНакладная.Контрагент, Регистр.ПартииТоваров.ТекущийДокумент.ПриходнаяНакладная.Контрагент; //указываю вид документа
и добавляю
|Условие (ПустоеЗначение(Контрагент)=0); // тогда удаляет поставщиков


inna.innainna84 @ Сегодня, 23:11 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #118736 · Ответов: 23 · Просмотров: 3493
 

>  Не правильно формирует вес
inna.innainna84
Отправлено: 06.11.16, 20:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 108
Регистрация: 30.01.14
Пользователь №: 33049


Не выбрала потому, что данные с приходной(возврат от покупателя) не записываются в регистр оборот товара. Нужна фактич. сумма продажи. (расход-возврат).Если я не права, сообщите пожалуйста. Sharzem @ Сегодня, 18:28 * ,
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #118734 · Ответов: 23 · Просмотров: 3493
 

5 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.11.20, 12:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!