Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Выгрузка справочника ТМЦ в Ексель          
kostya77 Подменю пользователя
сообщение 07.06.23, 6:15
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 132
Спасибо сказали: 5 раз
Рейтинг: 4

Добрый день. Подскажите, как реализовать выгрузку в ексель справочника ТМЦ.

Сообщение отредактировал Vofka - 07.06.23, 8:10

denis84 Подменю пользователя
сообщение 07.06.23, 7:06
Сообщение #2

Оратор
Иконка группы
Группа: Местный
Сообщений: 438
Из: Украина
Спасибо сказали: 143 раз
Рейтинг: 144.5

kostya77 @ Сегодня, 7:15 * ,
Добрый день! Написать обработку, котрая сформирует печатную форму и потом сохранить в эксель. Ещё встречал обработку: "Универсальный отчет: Печать содержимого справочника" refprint.ert называеться

Сообщение отредактировал denis84 - 07.06.23, 7:08

kostya77 Подменю пользователя
сообщение 07.06.23, 7:41
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 132
Спасибо сказали: 5 раз
Рейтинг: 4

denis84 @ Сегодня, 8:06 * ,
Можно пример обработки?

denis84 Подменю пользователя
сообщение 07.06.23, 9:23
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 438
Из: Украина
Спасибо сказали: 143 раз
Рейтинг: 144.5

kostya77 @ Сегодня, 8:41 * ,
Пример формирования данных по справочнику контрагентов, печатную форму можно сохранить в эксель
//*******************************************
// Процедура генерации запроса Сформировать.
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ТекущийЭлемент = Справочник.Контрагенты.ТекущийЭлемент;
    |Наименование = Справочник.Контрагенты.Наименование;
    |Родитель = Справочник.Контрагенты.Родитель;
    |ЕДРПОУ = Справочник.Контрагенты.ЕДРПОУ;
    |Группировка ТекущийЭлемент без групп;
    |Условие (ТекущийЭлемент.ПринадлежитГруппе(ВыбРодитель) = 1);
    |"//}}ЗАПРОС
;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей ТекущийЭлемент
        Таб.ВывестиСекцию("ТекущийЭлемент");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры

Pepe Подменю пользователя
сообщение 07.06.23, 10:14
Сообщение #5

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1434
Из: Ужгород
Спасибо сказали: 761 раз
Рейтинг: 230

Цитата(kostya77 @ 07.06.23, 8:41) *
Можно пример обработки?

Мыло для передачи готовой внешней обработки в студию.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.05.24, 14:22
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!