Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Зависла номерация поручения , 1С:Предприятие 8.3 (8.3.10.2252)          
admin@stark.ua Подменю пользователя
сообщение 26.09.18, 13:23
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

"Управление торговым предприятием для Украины", редакция 1.2. (1.2.45.2)

Добрый день. Помогите с такой проблемой. При формировании Платежного поручения в Номере поручения автоматически выбивается какой то старый номер и всегда один и тот же. После чего это произошло - неизвестно. Ставим правильные номера вручную. Но когда платежек по 30 шт. - напрягает руками изменять (( Подскажите как исправить эту проблему?

Володька Подменю пользователя
сообщение 26.09.18, 15:57
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 104
Спасибо сказали: 4 раз
Рейтинг: 3

admin@stark.ua @ Сегодня, 14:23 * ,
В Бухгалтерии для Украины есть соответствующий регистр (Нумерация), попробуйте и в УТП поискать.

vita2011 Подменю пользователя
сообщение 26.09.18, 21:58
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 85
Спасибо сказали: 45 раз
Рейтинг: 17

Цитата(admin@stark.ua @ 26.09.18, 14:23) *
выбивается какой то старый номер и всегда один и тот же

Нумерация платежек ежегодно начинается с единицы для каждого расчетного счета. В окне платежных документов выбираем период 2018 года. В окошко поиска вбиваем номер на единицу меньше "старого номера". Таким образом находим ошибочный номер и изменяем его.



admin@stark.ua Подменю пользователя
сообщение 27.09.18, 7:53
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

vita2011 @ Вчера, 22:58 * ,
Проблема не в номере документа, а номере поручения (( Номер я знаю как исправить.

vita2011 Подменю пользователя
сообщение 27.09.18, 20:59
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 85
Спасибо сказали: 45 раз
Рейтинг: 17

Так ведь
Цитата(admin@stark.ua @ 27.09.18, 8:53) *
номер поручения
и имелся ввиду.


vita2011 @ Сегодня, 21:54 * ,
выбивается какой то старый номер и всегда один и тот же - это номер 5641 ? И его нужно исправить на 5777 ?

admin@stark.ua Подменю пользователя
сообщение 28.09.18, 7:55
Сообщение #6

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

vita2011 @ Вчера, 21:59 * ,
Такого документа уже нет (((

awp Подменю пользователя
сообщение 28.09.18, 8:26
Сообщение #7

Оратор
Иконка группы
Группа: Местный
Сообщений: 395
Спасибо сказали: 37 раз
Рейтинг: 24

admin@stark.ua @ Сегодня, 8:55 * ,

В модуле документа есть код - курите:

Процедура УстановитьНомерПоручения()
    
    Если глЗначениеПеременной("ИспользоватьУправляемыеБлокировки") Тогда
        СтруктураПараметровБлокировка = Новый Структура("ТипТаблицы, ИмяТаблицы", "Справочник", "БанковскиеСчета");
        
        ЗначенияБлокировки = Новый Структура;
        ЗначенияБлокировки.Вставить("Ссылка",      СчетОрганизации);
        ОбщегоНазначения.УстановитьУправляемуюБлокировку(СтруктураПараметровБлокировка, ЗначенияБлокировки, , Ложь, "");
    КонецЕсли;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ДатаНачалаГода", НачалоГода(Дата));
    Запрос.УстановитьПараметр("ДатаКонцаГода", КонецГода(Дата));
    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("СчетОрганизации", СчетОрганизации);
    Запрос.УстановитьПараметр("Ссылка", Ссылка);

    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ
    |    НомерПоручения КАК НомерПоручения
    |ИЗ
    |    Документ.ПлатежноеПоручениеИсходящее КАК ПлатежноеПоручение
    |
    |ГДЕ
    |    ПлатежноеПоручение.Организация = &Организация
    |    //самого себя не учитываем
    |    И ПлатежноеПоручение.Ссылка <> &Ссылка
    |    И ПлатежноеПоручение.СчетОрганизации = &СчетОрганизации
    |    И ПлатежноеПоручение.Дата >= &ДатаНачалаГода
    |    И ПлатежноеПоручение.Дата <= &ДатаКонцаГода";

    СписокПлатежек = Запрос.Выполнить().Выбрать();
    
    ТаблицаЗначений = Новый ТаблицаЗначений;
    
    ТаблицаЗначений.Колонки.Добавить("Номер");
    ТаблицаЗначений.Колонки.Добавить("Длина");

    Пока СписокПлатежек.Следующий() Цикл
        НоваяСтрока = ТаблицаЗначений.Добавить();
        НоваяСтрока.Номер = СписокПлатежек.НомерПоручения;
        НоваяСтрока.Длина = СтрДлина(СписокПлатежек.НомерПоручения);
    КонецЦикла;
    
    ТаблицаЗначений.Сортировать("Длина Убыв, Номер Убыв");
    
    Если ТаблицаЗначений.Количество() > 0 Тогда
        Попытка
            НомерПоручения = Формат(Число(ТаблицаЗначений[0].Номер) + 1, "ЧГ=0");
        Исключение
            НомерПоручения = 1;    
        КонецПопытки;
    Иначе
        НомерПоручения = 1;
    КонецЕсли;
    
КонецПроцедуры


Signature
Бухгалтер - это не профессия! Это диагноз!

admin@stark.ua Подменю пользователя
сообщение 08.10.18, 11:11
Сообщение #8

Молчаливый
*
Группа: Пользователи
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

awp @ 28.09.18, 9:26 * ,Разобрался. Может кому будет интересно. Бухгалтер изменила вручную номер поручения и к 4-х значному числу добавила точку в конце (2525.), а программа когда когда ищет последнюю платежку сортирует и по номеру платежного документа и по длине (количество знаков). Убрали точку, все заработало. Проблема решена. Спасибо.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.11.18, 20:11
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне