Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Программное определение проведения документа в 1с 8          
Gigi Подменю пользователя
сообщение 07.06.17, 12:02
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 132
Спасибо сказали: 0 раз
Рейтинг: 0

Всем привет!
Перейду сразу к делу...
Как программно определить факт проведения документа? Т.е. он записан и проведен или только записан, но не проведен?
Вот код в котором все с комментарием где это нужно:

&НаСервере
Процедура УдалитьДоументыПоказаний_ОбъектПериод(ОбъектПринадлежностиКОД,ОтчетныйМесяц)
// Ставим пометку на удаление
ВыборкаДокументов = Документы.ТочкаУчетаПоказания.Выбрать();
//=================================================
Пока ВыборкаДокументов.Следующий() Цикл
ДокВыборки = ВыборкаДокументов.ПолучитьОбъект();
//-------------------------------------------------

//ЗДЕСЬ НУЖЕНО ОПРЕДЕЛИТЬ ДОКУМЕНТ ПРОВЕДЕН ИЛИ НЕТ!
//КАК ЭТО СДЕЛАТЬ?
//НИГДЕ НЕ НАШЕЛ ИНФУ ОБ ЭТОМ... ПОЭТОМУ ОПЯТЬ ПРИХОДИТЬСЯ МЕТОДОМ ТЫКА.. КАК ЭТОТ ВАРИАНТ:
//Если ДокВыборки.Проведение=Ложь; Тогда знДокументПроведен="Нет"; КонецЕсли;
//КОТОРЫЙ НЕ РАБОТАЕТ! :):) ИНОГДА ПОПАДАЛ, А НА ЭТОТ РАЗ НЕТ! :):)


//-------------------------------------------------
ДокВыборки_ОбъектПринадлКод = ДокВыборки.ОбъектПринадлКод;
ДокВыборки_ОтчПериодМесяц=ДокВыборки.ОтчетныйПериодМесяц;
//-------------------------------------------------
Если знДокументПроведен="Нет" и ДокВыборки_ОбъектПринадлКод=ОбъектПринадлежностиКОД и ДокВыборки_ОтчПериодМесяц=ОтчетныйМесяц Тогда
ДокВыборки.УстановитьПометкуУдаления(Истина);
ДокВыборки.Записать();
ДокВыборки.Удалить();
КонецЕсли;
//-------------------------------------------------
КонецЦикла;
//=================================================
КонецПроцедуры

К сожалению опять нужна Ваша помощь.
Нужно просто вставить код в указанную линию и все.
Буду признателен!

Vofka Подменю пользователя
сообщение 07.06.17, 12:05
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12336
Из: Киев
Спасибо сказали: 3649 раз
Рейтинг: 2789.4

Если ДокВыборки.Проведен Тогда


Signature
Услуги 1С программиста

Спасибо сказали: Gigi,

Gigi Подменю пользователя
сообщение 07.06.17, 12:15
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 132
Спасибо сказали: 0 раз
Рейтинг: 0

Vofka @ Сегодня, 13:05 * ,
Спасибо!
Быстро и коротко и ясно!
Супер сайт! Реакция моментальная!
Поэтому спасибо и этому сайту!

Vidocq05 Подменю пользователя
сообщение 07.06.17, 13:13
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 58
Из: Сумы
Спасибо сказали: 13 раз
Рейтинг: 13

Gigi @ Сегодня, 13:15 * ,
Похоже Вы не знаете что такое "Точка останова" и "Вычислить выражение". Советую ознакомится и жить станет легче.

Пардон. Не заметил, что процедура на сервере

Bernet Подменю пользователя
сообщение 07.06.17, 13:25
Сообщение #5

Оратор
*****
Группа: Пользователи
Сообщений: 369
Из: Хмельницкий
Спасибо сказали: 97 раз
Рейтинг: 94.5


Кстати, по поводу быстроты реакции, было бы наверно прикольно сделать либо какого-то бота в Телеграме или Вайбере, который бы оповещал об ответах в топиках, или просто о создании новых тем и т.д. Vofka, как считаете насколько это реально и нужно?)


Signature
Дописываю конфигурации на платформе 8.х.
- Управление торговым предприятием для Украины
- Управление производственным предприятием для Украины
- Управление небольшой фирмой для Украины
- Бухгалтерия для Украины;
- Общепит для Украины
- Ресторан (Рарус)
- Розница

Спасибо сказали: Gigi,

Vidocq05 Подменю пользователя
сообщение 07.06.17, 13:32
Сообщение #6

Говорящий
***
Группа: Пользователи
Сообщений: 58
Из: Сумы
Спасибо сказали: 13 раз
Рейтинг: 13

Цитата(Vidocq05 @ 07.06.17, 14:13) *
Похоже Вы не знаете что такое "Точка останова" и "Вычислить выражение". Советую ознакомится и жить станет легче.

Пардон. Не заметил, что процедура на сервере


Я забыл как работают управляемые формы! Позор мне

Спасибо сказали: Gigi,

Gigi Подменю пользователя
сообщение 07.06.17, 14:46
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 132
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(Vidocq05 @ 07.06.17, 14:32) *
Я забыл как работают управляемые формы! Позор мне

Да ниче.. ерунда ..
Ша уже вот в таком виде .. знаю. что вам это не нужно ... это так ... для тех которые как я шастают по форумам:
&НаСервере
Процедура УдалитьДоументыПоказаний_ОбъектПериод(КонфигуратЭлемент,ОбъектПринадлежностиКОД,ОтчетныйМесяц)
// Ставим пометку на удаление
ВыборкаДокументов = Документы[КонфигуратЭлемент].Выбрать();
//=================================================
Пока ВыборкаДокументов.Следующий() Цикл
ДокВыборки = ВыборкаДокументов.ПолучитьОбъект();
//-------------------------------------------------
ДокВыборки_ОбъектПринадлКод = ДокВыборки.ОбъектПринадлКод;
ДокВыборки_ОтчПериодМесяц=ДокВыборки.ОтчетныйПериодМесяц;
//-------------------------------------------------
Если ДокВыборки.Проведен=Ложь и ДокВыборки_ОбъектПринадлКод=ОбъектПринадлежностиКОД и ДокВыборки_ОтчПериодМесяц=ОтчетныйМесяц Тогда
//Сообщить(ДокВыборки_ОтчПериодМесяц+" -- "+ДокВыборки);
ДокВыборки.УстановитьПометкуУдаления(Истина); // Пометка на удаление
ДокВыборки.Записать();
ДокВыборки.Удалить(); // Удаление
КонецЕсли
//-------------------------------------------------
КонецЦикла;
//=================================================
КонецПроцедуры


Цитата(Bernet @ 07.06.17, 14:25) *
Кстати, по поводу быстроты реакции, было бы наверно прикольно сделать либо какого-то бота в Телеграме или Вайбере, который бы оповещал об ответах в топиках, или просто о создании новых тем и т.д. Vofka, как считаете насколько это реально и нужно?)

Нужно нужно smile.gifsmile.gif Все нужно! smile.gifsmile.gif
И привет и ответ..
Ладно! Главное... хоть и не супер красиво, но на данном этапе развития smile.gifsmile.gif доволен результатом.
Еще раз всем спасибо за реакцию!
Пока!


Vofka Подменю пользователя
сообщение 07.06.17, 15:52
Сообщение #8

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12336
Из: Киев
Спасибо сказали: 3649 раз
Рейтинг: 2789.4

Цитата(Bernet @ 07.06.17, 14:25) *
Кстати, по поводу быстроты реакции, было бы наверно прикольно сделать либо какого-то бота в Телеграме или Вайбере, который бы оповещал об ответах в топиках, или просто о создании новых тем и т.д. Vofka, как считаете насколько это реально и нужно?)

Насчет нужно или нет - ответить сложно, т.к. это субъективно: кому-то нужно, кому-то будет надоедать. Эту проблему можно решить, сделать это как-то опционально, чтобы человек сам себе выбирал. Но тут мы упираемся в то, что это нужно реализовать, т.е. программировать. "Штатных" программистов у нас сейчас всего один, я crazy.gif . Сам я сейчас не могу оценить трудоемкость этой разработки. Сколько это может стоить, чтобы нанять кого-то - я тоже не знаю, но думаю, что сумма получится не меньше, чем с 4 нулями. А сайт у нас так то не коммерческий и лишних денег он не приносит. Кроме того ещё возникает вопрос о том, сколько денег могут стоить услуги отправки различных сообщений. Так, например, я знаю, что открытого АПИ у Вайбера нету (либо я чего-то не знаю) и у нас был проектик, где мы пробовали работать с Вайбером через стороннего провайдера (как провайдер взаимодействует с Вайбером я уже не знаю), который берет за это бабло.

Идея не плохая, но сил и денег в её реализацию придется вложить заметно. А многим ли такое нужно - это вопрос smile.gif .


Signature
Услуги 1С программиста

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 24.09.17, 10:29
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне