Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Получить Текущую Строку Списка с помощью процедуры из общего модуля          
Gigi Подменю пользователя
сообщение 30.05.17, 15:07
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 137
Спасибо сказали: 0 раз
Рейтинг: 0

Привет всем!
проблема такая...
Накидал малый код функции для получения текущей выделенной строки списка
Поскольку в синтаксис помощнике инфа довольно скупая и размытая.... сколько пробовал разные варианты и еле попал в то, как по синтаксису правильно написать... буквально методом тыка и догадкой
И вроде получилось попасть как эту ерунду правильно написать, вот в таком вот виде:
&НаКлиенте
Функция Получить_ТекущуюСтрокуСписка(ИмяСписка,Столбец) Экспорт
//------------------------------------------------------
ТекСтрока= Элементы[ИмяСписка].ТекущаяСтрока;
ТекСтрокаЗнСтолбца = Элементы[ИмяСписка].ДанныеСтроки(ТекСтрока)[Столбец];
Возврат ТекСтрокаЗнСтолбца;
//------------------------------------------------------
КонецФункции

Вроде все путем, но просто охота это перенести в общий модуль
Но как только перенес в общий модуль то, на линии: "Элементы" естественно выдает ошибку и пишет:
Цитата
{ОбщийМодуль.Fx_Список.Модуль(4,12)}: Переменная не определена (Элементы)
ТекСтрока= <<?>>Элементы[ИмяСписка].ТекущаяСтрока; (Проверка: Тонкий клиент)
{ОбщийМодуль.Fx_Список.Модуль(5,22)}: Переменная не определена (Элементы)
ТекСтрокаЗнСтолбца = <<?>>Элементы[ИмяСписка].ДанныеСтроки(ТекСтрока)[Столбец]; (Проверка: Тонкий клиент)

Так что, прошу помощи.
Может для общего модуля кто подкорректирует, если не сильно накладно и сложно.
Буду признателен!

logist Подменю пользователя
сообщение 30.05.17, 15:21
Сообщение #2

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 8864
Из: Харьков
Спасибо сказали: 2354 раз
Рейтинг: 1436.9

Элементы тоже передавайте в общий модуль.

Функция Получить_ТекущуюСтрокуСписка(Элементы, ИмяСписка, Столбец) Экспорт


p.s. но тут опять же становится вопрос начальной задачи, нахрена всё это, если это можно сделать в форме одной строкой
ЗначениеКолонки = Элементы.ИмяСписка.ТекущиеДанные.ИмяКолонки;

даже если подумать, что вам нужна унифицированная процедура, то она бы выглядела скорее так
&НаКлиенте
Функция Получить_ТекущуюСтрокуСписка(ЭлементСписок, ИмяКолонки) Экспорт
// где ЭлементСписок это сам элемент списка
    Возврат ЭлементСписок.ТекущиеДанные[ИмяКолонки];
КонецФункции


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Спасибо сказали: Gigi,

Petre Подменю пользователя
сообщение 30.05.17, 15:23
Сообщение #3

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2111
Из: Київ, Україна
Спасибо сказали: 491 раз
Рейтинг: 459.6

Gigi @ Сегодня, 16:07 * ,
"Элементы" - контекст "ЭтотОбъект" / "ЭтаФорма".


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: Gigi,

Bernet Подменю пользователя
сообщение 30.05.17, 15:24
Сообщение #4

Оратор
Иконка группы
Группа: Местный
Сообщений: 394
Из: Хмельницкий
Спасибо сказали: 106 раз
Рейтинг: 100.5

Gigi @ Сегодня, 16:07 * ,
Если функция будет в общем модуле, то должна быть включена галочка "Клиент (управляемое приложение)"
Функция Получить_ТекущуюСтрокуСписка(Элементы, ИмяСписка, Столбец) Экспорт
   ТекСтрока= Элементы[ИмяСписка].ТекущаяСтрока;
   ТекСтрокаЗнСтолбца = Элементы[ИмяСписка].ДанныеСтроки(ТекСтрока)[Столбец];
   Возврат ТекСтрокаЗнСтолбца;
КонецФункции


В формах где будете вызывать пишите такой код:
     ТекущееЗначение = ВашОбщийМодуль.Получить_ТекущуюСтрокуСписка(Элементы, "ВашаТаблица", "ВашСтолбец");


Signature
Дописываю конфигурации на платформе 8.х.
- Управление торговым предприятием для Украины
- Управление производственным предприятием для Украины
- Управление небольшой фирмой для Украины
- Бухгалтерия для Украины;
- Общепит для Украины
- Ресторан (Рарус)
- Розница

Спасибо сказали: Gigi,

Gigi Подменю пользователя
сообщение 30.05.17, 15:49
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 137
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(logist @ 30.05.17, 16:21) *
p.s. но тут опять же становится вопрос начальной задачи, нахрена всё это, если это можно сделать в форме одной строкой
ЗначениеКолонки = Элементы.ИмяСписка.ТекущиеДанные.ИмяКолонки;

Ну и ладно .. можно и в таком виде ... не важно .. я просто сам че то накидал.. то как мог.. а так думаю и вправду лучше.
Цитата(Bernet @ 30.05.17, 16:24) *
галочка "Клиент (управляемое приложение)"

Да! так и сделал и теперь все выглядит вот так:

&НаКлиенте
Процедура Тест(Команда)
знИмяКолонки="Код";
ТекСтрока=Fx_Список.ПолучитьТекущуюСтрокуСписка(Элементы.ТочкиУчетаСписок, знИмяКолонки);
Сообщить(ТекСтрока);    
КонецПроцедуры

//В общем модуле: "Fx_Список"
Функция ПолучитьТекущуюСтрокуСписка(ЭлементСписок, ИмяКолонки) Экспорт
//где ЭлементСписок это сам элемент списка
Возврат ЭлементСписок.ТекущиеДанные[ИмяКолонки];
КонецФункции

Все работает!
Первый раз без кучи дискуссий!
Спасибо всем!




logist Подменю пользователя
сообщение 30.05.17, 23:04
Сообщение #6

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 8864
Из: Харьков
Спасибо сказали: 2354 раз
Рейтинг: 1436.9

Цитата(Gigi @ 30.05.17, 16:49) *
знИмяКолонки="Код";
ТекСтрока=Fx_Список.ПолучитьТекущуюСтрокуСписка(Элементы.ТочкиУчетаСписок, знИмяКолонки);

Не создавайте не нужный хлам переменных
ТекСтрока=Fx_Список.ПолучитьТекущуюСтрокуСписка(Элементы.ТочкиУчетаСписок, "Код");


Цитата(Gigi @ 30.05.17, 16:49) *
Первый раз без кучи дискуссий!

Это может быть не вашей заслугой, а людей которые научились понимать wink.gif


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.10.17, 21:26
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне