Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Поиск в таблице значений , Поиск через построитель запросов          
cao0603 Подменю пользователя
сообщение 09.06.17, 9:30
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

У меня есть массив слов,мне необходимо проверить наличие каждого это слова в таблице и отобрать только ту строчку где есть вся комбинация этих слов,не важно в каком порядке

Пробовал через
Построитель=новый построитель запросов
Но в цикле не получилось

Petre Подменю пользователя
сообщение 09.06.17, 10:02
Сообщение #2

Крутой
Иконка группы
Группа: Местный
Сообщений: 1976
Из: Київ, Україна
Спасибо сказали: 445 раз
Рейтинг: 429.9

Бывает. Но вы не теряйте надежды, пробуйте еще...


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Vidocq05 Подменю пользователя
сообщение 09.06.17, 10:28
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 35
Из: Сумы
Спасибо сказали: 11 раз
Рейтинг: 11

cao0603 @ Сегодня, 10:30 * ,

Если таблица это ТаблицаЗначений то както так...

Для Каждого СтрТЗ Из ВашаТЗ Цикл 
        
        НайденоСовпадение = Ложь;
        
        Для Каждого СтрМас Из ВашМассив Цикл
            
            Результат = Найти(СтрТЗ.ВашаКолонка,СтрМас);
            
            Если Результат = 0 Тогда
                НайденоСовпадение = Ложь;
                Прервать;
            Иначе
                НайденоСовпадение = Истина;
            КонецЕсли;
            
        КонецЦикла;
        
        Если НайденоСовпадение Тогда
            
            // Делаете со строкой что нужно
            
        КонецЕсли;
    КонецЦикла;


Спасибо сказали: cao0603,

cao0603 Подменю пользователя
сообщение 09.06.17, 20:27
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Vidocq05 @ Сегодня, 11:28 * ,
гениально чувак, спасибо большое, а более сложные алгоритм знаеТЕ?
у меня есть например
болт 2-8-10-кд ост 133078
болт 3-8-12ц ост 133078
и вывести насколько они совпадают
но это не значит что у меня все строки в таком формате, у них может быть совершенно любой разделительный символ и формат

cao0603 @ Сегодня, 21:00 * ,
и если например 100% совпадения нет то подобрать варианты со схожими значениями

Vidocq05 @ Сегодня, 11:28 * ,

что-то тип это [необходимо зарегистрироваться для просмотра ссылки]


 ! 

Правила: 1
 


Сообщение отредактировал Vofka - 12.06.17, 8:34

Vofka Подменю пользователя
сообщение 12.06.17, 8:34
Сообщение #5

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12279
Из: Киев
Спасибо сказали: 3620 раз
Рейтинг: 2757.5

cao0603,
1. Правила, пункт 1!
2. Для спасибо есть специальная кнопка.


Signature
Услуги 1С программиста

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 22.06.17, 22:34
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне