Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Печать документа на общей форме "ПечатьДокументов" ориентация страницы          
Constantus Подменю пользователя
сообщение 15.11.17, 9:29
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 622
Спасибо сказали: 2 раз
Рейтинг: 2

Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал печать документа на основе общей формы "ПечатьДокументов".

Но печать вышла с книжной ориентацией, а требуется печать по-умолчанию в альбомной ориентации. Как такое сделать?

Процедура НапечататьДокумент1(ПечДокумент, КоличествоЭкземпляров = 1, НаПринтер = Ложь, Заголовок = "") Экспорт
Если ПечДокумент = Неопределено тогда
    Возврат;
КонецЕсли;
// Получить необходимое количество копий
Если КоличествоЭкземпляров < 1 Тогда
    ПечДокумент.КоличествоЭкземпляров = 1;
Иначе
     ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров;
КонецЕсли;
Если НаПринтер Тогда
     ПечДокумент.Напечатать();
Иначе
// Отобразить печатный документ на экране
    ФормаПечати = ПолучитьОбщуюФорму("ПечатьДокументов",, ПечДокумент);
    ФормаПечати.ПечатныйДокумент = ПечДокумент;
    ФормаПечати.Заголовок = Заголовок;
    ФормаПечати.Открыть();
КонецЕсли;
КонецПроцедуры // НапечататьДокумент()


В функции формирования табличного документа стоит ориентация

    Если ШК Тогда
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    Иначе
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    КонецЕсли;
    

    Возврат ТабДок;




Извините, поспешил...

В модуле общей формы при открытии добавил код

ЭлементыФормы.ПолеТабличногоДокумента.ОриентацияСтраницы=ПечатныйДокумент.ОриентацияСтраницы;


Вроде сработало

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 27.05.18, 5:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне