Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Отменить создание документа в 1С 8          
Gigi Подменю пользователя
сообщение 08.06.17, 12:23
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 102
Спасибо сказали: 0 раз
Рейтинг: 0

Всем привет!
Проблема простая ... нужно отменить создание документа.

Вот код
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
знОтчПериодМесяц=""+ Объект.Месяц+" "+Объект.Год+" г.";
ПроверкаСуществованияДока=ПроверкаСуществованияДокумента("ТОЧКА_показания", Объект.ТочкаУчетаКод,"ТочкаУчетаКод", знОтчПериодМесяц,"ОтчетныйПериодМесяц",,);
Если ПроверкаСуществованияДока="Yes" тогда
Если Вопрос("Документ по показаниям точки учета: «"+Объект.ТочкаУчета+"» на период: "+знОтчПериодМесяц+"  уже создан! Добавить новый?",РежимДиалогаВопрос.ДаНет,,,"Предуперждение во избежания дублирования данных!")=КодВозвратаДиалога.Нет Тогда
//Тут нужно создание нового документа ОТМЕНИТЬ           
//Как это сделать?
//Можно ли это сделать тут же, одной командой. Или нужна спец процедура на серваке?
//Вообщем как это сделать КОНКРЕТНО! На примере кода        
КонецЕсли;    
КонецЕсли;
КонецПроцедуры

опять буду сильно признателен Вам, если кто поможет решить задачу.

Сообщение отредактировал Vofka - 12.06.17, 10:58

Vidocq05 Подменю пользователя
сообщение 08.06.17, 12:35
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 43
Из: Сумы
Спасибо сказали: 11 раз
Рейтинг: 11

Gigi @ Сегодня, 13:23 * ,
Вроде как ...

Отказ = Истина;

Спасибо сказали: Gigi,

Gigi Подменю пользователя
сообщение 08.06.17, 13:06
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 102
Спасибо сказали: 0 раз
Рейтинг: 0

Vidocq05 @ Сегодня, 13:35 * ,
Спасибо!
Вот удивляюсь... как сам не догнал? smile.gif
Это исходя из:
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Не говорит а, просто кричит само за себя... smile.gif
Ладно! Спасибо!

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 19.08.17, 18:59
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне