Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Отловить процедуру при закрытии подиченной формы , Обычные формы          
dsfdsfsdf Подменю пользователя
сообщение 10.08.18, 10:45
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Вообщем такая проблема. Есть форма обработки из короторой я получаю другую форму. Задача отловить закрытие другой формы, и написать туда какиэто действия. Пробовал ставить модифицированост ьв истину не катит. Обычные формы. Вот пробую через оповещение но не катит.
Процедура КнопкаВыполнитьНажатие(Кнопка)
    Попытка
        ФормаВыбора = Документы.РегламентированныйОтчет.ПолучитьФормуВыбора();
        ФормаВыбора.ДокументСписок.Отбор.НаименованиеОтчета.ВидСравнения = ВидСравнения.Равно;
        ФормаВыбора.ДокументСписок.Отбор.НаименованиеОтчета.Значение = "Декларация по НДС";
        ФормаВыбора.ДокументСписок.Отбор.НаименованиеОтчета.Установить();
        ФормаВыбора.Заголовок = "Выберите документ ""Декларация по НДС""";
        ВыбДок = ФормаВыбора.ОткрытьМодально();  
        ФормаДок = ВыбДок.ПолучитьФорму();        
        //ФормаДок.ОткрытьМодально();
        
        ОткрытьФорму(ФормаДок,,,,,,сохранение(ФормаДок),);
        Оповестить("ЗакрытьФорму",сохранение(ФормаДок),ФормаДок);

    Исключение
    КонецПопытки
КонецПроцедуры

функция сохранение(ФормаДок)
    Попытка
            ФормаДок.ЭтотОбъект.Записать();
        Исключение
            Сообщить(ОписаниеОшибки(), СтатусСообщения.Важное);
        КонецПопытки;
    
КонецФункции;


takefive Подменю пользователя
сообщение 10.08.18, 11:06
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 27
Из: Днепропетровск
Спасибо сказали: 12 раз
Рейтинг: 12.6

dsfdsfsdf @ Сегодня, 11:45 * ,
ЗначениеВыбора = ФормаВыбора.ОткрытьМодально();
ЗначениеВыбора - это значение из формы выбора
в форме выбора пишете
ЭтоФорма.Закрыть(ЗначениеКотороеНужноВернуть)


Signature
без свинга нет музыки...

sava1 Подменю пользователя
сообщение 10.08.18, 11:06
Сообщение #3

Крутой
Иконка группы
Группа: Местный
Сообщений: 1875
Из: Проскуров
Спасибо сказали: 435 раз
Рейтинг: 428.2

оповестить отрабатывает в ОбработкаОповещения формы.

вызывать Оповестить надо из подчиненной формы, а не при ее открытии

или откройте подчиненную форму модально.

dsfdsfsdf Подменю пользователя
сообщение 10.08.18, 11:45
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Процедура КнопкаВыполнитьНажатие(Кнопка)
    ФормаВыбора = Документы.РегламентированныйОтчет.ПолучитьФормуВыбора();
        ФормаВыбора.ДокументСписок.Отбор.НаименованиеОтчета.ВидСравнения = ВидСравнения.Равно;
        ФормаВыбора.ДокументСписок.Отбор.НаименованиеОтчета.Значение = "Декларация по НДС";
        ФормаВыбора.ДокументСписок.Отбор.НаименованиеОтчета.Установить();
        ФормаВыбора.Заголовок = "Выберите документ ""Декларация по НДС""";
        ВыбДок = ФормаВыбора.ОткрытьМодально();  
        ФормаДок = ВыбДок.ПолучитьФорму();

        ФормаДок.Открыть();
        //ФормаДок.Закрыть();
        //      Попытка
        //    ФормаДок.ЭтотОбъект.Записать();
        //Исключение
        //    Сообщить(ОписаниеОшибки(), СтатусСообщения.Важное);
        СтруктураПараметров = Новый Структура("Ссылка");
        СтруктураПараметров.Ссылка = ФормаДок;

        Открытьформу("Отчет.РегламентированныйОтчетДекларацияНДС.Форма.ФормаОтчета2017", СтруктураПараметров,,,,"Сохранение")
        
        //КонецПопытки;
    КонецПроцедуры
    
        

Процедура Сохранение() Экспорт
    Сообщить("***")
КонецПроцедуры;

Я открываю форму подчиненную, потом жму на крестик, при этом я должен сделать вопрос сохранить форму или нет, как это сделать? не форму выбора а форму которую я открываю последней.

sava1 Подменю пользователя
сообщение 10.08.18, 12:00
Сообщение #5

Крутой
Иконка группы
Группа: Местный
Сообщений: 1875
Из: Проскуров
Спасибо сказали: 435 раз
Рейтинг: 428.2

Событие ПередЗакрытием
Отказ=Истина - не закрывается форма

dsfdsfsdf Подменю пользователя
сообщение 10.08.18, 12:31
Сообщение #6

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 13:00 * ,
Мне надо все сделать в обработке, не затрагивая код починенной формы

sava1 Подменю пользователя
сообщение 10.08.18, 13:40
Сообщение #7

Крутой
Иконка группы
Группа: Местный
Сообщений: 1875
Из: Проскуров
Спасибо сказали: 435 раз
Рейтинг: 428.2

"Я хочу поймать рыбку, не забрасывая удочку в речку...."

dsfdsfsdf Подменю пользователя
сообщение 10.08.18, 14:14
Сообщение #8

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:40 * ,
Я в коде написал свой способ, который не работает, нужно исправить или посоветовтаь другой.

takefive Подменю пользователя
сообщение 10.08.18, 15:01
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 27
Из: Днепропетровск
Спасибо сказали: 12 раз
Рейтинг: 12.6

dsfdsfsdf @ Сегодня, 15:14 * ,
Вам нужно:
1 передать в форму выбора владельца формы
2 у владельца формы создать событие Обработка выбора где и ловить выбор

еще возможно надо установить в Истина форме выбора: Форма выбора и Закрывать при выборе


Signature
без свинга нет музыки...

dsfdsfsdf Подменю пользователя
сообщение 10.08.18, 15:04
Сообщение #10

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Я уже целый день это мучаю, ест ь укого идеи?

sava1 Подменю пользователя
сообщение 10.08.18, 15:11
Сообщение #11

Крутой
Иконка группы
Группа: Местный
Сообщений: 1875
Из: Проскуров
Спасибо сказали: 435 раз
Рейтинг: 428.2

Цитата(dsfdsfsdf @ 10.08.18, 13:31) *
Мне надо все сделать в обработке, не затрагивая код починенной формы


На момент Ваших действий форма уже будет закрыта. Что и как Вы собираетесь сохранять ?

dsfdsfsdf Подменю пользователя
сообщение 10.08.18, 15:51
Сообщение #12

Молчаливый
*
Группа: Пользователи
Сообщений: 7
Спасибо сказали: 0 раз
Рейтинг: 0

Модифицированость пробовал ставить в истину не катит и вложь тоже и после перед открытием.
Вы можете на примере по коду показать?

takefive @ Сегодня, 16:01 * ,
А причем тут ловить выбор к закрытию документа?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.08.18, 17:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне