Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Обработка 1С 8.3 & CABiNET , Новый клиент банк от Credit Agricole Bank          
Espresso.Doktor Подменю пользователя
сообщение 11.12.18, 18:44
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 21
Из: Lemberg
Спасибо сказали: 0 раз
Рейтинг: 0

Счастье привалило, в виде нового клиент банка CABiNET от Credit Agricole Bank.

Ранее было 1С 8.2 УТП для України + обработка клієнт банк от Аbbyy Україна, с помощью костыля работало с клиент банком Стиль(М).

И так на самом сайте есть возможность выгрузки платежных поручений в следующих форматах:



Загрузка входных платежей чуть скромнее:



Сегодня, узнал что новый супер клиент банк CABiNET от Credit Agricole Bank, не совместим с 1С.
О чем думали IT-специалисты, лично мне не совсем понятно 44000000.gif

На звонки, мол как работать 1С & CABiNET, ответы как пользоваться сайтом, и это уже успех rulez.gif

Выгрузил первую платежку пальчиками из 1С в CABiNET, радости мало, спасибо чудесным клавишам "Ctrl + C & Ctrl + V"

Вопрос можно ли штатный клиент банк 1С, подружить с новым клиент банком CABiNET от Credit Agricole Bank





Банк пошел на встречу и прислал два файла с полезной инфой для обмена.

Первый: Формат экспорта выписки (CSV & TXT)

Что хорошего из этого можно сделать?

sava1 Подменю пользователя
сообщение 11.12.18, 19:06
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2019
Из: Проскуров
Спасибо сказали: 471 раз
Рейтинг: 461

проще обработка от Аббии + обработка формата (написать)

Espresso.Doktor Подменю пользователя
сообщение 11.12.18, 19:11
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 21
Из: Lemberg
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 19:06 * ,

А родной модуль клиент банка в 1С сложно заставить работать?

takefive Подменю пользователя
сообщение 12.12.18, 11:24
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 35
Из: Днепропетровск
Спасибо сказали: 13 раз
Рейтинг: 13.9

конвертер - обработка, которая по данным банка создаст файл в нужном формате...


Signature
без свинга нет музыки...

Vladal Подменю пользователя
сообщение 13.12.18, 8:27
Сообщение #5

Оратор
*****
Группа: Пользователи
Сообщений: 275
Из: Украина
Спасибо сказали: 47 раз
Рейтинг: 32

Цитата(Espresso.Doktor @ 11.12.18, 18:44) *
Сегодня, узнал что новый супер клиент банк CABiNET от Credit Agricole Bank, не совместим с 1С.
О чем думали IT-специалисты, лично мне не совсем понятно

Да ладно?
Цитата(Espresso.Doktor @ 11.12.18, 18:44) *
На звонки, мол как работать 1С & CABiNET, ответы как пользоваться сайтом, и это уже успех
Сталкивался. Когда-то мне прислали файлик в несколько мегабайт с клиентами по всему району. Забыли отобрать по нашей организации.
Цитата(Espresso.Doktor @ 11.12.18, 18:44) *
Вопрос можно ли штатный клиент банк 1С, подружить с новым клиент банком CABiNET от Credit Agricole Bank

Да, можно. Взять за образец любую подключаемую обработку формата, там и дописать в соответствии с форматом выгрузки.
В обработке оставляют шаблонные процедуры обработки - TXT, DBF, XLS... Там же в экспортных переменных и указать обрабатываемые форматы этой обработки, например, из того же КредиАгриколь можно делать выгрузки в форматированном тексте или тексте с разделителями и т.д.

Вам нужна конкретика? Опишите формат выгрузки. Скачивать какие-то файлы для ознакомления не хочется.
Цитата(Espresso.Doktor @ 11.12.18, 19:11) *
А родной модуль клиент банка в 1С сложно заставить работать?

Родной модуль работает как универсальный? Там есть мастер настройки, в котором можно выбрать тип файла, а в соотвтествии с типом, например, текста, выбрать это файл с разделителями или с фиксированными строками, а также указать длину фиксированного поля и соответствие полей импорта строкам этого текста?
Если есть такое - то настроить в режиме пользователя.

Нужно дописывать или взять готовую обработку.

Espresso.Doktor Подменю пользователя
сообщение 17.12.18, 22:42
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 21
Из: Lemberg
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(Vladal @ 13.12.18, 8:27) *
Родной модуль работает как универсальный? Там есть мастер настройки, в котором можно выбрать тип файла, а в соотвтествии с типом, например, текста, выбрать это файл с разделителями или с фиксированными строками, а также указать длину фиксированного поля и соответствие полей импорта строкам этого текста?
Если есть такое - то настроить в режиме пользователя.

Родной модуль есть, но что он не хочет даже показывать в отборе платежку, которую через него и создал sad.gif
Мастер настройки это вот эта кнопочка ? 64000000.gif


nomer Подменю пользователя
сообщение 20.01.19, 16:55
Сообщение #7

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Espresso.Doktor @ 11.12.18, 18:44 * ,
В этом файле есть поля и нужно будет по них сделать обработку для клиента Аbbyy Україна 1С.
Задача не столь и сложная.
Самый простой вариант, взять обработку любого банка и ее исправить под формат нового клиента этого банка.

kooperdj Подменю пользователя
сообщение 24.01.19, 22:33
Сообщение #8

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Из: Полтава
Спасибо сказали: 1 раз
Рейтинг: 1

Тоже столкнулся с выпиской CABiNET, изменил под нее iBank2, Функция ИмпортTXT(Параметры) Ничего сложного, только учесть что выписка начинается со второй строки.
 Функция ИмпортTXT(Параметры)
    ФайлTXT    = Новый ТекстовыйДокумент;
    ИмяФайла = Параметры.ИмяФайла;
    Попытка
        ФайлTXT.Прочитать(ИмяФайла, КодировкаТекста[Параметры.КодировкаФайла]);
    Исключение
        Предупреждение("Ошибка открытия файла " + ИмяФайла);
        Возврат Неопределено;
    КонецПопытки;        
    
    тзВыписка =  Новый ТаблицаЗначений;
    тзВыписка.Колонки.Добавить("НомерПП");
    тзВыписка.Колонки.Добавить("Приход");
    тзВыписка.Колонки.Добавить("Расход");
    тзВыписка.Колонки.Добавить("ОКПО");
    тзВыписка.Колонки.Добавить("Контрагент");
    тзВыписка.Колонки.Добавить("МФО");
    тзВыписка.Колонки.Добавить("РСчет");
    тзВыписка.Колонки.Добавить("Содержание");
    
    // В первой строке хранятся параметры выписки
    Дельта = -1;
    ТекСтрока = ФайлTXT.ПолучитьСтроку(1);
    Спис = РазобратьСтроку(ТекСтрока);
    шСчет       = СокрЛП(Спис[1+Дельта].Значение);
    шВалюта     = СокрЛП(Спис[2+Дельта].Значение);
    шКвоЗаписей = СокрЛП(Спис[3+Дельта].Значение);
    
    Если шСчет <> Формат(Параметры.РСчет,"ЧН=0") Тогда
        Предупреждение("В текущем файле нет платежей с выбранным расчетным счетом!");
        Возврат тзВыписка;
    КонецЕсли;
    
    Для н = 2 По ФайлTXT.КоличествоСтрок() Цикл
        ТекСтрока = ФайлTXT.ПолучитьСтроку(н);
        Спис = РазобратьСтроку(ТекСтрока);
        
        ДатаОперации = Дата(Спис[2+Дельта].Значение);  // ггггммдд
        Если ДатаОперации <> Параметры.ДатаДок Тогда
            Продолжить;    
        КонецЕсли;
                    
        МФОКонтрагента = СокрЛП(Спис[33+Дельта].Значение);
        КодОКПОКонтрагента = СокрЛП(Спис[34+Дельта].Значение);
        РСчетКонтрагента = СокрЛП(Спис[26+Дельта].Значение);
        ИмяКонтрагента = СокрЛП(Спис[27+Дельта].Значение);
        
        Если Лев(ИмяКонтрагента, 1)  = """" И Прав(ИмяКонтрагента, 1)  = """" Тогда
            ИмяКонтрагента = Сред(ИмяКонтрагента, 2, СтрДлина(ИмяКонтрагента) - 2);
            ИмяКонтрагента = СтрЗаменить(ИмяКонтрагента,"""""", """");
        КонецЕсли;
        
        НомерПП  = СокрЛП(Спис[25+Дельта].Значение);
        Назначение = СокрЛП(Спис[24+Дельта].Значение);
        Если Лев(Назначение, 1)  = """" И Прав(Назначение, 1)  = """" Тогда
            Назначение = Сред(Назначение, 2, СтрДлина(Назначение) - 2);
            Назначение = СтрЗаменить(Назначение,"""""", """");
        КонецЕсли;
                
        НовСтрока = тзВыписка.Добавить();
        НовСтрока.НомерПП        = НомерПП;
        НовСтрока.Контрагент    = ИмяКонтрагента;
        НовСтрока.ОКПО            = СокрЛП(Формат(КодОКПОКонтрагента,"ЧГ=0"));
        НовСтрока.РСчет            = СокрЛП(Формат(РСчетКонтрагента,"ЧГ=0"));
        НовСтрока.МФО             = СокрЛП(Формат(МФОКонтрагента,"ЧГ=0"));
        НовСтрока.Содержание     = Назначение;
        
        ДебетКредит  = СокрЛП(Спис[11+Дельта].Значение); //'D' - мы платим 'C' - нам платят
        Если ДебетКредит = "D" Тогда
            Приход = 0;
            Расход = Спис[10+Дельта].Значение/100; //Сумма в копейках
        Иначе
            Приход = Спис[10+Дельта].Значение/100; //Сумма в копейках
            Расход = 0;
        КонецЕсли;

        Если Расход > 0 Тогда //Расход
            НовСтрока.Расход         = Расход;
            НовСтрока.Приход        = 0;
        Иначе //Приход
            НовСтрока.Расход         = 0;
            НовСтрока.Приход        = Приход;
        КонецЕсли;
    КонецЦикла;    
    
    Если НЕ тзВыписка.Количество() И ФайлTXT.КоличествоСтрок() Тогда
        Предупреждение("В текущем файле нет платежей с данной датой выписки и расчетным счетом!");
    КонецЕсли;
    
    Возврат тзВыписка;    
КонецФункции

Спасибо сказали: andr_andrey,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.05.19, 7:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне