Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Обмен данными между базами без РИБ          
Constantus Подменю пользователя
сообщение 16.12.17, 7:47
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 622
Спасибо сказали: 2 раз
Рейтинг: 2

Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В данный момент у меня настроен РИБ. Центральная база и 2-а подчиненных узла.
Естественно, что если я вношу изменения в конфигураторе, то мне приходится проводить операцию и по сохранению изменений в конфигурации и в подчиненных узлах.

Моему руководству "надоело" моё "нытьё", что каждый раз мне нужно проводить столь сложные махинации. Ну и мне надоело делать их хотелки и выслушивать мои претензии.

Тогда встал у меня вопрос: а можно сделать обмен между базами так, чтобы при изменении конфигурации, это изменение не требовало изменений конфигураций на подчиненных узлах? Т.е. в основном все "хотелки" затрагивают центральный офис и они не нужны на филиалах.

Возможно ли такое сделать без создания правил обмена?

И еще один вопрос: в планах обмена есть галочка "Распределенная информационная база". За что она отвечает и что будет, если ее отключить?

Moloko Подменю пользователя
сообщение 16.12.17, 12:39
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 13
Спасибо сказали: 2 раз
Рейтинг: 2

1. Давно отказался от планов обмена. Создайте через конвертацию свои правила обмена "база-база" и перегоняйте только то, что вам нужно.
2.
 Процедура ОтключитьГлавныйУзелНажатие(Элемент)
    Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
        СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном",
                ПланыОбмена.ГлавныйУзел());
        ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
    КонецЕсли;
    Предупреждение("Главный узел отключен");

КонецПроцедуры
Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
    Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
        ПланыОбмена.УстановитьГлавныйУзел(
              ВосстановитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
    КонецЕсли;
    Предупреждение("Главный узел восстановлен");
КонецПроцедуры


DrLivsi Подменю пользователя
сообщение 20.12.17, 9:34
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 135
Из: Киев
Спасибо сказали: 15 раз
Рейтинг: 15

Moloko @ 16.12.17, 13:39 * ,
Можно подробнее, как реализована логика обмена через конвертацию данных?

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 27.05.18, 5:09
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне