Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Обережно грабля: ошибка в ППВ в 1.2.45.1          
Trintintin Подменю пользователя
сообщение 01.02.18, 14:20
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 35
Спасибо сказали: 23 раз
Рейтинг: 25.7

Вітаю!
В док ППВ в форме решили перерисовать процедуру:

Процедура РассчитатьСуммуВзаиморасчетов()
    
    ПроверкаКурсовВалют(СтрокаПлатеж);
    мТекущаяВалютаВзаиморасчетов = СтрокаПлатеж.ДоговорКонтрагента.ВалютаВзаиморасчетов;
    
    СтрокаПлатеж.СуммаВзаиморасчетов=МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(СтрокаПлатеж.СуммаПлатежа, ВалютаДокумента,
                                    мТекущаяВалютаВзаиморасчетов,
                                    КурсДокумента, СтрокаПлатеж.КурсВзаиморасчетов,
                                    КратностьДокумента, СтрокаПлатеж.КратностьВзаиморасчетов);
                                    
    Если СтрокаПлатеж.КурсВзаиморасчетовПлан>0 Тогда
        РассчитатьСуммуПлатежаПлан();
    КонецЕсли;
    
КонецПроцедуры // РассчитатьСуммуВзаиморасчетов()


на процеДуру:
Процедура РассчитатьСуммуВзаиморасчетов()
    
    ПроверкаКурсовВалют(СтрокаПлатеж);
    
    Если ЕстьРасчетыСКонтрагентами ИЛИ ВидОперации = Перечисления.ВидыОперацийПоступлениеБезналичныхДенежныхСредств.РасчетыПоКредитамИЗаймам Тогда
        мТекущаяВалютаВзаиморасчетов = СтрокаПлатеж.ДоговорКонтрагента.ВалютаВзаиморасчетов;
    Иначе
        СтрокаПлатеж.СуммаПлатежа = СтрокаПлатеж.СуммаВзаиморасчетов;
        Возврат;
    КонецЕсли;
    
    Если мТекущаяВалютаВзаиморасчетов = ВалютаДокумента Тогда
        
        СтрокаПлатеж.СуммаПлатежа = СтрокаПлатеж.СуммаВзаиморасчетов;
        
    ИначеЕсли (КурсДокумента <> 0) И (СтрокаПлатеж.КратностьВзаиморасчетов <> 0) И (СтрокаПлатеж.КурсВзаиморасчетов <> 0) Тогда
    
        СтрокаПлатеж.СуммаВзаиморасчетов=МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(СтрокаПлатеж.СуммаПлатежа, ВалютаДокумента,
                                        мТекущаяВалютаВзаиморасчетов,
                                        КурсДокумента, СтрокаПлатеж.КурсВзаиморасчетов,
                                        КратностьДокумента, СтрокаПлатеж.КратностьВзаиморасчетов);
    
    Иначе
        СтрокаПлатеж.СуммаПлатежа = 0;
    КонецЕсли;
                                    
    Если СтрокаПлатеж.КурсВзаиморасчетовПлан > 0 Тогда
        РассчитатьСуммуПлатежаПлан();
    КонецЕсли;
    
КонецПроцедуры // РассчитатьСуммуВзаиморасчетов()


Теперь ППВ в грн вводиться або тіко списком, предварительно проставив СуммаВзаиморасчетов або вместо строки:

СтрокаПлатеж.СуммаПлатежа = СтрокаПлатеж.СуммаВзаиморасчетов;


пилим строку:

СтрокаПлатеж.СуммаВзаиморасчетов=МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(СтрокаПлатеж.СуммаПлатежа, ВалютаДокумента,
                                        мТекущаяВалютаВзаиморасчетов,
                                        КурсДокумента, СтрокаПлатеж.КурсВзаиморасчетов,
                                        КратностьДокумента, СтрокаПлатеж.КратностьВзаиморасчетов);


Сообщение отредактировал Vofka - 01.02.18, 14:51

Спасибо сказали: mila_romaniuk, Vofka,

Vofka Подменю пользователя
сообщение 01.02.18, 14:51
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12650
Из: Киев
Спасибо сказали: 3784 раз
Рейтинг: 2903.4

Только я ничего не понял?


Signature
Услуги 1С программиста

logist Подменю пользователя
сообщение 01.02.18, 15:10
Сообщение #3

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2449 раз
Рейтинг: 1519.4

Цитата(Vofka @ 01.02.18, 14:51) *
Только я ничего не понял?

+


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Gazulo Подменю пользователя
сообщение 01.02.18, 18:02
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 150
Спасибо сказали: 17 раз
Рейтинг: 17

Vofka @ Сегодня, 14:51 * ,
Напевно йде мова про новий реліз УТП 1.2.45.1 де переробили процедуру, але в чому питання не відомо)

Спасибо сказали: Vofka,

kihor Подменю пользователя
сообщение 01.02.18, 18:16
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 3 раз
Рейтинг: 1

Gazulo @ Сегодня, 18:02 * ,

Я тоже не полностью понял ТС, но сегодня мои пользователи уже начали жаловаться на "геморой" с вводом платежных поручений в новой версии 1.2.45.1. Я вернул указанную выше процедуру на старую версию.

Vofka Подменю пользователя
сообщение 02.02.18, 9:41
Сообщение #6

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12650
Из: Киев
Спасибо сказали: 3784 раз
Рейтинг: 2903.4

Gazulo, вот оно что smile.gif


Signature
Услуги 1С программиста

logist Подменю пользователя
сообщение 02.02.18, 10:57
Сообщение #7

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2449 раз
Рейтинг: 1519.4

Цитата(kihor @ 01.02.18, 18:16) *
начали жаловаться на "геморой" с вводом платежных поручений в новой версии

И какой там геморой?


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

kihor Подменю пользователя
сообщение 05.02.18, 18:13
Сообщение #8

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 3 раз
Рейтинг: 1

logist @ 02.02.18, 10:57 * ,

Пользователи создавали платежные поручения как обычно, но при проведении появлялось сообщение, что сумма документа не соответствует итоговой сумме в расшифровке (табличная часть документа). Решалось "шаманским" способом перевыбора суммы документа - таким образом переустанавливалась сумма в строке расшифровки. Я не стал тратить время на отладку и детально вчитываться в изменения вышеуказанной процедуры, т.к. там изменения, которые не были заявлены в описании новшеств обновления (заявлено просто - сброс флажка "Оплачено" при копировании платежки), и вернул предыдущую версию. Сейчас проблем у пользователей не возникает.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.06.18, 0:25
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне