Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Не находит Реквизит табличной части справочника          
Constantus Подменю пользователя
сообщение 30.11.17, 14:42
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 557
Спасибо сказали: 2 раз
Рейтинг: 2

Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Пытаюсь обойти все табличные части справочника и проверить на его изменения:

    Для Каждого ТабЧасть из ЭтотОбъект.Метаданные().ТабличныеЧасти.Водители.Реквизиты.  Цикл
        Если ЭтотОбъект[ТабЧасть.Имя].Количество() > 0 тогда
            Для каждого РеквизитТабЧасти из ТабЧасть.Реквизиты цикл
                Сообщить("" + Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] + "/" + ЭтотОбъект[ТабЧасть.Имя] + "/" +РеквизитТабЧасти.Имя);
                //Сообщить("" + Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] + "/" + ЭтотОбъект[ТабЧасть.Имя][РеквизитТабЧасти.Имя]);
                //Если Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] <>
                //        ЭтотОбъект[ТабЧасть.Имя][РеквизитТабЧасти.Имя] тогда
                //    Сообщить("ДА");
                //КонецЕсли;    
            КонецЦикла;    
        КонецЕсли;    
    КонецЦикла;


Ошибка на [РеквизитТабЧасти.Имя]

{Справочник.АвтопаркПредприятия.МодульОбъекта(54)}: Поле объекта не обнаружено (Регион)
Сообщить("" + Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] + "/" + ЭтотОбъект[ТабЧасть.Имя] + "/" +РеквизитТабЧасти.Имя);


Если вывести на экран РеквизитТабЧасти.Имя, то на экране четко высвечиваются все реквизиты

Как до него правильно достучаться?

salton Подменю пользователя
сообщение 30.11.17, 16:22
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 92
Из: Полтава
Спасибо сказали: 24 раз
Рейтинг: 24

А можете весь код от первой до 55 строки выложить под спойлер?

Constantus Подменю пользователя
сообщение 30.11.17, 17:18
Сообщение #3

Почти ветеран
******
Группа: Пользователи
Сообщений: 557
Спасибо сказали: 2 раз
Рейтинг: 2

salton @ Сегодня, 19:22 * ,


Это и есть весь код в модуле объекта при записи документа... Остальное заремачено


Petre Подменю пользователя
сообщение 30.11.17, 17:41
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2196
Из: Київ, Україна
Спасибо сказали: 517 раз
Рейтинг: 483

Что это за байда?
ЭтотОбъект.Метаданные().ТабличныеЧасти.Водители.Реквизиты.


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Constantus Подменю пользователя
сообщение 30.11.17, 17:51
Сообщение #5

Почти ветеран
******
Группа: Пользователи
Сообщений: 557
Спасибо сказали: 2 раз
Рейтинг: 2

Petre @ Сегодня, 20:41 * ,

Виноват, снял код с очередного эксперимента

   Для Каждого ТабЧасть из ЭтотОбъект.Метаданные().ТабличныеЧасти  Цикл
        Если ЭтотОбъект[ТабЧасть.Имя].Количество() > 0 тогда
            Для каждого РеквизитТабЧасти из ТабЧасть.Реквизиты цикл
                Сообщить("" + Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] + "/" + ЭтотОбъект[ТабЧасть.Имя] + "/" +РеквизитТабЧасти.Имя);
                //Сообщить("" + Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] + "/" + ЭтотОбъект[ТабЧасть.Имя][РеквизитТабЧасти.Имя]);
                //Если Ссылка[ТабЧасть.Имя][РеквизитТабЧасти.Имя] <>
                //        ЭтотОбъект[ТабЧасть.Имя][РеквизитТабЧасти.Имя] тогда
                //    Сообщить("ДА");
                //КонецЕсли;    
            КонецЦикла;    
        КонецЕсли;    
    КонецЦикла;


В Справочнике есть ТЧ "Водители"

Petre Подменю пользователя
сообщение 01.12.17, 9:11
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2196
Из: Київ, Україна
Спасибо сказали: 517 раз
Рейтинг: 483

Constantus @ Вчера, 17:51 * ,
Не вижу обхода строк тч.

А потом, как вы собираетесь сравнивать эти строки, если в объекте строка была: а) удалена, б) добавлена, в) сдвинута...


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.01.18, 11:36
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне