Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Маршрутный лист , Печатная форма 3 страниц V  < 1 2 3          
XacTLa Подменю пользователя
сообщение 09.10.17, 10:42
Сообщение #41

Общительный
**
Группа: Пользователи
Сообщений: 46
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

Может кто то знает как это чудо переделать так что бы работало, а то вообще я уже подставляю параметры все равно пишет много факт. данных

salton Подменю пользователя
сообщение 09.10.17, 12:07
Сообщение #42

Говорящий
***
Группа: Пользователи
Сообщений: 73
Из: Полтава
Спасибо сказали: 21 раз
Рейтинг: 21

Цитата(Petre @ 06.10.17, 17:57) *
Из какого документа вы печатаете?
Где располагается данная процедура?

Дайте ответы на эти вопросы.
Совсем не понятно в каком месте вы пытаетесь вызвать свою функцию печати и передать ей параметры! Потому как исходя из ошибок которые вы описываете - функция печати вызывается без Вашего участия...

XacTLa Подменю пользователя
сообщение 09.10.17, 13:07
Сообщение #43

Общительный
**
Группа: Пользователи
Сообщений: 46
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

salton @ Сегодня, 12:07 * ,
Функция Печать(СсылкаНаОбъект, ПараметрыИсточника, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    Для Каждого ОбъектПечати Из СсылкаНаОбъект Цикл
        УправлениеПечатью.
        ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,
        "МаршрутныйНовый",
        "Маршрутный новый",
        СформироватьПечатнуюФорму(СсылкаНаОбъект, ПараметрыИсточника, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода));
    КонецЦикла;
    
    ТабДок = новый ТабличныйДокумент;
    
    Макет = ПолучитьМакет("МакетМаршрутныйЛист");
    
    ОбластьШапки   = Макет.ПолучитьОбласть("Шапка");
    ОбластьСтрокаТЧ  = Макет.ПолучитьОбласть("СтрокаТЧ");
        
    ОбластьШапки.Параметры.ТекстЗаголовка                      = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ТекстЗаголовка                      = СсылкаНаОбъект.Дата;
    ОбластьШапки.Параметры.ПодразделениеПредставление       = СсылкаНаОбъект.Подразделение;
    ОбластьШапки.Параметры.ИзделиеПредставление              = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление         = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление         = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение                         = СсылкаНаОбъект.Назначение;

    
    ТабДок.Вывести(ОбластьШапки);
    
    Запрос = Новый Запрос;
    
    Запрос.Текст = "ВЫБРАТЬ
                   |    МаршрутныйЛистПроизводства.Номенклатура,
                   |    МаршрутныйЛистПроизводства.ВыходныеИзделия.(
                   |        Количество
                   |    )
                   |ИЗ
                   |    Документ.МаршрутныйЛистПроизводства КАК МаршрутныйЛистПроизводства
                   |ГДЕ
                   |    МаршрутныйЛистПроизводства.Ссылка = &Ссылка";
                  
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
    Запрос.УстановитьПараметр("ТекущаяДата",ТекущаяДата());
    
          
    
    
    
                  
    возврат ТабДок;
КонецФункции

salton Подменю пользователя
сообщение 09.10.17, 13:16
Сообщение #44

Говорящий
***
Группа: Пользователи
Сообщений: 73
Из: Полтава
Спасибо сказали: 21 раз
Рейтинг: 21

XacTLa @ Сегодня, 14:07 * ,
вполне даже очень ничего код, не понятно зачем там запрос и что вы делаете с его результатами.. но то уже другая опера.

а теперь покажите код в котором Вы вызываете функцию печать, код которой Вы тут выложили!

XacTLa Подменю пользователя
сообщение 09.10.17, 13:23
Сообщение #45

Общительный
**
Группа: Пользователи
Сообщений: 46
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

salton @ Сегодня, 13:16 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ПараметрыИсточника,
        КоллекцияПечатныхФорм,
        ОбъектыПечати,
        ПараметрыВывода)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ПодразделениеПредставление = СсылкаНаОбъект.Подразделение;
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
        
        ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции

salton Подменю пользователя
сообщение 09.10.17, 13:54
Сообщение #46

Говорящий
***
Группа: Пользователи
Сообщений: 73
Из: Полтава
Спасибо сказали: 21 раз
Рейтинг: 21

Вы в коде функции
СформироватьПечатнуюФорму()
(вот в той которую выложили последней), видите где-то вызов функции Печать()??
Возможно мне мерещится..... но я лично не вижу, а значит она вызывается не отсюда...

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


3 страниц V  < 1 2 3
Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 22.10.17, 15:43
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне