Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как проверить существование общего модуля?          
Inkognito Подменю пользователя
сообщение 06.03.17, 12:10
Сообщение #1

Почти ветеран
******
Группа: Пользователи
Сообщений: 595
Из: Украина
Спасибо сказали: 423 раз
Рейтинг: 6.2

Есть общий модуль в УПП/УТП, называется "Ценнобразование". Вызывается например, для получения скидки:
Скидка = Ценообразование.ПолучитьСуммуСкидки(Сумма, ПроцентСкидки);
Проблема в том, что код используется во внешней обработке, которая может быть вызвана из конфигураций, которые его не имеют.
Например, пр открытии в ЗУП, программа ругается: "Переменная не определена (Ценообразование)"

Вопрос: как сделать проверку на наличие общего модуля "Ценообразование"?

sava1 Подменю пользователя
сообщение 06.03.17, 12:12
Сообщение #2

Крутой
Иконка группы
Группа: Местный
Сообщений: 1934
Из: Проскуров
Спасибо сказали: 450 раз
Рейтинг: 440.1

Попытка/Исключение Вызвать процедуру/функцию

Inkognito Подменю пользователя
сообщение 06.03.17, 12:16
Сообщение #3

Почти ветеран
******
Группа: Пользователи
Сообщений: 595
Из: Украина
Спасибо сказали: 423 раз
Рейтинг: 6.2

Ошибка возникает при открытии обработки, и Попыткой/Исключением не обрабатывается.

Petre Подменю пользователя
сообщение 06.03.17, 12:17
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2458
Из: Київ, Україна
Спасибо сказали: 615 раз
Рейтинг: 575.5

Выполнить("текст кода не проверяется на синтаксис");


Signature
Допрацьовую:
- "Бухгалтерія для України 1.2";
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: Inkognito,

Егор Динин Подменю пользователя
сообщение 06.03.17, 12:39
Сообщение #5

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1422
Из: Киев
Спасибо сказали: 521 раз
Рейтинг: 355.7

Обычно проверяют имя конфигурации.

Inkognito Подменю пользователя
сообщение 06.03.17, 13:17
Сообщение #6

Почти ветеран
******
Группа: Пользователи
Сообщений: 595
Из: Украина
Спасибо сказали: 423 раз
Рейтинг: 6.2

Егор Динин
Обработка универсальная, конфигураций море....
Petre
Спасибо, все получилось.

Vofka Подменю пользователя
сообщение 06.03.17, 14:01
Сообщение #7

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12775
Из: Киев
Спасибо сказали: 3849 раз
Рейтинг: 2972.5

ОбщиеМодули = Метаданные.ОбщиеМодули;
МойМодуль = ОбщиеМодули.Найти("МойМодуль");
Если МойМодуль <> Неопределено Тогда
   //...
КонецЕсли;


Сообщение отредактировал Vofka - 06.03.17, 14:03


Signature
Услуги 1С программиста

Kerberos Подменю пользователя
сообщение 05.11.18, 18:06
Сообщение #8

Говорящий
***
Группа: Пользователи
Сообщений: 50
Спасибо сказали: 12 раз
Рейтинг: 6

Цитата(Vofka @ 06.03.17, 15:01) *
ОбщиеМодули = Метаданные.ОбщиеМодули;
МойМодуль = ОбщиеМодули.Найти("МойМодуль");
Если МойМодуль <> Неопределено Тогда
   //...
КонецЕсли;


в конфигурациях этот код объединяют smile.gif

Если Метаданные.ОбщиеМодули.Найти("МойМодуль") <> Неопределено Тогда
   //...
КонецЕсли;


Или в БСП

Если ОбщегоНазначения.ОбщийМодуль("МойМодуль") <> Неопределено Тогда
   //...
КонецЕсли;


во 2м случае, можно еще вызывать потом модуль "по ссылке"

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 17.12.18, 21:43
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне