Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

4 страниц V   1 2 3 > » 

>  Нужна обработка для заполнение всех полей справочника
burza
Отправлено: 20.02.18, 15:25


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


sava1 @ Сегодня, 14:24 * ,
не очень мне помогло)

burza @ Сегодня, 14:52 * ,
дайте хотя бы пример)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138782 · Ответов: 18 · Просмотров: 146
 

>  Нужна обработка для заполнение всех полей справочника
burza
Отправлено: 20.02.18, 14:06


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Вот есть код для формы. Заполняет значение в поле перед сохранением. Что прописать во внешней обработке чтобы она прошла по всем полям справочника и записала там новые данные из этой функции. Справочник "ХарактеристикиНоменклатуры"
    Если ЭтаФорма.АдресURL  = "" ТОГДА
    ГСЧ = Новый ГенераторСлучайныхЧисел();
    АдресURL = "products/item/" +  Формат(ГСЧ.СлучайноеЧисло(0, 100000000),"ЧГ=0");
   КонецЕсли;



 ! 

Правила: 5
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138779 · Ответов: 18 · Просмотров: 146
 

>  Добавить в запрос параметр отображение по дате Дата
burza
Отправлено: 08.02.18, 13:05


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Vidocq05 @ Сегодня, 12:28 * ,
УТ 3.0 Отчет Досье Партнера
Да в том и дело что там нету параметров, так бы подсмотрел)

Сделал, допер сам спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138370 · Ответов: 5 · Просмотров: 1387
 

>  Добавить в запрос параметр отображение по дате Дата
burza
Отправлено: 08.02.18, 12:14


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Vidocq05 @ Сегодня, 12:10 * ,
нет не так. мне нужно правельно прописать параметр для выбора его потом на форме, вот что мне пишит




 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138368 · Ответов: 5 · Просмотров: 1387
 

>  Добавить в запрос параметр отображение по дате Дата
burza
Отправлено: 08.02.18, 12:03


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Нужно поставить параметр для Телефоного звонка чтобы не все тянуло а от даты.
в запросе поле прописал а вот как вывести параметр не получается.

Код
    СоответствиеЗапросыДанные.Вставить("НеотработанныеВзаимодействия",НомерПоследнегоПакета + 1);
    НомерПоследнегоПакета = НомерПоследнегоПакета + 1;
    // Запрос модифицирован таким образом, что возвращает все взаимодействия, а не только отработанные    kv   27.03.2014
    Возврат "
    |ВЫБРАТЬ РАЗЛИЧНЫЕ РАЗРЕШЕННЫЕ
    |    ВЫРАЗИТЬ(Встреча.Описание КАК СТРОКА(1024)) КАК Описание,
    |    Встреча.Ссылка КАК Ссылка,
    |    Встреча.Ответственный,
    |    Встреча.Дата,
    //|    Встреча.РассмотретьПосле,
    |    &СтрокаВстреча КАК Вид
    |ИЗ
    |    Документ.Встреча.Участники КАК ВстречаУчастники
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.Встреча КАК Встреча
    |        ПО ВстречаУчастники.Ссылка = Встреча.Ссылка
    |ГДЕ
    |    (ВстречаУчастники.Контакт = &Партнер
    |            ИЛИ ВстречаУчастники.Контакт.Владелец = &Партнер)
    |    И (НЕ Встреча.ПометкаУдаления)
    //|    И (НЕ Встреча.Рассмотрено)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ЗапланированноеВзаимодействие.Описание КАК СТРОКА(1024)),
    |    ЗапланированноеВзаимодействие.Ссылка,
    |    ЗапланированноеВзаимодействие.Дата,
    |    ЗапланированноеВзаимодействие.Ответственный,
    //|    ЗапланированноеВзаимодействие.РассмотретьПосле,
    |    &СтрокаЗапланированноеВзаимодействие
    |ИЗ
    |    Документ.ЗапланированноеВзаимодействие.Участники КАК ЗапланированноеВзаимодействиеУчастники
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ЗапланированноеВзаимодействие КАК ЗапланированноеВзаимодействие
    |        ПО ЗапланированноеВзаимодействиеУчастники.Ссылка = ЗапланированноеВзаимодействие.Ссылка
    |ГДЕ
    |    (ЗапланированноеВзаимодействиеУчастники.Контакт = &Партнер
    |            ИЛИ ЗапланированноеВзаимодействиеУчастники.Контакт.Владелец = &Партнер)
    //|    И (НЕ ЗапланированноеВзаимодействие.Рассмотрено)
    |    И (НЕ ЗапланированноеВзаимодействие.ПометкаУдаления)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ТелефонныйЗвонок.Описание КАК СТРОКА(1024)),
    |    ТелефонныйЗвонок.Ссылка,
    |    ТелефонныйЗвонок.Ответственный,
    |    ТелефонныйЗвонок.Дата,
    //|    ТелефонныйЗвонок.РассмотретьПосле,
    |    &СтрокаТелефонныйЗвонок
    |ИЗ
    |    Документ.ТелефонныйЗвонок КАК ТелефонныйЗвонок
    |ГДЕ
        |    ТелефонныйЗвонок.Дата >= &ПараметрНачалоПериода
    |    (НЕ ТелефонныйЗвонок.ПометкаУдаления)
    |    И (ТелефонныйЗвонок.АбонентКонтакт = &Партнер
    |            ИЛИ ТелефонныйЗвонок.АбонентКонтакт.Владелец = &Партнер)
    //|    И (НЕ ТелефонныйЗвонок.Рассмотрено)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ЭлектронноеПисьмоВходящее.Тема КАК СТРОКА(1024)),
    |    ЭлектронноеПисьмоВходящее.Ссылка,
    |    ЭлектронноеПисьмоВходящее.Дата,
    |    ЭлектронноеПисьмоВходящее.Ответственный,
    //|    ЭлектронноеПисьмоВходящее.РассмотретьПосле,
    |    &СтрокаПисьмоВходящее
    |ИЗ
    |    Документ.ЭлектронноеПисьмоВходящее КАК ЭлектронноеПисьмоВходящее
    |ГДЕ
    |    (ЭлектронноеПисьмоВходящее.ОтправительКонтакт = &Партнер
    |            ИЛИ ЭлектронноеПисьмоВходящее.ОтправительКонтакт.Владелец = &Партнер)
    //|    И (НЕ ЭлектронноеПисьмоВходящее.Рассмотрено)
    |    И (НЕ ЭлектронноеПисьмоВходящее.ПометкаУдаления)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ЭлектронноеПисьмоИсходящее.Тема КАК СТРОКА(1024)),
    |    ЭлектронноеПисьмоИсходящее.Ссылка,
    |    ЭлектронноеПисьмоИсходящее.Дата,
    |    ЭлектронноеПисьмоИсходящее.Ответственный,
    //|    ЭлектронноеПисьмоИсходящее.РассмотретьПосле,
    |    &СтрокаПисьмоИсходящее
    |ИЗ
    |    Документ.ЭлектронноеПисьмоИсходящее.ПолучателиПисьма КАК ЭлектронноеПисьмоИсходящееПолучателиПисьма
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ЭлектронноеПисьмоИсходящее КАК ЭлектронноеПисьмоИсходящее
    |        ПО ЭлектронноеПисьмоИсходящееПолучателиПисьма.Ссылка = ЭлектронноеПисьмоИсходящее.Ссылка
    |ГДЕ
    |    (НЕ ЭлектронноеПисьмоИсходящее.ПометкаУдаления)
    //|    И (НЕ ЭлектронноеПисьмоИсходящее.Рассмотрено)
    |    И (ЭлектронноеПисьмоИсходящееПолучателиПисьма.Контакт = &Партнер
    |            ИЛИ ЭлектронноеПисьмоИсходящееПолучателиПисьма.Контакт.Владелец = &Партнер)
    |    И ЭлектронноеПисьмоИсходящее.СтатусПисьма = ЗНАЧЕНИЕ(Перечисление.СтатусыИсходящегоЭлектронногоПисьма.Отправлено)
    |ИТОГИ
    |    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Ссылка)
    |ПО
    |    ОБЩИЕ
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |";
    Запрос.УстановитьПараметр("ПараметрНачалоПериода", НачалоПериода);


Вот вся функция
Код
Функция ТекстЗапросаОНеотработанныхВзаимодействиях(СоответствиеЗапросыДанные,НачалоПериода,НомерПоследнегоПакета)
    
    Если (НЕ ПолучитьФункциональнуюОпцию("ИспользоватьПочтовыйКлиент")) ИЛИ
         (НЕ ПравоДоступа("Чтение",Метаданные.Документы.ЗапланированноеВзаимодействие) И
         НЕ ПравоДоступа("Чтение",Метаданные.Документы.Встреча) И
         НЕ ПравоДоступа("Чтение",Метаданные.Документы.ТелефонныйЗвонок) И
         НЕ ПравоДоступа("Чтение",Метаданные.Документы.ЭлектронноеПисьмоВходящее) И
         НЕ ПравоДоступа("Чтение",Метаданные.Документы.ЭлектронноеПисьмоИсходящее)) Тогда
        
        Возврат "";
        
    КонецЕсли;
    
    СоответствиеЗапросыДанные.Вставить("НеотработанныеВзаимодействия",НомерПоследнегоПакета + 1);
    НомерПоследнегоПакета = НомерПоследнегоПакета + 1;
    // Запрос модифицирован таким образом, что возвращает все взаимодействия, а не только отработанные    kv   27.03.2014
    Возврат "
    |ВЫБРАТЬ РАЗЛИЧНЫЕ РАЗРЕШЕННЫЕ
    |    ВЫРАЗИТЬ(Встреча.Описание КАК СТРОКА(1024)) КАК Описание,
    |    Встреча.Ссылка КАК Ссылка,
    |    Встреча.Ответственный,
    |    Встреча.Дата,
    //|    Встреча.РассмотретьПосле,
    |    &СтрокаВстреча КАК Вид
    |ИЗ
    |    Документ.Встреча.Участники КАК ВстречаУчастники
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.Встреча КАК Встреча
    |        ПО ВстречаУчастники.Ссылка = Встреча.Ссылка
    |ГДЕ
    |    (ВстречаУчастники.Контакт = &Партнер
    |            ИЛИ ВстречаУчастники.Контакт.Владелец = &Партнер)
    |    И (НЕ Встреча.ПометкаУдаления)
    //|    И (НЕ Встреча.Рассмотрено)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ЗапланированноеВзаимодействие.Описание КАК СТРОКА(1024)),
    |    ЗапланированноеВзаимодействие.Ссылка,
    |    ЗапланированноеВзаимодействие.Дата,
    |    ЗапланированноеВзаимодействие.Ответственный,
    //|    ЗапланированноеВзаимодействие.РассмотретьПосле,
    |    &СтрокаЗапланированноеВзаимодействие
    |ИЗ
    |    Документ.ЗапланированноеВзаимодействие.Участники КАК ЗапланированноеВзаимодействиеУчастники
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ЗапланированноеВзаимодействие КАК ЗапланированноеВзаимодействие
    |        ПО ЗапланированноеВзаимодействиеУчастники.Ссылка = ЗапланированноеВзаимодействие.Ссылка
    |ГДЕ
    |    (ЗапланированноеВзаимодействиеУчастники.Контакт = &Партнер
    |            ИЛИ ЗапланированноеВзаимодействиеУчастники.Контакт.Владелец = &Партнер)
    //|    И (НЕ ЗапланированноеВзаимодействие.Рассмотрено)
    |    И (НЕ ЗапланированноеВзаимодействие.ПометкаУдаления)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ТелефонныйЗвонок.Описание КАК СТРОКА(1024)),
    |    ТелефонныйЗвонок.Ссылка,
    |    ТелефонныйЗвонок.Ответственный,
    |    ТелефонныйЗвонок.Дата,
    //|    ТелефонныйЗвонок.РассмотретьПосле,
    |    &СтрокаТелефонныйЗвонок
    |ИЗ
    |    Документ.ТелефонныйЗвонок КАК ТелефонныйЗвонок
    |ГДЕ
    |    ТелефонныйЗвонок.Дата >= &ПараметрНачалоПериода
    |    (НЕ ТелефонныйЗвонок.ПометкаУдаления)
    |    И (ТелефонныйЗвонок.АбонентКонтакт = &Партнер
    |            ИЛИ ТелефонныйЗвонок.АбонентКонтакт.Владелец = &Партнер)
    //|    И (НЕ ТелефонныйЗвонок.Рассмотрено)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ЭлектронноеПисьмоВходящее.Тема КАК СТРОКА(1024)),
    |    ЭлектронноеПисьмоВходящее.Ссылка,
    |    ЭлектронноеПисьмоВходящее.Дата,
    |    ЭлектронноеПисьмоВходящее.Ответственный,
    //|    ЭлектронноеПисьмоВходящее.РассмотретьПосле,
    |    &СтрокаПисьмоВходящее
    |ИЗ
    |    Документ.ЭлектронноеПисьмоВходящее КАК ЭлектронноеПисьмоВходящее
    |ГДЕ
    |    (ЭлектронноеПисьмоВходящее.ОтправительКонтакт = &Партнер
    |            ИЛИ ЭлектронноеПисьмоВходящее.ОтправительКонтакт.Владелец = &Партнер)
    //|    И (НЕ ЭлектронноеПисьмоВходящее.Рассмотрено)
    |    И (НЕ ЭлектронноеПисьмоВходящее.ПометкаУдаления)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    ВЫРАЗИТЬ(ЭлектронноеПисьмоИсходящее.Тема КАК СТРОКА(1024)),
    |    ЭлектронноеПисьмоИсходящее.Ссылка,
    |    ЭлектронноеПисьмоИсходящее.Дата,
    |    ЭлектронноеПисьмоИсходящее.Ответственный,
    //|    ЭлектронноеПисьмоИсходящее.РассмотретьПосле,
    |    &СтрокаПисьмоИсходящее
    |ИЗ
    |    Документ.ЭлектронноеПисьмоИсходящее.ПолучателиПисьма КАК ЭлектронноеПисьмоИсходящееПолучателиПисьма
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ЭлектронноеПисьмоИсходящее КАК ЭлектронноеПисьмоИсходящее
    |        ПО ЭлектронноеПисьмоИсходящееПолучателиПисьма.Ссылка = ЭлектронноеПисьмоИсходящее.Ссылка
    |ГДЕ
    |    (НЕ ЭлектронноеПисьмоИсходящее.ПометкаУдаления)
    //|    И (НЕ ЭлектронноеПисьмоИсходящее.Рассмотрено)
    |    И (ЭлектронноеПисьмоИсходящееПолучателиПисьма.Контакт = &Партнер
    |            ИЛИ ЭлектронноеПисьмоИсходящееПолучателиПисьма.Контакт.Владелец = &Партнер)
    |    И ЭлектронноеПисьмоИсходящее.СтатусПисьма = ЗНАЧЕНИЕ(Перечисление.СтатусыИсходящегоЭлектронногоПисьма.Отправлено)
    |ИТОГИ
    |    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ Ссылка)
    |ПО
    |    ОБЩИЕ
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |";
    Запрос.УстановитьПараметр("ПараметрНачалоПериода", НачалоПериода);    
КонецФункции



 ! 

Правила: 5
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138360 · Ответов: 5 · Просмотров: 1387
 

>  Соединить ячейки в одну
burza
Отправлено: 07.02.18, 16:10


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


sava1, sava1 @ Сегодня, 15:12 * ,
в личку кинул

слепил все в одну ячейку, как теперь удалить дубли с них

 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138307 · Ответов: 8 · Просмотров: 166
 

>  Соединить ячейки в одну
burza
Отправлено: 07.02.18, 15:07


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


я думал чтобы сделать объединение ячеек и строк но не могу понять почему по разному описанию поля "Описание " дублируются другие строки
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138305 · Ответов: 8 · Просмотров: 166
 

>  Соединить ячейки в одну
burza
Отправлено: 07.02.18, 15:03


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


sava1 @ Сегодня, 14:59 * ,
https://drive.google.com/open?id=1BLU1m8jvr...YRmx0OpVZCLcX3Q
Группировки я вообще не какие не ставил ибо поле Описание на группировку ругается.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138303 · Ответов: 8 · Просмотров: 166
 

>  Соединить ячейки в одну
burza
Отправлено: 07.02.18, 14:59


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


sava1 @ Сегодня, 14:58 * ,
Напишите как надо пожалуйста
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138301 · Ответов: 8 · Просмотров: 166
 

>  Соединить ячейки в одну
burza
Отправлено: 07.02.18, 14:53


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Скажите как сгрупировать или соединить строки, ячейки что бы все было в одну строку и без повторений.

ВЫБРАТЬ
    ВложенныйЗапрос.Клиент,
    ВложенныйЗапрос.Ответственный,
    ПартнерыКонтактнаяИнформация.Представление,
    Телефон.Тема,
    Телефон.Описание,
    Телефон.Комментарий
ИЗ
    (ВЫБРАТЬ
        ПерспективнаяЗаявкаПлан.Клиент.Код КАК КлиентКод,
        ПерспективнаяЗаявкаПлан.Клиент КАК Клиент,
        ПерспективнаяЗаявкаПлан.Ссылка.Ответственный КАК Ответственный
    ИЗ
        Документ.ПерспективнаяЗаявка.План КАК ПерспективнаяЗаявкаПлан
    ГДЕ
        ПерспективнаяЗаявкаПлан.Командировка = &Командировка) КАК ВложенныйЗапрос
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Партнеры.КонтактнаяИнформация КАК ПартнерыКонтактнаяИнформация
        ПО ВложенныйЗапрос.КлиентКод = ПартнерыКонтактнаяИнформация.Ссылка.Код
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            ТелефонныйЗвонок.АбонентКонтакт КАК АбонентКонтакт,
            ТелефонныйЗвонок.Описание КАК Описание,
            ТелефонныйЗвонок.Ответственный КАК Ответственный,
            ТелефонныйЗвонок.Тема КАК Тема,
            ТелефонныйЗвонок.Комментарий КАК Комментарий
        ИЗ
            Документ.ТелефонныйЗвонок КАК ТелефонныйЗвонок) КАК Телефон
        ПО ВложенныйЗапрос.Клиент = Телефон.АбонентКонтакт
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138299 · Ответов: 8 · Просмотров: 166
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 01.12.17, 11:28


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


burza @ Сегодня, 9:34 * ,
вот так это делается.
НовыйПриходныйКассовыйОрдер.Контрагент = ПодобратьКонтрагента(Выборка.ПлательщикНаименование, Выборка.ПлательщикКодПоЕДРПОУ, Выборка.ПлательщикИНН);

как тяжело было сказать, все хотят помоч.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135588 · Ответов: 17 · Просмотров: 384
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 01.12.17, 9:34


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


logist @ Вчера, 15:59 * ,
Вы скажите как написать) пример дайте.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135576 · Ответов: 17 · Просмотров: 384
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 30.11.17, 15:40


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Разобрался.Импорт проходит только не заполняются все поля не могу понять почему. Контрагенты одинаковые и кассы тоже.

        // Создаём запрос для выборки всех исходящих платежей за период
            запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
                    |    Платеж.Дата,
                    |    Платеж.Номер,
                    |    Платеж.Плательщик.Наименование КАК ПлательщикНаименование,
                    |    Платеж.Получатель.Наименование КАК ПолучательНаименование,
                    |    Платеж.СтатьяДвиженияДенежныхСредств.Наименование КАК СтатьяДвиженияДенежныхСредств,
                    |    Платеж.СуммаВВалютеПлатежа КАК СуммаДокумента
                    |ИЗ
                    |    Документ.Платеж КАК Платеж
                    |ГДЕ
                    |    Платеж.Дата МЕЖДУ &НачалоПериода И &КонецПериода
                    |    И Платеж.Проведен = ИСТИНА";
            запр.УстановитьПараметр("НачалоПериода",Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода",Объект.КонецПериода);

            Выборка = запр.Выполнить().Выбрать();
            Пока Выборка.Следующий() Цикл
                Сообщить("Импорт платежа №" + Выборка.Номер);
                Если ПроверитьСуществованиеДокумента(Перечисления.ТипыПлатежей.ПриходБезналичный, Выборка.Номер, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                    Сообщить("Импорт платежа №" + Выборка.Номер + " невозможен, поскольку он уже был импортирован");
                Иначе
                    НачатьТранзакцию();
                    НовыйПриходныйКассовыйОрдер = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
                    НовыйПриходныйКассовыйОрдер.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПоступлениеОплатыОтКлиента;
                    НовыйПриходныйКассовыйОрдер.СуммаДокумента = Выборка.СуммаДокумента;
                    НовыйПриходныйКассовыйОрдер.СтатьяДвиженияДенежныхСредств = Выборка.СтатьяДвиженияДенежныхСредств;
                    НовыйПриходныйКассовыйОрдер.Дата = Выборка.Дата;
                    НовыйПриходныйКассовыйОрдер.Номер = Выборка.Номер;
                    НовыйПриходныйКассовыйОрдер.Контрагент = Выборка.ПлательщикНаименование;
                    НовыйПриходныйКассовыйОрдер.Касса = Выборка.ПолучательНаименование;
                    НовыйПриходныйКассовыйОрдер.Кассир = ПараметрыСеанса.ТекущийПользователь;
                    НовыйПриходныйКассовыйОрдер.Записать();
                    ЗафиксироватьТранзакцию();
                КонецЕсли;
            КонецЦикла;


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135543 · Ответов: 17 · Просмотров: 384
 

>  Нужно скопировать Иерархию справочника
burza
Отправлено: 30.11.17, 11:22


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Нужно скопировать Иерархию справочника со всеми элементами с одной группы в другую, подскажите как это можно реализовать. Нужно чтото на подобии https://infostart.ru/public/92395/ если есть дайте пожалуйста обработку эту.

burza @ Сегодня, 10:38 * ,
1С 8.3 управляемое приложение.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135521 · Ответов: 0 · Просмотров: 232
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 29.11.17, 13:02


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Petre @ Сегодня, 12:44 * ,

Исключено. я не настолько маша растеряша
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135474 · Ответов: 17 · Просмотров: 384
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 29.11.17, 12:15


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Petre @ Сегодня, 11:58 * ,
Это вы что этим хотите сказать? что я дал код другой обработки?) код правильный и скрин верный.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135471 · Ответов: 17 · Просмотров: 384
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 29.11.17, 11:35


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


salton @ Сегодня, 10:02 * ,
вы не про то подумали, выгрузка идет с базы в Ут а не наоборот
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135463 · Ответов: 17 · Просмотров: 384
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 29.11.17, 9:57


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


salton @ Сегодня, 9:50 * ,
Я тяну с своей базы в УТ.Документ есть, на фото с ошибкой видно что он вытягивает его номер с другой базы УУ0132433 а дальше ошибка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135441 · Ответов: 17 · Просмотров: 384
 

>  Не могу произвести импорт документов с одной базы в другую
burza
Отправлено: 29.11.17, 9:42


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Пытаюсь втянуть документы из одной базы в УТ. обработку пишу сам, ну где-то не стыковка не могу рассмотреть где . помогите.

            // Создаём запрос для выборки всех исходящих платежей за период
            запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
                    |    Платеж.Дата,
                    |    Платеж.Номер,
                    |    Платеж.Плательщик,
                    |    Платеж.Получатель,
                    |    Платеж.СтатьяДвиженияДенежныхСредств,
                    |    Платеж.СуммаВВалютеПлатежа
                    |ИЗ
                    |    Документ.Платеж КАК Платеж
                    |ГДЕ
                    |    Платеж.Дата МЕЖДУ &НачалоПериода И &КонецПериода
                    |    И Платеж.Проведен = ИСТИНА";
            запр.УстановитьПараметр("НачалоПериода",Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода",Объект.КонецПериода);

            Выборка = запр.Выполнить().Выбрать();
            Пока Выборка.Следующий() Цикл
                Сообщить("Импорт платежа №" + Выборка.Номер);
                Если ПроверитьСуществованиеДокумента(Перечисления.ТипыПлатежей.ПриходБезналичный, Выборка.Номер, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                    Сообщить("Импорт платежа №" + Выборка.Номер + " невозможен, поскольку он уже был импортирован");
                Иначе
                    НачатьТранзакцию();
                    НовыйРасходныйКассовыйОрдер = Документы.РасходныйКассовыйОрдер.СоздатьДокумент();
                    НовыйРасходныйКассовыйОрдер.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПоступлениеОплатыОтКлиента;
                    НовыйРасходныйКассовыйОрдер.СуммаДокумента = Выборка.СуммаВВалютеПлатежа;
                    НовыйРасходныйКассовыйОрдер.СтатьяДвиженияДенежныхСредств = Выборка.СтатьяДвиженияДенежныхСредств;
                    //НовыйРасходныйКассовыйОрдер.Валюта = Справочники.Валюты.НайтиПоНаименованию(Выборка.ВалютаПлатежаНаименование);
                    //Если НовыйРасходныйКассовыйОрдер.Валюта = Константы.ОсновнаяВалютаСистемы.Получить() тогда
                    //    НовыйРасходныйКассовыйОрдер.Курс = 1;
                    //    НовыйПлатёж.СуммаВБазовойВалюте = НовыйПлатёж.СуммаВВалютеПлатежа;
                    //КонецЕсли;
                    НовыйРасходныйКассовыйОрдер.Дата = Выборка.Дата;
                    НовыйРасходныйКассовыйОрдер.СправочныйНомерДокумента = Выборка.Номер;
                    НовыйРасходныйКассовыйОрдер.Контрагент =Выборка.Плательщик;
                    НовыйРасходныйКассовыйОрдер.Касса = Выборка.Получатель;
                    НовыйРасходныйКассовыйОрдер.Кассир = ПараметрыСеанса.ТекущийПользователь;
                    НовыйРасходныйКассовыйОрдер.Записать();
                    ЗафиксироватьТранзакцию();
                КонецЕсли;
            КонецЦикла;


вот и сама ошибка
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #135439 · Ответов: 17 · Просмотров: 384
 

>  Автозаполнение табличного документа
burza
Отправлено: 10.11.17, 15:49


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Vidocq05 @ Сегодня, 15:38 * ,
Спасибо помогло)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #134742 · Ответов: 5 · Просмотров: 304
 

>  Автозаполнение табличного документа
burza
Отправлено: 10.11.17, 13:00


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Есть форма с табличной частью при добавлении новой строки нужно чтобы в поле выбора статуса он заполнялся автоматически(какой укажу) сейчас есть вот это. Понимаю что справочник нужно проводить через сервер но не могу понять как потом вставить переменную сюда.
&НаКлиенте
Процедура ПланПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока И Не Копирование тогда
        Элемент.ТекущиеДанные.Дата = ТекущаяДата();
        Элемент.ТекущиеДанные.СтатусВыполнения = Справочники.СтатусВыполнения.НайтиПоНаименованию("В работе");
    КонецЕсли;

КонецПроцедуры

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #134736 · Ответов: 5 · Просмотров: 304
 

>  УТ Запрос при выборе клиента из справочника
burza
Отправлено: 10.11.17, 12:00


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Bernet @ Сегодня, 11:53 * ,
спасибо
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #134728 · Ответов: 2 · Просмотров: 217
 

>  УТ Запрос при выборе клиента из справочника
burza
Отправлено: 10.11.17, 11:40


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Подскажите как сделать запрос перед выбором справочника. То есть есть справочник партнеров есть документ продажи где ссылка на партнеров идет само собой. Есть третий документ где нужно при выборе партнера чтобы было видны только те которые купили товар.(документ в табличной форме)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #134725 · Ответов: 2 · Просмотров: 217
 

>  Нужно сделать отчет чтобы его видели только ответственый
burza
Отправлено: 31.03.17, 9:44


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Bernet @ Сегодня, 10:12 * ,
БОЛЬШОЕ ВАМ спасибо!!! Очень выручили)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #125094 · Ответов: 15 · Просмотров: 1220
 

>  Нужно сделать отчет чтобы его видели только ответственый
burza
Отправлено: 30.03.17, 20:48


Говорящий
***

Группа: Пользователи
Сообщений: 97
Регистрация: 02.08.15
Пользователь №: 45113


Bernet @ Сегодня, 17:14 * ,
Прошу вас написать запрос. мне очень надо.

Сделал вот так
ВЫБРАТЬ
    ДенежныеСредстваОстаткиИОбороты.СуммаНачальныйОстаток,
    ДенежныеСредстваОстаткиИОбороты.СуммаКонечныйОстаток,
    ДенежныеСредстваОстаткиИОбороты.СуммаПриход,
    ДенежныеСредстваОстаткиИОбороты.СуммаРасход,
    ДенежныеСредстваОстаткиИОбороты.БанковскийСчетКасса
ИЗ
    РегистрНакопления.ДенежныеСредства.ОстаткиИОбороты КАК ДенежныеСредстваОстаткиИОбороты
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних КАК ОтветственныеЛицаСрезПоследних
        ПО ДенежныеСредстваОстаткиИОбороты.БанковскийСчетКасса.Наименование = ОтветственныеЛицаСрезПоследних.СтруктурнаяЕдиница.Наименование
ГДЕ
    ОтветственныеЛицаСрезПоследних.ФизическоеЛицо = &ФизическоеЛицо


как сюда отбор по физ лицу добавить без выбора самому

вот такое или близко )
     Запрос = новый Запрос;
Запрос.УстановитьПараметр("ФизическоеЛицо",СсылкаНаОбъект.ФизическоеЛицо);

Запрос.Текст = "ВЫБРАТЬ
|    ДенежныеСредстваОстаткиИОбороты.СуммаНачальныйОстаток,
|    ДенежныеСредстваОстаткиИОбороты.СуммаКонечныйОстаток,
|    ДенежныеСредстваОстаткиИОбороты.СуммаПриход,
|    ДенежныеСредстваОстаткиИОбороты.СуммаРасход,
|    ДенежныеСредстваОстаткиИОбороты.БанковскийСчетКасса
|ИЗ
|    РегистрНакопления.ДенежныеСредства.ОстаткиИОбороты КАК ДенежныеСредстваОстаткиИОбороты
|        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних КАК ОтветственныеЛицаСрезПоследних
|        ПО ДенежныеСредстваОстаткиИОбороты.БанковскийСчетКасса.Наименование = ОтветственныеЛицаСрезПоследних.СтруктурнаяЕдиница.Наименование
|ГДЕ
|    ОтветственныеЛицаСрезПоследних.ФизическоеЛицо = &ФизическоеЛицо";
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #125063 · Ответов: 15 · Просмотров: 1220
 

4 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.02.18, 1:08
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне