Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Импорт выписки с КБ iFobs (ОТП)          
marveL Подменю пользователя
сообщение 04.03.13, 15:58
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 31
Спасибо сказали: 2 раз
Рейтинг: 0

Добрый день. Помогите пожалуйста, нужна обработка чтоб импортировать выписки с клиент-банка iFobs. Формат импорта txt, xls, xml. Конфигурация 1с 7,7 Комплексная


Поделитесь плз хотя бы импортом выписки из txt файла, там уже будем допиливать.

vadim007 Подменю пользователя
сообщение 05.03.13, 12:17
Сообщение #2

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1298
Из: Донецк
Спасибо сказали: 200 раз
Рейтинг: 0

Интересно посмотреть на формат импорта.

sava1 Подменю пользователя
сообщение 05.03.13, 12:59
Сообщение #3

Крутой
Иконка группы
Группа: Местный
Сообщений: 1906
Из: Проскуров
Спасибо сказали: 444 раз
Рейтинг: 433.5

Вот для ХМЛ:

Функция ИмпортXML(Параметры)
    ФайлXML = Новый ЧтениеXML;
    ИмяФайла = Параметры.ИмяФайла;
    
    Попытка
        ФайлXML.ОткрытьФайл(ИмяФайла);
    Исключение
        Предупреждение("Ошибка открытия файла " + ИмяФайла);
        Возврат Неопределено;
    КонецПопытки;        
    
    тзВыписка =  Новый ТаблицаЗначений;
    тзВыписка.Колонки.Добавить("НомерПП");
    тзВыписка.Колонки.Добавить("Приход");
    тзВыписка.Колонки.Добавить("Расход");
    тзВыписка.Колонки.Добавить("ОКПО");
    тзВыписка.Колонки.Добавить("Контрагент");
    тзВыписка.Колонки.Добавить("МФО");
    тзВыписка.Колонки.Добавить("РСчет");
    тзВыписка.Колонки.Добавить("Содержание");
    
    КолвоЗаписей = 0;
    Пока ФайлXML.Прочитать() Цикл
        ИмяТега = ФайлXML.Имя;
        Если ИмяТега = "ROW" И ФайлXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            
            ДатаВыписки = ФайлXML.ПолучитьАтрибут("DOCUMENTDATE");  // 20081110
            // Проверка на дату выписки
            Если ДатаВыписки <> Формат(Параметры.ДатаДок,"ДФ=yyyyMMdd") И ДатаВыписки <> Формат(Параметры.ДатаДок,"ДФ=dd.MM.yyyy") Тогда
                Продолжить;
            КонецЕсли;    
            
            РСчетА = СокрЛП(ФайлXML.ПолучитьАтрибут("ACCOUNTNO"));
            РСчетБ = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRACCOUNTNO"));
            
            Если РСчетБ = Параметры.РСчет Тогда // дебет
                НовСтрока = тзВыписка.Добавить();
                НовСтрока.Приход        = Число(ФайлXML.ПолучитьАтрибут("AMOUNT"))/100;
                НовСтрока.Расход        = 0;
                
                НовСтрока.РСчет            = СокрЛП(Формат(РСчетА,"ЧГ=0"));
                    
                //НовСтрока.ОКПО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRIDENTIFYCODE"),"ЧГ=0"));
                //НовСтрока.МФО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("BANKID"),"ЧГ=0"));
                //НовСтрока.Контрагент    = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRCONTRAGENTSNAME"));
                
            ИначеЕсли РСчетА = Параметры.РСчет Тогда // кредит    
                НовСтрока = тзВыписка.Добавить();
                НовСтрока.Приход        = 0;
                НовСтрока.Расход        = Число(ФайлXML.ПолучитьАтрибут("AMOUNT"))/100;
                
                НовСтрока.РСчет            = СокрЛП(Формат(РСчетБ,"ЧГ=0"));
                    
                //НовСтрока.ОКПО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRIDENTIFYCODE"),"ЧГ=0"));
                //НовСтрока.МФО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRBANKID"),"ЧГ=0"));
                //НовСтрока.Контрагент    = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRSNAME"));
            Иначе
                Продолжить;
            КонецЕсли;    
            
            НовСтрока.ОКПО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRIDENTIFYCODE"),"ЧГ=0"));
            НовСтрока.МФО            = СокрЛП(Формат(ФайлXML.ПолучитьАтрибут("CORRBANKID"),"ЧГ=0"));
            НовСтрока.Контрагент    = СокрЛП(ФайлXML.ПолучитьАтрибут("CORRSNAME"));
            
                
            НовСтрока.Содержание     = СокрЛП(ФайлXML.ПолучитьАтрибут("DETAILSOFPAYMENT"));
            НовСтрока.НомерПП         = СокрЛП(ФайлXML.ПолучитьАтрибут("DOCUMENTNO"));
            
            КолвоЗаписей = КолвоЗаписей + 1;
            
        Иначе
            Продолжить;    
        КонецЕсли;    
        
    КонецЦикла;      
    
    
    Если НЕ тзВыписка.Количество() И КолвоЗаписей > 0 Тогда
        Предупреждение("В текущем файле нет платежей с данной датой выписки и расчетным счетом!");
    КонецЕсли;
    
    ФайлXML.Закрыть();
    
    Возврат тзВыписка;

Спасибо сказали: Ardi, Ortman_fon_but,

marveL Подменю пользователя
сообщение 05.03.13, 13:18
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 31
Спасибо сказали: 2 раз
Рейтинг: 0

Спасибо и за это, буду мучать.

vadim007 Подменю пользователя
сообщение 05.03.13, 14:46
Сообщение #5

Почти крутой
Иконка группы
Группа: Местный
Сообщений: 1298
Из: Донецк
Спасибо сказали: 200 раз
Рейтинг: 0

Цитата(sava1 @ 05.03.13, 12:59) *
Вот для ХМЛ:

Спасибо конечно, но я имел в виду примерно вот это [необходимо зарегистрироваться для просмотра ссылки]
И ещ вот нашел: [необходимо зарегистрироваться для просмотра ссылки]

Сообщение отредактировал vadim007 - 05.03.13, 14:50

Спасибо сказали: Ardi,

marveL Подменю пользователя
сообщение 05.03.13, 16:06
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 31
Спасибо сказали: 2 раз
Рейтинг: 0

На инфостарте видел, там два "но": для 1с 8,2 и не пойму систему как оттуда скачивать. Некоторые обработки дает качать, некоторые нет.
Спасибо.

sava1 Подменю пользователя
сообщение 05.03.13, 16:37
Сообщение #7

Крутой
Иконка группы
Группа: Местный
Сообщений: 1906
Из: Проскуров
Спасибо сказали: 444 раз
Рейтинг: 433.5

Куда слить? Адрес...

Для Факториала под 77
[необходимо зарегистрироваться для просмотра ссылки]

marveL Подменю пользователя
сообщение 05.03.13, 17:07
Сообщение #8

Общительный
**
Группа: Пользователи
Сообщений: 31
Спасибо сказали: 2 раз
Рейтинг: 0

Поделитесь пожалуйста, lg2marvel@ukr.net

mobitay Подменю пользователя
сообщение 28.05.13, 15:07
Сообщение #9

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Доброго времени суток.
У кого есть решение iFobs ОТП + 1С 7.7 прошу помощи.
СПАСИБО !!!

logist Подменю пользователя
сообщение 28.05.13, 15:23
Сообщение #10

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Цитата(mobitay @ 28.05.13, 16:07) *
прошу помощи.

Чем помочь?


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Спасибо сказали: mobitay,

marveL Подменю пользователя
сообщение 28.05.13, 15:36
Сообщение #11

Общительный
**
Группа: Пользователи
Сообщений: 31
Спасибо сказали: 2 раз
Рейтинг: 0

Цитата(mobitay @ 28.05.13, 16:07) *
Доброго времени суток.
У кого есть решение iFobs ОТП + 1С 7.7 прошу помощи.
СПАСИБО !!!

[необходимо зарегистрироваться для просмотра ссылки]

Спасибо сказали: mobitay,

mobitay Подменю пользователя
сообщение 28.05.13, 17:34
Сообщение #12

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(marveL @ 28.05.13, 15:36) *
[необходимо зарегистрироваться для просмотра ссылки]


Спасибо !!!

Цитата(logist @ 28.05.13, 15:23) *
Чем помочь?

Спасибо за отклик, задачу решил!!!

akaLOM Подменю пользователя
сообщение 19.03.14, 15:22
Сообщение #13

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(marveL @ 28.05.13, 15:36) *
[необходимо зарегистрироваться для просмотра ссылки]


Данная ссылка давно не рбаотает. Можно ли повторно выложить файл?
Заранее спасибо.

Brook Подменю пользователя
сообщение 01.04.14, 13:27
Сообщение #14

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Да, ссылка не работает. Пожалуйста, выложите повторно файлик...

satdnepr Подменю пользователя
сообщение 03.09.14, 9:59
Сообщение #15

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Пожалуйста перезалейте у кого есчть на файлообменник.

moongrass Подменю пользователя
сообщение 15.12.15, 16:52
Сообщение #16

Общительный
**
Группа: Пользователи
Сообщений: 17
Спасибо сказали: 0 раз
Рейтинг: 0

Здравствуйте уважаемые. У меня стал острый вопрос по данной теме. Кто может помочь решить её?

Acid Подменю пользователя
сообщение 16.12.15, 9:01
Сообщение #17

Про1С-ник
Иконка группы
За заслуги на форуме в 2010 году
Группа: Местный
Сообщений: 2034
Из: Занзибар
Спасибо сказали: 336 раз
Рейтинг: 214.2

Цитата(moongrass @ 15.12.15, 16:52) *
Здравствуйте уважаемые. У меня стал острый вопрос по данной теме. Кто может помочь решить её?

Оформите заявку в Столе Заказов. Помогут.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.18, 22:51
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне