Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как ускорить управляемую форму?          
pablo Подменю пользователя
сообщение 27.04.16, 14:43
Сообщение #1

Ветеран
*******
Группа: Команда (модераторы)
Сообщений: 921
Из: Одесса-Луганск
Спасибо сказали: 133 раз
Рейтинг: 97.9

Есть у меня документ, в котором есть одна основная табличная часть и 12 вспомогательных. В форме документа есть страницы для основной ТЧ и несколько страниц для дополнительных, т.е. на одной странице могут располагаться несколько ТЧ. И есть у меня некоторая проблема быстродействия при переключении закладок, а именно: если в основной ТЧ порядка 200 строк, то переключение на страницу с другими ТЧ код процедуры ПриСменеСтраниц выполняется 4-5 секунд.
При этом экспериментально я выяснил, что основная часть потраченного времени тратится на следующий код:
    Отбор1=новый Структура;
    Если НомерИзделия=0 тогда        
        Если Объект.Изделия.Количество()=0 тогда
            Возврат;
        КонецЕсли;    
        Отбор1.Вставить("НомерИзделия",Объект.Изделия[0].НомерИзделия);
    иначе    
        Отбор1.Вставить("НомерИзделия",Объект.Изделия[НомерИзделия-1].НомерИзделия);
    КонецЕсли;    
    ОтборПараметров=новый ФиксированнаяСтруктура(Отбор1);
    Если ТекущаяСтраница=Элементы.Группа4.ПодчиненныеЭлементы.Обработка тогда
        Элементы.Обработки.ОтборСтрок=ОтборПараметров;
    ИначеЕсли ТекущаяСтраница=Элементы.Группа4.ПодчиненныеЭлементы.Структура тогда          
        Элементы.Материалы.ОтборСтрок=ОтборПараметров;
    КонецЕсли;

Т.е. именно ОтборСтрок по Табличной части тормозит вывод данных.

Как можно ускорить отбор строк?
P.S. Я пробовал создать отдельный реквизит формы типа ТаблицаЗначений и заполнять ее вручную, но результат в лучшем случае не улучшался.



P.P.S. Управляемая форма используется в толстом клиенте.


Signature
Правильно поставленный вопрос содержит до 90% ответа.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.09.17, 13:05
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне