Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику bereznoy ::: Спасибо сказали: 9 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
28.05.13, 23:19 Водяной знак на изображениях в номенклатуре
Спасибо никто получить не хотел = не подсказал, вообщем то вот так сделал, теперь все ок, теперь осталось допилить (цену,артикул нанести), но это уже мелочи ))), вот код, может кому пригодиться
 КВФ = Лев(КаталогВременныхФайлов(), 3)  + "SlideShowTemp\";
    СоздатьКаталог(КВФ);
    КаталогКонвертатора = КаталогВременныхФайлов() + "SlideShow\ImageMagick\";
    WScript = Новый COMОбъект("WScript.Shell");

    ИмяФайлаТекста = КВФ + "txt.txt";
    Текст = Новый ТекстовыйДокумент;
    Текст.УстановитьТекст(Изображение1.Номенклатура.Наименование);
    Текст.Записать(ИмяФайлаТекста, "windows-1251", Символы.ВК);

    Темп_ИмяФайлаШрифта = "C:\Users\Администратор\Desktop\AGBENGR.TTF";
    ИмяФайлаШрифта = КВФ + "font.TTF";
    КопироватьФайл(Темп_ИмяФайлаШрифта, ИмяФайлаШрифта);

   ИмяФайлаСлайда =КВФ +  "text.png";
   ИмяФайлаКартинки = КВФ +  "img.jpg";
   ИмяФайлаНовойКартинки = КВФ +  "img." + Файл.Формат();
   Файл.Записать(ИмяФайлаКартинки);
   КопироватьФайл(КаталогИзображений+"\"+СокрЛП(Папки1.Папка.Родитель)+"\"+СокрЛП(Папки1.Папка.Наименование)+"\"+ИмяФайла,ИмяФайлаСлайда);
  
  
   ИмяФайлаПодложки = КВФ +  "source.png";
   КопироватьФайл(ИмяФайлаКартинки, ИмяФайлаПодложки);

    
    КомандаКонвертацииКартинки = """" + КаталогКонвертатора + "convert.exe"" -background transparent -font """ + ИмяФайлаШрифта + """ -pointsize 18 -page A2 -fill #00000fff text:""" + ИмяФайлаТекста + """ -trim -bordercolor transparent -border 24 """ + ИмяФайлаСлайда + """";
      WScript.Run(КомандаКонвертацииКартинки, 0, Истина);

    
    

    КомандаКонвертацииКартинки = """" + КаталогКонвертатора + "convert.exe"" """ + ИмяФайлаПодложки + """ -compose over -gravity South """ + ИмяФайлаСлайда + """ -composite -alpha off """ + ИмяФайлаКартинки + """";
    WScript.Run(КомандаКонвертацииКартинки, 0, Истина);
    
     КопироватьФайл(ИмяФайлаКартинки, КаталогИзображений+"\"+СокрЛП(Папки1.Папка.Родитель)+"\"+СокрЛП(Папки1.Папка.Наименование)+"\"+ИмяФайла);
Vofka, zay,
06.01.13, 11:34 Текст на картинке в макете отчета
Цитата(Ardi @ 06.01.13, 4:20) *
Вставить объект "Текст". Поместить его над картинкой. Убрать рамки.

А где можно почитать или подскажите как "Вставить объект "Текст" ?
Рисунок.Текст .... ?
Рисунок.РазмещениеТекста ..... ?
Это есть но у меня не получается, пытался Рисунок.Текст = "какой то текст"


Получилось, но вот как бы сделать что б прямоугольник текста не перекрывал рисунок, т.е. был просто прозрачный и виден только текст и рамки у самой картики не получается обрезать


ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура");
            Изображение = Выборка.Номенклатура.ОсновноеИзображение.Хранилище.Получить();
        Если НЕ Изображение = Неопределено Тогда
         Рисунок = ОбластьНоменклатура.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
Рисунок.Верх = 3;
Рисунок.Высота =70;
Рисунок.Ширина = 90;
Рисунок.Лево = 3.5;

Рисунок.РазмерКартинки = РазмерКартинки.Растянуть;//.Пропорционально;

Рисунок.Картинка = Изображение;
///////////////////////////////////////
Рисунок = ОбластьНоменклатура.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Текст);
Рисунок.Верх = 10;
Рисунок.Лево = 10;
Рисунок.Ширина = 30;
Рисунок.Высота = 10;
Рисунок.ОриентацияТекста = -15; //наклон 15 градусов по часовой стрелке
Рисунок.ГоризонтальноеПоложение = ГоризонтальноеПоложение.Центр;
Рисунок.ВертикальноеПоложение = ВертикальноеПоложение.Центр;
Рисунок.Шрифт = Новый Шрифт (,,Истина); //жирный
Рисунок.ЦветТекста = Новый Цвет(0,0,255); //синий
Рисунок.Текст = Выборка.Номенклатура.Артикул;

/////////////////////////////////////////////////////
Если ЛевыйСтолбец Тогда
                    ТабДок1.Вывести(ОбластьНоменклатура);
                Иначе
                    ТабДок2.Вывести(ОбластьНоменклатура);
                КонецЕсли;


КонецЕсли;
IrinaKostroma,
12.09.12, 23:22 Установка цен номенклатуры (табличная часть)
Фухх, все получилось, дописал в процедуру ПередЗаписью() запись реквизитов из временную таблицы в "Товары" и в процедуре ЗаполнитьТаблицуЦенФормы() выгрузил
из таблицы товаров в колонки соотвествующие, выкладываю свои процедурки, быть может есть косяки
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

    // Сохраним таблицу значений в табличную часть товаров.
    Товары.Очистить();
    КоличествоСтрок = ТаблицаЦен.Количество() - 1;
    Для Тмп = 0 По КоличествоСтрок Цикл
        СтрокаТаблицыТиповЦен = ТаблицаЦен[Тмп];

        Для Каждого СтрокаТипаЦен Из ТипыЦен Цикл
            НомерСоответствияТекущейКолонки = мСоответствиеТиповЦен[СтрокаТипаЦен.ТипЦен];

            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.ИндексСтрокиТаблицыЦен     = Тмп;
            НоваяСтрока.Номенклатура               = СтрокаТаблицыТиповЦен.Номенклатура;
            
            НоваяСтрока.ХарактеристикаНоменклатуры = СтрокаТаблицыТиповЦен.ХарактеристикаНоменклатуры;
            НоваяСтрока.ТипЦен                     = СтрокаТипаЦен.ТипЦен;
            НоваяСтрока.Цена                       = СтрокаТаблицыТиповЦен["цена" + НомерСоответствияТекущейКолонки];
            НоваяСтрока.Валюта                     = СтрокаТаблицыТиповЦен["валюта" + НомерСоответствияТекущейКолонки];
            НоваяСтрока.ЕдиницаИзмерения           = СтрокаТаблицыТиповЦен["единица" + НомерСоответствияТекущейКолонки];
            НоваяСтрока.ПриходнаяЦена = СтрокаТаблицыТиповЦен.ПриходнаяЦена;
            НоваяСтрока.НаценкаТрансп = СтрокаТаблицыТиповЦен.НаценкаТрансп;
            НоваяСтрока.ЦеноваяГруппаНоменклатуры = СтрокаТаблицыТиповЦен.ЦеноваяГруппаНоменклатуры;
        
        КонецЦикла;
    КонецЦикла;

КонецПроцедуры // ПередЗаписью()



и вторая

Процедура ЗаполнитьТаблицуЦенФормы()

    Если ТипыЦен.Количество() = 0 Тогда // ничего делать не надо
        Возврат;
    КонецЕсли;

    ТаблицаТоваров = Товары.Выгрузить();
    ТаблицаТоваров.Сортировать("ИндексСтрокиТаблицыЦен, Номенклатура, ХарактеристикаНоменклатуры");

    ТекущийИндексСтрокиТаблицыЦен = Неопределено;
    НоваяСтрока = Неопределено;
    Для Каждого СтрокаТаблицыТоваров Из ТаблицаТоваров Цикл
        Если ТекущийИндексСтрокиТаблицыЦен <> СтрокаТаблицыТоваров.ИндексСтрокиТаблицыЦен
         Или НоваяСтрока.Номенклатура <> СтрокаТаблицыТоваров.Номенклатура
         Или НоваяСтрока.ХарактеристикаНоменклатуры <> СтрокаТаблицыТоваров.ХарактеристикаНоменклатуры Тогда
            НоваяСтрока = ТаблицаЦен.Добавить();
            НоваяСтрока.Номенклатура = СтрокаТаблицыТоваров.Номенклатура;
            НоваяСтрока.ХарактеристикаНоменклатуры = СтрокаТаблицыТоваров.ХарактеристикаНоменклатуры;
            ТекущийИндексСтрокиТаблицыЦен = СтрокаТаблицыТоваров.ИндексСтрокиТаблицыЦен;
        КонецЕсли;

        НомерСоответствияТекущейКолонки = мСоответствиеТиповЦен[СтрокаТаблицыТоваров.ТипЦен];

        НоваяСтрока["цена" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.Цена;
    //    НоваяСтрока["СпособРасчета" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.СпособРасчетаЦены;
        НоваяСтрока["валюта" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.Валюта;
        НоваяСтрока["единица" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.ЕдиницаИзмерения;
    //    НоваяСтрока["процент" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.ПроцентСкидкиНаценки;
    НоваяСтрока.ПриходнаяЦена = СтрокаТаблицыТоваров.ПриходнаяЦена;
    НоваяСтрока.ЦеноваяГруппаНоменклатуры = СтрокаТаблицыТоваров.ЦеноваяГруппаНоменклатуры;
    НоваяСтрока.НаценкаТрансп = СтрокаТаблицыТоваров.НаценкаТрансп;

    
    
        КонецЦикла;

КонецПроцедуры // ЗаполнитьТаблицуЦенФормы()



mariupol,
03.07.12, 21:25 Печать без открытия формы
Господа, всем спасибо за подсказки, сделал так, в процедуре ПриОткрытии в документе который надо распечатать
добавил такой код
Если Форма.Параметр="Печать" тогда
    Печать1(1);
    СтатусВозврата(0);
  КонецЕсли;

nonsens,
01.02.12, 0:47 Выкладываю спр-к УКТВЭД
Мне на этом форуме очень помогают, вот и я решил быть чем то полезным,
быть может кому надо весь справочник УКТВЭД в формате dbf, выгрузил из другой
программки что б загрузить в 1с

вот ссылка для скачивания
УКТВЭД dbf


 i 

ми були б вам вдячні, якщо б ви залили цей файл в скриню (Хранилище) згідно правил
 
craneua, m1shok,
06.09.11, 23:14 Загрузки из EXCEL
offtopic.gif
alexshakh,
03.09.11, 23:16 Загрузки из EXCEL
Перезалейте, очень нужно иерархию сохранить
alexshakh,

RSS Текстовая версия Сейчас: 18.08.19, 7:18
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!