Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Відбір на списку форми документа по додаткових реквізитах , конфігурація Малий бізнес остання версія, платформа 19          
bandrah Подменю пользователя
сообщение 10.08.22, 20:59
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 37
Из: Україна
Спасибо сказали: 4 раз
Рейтинг: 4.9

Добрий вечір, виникла потреба написати код по відбору документів на формі списку, але звертаючить створених користувачем додаткових реквізитів (стандартний функціонал), можливо у когось була аналогічна потреба і є готовий код, стандартний функціонал відбору працює чудесно по дод реквізитах, але треба дописати це щоб було у всіх користувачів без прив'язки до налаштувань користувача і т.д

AnryMc Подменю пользователя
сообщение 12.08.22, 9:38
Сообщение #2

Завсегдатай
Иконка группы
Группа: Местный
Сообщений: 103
Спасибо сказали: 46 раз
Рейтинг: 44.9

bandrah @ 10.08.22, 21:59 * ,

Практически все списки документов формируются запросом, добавьте в него выборку доп. реквизитов и сделайте по ним условие...
При СозданииНаСервере устанавливайте нужное значение параметра для условия...

AnryMc @ Сегодня, 10:17 * ,


Туплю я с утра однако...

ПриСозданииНаСервере программно напишите нужный отбор по "ДополнительныеРеквизиты"

Туплю я с утра однако...

ПриСозданииНаСервере программно напишите нужный отбор по "ДополнительныеРеквизиты"

А ещё проще: общий модуль "ОбщегоНазначенияКлиентСервер"
- Процедура УстановитьЭлементОтбора
- Процедура УстановитьЭлементОтбораДинамическогоСписка
- Процедура УстановитьПараметрДинамическогоСписка
- Процедура УдалитьЭлементыГруппыОтбораДинамическогоСписка

Пример кода "альтернативного" поиска по наименованию
&НаКлиенте
Процедура СтрокаДляПоискаПриИзменении(Элемент)
    
    Если ЗначениеЗаполнено(СтрокаДляПоиска) Тогда
        
        УстановитьМойОтбор(СтрокаДляПоиска);
        
    Иначе
        
        УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОчистка(Элемент, СтандартнаяОбработка)
    
    УдалитьМойОтбор();
        
КонецПроцедуры

&НаКлиенте
Процедура СтрокаДляПоискаОткрытие(Элемент, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ЛОЖЬ;
    
    Если ЗначениеЗаполнено(Элемент.ТекстРедактирования) Тогда
        
        УстановитьМойОтбор(Элемент.ТекстРедактирования);
        
    //Иначе
    //    
    //    УдалитьМойОтбор();
        
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьМойОтбор(СДП)
    
    ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(Список, "Наименование", СДП, ВидСравненияКомпоновкиДанных.Содержит,,Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура УдалитьМойОтбор()
    
    ОбщегоНазначенияКлиентСервер.УдалитьЭлементыГруппыОтбораДинамическогоСписка(Список, "Наименование");
    
КонецПроцедуры


Сообщение отредактировал AnryMc - 12.08.22, 10:04

Спасибо сказали: bandrah,

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 06.10.22, 15:13
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!