Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Сохранить и восстановить результат отчета          
Bdrh Подменю пользователя
сообщение 21.06.22, 13:09
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

Всем привет.
Есть РС с измерением типа Документ и ресурсом Хранилище значений. В него помещается табличный документ. Можно ли как-то отчетом вытянуть записи из этого РС в таком виде?:
-Документ
---- Табличный документ из хранилища значений
Я сделал отчет, в вычисляемых полях сделал поле, которое через общий модуль получает значение хранилища значения. Но при выводе этого поля в групировку скд просто выводит надпись "Табличный документ". Как бы сделать так, чтобы выводился сам табличный документ?

sava1 Подменю пользователя
сообщение 21.06.22, 13:37
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2568
Из: Проскуров
Спасибо сказали: 633 раз
Рейтинг: 613.2

дык и сохраняйте таб.док.
Восстановление - вытащили табдок из хранилища, вставили в итоговый Табличный документ

lolmatrix Подменю пользователя
сообщение 21.06.22, 14:58
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 107
Спасибо сказали: 1 раз
Рейтинг: 1

Цитата(Bdrh @ 21.06.22, 14:09) *
Всем привет.
Есть РС с измерением типа Документ и ресурсом Хранилище значений. В него помещается табличный документ. Можно ли как-то отчетом вытянуть записи из этого РС в таком виде?:
-Документ
---- Табличный документ из хранилища значений
Я сделал отчет, в вычисляемых полях сделал поле, которое через общий модуль получает значение хранилища значения. Но при выводе этого поля в групировку скд просто выводит надпись "Табличный документ". Как бы сделать так, чтобы выводился сам табличный документ?

&НаКлиенте
Процедура ТипВФормеНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    
    ТекущийПараметр = Элементы.Параметры.ТекущиеДанные;
    
    ЗаголовокЭлемента = НСтр("ru = 'Выбрать тип'");
    ВыбранныйЭлемент = СписокТипов.ВыбратьЭлемент(ЗаголовокЭлемента);
    Если ВыбранныйЭлемент <> Неопределено Тогда
        ТекущийТип                     = ВыбранныйЭлемент;
        
        Если ТекущийТип.Значение = "ТаблицаЗначений"
            или ТекущийТип.Значение = "МоментВремени"
            или ТекущийТип.Значение = "Граница" Тогда
        
            ТипСтрока                        = ТипСтрока(ТекущийТип.Значение);
            ТекущийПараметр.Тип             = ТипСтрока;
            ТекущийПараметр.ТипВФорме         = ТекущийТип.Представление;
            ТекущийПараметр.Значение         = "";
            ТекущийПараметр.ЗначениеВФорме     = ТекущийТип.Представление;
        Иначе
            ИнициализацияТипаИЗначенияПараметра(ТекущийПараметр, ТекущийТип);
        КонецЕсли;    
        
        Модифицированность = Истина;
    КонецЕсли;
КонецПроцедуры


я делал так в стандартной консоли запросов


Bdrh Подменю пользователя
сообщение 21.06.22, 16:28
Сообщение #4

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:37 * ,
Так вот как его вставить в результат? Можно ли как-то обходить то, что получила СКД циклом, обрабатывать группировки и результат обработки выводить в конечный таблиный документ?
Сейчас выводится так


sava1 Подменю пользователя
сообщение 21.06.22, 18:37
Сообщение #5

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2568
Из: Проскуров
Спасибо сказали: 633 раз
Рейтинг: 613.2

можно, но сохранять надо не таю.док. а выборку.
В типовых посмотрите ПриКомпоновке - НачатьВывод (вроде так называется метод), т.е. -
при формировании отчета сохраняете не табдок, а выборку
потом получаете выборки и выводите в Результат методом СКД

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 13.08.22, 20:16
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!