Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Системная функция "ТипЗнч()" - не вопрос, а просто мнение , 1С:Предприятие 8.3 (8.3.5.1517) - управляемое приложение 4 страниц V   1 2 3 > »           
Gigi Подменю пользователя
сообщение 18.10.19, 12:07
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Всем опять привет!
В данном случае вышел на форум не по поводу вопроса, а по поводу просто мнения.
Не знаю, уместно ли это и есть ли польза какая то от этого.
Хотя думаю все таки есть. По крайней мере думаю гостям данного сайта пригодится.
В особенности новичкам в системе 1С. Тем которые так же как я столкнулись с кое какими вопросами. И пока так и не нашли ответ почему разработчики великого и могучего языка 1С сделали именно так как сделали. А не чуть иначе.
Не буду объяснять детально в чем именно возникает вопрос, а вместо этого скину одну функцию, которую пришлось самому написать в общем модуле.
Думаю понимающему и без слов будет ясно почему и зачем пришлось писать такую функцию, и в чем именно сама функция: "ТипЗнч()" вынудила опять заниматься изобретательством и прочей ерундой.
В особенности если сравнивать две функции. Одна из которой это функция самой системы 1С, т.е. та самая: "ТипЗнч()" и другую, которая, слава богу вообще оказалась, но которая уже не из 1С, а из ХML. Т.е. если сравнить эти две функции и задать вопрос какая лучше. От 1С или от ХML. И лучше в смысле больших возможностей.
Вот код функции:
Функция ПоЗначению(Значение,ЗначВозврата) Экспорт
XMLТип=XMLТипЗнч(Значение).ИмяТипа;
Если Найти(XMLТип,".")=0 Тогда
    ТипГруппа=Строка(ТипЗнч(Значение)); //ТипГруппа=ТипЗнч(Значение);        
    Тип=ТипГруппа;
    МетаданныеГруппа=ТипГруппа;
    МетаданныеИмя=ТипГруппа;
    МетаДанныеПолноеИмя=ТипГруппа;
Иначе
    МетаДанныеПолноеИмя=Значение.Метаданные().ПолноеИмя();
    МетаданныеГруппа=Config_String_серв.Парсер(МетаДанныеПолноеИмя,".",1);
    МетаданныеИмя=Config_String_серв.Парсер(МетаДанныеПолноеИмя,".",2);
    Если Найти(XMLТип,"RecordSet")>0 Тогда
    ТипГруппа="НаборЗаписей";    
    ИначеЕсли Найти(XMLТип,"Ref")>0 Тогда
    ТипГруппа="Ссылка";    
    Иначе
    ТипГруппа="Объект";    
    КонецЕсли;
    Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
КонецЕсли;    
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если ЗначВозврата="Структура" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[ЗначВозврата];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
         //------- Ref --------- Object
            //"Catalog","Справочник"
            //"Document","Документ"
            //"Enum","Перечисление"
            //"ChartOfCharacteristicTypes","ПланВидовХарактеристик"
            //"ChartOfAccounts","ПланСчетов"
            //"Task","Задача"
         //---- RecordSet ------
            //"InformationRegister","РегистрСведений"
            //"CalculationRegister","РегистрРасчета"
КонецФункции

К этому мне ничего еще добавить. Поэтому воздержусь ... Ибо на счет "возможностей" функции "ТипЗнч()", об этом, думаю сами эти строки кода скажут лучше всяких слов.
Так что, на этот раз решил не задавать вопросы, а просто высказать мнение ...
Ладно ... вот собственно и все.


Сообщение отредактировал Gigi - 18.10.19, 12:09

pablo Подменю пользователя
сообщение 18.10.19, 13:11
Сообщение #2

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1069
Из: Одесса-Луганск
Спасибо сказали: 180 раз
Рейтинг: 138.9

Загадочное сравнение молотка обычного и отбойного...


Signature
Правильно поставленный вопрос содержит до 90% ответа.

Gigi Подменю пользователя
сообщение 18.10.19, 13:24
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

pablo @ Сегодня, 14:11 * ,
Да ладно ... какой инструмент лично для меня не важен..
Важен только результат.
Открывалка, ложка, или край угла столика.... Не важно. Главное открыть бутылку smile.gif
А так, я понимаю, что наверняка есть причины почему так в системной функции. Но не знаю ... я вообще нашел ее в СП только потому что была нужна для конкретней цели.
И я знаю только то что эту цель она НЕ УДОВЛЕТВОРИЛА. Именно поэтому пришлось XML припихнуть. И слава богу что система понимает его.
Ладно ... это я так решил поделиться. И никого я не учу ... и не претендую на сто процентную правоту.
Просто выразил мнение и не более.
Вот и все дела...

Petre Подменю пользователя
сообщение 18.10.19, 14:01
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2649
Из: Київ, Україна
Спасибо сказали: 738 раз
Рейтинг: 716.6

Наверное, я один настолько ущербный, что ничего не понял из этого потока сознания...


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: awp,

Gigi Подменю пользователя
сообщение 18.10.19, 14:11
Сообщение #5

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Цитата(Petre @ 18.10.19, 15:01) *
Наверное, я один настолько ущербный, что ничего не понял из этого потока сознания...

Да ничего понимать не надо ... а нужно самому один раз столкнуться smile.gif тогда могу уверить Вас поймете smile.gif Лучше всяких слов .. .куда денетесь
Короче ... ладно ... я решил просто поделиться ... не более ... может я не прав, а может прав на ВСЕ СТО!! Не знаю... не мне судить.
Я просто поделился ... а дальше и Вы и гости сайта рассудите прав или нет.
А в остальном я очень благодарен этому сайту и всем Вам уважаемые.
Ибо если честно на этом сайте я просто вырос smile.gif. Благодаря Вам!
Так что спасибо!
А на сегодня у меня все!
Пока! smile.gif

Petre Подменю пользователя
сообщение 18.10.19, 14:44
Сообщение #6

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2649
Из: Київ, Україна
Спасибо сказали: 738 раз
Рейтинг: 716.6

Тоже решил поделиться. Вот, пожалуйста, юзайте (и намного короче):
Функция ПоЗначению(Значение, ЗначВозврата) Экспорт
    
    Возврат Config_String_серв.ПоЗначению(Значение, ЗначВозврата);
    
КонецФункции


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Gigi Подменю пользователя
сообщение 18.10.19, 18:39
Сообщение #7

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Petre @ Сегодня, 15:44 * ,
Цитата(Petre @ 18.10.19, 15:44) *
Тоже решил поделиться. Вот, пожалуйста, юзайте (и намного короче):

Не понял?
Вы что прикалываетесь?
Ладно! Буду это считать за шутку. Тем более, что это так и есть.
Только шутку чуть дополню…
Выше указанную функцию, на самом деле, прописал в общий серверный модуль с именем: «Config_Тип» )) . Т.е. в моем случае, вызывать ее надо не так как Вы пошутили, а чуть по другому ))
вот так.
&НаКлиенте
Процедура Команда1(Команда)
стрТип=Config_Тип.ПоЗначению(Объект.Ссылка,"Структура");
    Для Каждого Элемент Из стрТип Цикл
    Сообщить(Элемент.Ключ+"  -  "+ Элемент.Значение);
    КонецЦикла;
КонецПроцедуры

Это для теста.
Можете проверить, эту аж до смеха простую функцию…. без проблем…. вставив код в любую кнопку в элементе справочника или дока. И то, что выдаст функция это и будет ответ на то, что было нужно от СИСТЕМНОЙ функции ТипЗнч().
И сама функция названа «ПоЗначению», а не на пример: «ТипПоЗначению», не случайно.
Так как, во-первых само название общего модуля и текст вызова функции итак говорит о чем речь «Config_Тип.ПоЗначению». Во-вторых по типам данных такой же как с системной функцией: «ТипЗнач()», это ведь не единственный гем в системе 1С. Естественно. Есть и другой гемор. Именно поэтому там же, в том же модуле: «Config_Тип» пришлось прописать уже другую функцию : )) Только на этот раз функция уже называется не «ПоЗначению», а «ПоРеквизиту».
Вот эту:

Функция ПоРеквизиту(МетаданныеГруппа,МетаданныеИмя,Реквизит,ЗначВозврата) Экспорт  //Реквизит - должен быть объектного типа Реквизит = Метаданные.Документы.Документ1.Реквизиты["ИмяРеквизита"];
Если МетаданныеГруппа=Неопределено или МетаданныеГруппа=Неопределено Тогда
РеквизитОбъект = Реквизит;    
Иначе        
РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Реквизиты[Реквизит];
КонецЕсли;
//=================================
ВозможныеТипы = РеквизитОбъект.Тип.Типы();  //Config_СтрМассив.Массив_Обход(ВозможныеТипы);     
Для каждого ЭлементТип Из ВозможныеТипы Цикл
типXML = XMLТип(ЭлементТип).ИмяТипа;
КонецЦикла;
//=================================
Если Найти(типXML, ".")=0 Тогда
//----------------------------------
Тип=СтрЗаменить(типXML,"string","Строка");
Тип=СтрЗаменить(Тип,"decimal","Число");
Тип=СтрЗаменить(Тип,"dateTime","Дата");
Тип=СтрЗаменить(Тип,"boolean","Булево");
Тип=СтрЗаменить(Тип,"UUID","УникальныйИдентификатор");
Тип=СтрЗаменить(Тип,"ValueStorage","ХранилищеЗначения");
Тип=СтрЗаменить(Тип,"decimal","Число");
Тип=СтрЗаменить(Тип,"decimal","Число");
ТипГруппа=Тип;
МетаданныеГруппа=Тип;
МетаданныеИмя=Тип;
МетаДанныеПолноеИмя=Тип;
//----------------------------------
Иначе
//----------------------------------
    Если Найти(типXML,"RecordSet")>0 Тогда
    ТипГруппа="НаборЗаписей";    
    ИначеЕсли Найти(типXML,"Ref")>0 Тогда
    ТипГруппа="Ссылка";    
    Иначе
    ТипГруппа="Объект";    
    КонецЕсли;
//----------------------------------
МетаданныеСсылкаИмяXML=Config_String_серв.Парсер(типXML,".",1);
МетаданныеИмя=Config_String_серв.Парсер(типXML,".",2);
МетаданныеГруппа=СтрЗаменить(МетаданныеСсылкаИмяXML,"CatalogRef","Справочник");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"DocumentRef","Документ");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"EnumRef","Перечисление");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"ChartOfCharacteristicTypesRef","ПланВидовХарактеристик");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"ChartOfAccountsRef","ПланСчетов");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"TaskRef","Задача");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"InformationRegister","РегистрСведений");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"CalculationRegister","РегистрРасчета");
//----------------------------------
Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
МетаДанныеПолноеИмя=МетаданныеГруппа+"."+МетаданныеИмя;
//----------------------------------
КонецЕсли;
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если ЗначВозврата="Структура" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[ЗначВозврата];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
КонецФункции


Думаю эта функция тоже пригодиться гостям данного сайта. В особенности начинающим. Так что, решил оказать помощь начинающим)).. И делаю это вместо самих производителей системы 1С. Раз они об этом не позаботились. Что бы им «бедолагам», не пришлось писать самому, как мне)). Тем более начинающим. И что бы они, как я в свое время не парились с эти гемом а получили задачу в готовом виде. А дальше пусть сами доработают если нужно.
Ладно! Говорил что все на сегодня, но решил скинуть еще одну функцию. И тоже просто .. безо всякой причины.
А на последок скажу что если я не прав пусть докажут на этом сайте что именно так.. Я готов даже извиниться за свои слова в адрес системы 1С. И взять их обратно, если не прав. Да да … И не просто извиниться, а извиниться аж ПРОПИСНЫМИ БУКВАМИ…. И сделать это прямо тут ….на этом сайте….. Думаю я этим комплексую? Ничего подобного. Я это не считаю чем то уничижительным. Ибо никогда не ошибается только дурак.
Так что даже извинюсь… Но это если мне докажете что я не прав)))
А на сегодня все … чуть подустал.
Пока!

Gigi Подменю пользователя
сообщение 19.10.19, 10:40
Сообщение #8

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Gigi @ Вчера, 19:39 * ,
Стоп… посчитал необходимым добавить дополнение к сказанному выше.
Потому что в функции «ПоРеквизиту», ошибка. Вернее не совсем ошибка, а там где то нужно кое-что добавить, а где то присутствуют не нужные и не уместные строки кода, которые нужно убрать.
Гуу … короче гем …
Поэтому вот более правильный вариант:

//знВозврат=Config_Тип.ПоРеквизиту("МетаданныеГруппа","МетаданныеИмя","Реквизит","Структура");
Функция ПоРеквизиту(МетаданныеГруппа,МетаданныеИмя,Реквизит,ЗначВозврата) Экспорт  
Если МетаданныеГруппа=Неопределено или МетаданныеГруппа=Неопределено Тогда
РеквизитОбъект = Реквизит;    
Иначе
    Если Найти(МетаданныеГруппа,"Регистры")=0 Тогда    
    РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Реквизиты[Реквизит];
    Иначе
        Попытка
            РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Измерения[Реквизит];
        Исключение
            РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Ресурсы[Реквизит];
        КонецПопытки;    
    КонецЕсли;
КонецЕсли;
//=================================
ВозможныеТипы = РеквизитОбъект.Тип.Типы();  //Config_СтрМассив.Массив_Обход(ВозможныеТипы);     
Для каждого ЭлементТип Из ВозможныеТипы Цикл
типXML = XMLТип(ЭлементТип).ИмяТипа;
КонецЦикла;
//=================================
Если Найти(типXML, ".")=0 Тогда
//----------------------------------
Тип=СтрЗаменить(типXML,"string","Строка");
Тип=СтрЗаменить(Тип,"decimal","Число");
Тип=СтрЗаменить(Тип,"dateTime","Дата");
Тип=СтрЗаменить(Тип,"boolean","Булево");
Тип=СтрЗаменить(Тип,"UUID","УникальныйИдентификатор");
Тип=СтрЗаменить(Тип,"ValueStorage","ХранилищеЗначения");
ТипГруппа=Тип;
МетаданныеГруппа=Тип;
МетаданныеИмя=Тип;
МетаДанныеПолноеИмя=Тип;
//----------------------------------
Иначе
//----------------------------------
МетаданныеСсылкаИмяXML=Config_String_серв.Парсер(типXML,".",1);
МетаданныеИмя=Config_String_серв.Парсер(типXML,".",2);
МетаданныеГруппа=СтрЗаменить(МетаданныеСсылкаИмяXML,"CatalogRef","Справочник");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"DocumentRef","Документ");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"EnumRef","Перечисление");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"ChartOfCharacteristicTypesRef","ПланВидовХарактеристик");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"ChartOfAccountsRef","ПланСчетов");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"TaskRef","Задача");
//----------------------------------
ТипГруппа="Ссылка";
Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
МетаДанныеПолноеИмя=МетаданныеГруппа+"."+МетаданныеИмя;
//----------------------------------
КонецЕсли;
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если ЗначВозврата=Неопределено или ЗначВозврата="Структура" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[ЗначВозврата];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
КонецФункции


Но все это работает не на все случая. И нуждается в доработке. Но лично мне и этого хватало для нужд.
А по поводу функции ТипЗнч(), начинающим в системе 1С рекомендую создать две кнопки на форме на пример справочника. Одну кнопку назвать «СистемнаяФункцияТипЗнач», а вторую, назвать на пример: «Кустарщина». Можете смело так назвать. Я не обижусь )).
И в каждой кнопке прописать следующее:

&НаКлиенте
Процедура СистемнаяФункцияТипЗнч(Команда)
Тип=ТипЗнч(Объект.Ссылка); Сообщить("Результат системной функции: "+Символы.ПС+Тип);    
КонецПроцедуры

&НаКлиенте
Процедура Кустарщина(Команда)
стрТип=ПоЗначению(Объект.Ссылка,"Структура");
Сообщить("---------------------------------------"+
Символы.ПС+"Результат «кустарщины»: "+Символы.ПС+
"---------------------------------------"+Символы.ПС);    
    Для Каждого Элемент Из стрТип Цикл
    Сообщить(Элемент.Ключ+"  -  "+ Элемент.Значение);
    КонецЦикла;
Сообщить("---------------------------------------");
КонецПроцедуры

&&НаСервере
// а здесь вставить саму функцию: «ПоЗначению». Т.е. для теста не в общий модуль, а тут же в модуле формы.


И сделав так запустить режим 1С предприятия и нажать сперва на первую кнопку, а потом на вторую. И тем самым увидеть, разницу между системной функцией и «кустарщиной».

Gigi @ Сегодня, 10:45 * ,
P.S.
Да еще ... совсем забыл.
О Господи ..
Весь выше изложенный код работать НЕ БУДЕТ!
Ведь, я совсем забыл, что в системе 1С нет Парсера. .. "дебилизм".
Поэтому что бы сработал нужно еще создать серверный общий модуль с именем: "Config_String_серв"
И в этот модуль вставить вот эти функции:

//Текст=Config_String_серв.Парсер(Текст,Символ,НомерВхода);
Функция Парсер(Текст,Символ,НомерВхода) Экспорт
НомерВхода=НомерВхода-1;
КоличПовтСимвола = СтрЧислоВхождений(Текст, Символ);
НомСимвПовтора = Число((НомерВходаСимвола(Текст, Символ, НомерВхода)));
If КоличПовтСимвола = 0 Then
strPart = Текст;
ИначеЕсли КоличПовтСимвола = НомерВхода Then
strPart = Сред(Текст, НомСимвПовтора+1);
ИначеЕсли КоличПовтСимвола > НомерВхода Then
strТекст = Сред(Текст, НомСимвПовтора+1);
СимволNext = Найти(strТекст, Символ);
strPart = Сред(Текст, НомСимвПовтора+1, СимволNext - 1);
Else
НомСимКонечногоПовтора = НомерВходаСимвола(Текст, Символ, КоличПовтСимвола);
strPart = Сред(Текст, НомСимКонечногоПовтора+1);   //+ 1
EndIf;
Возврат strPart;
КонецФункции

Функция НомерВходаСимвола(Текст,Символ,НомерВхода) Экспорт
КолРазделителя=СтрЧислоВхождений(Текст, Символ);
ТекстДлина=СтрДлина(Текст);
Count = 0;
CountSymb = 0;
SymbNum = 0;
//---------------------------
Для i = 1 по ТекстДлина Цикл
Count = Count + 1;
char = Сред(Текст, i, 1);
    If char = Символ Then
    CountSymb = CountSymb + 1;
    If CountSymb = НомерВхода Then SymbNum = Count EndIf;
    EndIf;
КонецЦикла;
//---------------------------
Возврат SymbNum;
КонецФункции


Только в таком случае сработает.
Да..именно... это тот самый папрсер. О котором говорил на этом сайте. И которого опять нет в системе 1С... "идиотизм". Поэтому и тут самому пришлось возиться.
Вот теперь у меня все!
Ладно! Пока
.

getnight Подменю пользователя
сообщение 19.10.19, 13:32
Сообщение #9

Молчаливый
*
Группа: Пользователи
Сообщений: 6
Спасибо сказали: 2 раз
Рейтинг: 2

Gigi @ Сегодня, 10:40 * ,
Друг... кто ясно мыслит, тот ясно выражается. У меня пошла из мозга кровь, когда я начал читать...

Возможно, вы придумали что-то гениальное.
Но люди, которые посещают специализированные форумы - в основном люди, которым нужна помощь или люди, которые хотят чем-то помочь, или люди, которые хотят найти что-то новенькое...
В любом случае, нужно уважать их время. Нельзя все ваши эмоции выплескивать на людей, как кипяток...

Попробуйте структурировать свои мысли:

1. Суть проблемы
2. Стандартные (существующие) решения, их недостатки для вашего конкретного случая
3. Ваше решение
4. Примеры использования

П.С. не забывайте, что ваша конфигурация - это только ваша конфигурация, поэтому если используете какой-нибудь личный модуль, приводите его текст тоже.
При всём желании разобраться, натыкаясь на участки кода, ссылающиеся на ЭтоМояМегаКрутаяФункция(Параметр1, Параметр2) без приведения текста самой функции, я автоматически закрываю тему.
В данном случае решил всё-же написать вам, т.к. узнал вас по нику (несколько лет назад уже попадал на вас с точно такими же эмоциями) и есть желание донести до вас свои пожелания. Спасибо.

Цитата(Gigi @ 18.10.19, 14:11) *
Цитата(Petre @ 18.10.19, 15:01)
Наверное, я один настолько ущербный, что ничего не понял из этого потока сознания...

Слово в слово... угадал мои мысли.

Gigi Подменю пользователя
сообщение 19.10.19, 21:31
Сообщение #10

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

getnight @ Сегодня, 14:32 * ,
Цитата(getnight @ 19.10.19, 14:32) *
Слово в слово... угадал мои мысли.

Дорогой друг … а я например не угадал. Поверьте!
И не то что не угадал… более того я и вовсе ничего не понял на самом деле
Цитата(getnight @ 19.10.19, 14:32) *
из этого потока сознания...

Уверяю Вас … я ничего не понял. .. о каком потоке идет речь.
Цитата(getnight @ 19.10.19, 14:32) *
Нельзя все ваши эмоции выплескивать на людей, как кипяток..

Спасибо Вам большое друг … , возьму на вооружение. .. Вы правы не стоит так ...Говорю без иронии... И в этом согласен .. иногда перебарщиваю.. на самом деле.. Извините.
Однако Вы знаете, как поступим…
Это я шас по поводу:
Цитата(getnight @ 19.10.19, 14:32) *
1. Суть проблемы
2. Стандартные (существующие) решения, их недостатки для вашего конкретного случая
3. Ваше решение
4. Примеры использования

Судя по тому что я читаю в ответ, в особенности про «поток сознания» я уже даже сомневаюсь правильно ли меня понимают.
Ибо, на этом сайте вообще решил поделиться мнением по той причине, что думал, что тут в основном люди понятливые. В особенности те, которые далеко не новички в системе 1С. Думал поймут с полу слова. Без детальных объяснений, где уже итак написал кучу строк. И это помимо «Эмоций». Но в итоги, что получается уважаемые? Сталкиваюсь с не пониманием.
Поэтому давайте оставим в покое пункты и тезисы. А сделаем пока иначе.
И для этого друг …приведу Вам один пример, и в конце задам вопрос, на который как хотите … хотите отвечайте хотите нет.
Пример имеет не прямое отношение к профессии программиста. А только косвенное. И он будет понятен не только программисту, но всем.
Вообще всем ..абсолютно. Уверяю Вас ….
Так вот представьте один пример…
Конкурс изобретений робототехники.
Что делают роботы? Следующее:
определяют овощи и фрукты.
Т.е. на сканер кладешь любой овощ или фрукт. И машина определяет что лежит на сканере.
Извините друг ...это я щас вынужден приводить такой пример. Раз речь уже пошла о каком то не понимании «потока мыслей» .
И вот, представьте, что сидит комиссия. И кто-то в конкурсе должен победить.
И вот, ведущий говорит в микрофон: модель номер 1.
Кладут на сканер, на пример картошку. И спрашивают машину, что лежит на сканере
Робот отвечает: «картошка».
И как только робот это произносит в зале аплодисменты. Все рады, и просто в полном восторге от услышанного.
Теперь говорят машине … Ладно поняли… картошка … молодец.
Теперь задают роботу другой вопрос. Следующий:
А картошка это что овощ или фрукт?
А на второй вопрос робот отвечает, знаете что?
КАРТОШКА! smile.gif))))
Люди в зале переглядываются ... но позже предполагают, что у робота наверно просто заело.
Поэтому опять ему задают тот же вопрос.
А картошка это фрукт или овощ?
И вот в предвкушении услышать истину в зале полная тишина.
И слышат опять
КАРТОШКА! smile.gif)))
На что опять задают ... картошка фрукт или овощ?... и опять КАРТОШКА.. еще задают, а он опять КАРТОШКА )))
И т.д. каждый раз..
Картошка...Картошка...Картошка...Картошка...Картошка...Картошка...Картошка... ))

Ладно ... не буду дальше...
Поэтому не буду задавать никаких вопросов.
А скажу так в качестве совета ...
Друг …Возьмите одну системную функцию на пример вот эту:
ТипЗнч()

Которая, и имеет к данной теме форума прямое отношение.
Возьмите ее и хорошенько проанализируйте. Имею ввиду "возможности" этой функции от системы 1С
А уже после сами догадайтесь, почему привел выше указанный пример про КАРТОШКУ.
Пожалуйста… только без обид.
Я думаю Вы сами поймете при чем тут выше указанный пример, и при чем тут функция ТипЗнч(). Хорошенько ее изучите.
А я пока воздержусь.
И приношу извинения за опять не экономию и всего времени и времени других
А пока у меня на этом все!

Gigi Подменю пользователя
сообщение 21.10.19, 14:36
Сообщение #11

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Gigi @ 19.10.19, 21:31 * ,
Да .. еще … по поводу:
Цитата(Gigi @ 19.10.19, 22:31) *
П.С. не забывайте, что ваша конфигурация - это только ваша конфигурация, поэтому если используете какой-нибудь личный модуль, приводите его текст тоже.
При всём желании разобраться, натыкаясь на участки кода, ссылающиеся на ЭтоМояМегаКрутаяФункция(Параметр1, Параметр2) без приведения текста самой функции, я автоматически закрываю тему.

Ладно так и быть.
Решил все-таки, специально для этого создать новую тему,
Вот эту …
Пример по получению основных сведений по типу данных любого значения
И это что бы
Цитата(Gigi @ 19.10.19, 22:31) *
уважать их время.

При этом понимая, как сами разработчики системы 1С «уважили», уже мое время, раз мне слишком часто приходилось делать работу за них. Именно поэтому с этим
Цитата(Gigi @ 19.10.19, 22:31) *
Возможно, вы придумали что-то гениальное.

НЕ СОГЛАСЕН!
На самом деле, в своей функции, ничего гениального не вижу. А это только одно их самых элементарных из того что было необходимо.
Ладно! Еще раз приношу извинения, если был резок!
Спасибо за понимание!

Batchir Подменю пользователя
сообщение 08.11.19, 13:26
Сообщение #12

Живет на форуме
Иконка группы
Группа: Команда
Сообщений: 3486
Из: Одесса
Спасибо сказали: 1340 раз
Рейтинг: 987.3

Gigi,
ЖКК
Глобальный контекст (Global context)
ТипЗнч (TypeOf)
Синтаксис:
ТипЗнч(<Значение>)
Параметры:
<Значение> (обязательный)
Тип: Произвольный.
Значение, тип которого необходимо получить.
Возвращаемое значение:
Тип: Тип.
Описание:
Получает тип значения.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Пример:
Если ТипЗнч(ТекОбъект) = Тип("СправочникСсылка.Номенклатура") Тогда
...
КонецЕсли;


Тип (Type)
Описание:
Значения данного типа используются для идентификации типов значений. Это необходимо для определения и сравнения типов. Данный тип не имеет литералов и возвращается функциями встроенного языка ТипЗнч и Тип.
Доступность: Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер). Возможен обмен с сервером. Сериализуется.
Данный объект может быть сериализован в/из XDTO. Тип XDTO, соответствующий данному объекту, определяется в пространстве имен {http://v8.1c.ru/8.1/data/core}. Имя типа XDTO: Type


Вопрос. С чего Вы взяли что метод который ТипЗнч должен быть именно такой как Вам он нужен?

Вы там упоминали о том что инструмент не важен для открытия бутылки (с таким подходом Вы б у меня не работали, повзрослеете как специалист - поймете, даже стараться объяснять это не буду).
Но у меня почему-то другая ассоциация возникает:
Купив велосипед Вы предъявляете производителю претензию к тому что велосипед не летает. И самостоятельно начинаете приваривать крылья к велосипеду, пытаясь доказать всем что именно такими и должны быть велосипеды. Хотя даже с приваренными крыльями он всё-равно летать не станет.

Сообщение отредактировал Batchir - 08.11.19, 13:27

Спасибо сказали: MATEVI,

MATEVI Подменю пользователя
сообщение 08.11.19, 23:16
Сообщение #13

Отдыхающий
Иконка группы
Ветеран троянской войныМодератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 2174
Из: Одесса
Спасибо сказали: 912 раз
Рейтинг: 728.2

А может Вам просто нужно было это?
XMLЗначение


Gigi Подменю пользователя
сообщение 12.11.19, 12:26
Сообщение #14

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Batchir @ 08.11.19, 14:26 * ,
Не буду комментировать описание функции, ибо сам тоже читал
Отмечу только то что функция ТипЗнч() годна только в таком стиле:
ИстинаЛожь=ТипЗнч(ТекОбъект) = Тип("СправочникСсылка.Номенклатура")

Это единственное на что она вообще годна.
Цитата(Batchir @ 08.11.19, 14:26) *
Вопрос. С чего Вы взяли что метод который ТипЗнч должен быть именно такой как Вам он нужен?

Согласен!
Дело в том, что если возможности метода нужны были только мне лично то это не аргумент. С этим не спорю. Однако, в том и все дело что сам вопрос возможностей функций выходит за рамки того что кому то нужно лично, а охватывает то что нужно вообще. Поверьте это именно так.
И в подтверждении сказанного опять повторю то что говорил на этом сайте по поводу функции ТипЗнч. В ответ на вопрос для чего и зачем нужно то что я уже в своей функции прописал. Чем, если честно, за одно удивили меня тем, что вообще задали такой вопрос. И удивили тем, что вообще подвергли сомнению то, что прописанные возможности моей функции вообще нужны.
И тут еще понимается, то в чем разработчики системы 1С согрешили, написав кучу разных функций. И то, что согрешили в том, что при этом считали себя сильно умными. Вот в чем на мой взгляд согрешили. И это самый главный их грех. Ну типа ... вот вам наши "мощные" функции и пользуйтесь ими. А что то еще кроме этих наших функций типа "не нужно" и типа "не понадобятся". Надо же а? Это они так думали наверно. Равно как и считали ,что знают все про жизнь во всем ее многообразии. Да уж... видишь ли думали, что "знают" то в чем даже сам черт сломает голову. Наивные.
Поэтому повторяю то что говорил в другой теме и опять на этот раз пишу прописными одну аксиому.
Не знаю, как считали разработчики при написании функции ТипЗнч, а я считаю, что ПРО ЛЮБОЕ ЗНАЧЕНИЕ НУЖНО ЗНАТЬ ВСЕ! Равно как и не знаю как думают разработчики, но для меня это АКСИОМА.
А что касается того где это нужно за что вы переживаете уважаемые? Вы боитесь того, что лишняя возможность функции останется не у дел? Да не смешите меня уважаемые ... НЕ ОСТАНЕТСЯ! УВЕРЯЮ Вас!
Ну а если Вам нужно в этом убедиться, убедиться в том, что лично на мой взгляд АКСИОМА, то нет проблем могу привести конкретный пример использования. И не один а целых десять если угодно если угодноsmile.gif!
И это если угодно опять, как раз, в знак того, как не стоило разработчикам системы 1С считать себя сильно умными. И какие это вообще вредные взгляды. Считать, что типа "знаем все про жизнь" и поэтому типа "учитываем все ее ситуации".
Цитата(Batchir @ 08.11.19, 14:26) *
Вы там упоминали о том что инструмент не важен для открытия бутылки (с таким подходом Вы б у меня не работали, повзрослеете как специалист - поймете, даже стараться объяснять это не буду).

Тоже согласен! Однако одно малое дополнение. Следующее:
Когда, например, сидишь за столом где лежит бутылка а рядом с ней открывалка. И не одна а целая куча на разный вкус. И когда для открытия бутылки выбирай какую хочешь... Ну сами подумайте какой нормальный человек будет открывать бутылку краем столика?
Но это когда на столе помимо бутылки, открывалок целая куча. А как быть тогда когда на столике лежит бутылка, но нет НЕ ОДНОЙ открывалки. В таком случае как? smile.gif
Может зубами smile.gif .... И в такой ситуации есть дело до того как открыть ... вилкой, ложкой или краем столика. Тогда когда бутылку нужно ОТКРЫТЬ наконец. И ПОСКОРЕЕ. Без лишнего гема.
Так что, в таких случаях точно не до эстетики. Ибо раз разработчики об этом не подумали, тем более если это так важно, зачем я об этом должен думать.
Цитата(Batchir @ 08.11.19, 14:26) *
Но у меня почему-то другая ассоциация возникает:
Купив велосипед Вы предъявляете производителю претензию к тому что велосипед не летает. И самостоятельно начинаете приваривать крылья к велосипеду, пытаясь доказать всем что именно такими и должны быть велосипеды. Хотя даже с приваренными крыльями он всё-равно летать не станет.

Уважаемый друг! О каком полете идет речь в системе 1С. Говорю Вам честно, когда слышу такое мне и тут опять смешно smile.gif
Наверно системе 1С только взлететь не хватает. А в остальном все просто зашибись. Т.е. только взлететь наверно оступается. И оказывается система 1С только летать не умеет, а все остальное как у чемпиона по бегу.
Как я понимаю, далеко не так обстоит дело. Так что речь не о полете а о нормальной ходьбе без прихрамывания.
И в этом вопросе, для наилучшего понимания что имею ввиду, напоследок приведу Вам один сравнительный пример. Например, пример сравнения двух видов языка общения. Языков общения между людьми и человека с машиной. Про первый вид языка можно смело сказать ВЕЛИКИЙ И МОГУЧИЙ. И без кавычек. И сказать это без преувеличения. На пример такие языки как языки: Украинский, Русский, Грузинский, Английский и т.д. На этих языках ПИШУТ СТИХИ! smile.gif Но это людской язык.
Теперь о другом виде языка. О языке для машины. А именно на пример о языке 1С smile.gif. Дело в том, что этот "могучий" язык даже ФИО толком склонять не умеет smile.gif. И поэтому как Вы думаете уважаемые? На этом языке возможно ли писать стихи? smile.gif Возможно ли например, при наличии даже таланта (это я, не беспокойтесь, не про себя), написать стихи, на том языке, который даже склонять не умеетsmile.gifsmile.gif?
А уважаемые?
Так что, о каком это "полете" и каких это "крыльях" идет речь. Это даже смешно
Ладно уважаемые ... без обид пожалуйста. Ибо я говорю то как сам думаю. Имею право.
И я уважаю Ваше мнение, но что бы кто не говорил, опять остаюсь при своем. И при том, что не комплексую тем, что бы поменять свое мнение, я так и не услышал не один аргумент, для этого.
Опять приношу извинение за большое количество букв. Но решил изложить свое понимание и в двух словах опять не получилось.
У меня все!

Vofka Подменю пользователя
сообщение 12.11.19, 12:33
Сообщение #15

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13178
Из: Киев
Спасибо сказали: 4001 раз
Рейтинг: 3136.2

Цитата(Gigi @ 12.11.19, 12:26) *
Отмечу только то что функция ТипЗнч() годна только в таком стиле

А вам как надо было?

Gigi Подменю пользователя
сообщение 12.11.19, 12:50
Сообщение #16

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Цитата(Vofka @ 12.11.19, 13:33) *
А вам как надо было?

Гуу.... об этом уже говорил ... и сразу в нескольких темах на этом сайте
Мне надо было знать ВСЕ про значение. В том числе и что за это группа. Например это Ссылка или сам объект, или это набор записей. Вообще все. И с любой стороны.

И для этого еще приведу один пример использования о котором тут уже говорил в другой теме.
Допустим реквизиты табличной части: "ЗначениеСсылка"(тип: "ЛюбаяСсылка"), "ЗначениеСтрока", "ЗначениеЧисло", "ЗначениеДата" и т.д.
И вот тема такая.... нужно получить значение. И при его получении создается новая строка табличной части. И заполняется соотв-ими значениями. Но из указанных полей, по каждой стоке, должно заполняться только одна из них. И при этом не известно что за это значение, которую нужно будет получить и вставить в одно из выше указанных реквизитов. И к какой группе оно относиться.
Вот один из примеров использования.

Vofka Подменю пользователя
сообщение 12.11.19, 16:10
Сообщение #17

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13178
Из: Киев
Спасибо сказали: 4001 раз
Рейтинг: 3136.2

Gigi @ Сегодня, 12:50 * ,
В вашем примере известно же заранее какой реквизит какого типа. Непонятно зачем тут вообще тип проверять.

pablo Подменю пользователя
сообщение 12.11.19, 16:46
Сообщение #18

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1069
Из: Одесса-Луганск
Спасибо сказали: 180 раз
Рейтинг: 138.9

ИМХО, пример не из жизни. Это больше нужно при сериализации значений, чем при обычной работе.


Signature
Правильно поставленный вопрос содержит до 90% ответа.

Vofka Подменю пользователя
сообщение 12.11.19, 18:33
Сообщение #19

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13178
Из: Киев
Спасибо сказали: 4001 раз
Рейтинг: 3136.2

Цитата(pablo @ 12.11.19, 16:46) *
ИМХО, пример не из жизни.

А мне кажется, что это у нас не настолько интересная жизнь, по сравнению с автором crazy.gif

Спасибо сказали: demon14,

Gigi Подменю пользователя
сообщение 13.11.19, 9:28
Сообщение #20

Оратор
*****
Группа: Пользователи
Сообщений: 460
Спасибо сказали: 5 раз
Рейтинг: 2

Цитата(Vofka @ 12.11.19, 17:10) *
В вашем примере известно же заранее какой реквизит какого типа. Непонятно зачем тут вообще тип проверять.

Согласен! Можно было и по типу реквизита, но уважаемый знаете что меня опять смешит smile.gif
Смешит в особенности вот эта фраза... и вот этот фрагмент из цитаты:
Цитата(Vofka @ 12.11.19, 17:10) *
какой реквизит какого типа.

И разделим выражение на две части на эту "какой реквизит" и на эту "какого типа"?
Так вот, с первой частью нет проблем, и это без иронии. А что касается второй то, тут уже мне просто смешно. И в особенности от понимания того, сколько времени уважаемый друг Вы потратили на написание этой фразы: "какого типа", и сколько времени нужно потратить на написание функций которая получает тип по реквизиту в 1С. Так что, напрасно Вы вообще затронули вопрос типа по реквизиту уважаемый! Напрасно! Вы хотите что бы я тут скинул уже другую функцию из общего модуля с которой опять парился? И тем самым хотите, что бы я посетителям тут дал понять, что с типом по реквизиту в "могучем" языке 1С дело обстоит намного хуже чем с функцией "ТипЗня"? Ладно без проблем.
Вот еще одна функция:

Функция СведРеквизит(МетаданныеГруппа,МетаданныеИмя,Реквизит,Сведения) Экспорт  
Если МетаданныеГруппа=Неопределено или МетаданныеГруппа=Неопределено Тогда
    РеквизитОбъект = Реквизит;    
Иначе
    Если Найти(МетаданныеГруппа,"Регистры")=0 Тогда    
        РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Реквизиты[Реквизит];
    Иначе
        Попытка
            РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Измерения[Реквизит];
        Исключение
            РеквизитОбъект = Метаданные[МетаданныеГруппа][МетаданныеИмя].Ресурсы[Реквизит];
        КонецПопытки;    
    КонецЕсли;
КонецЕсли;
//=================================
ВозможныеТипы = РеквизитОбъект.Тип.Типы();  //Config_СтрМассив.Массив_Обход(ВозможныеТипы);     
Для каждого ЭлементТип Из ВозможныеТипы Цикл
типXML = XMLТип(ЭлементТип).ИмяТипа;
КонецЦикла;
//=================================
Если Найти(типXML, ".")=0 Тогда
//----------------------------------
Тип=СтрЗаменить(типXML,"string","Строка");
Тип=СтрЗаменить(Тип,"decimal","Число");
Тип=СтрЗаменить(Тип,"dateTime","Дата");
Тип=СтрЗаменить(Тип,"boolean","Булево");
Тип=СтрЗаменить(Тип,"UUID","УникальныйИдентификатор");
Тип=СтрЗаменить(Тип,"ValueStorage","ХранилищеЗначения");
ТипГруппа=Тип;
МетаданныеГруппа=Тип;
МетаданныеИмя=Тип;
МетаДанныеПолноеИмя=Тип;
//----------------------------------
Иначе
//----------------------------------
МетаданныеИмя = Сред(типXML,Найти(типXML,".")+1);
МетаданныеГруппаИмяXML = СтрЗаменить(типXML,"."+МетаданныеИмя,"");
//----------------------------------
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппаИмяXML,"CatalogRef","Справочник");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"DocumentRef","Документ");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"EnumRef","Перечисление");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"ChartOfCharacteristicTypesRef","ПланВидовХарактеристик");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"ChartOfAccountsRef","ПланСчетов");
МетаданныеГруппа=СтрЗаменить(МетаданныеГруппа,"TaskRef","Задача");

// и т.д. ... Мне просто уже надоело заниматься кустарщиной, и опять и опять делать работу разработчиков ...

//----------------------------------
ТипГруппа="Ссылка";
Тип=МетаданныеГруппа+ТипГруппа+"."+МетаданныеИмя;
МетаДанныеПолноеИмя=МетаданныеГруппа+"."+МетаданныеИмя;
//----------------------------------
КонецЕсли;
//============================
Стр=Новый Структура();
Стр.Вставить("Группа",ТипГруппа);
Стр.Вставить("Тип",Тип);
Стр.Вставить("МетаданныеГруппа",МетаданныеГруппа);
Стр.Вставить("МетаданныеИмя",МетаданныеИмя);
Стр.Вставить("МетаДанныеПолноеИмя",МетаДанныеПолноеИмя);
//============================
    Если Сведения=Неопределено или Сведения="Все" Тогда
    знВозврат=стр;    
    Иначе
    знВозврат=стр[Сведения];
    КонецЕсли;
//============================
Возврат знВозврат;
//============================
КонецФункции

Как видно из указанной функции с типом по реквизиту в 1С дело обстоит ЕЩЕ ХУЖЕ чем с типом по значению. И это потому, что для второй цели все таки есть готовая функция: "ТипЗнч". Хотя сильно "могучая", но все таки имеется. И слава богу что уважаемые разработчики вообще посчитали нужным ее включить пусть даже такую немощную. Что, конечно меня уже даже удивляет что посчитали. Года два назад не удивило бы. Ибо тогда не сильно был знаком с языком 1С. А уже теперь удивляетsmile.gif. Но это по вопросу типа по значению. А что касается вопроса типа по реквизиту тут в 1С самой такой функции ПРОСТО НЕТsmile.gif! Да именно ... Нет и точка! Опять нет! Даа .. "сильно"... ничего не скажешь. И наверно и тут разработчики тоже считали себя опять сильно умными и думали что такая функция "не понадобиться".
Поэтому, к выше указанному девизу в другом сообщении уже тут добавлю еще одну АКСИОМУ! Которую опять нужно было объяснить разработчикам, раз сами наверно не понимали. Те АКСИОМЫ, о которых даже ребенок знает!
В языке программирования, если он претендует на статус мощного, должен быть ВЫБОР! Да именно ...ВЫБОР! И выбор в смысле, решить одну и ту же цель разным путем. Вот что! И это тоже на мой взгляд АКСИОМА!
Так что, до написания этой функции: "СведРеквизит", я тогда решил получать тип по значению. Ибо тогда это было ПРОЩЕ! И потому что функция типа по значению была уже мною написана. Поэтому!
Но опять таки и .... повторяю для одной и той же цели должен быть выбор. И в данном случае получить тип как по значению так и по реквизиту.
Так что, должна быть возможность сделать по разному. Каким угодно путем. В зависимости от того как удобнее в крокетном случае.
Но для указанной цели покажите мне готовую функцию в 1С. Покажите мне ее уважаемые! Не ту выше указанную функцию которая через язык XML, и на написание которой потратил время, а готовую от 1С. Где она?
И только так и докажите что ошибаюсь!
У меня все!



Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


4 страниц V   1 2 3 > » 
Ответить Новая тема
2 чел. читают эту тему (гостей: 2, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.12.19, 7:02
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!