Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Отключение объединения номенклатурных позиций          
KIODAMAGE Подменю пользователя
сообщение 16.09.20, 14:06
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день. В Рознице 2.2 есть возможность в настройках РМК запретить объединение одинаковых номенклатурных позиций в одну строку(когда при добавлении не добавляется новая строка, а только возрастает количество). Подскажите, можно ли это каким-то образом сделать в УТ 3.2.16.3?

KIODAMAGE Подменю пользователя
сообщение 16.09.20, 15:32
Сообщение #2

Молчаливый
*
Группа: Пользователи
Сообщений: 3
Спасибо сказали: 0 раз
Рейтинг: 0

Получилось сделать таким образом:

Процедура ПолучитьТаблицуДоступныхДействий(Отбор, АдресаВХранилище, НадписьОбеспечено)
    
    ...
            
            НайденныеСтроки = ТаблицаДоступныхДействий.НайтиСтроки(СтруктураПоиска);
            //Если НайденныеСтроки.Количество()>0 Тогда
            //    НайденныеСтроки[0].Доступно = НайденныеСтроки[0].Доступно + КоличествоОформлено;  - отключил проверку на количество;
            //Иначе
                НоваяСтрока = ТаблицаДоступныхДействий.Добавить();
                ЗаполнитьЗначенияСвойств(НоваяСтрока, ТаблицаДоступныхДействий[ТаблицаДоступныхДействий.Количество()-2]);
                НоваяСтрока.ВариантОбеспечения = СтруктураПоиска.ВариантОбеспечения;
                НоваяСтрока.Доступно = КоличествоОформлено;
            //КонецЕсли;
        КонецЕсли;
        
    ...
    
КонецПроцедуры


В процедуре отключил проверку на количество, при добавлении через подбор товаров работает нормально, но при выборе быстрых товаров по-прежнему объединяет строки.

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 30.10.20, 2:50
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!