Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Общая форма не раскрывается во весь экран          
Constantus Подменю пользователя
сообщение 09.07.19, 10:46
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 839
Спасибо сказали: 5 раз
Рейтинг: 4

Приветствую, Форумчане!
1с.8.3.13, БСП, самопис, УФ

Прямого отношения к программированию не имеет, приношу извинения, но более правильной ветки не нашел

Ранее на 8.3.6 работали и перешли на 8.3.12

В документе Заказ на панели навигации есть ссылка на "Присоединенные файлы" . Это общая форма, где отображаются графические файлы к этому документу.

После перехода на 8.3.12 эта общая форма не раскрывается по вертикали и горизонтали на весь экран.

Где хранятся эти настройки, чтобы при активации раскрывалась эта форма во весь экран? Уже всё, где нашел поставил расширять по вертикали и горизонтели, но как стоит скромно с полосами прокрутки, так и стоит

Подскажите...

_________________________________________________________________

Такая же ерунда и с другим документом, точнее с выводом формы списка по команде:

Код
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ПараметрыФормы = Новый Структура("Отбор", Новый Структура("Заказ", ПараметрКоманды));
    ОткрытьФорму("Документ.Ретушь.ФормаСписка", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
КонецПроцедуры


Документ.Ретушь.ФормаСписка тоже не раскрывается во весь экран, а скромно выходит маленькой с полосами прокруток

//------------------------------------------------

Если вызывать эти документы через правую клавишу в отдельном окне, то форма раскрывается по полной программе

Сообщение отредактировал Vofka - 09.07.19, 12:04

Constantus Подменю пользователя
сообщение 09.07.19, 15:12
Сообщение #2

Ветеран
*******
Группа: Пользователи
Сообщений: 839
Спасибо сказали: 5 раз
Рейтинг: 4

_______________________________

Обратил внимание, что при переходе на новую платформу многие формы как-то странно отображаться стали, т.е. где-то поля съехали, нокоторые табличные части скрылись...

Такое ощущение, что типа не хватает разрешения монитора, хотя мониторы у пользователей остались прежними...

Как платформа регулирует процесс размещения элементов на форме? Может есть где-то настройка разрешения экрана для форм 1с? Или что-то в этом роде?

Constantus Подменю пользователя
сообщение 11.07.19, 12:30
Сообщение #3

Ветеран
*******
Группа: Пользователи
Сообщений: 839
Спасибо сказали: 5 раз
Рейтинг: 4

Мне тут шыпнули, что это из-за того, что начиная с 8.3.7 1с изменил политику рисования форм, понадобвлял всяко разно...
А можно как-то одним движением руки сбросить настройки настройки от 8.3.6, чтобы они перерисовались заново? Или легче заново создать форму?

У меня и в других формах стали проявляться косяки прорисовки

python Подменю пользователя
сообщение 15.07.19, 14:06
Сообщение #4

Говорящий
***
Группа: Пользователи
Сообщений: 77
Из: Киев
Спасибо сказали: 11 раз
Рейтинг: 9

Constantus @ 11.07.19, 13:30 * ,
Сбросить настройки на стандартные можно, но не сильно это помогает.

&НаСервере
Процедура СброситьРазмерыИПоложениеОкна()
    
    КлючОбъекта        = "РегистрСведений.Отправления.Форма.ФормаЗаписи/Такси/НастройкиОкна";
    ИмяПользователя = ПользователиИнформационнойБазы.ТекущийПользователь().Имя;
    
    ХранилищеСистемныхНастроек.Удалить(КлючОбъекта, "", ИмяПользователя);
    КлючСохраненияПоложенияОкна = Строка(Новый УникальныйИдентификатор);
    
КонецПроцедуры    // СброситьРазмерыИПоложениеОкна

Constantus Подменю пользователя
сообщение 25.07.19, 8:14
Сообщение #5

Ветеран
*******
Группа: Пользователи
Сообщений: 839
Спасибо сказали: 5 раз
Рейтинг: 4

Обратил внимание на следующее.

У меня открытие формы стоит в разделе навигации. Если на ссылку нажать правую кнопку, то выходит "Открыть в новом окне". При нажатии открытия в новом окне - открывается всё нормально... во весь экран

Открытие идет по общей команде:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ВладелецФайла",  ПараметрКоманды);
    //34246 -->
    //ПараметрыФормы.Вставить("ТолькоПросмотр", ПараметрыВыполненияКоманды.Источник.ТолькоПросмотр);
    ПараметрыФормы.Вставить("ТолькоПросмотр", Ложь);
    //34246 <--
    
    ОткрытьФорму("ОбщаяФорма.ПрисоединенныеФайлы2",
                 ПараметрыФормы,
                 ПараметрыВыполненияКоманды.Источник,
                 ПараметрыВыполненияКоманды.Уникальность,
                 ПараметрыВыполненияКоманды.Окно);
    
КонецПроцедуры


Как мне тогда открыть эту форму в новом окне по полному аналогу контекстного меню открытия этой формы в отдельном окне?


Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.10.19, 12:32
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!