Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Обробка "Обмін з банком" для БУ 2.0 , завантаження банківської виписки 16 страниц V  « < 12 13 14 15 16 >          
Petre Подменю пользователя
сообщение 27.05.20, 12:52
Сообщение #261

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2741
Из: Київ, Україна
Спасибо сказали: 821 раз
Рейтинг: 817.8

Anderson @ Today, 11:30 * ,
Кодировка закладывается в обработке формата.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Anderson Подменю пользователя
сообщение 27.05.20, 18:11
Сообщение #262

Говорящий
***
Группа: Пользователи
Сообщений: 60
Из: Одесса
Спасибо сказали: 8 раз
Рейтинг: 9.8

Цитата(Petre @ 27.05.20, 12:52) *
Кодировка закладывается в обработке формата.

Да, но иногда то ли банк, то ли на разных машинах кодировки разные и одну и ту же выгрузку получают в разных кодировках и приходится править обработку формата.
Было бы удобно выбирать кодировку в главной обработке и получать ее в параметрах обработки формата.

gleb-khil Подменю пользователя
сообщение 04.06.20, 12:21
Сообщение #263

Общительный
**
Группа: Пользователи
Сообщений: 24
Из: Одесса
Спасибо сказали: 4 раз
Рейтинг: 0

У кого то есть шаблон для Банка Пивденый. Выгрузка в формате xml

Вікторія_1990 Подменю пользователя
сообщение 05.06.20, 8:59
Сообщение #264

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

igmig65 @ 10.10.19, 14:22 * ,
Добрый день? Где находится эта обработка в приват24?

sergeyfit Подменю пользователя
сообщение 08.06.20, 20:01
Сообщение #265

Общительный
**
Группа: Пользователи
Сообщений: 31
Спасибо сказали: 20 раз
Рейтинг: 19.5

УстановитьНовыйКод()


При создании Контрагента у меня почему-то кодировка дальше 999 не идет...
В Спр.Контрагента кодировка до 8 знаков...
Ваш код разобрать это ещё то %;№№!";№%%:
Вам не икается?


Если _____________А____=Неопределено Тогда
_______________А__=CaTALOGS.Контрагенты.СоздатьЭлемент();
_______________А__.УстановитьНовыйКод();
TRy _______А__=СтрЗаменить(__________а____.НазваКонтрагента,_a___("C"),CHarS.lf);
_______________a____=СтрЧислоСтрок(_______А__);
___________A__=TRiMaLL(СтрПолучитьСтроку(_______А__,_______________a____));
Если _______________a____>___________А___("2GE") Тогда
___________A__=___________A__+_a___("F");
FOr ___а____=___________А___("2GE") TO _______________a____-___________А___("2GE") dO ___________A__=___________A__+_a___("I")+trIMalL(СтрПолучитьСтроку(_______А__,___а____));
Enddo;
КонецЕсли;
_______________А__.Наименование=___________A__;
ExCePT _______________А__.Наименование=__________а____.НазваКонтрагента;
endtry;
_______________А__.НАимЕнОВаниеПоЛнОЕ=__________а____.НазваКонтрагента;
_______________А__.КодПоЕдрпоу=__________а____.КодКонтрагента;
_______________А__.ЮридическоефизическоеЛицо=?(СтрДлина(__________а____.КодКонтрагента)=___________А___("2KA"),ENUms.ЮридическоефизическоеЛицо.ФизическоеЛицо,eNums.ЮридическоефизическоеЛицо.ЮридическоеЛицо);
Если ЗначениеЗаполнено(ГрупаНовихКонтрагентів)Тогда
_______________А__.Родитель=ГрупаНовихКонтрагентів;
КонецЕсли;
tRy _______________А__.Записать();
_____________А____=_______________А__.Ссылка;
____________А__.Вставить(__________а____.КодКонтрагента,_____________А____);
eXCEpt Сообщить(erRordEscriPtIOn());
Продолжить;
enDtRy;
КонецЕсли;


andr_andrey Подменю пользователя
сообщение 09.06.20, 8:05
Сообщение #266

Почти ветеран
Иконка группы
Группа: Местный
Сообщений: 531
Спасибо сказали: 124 раз
Рейтинг: 100.5

Цитата(sergeyfit @ 08.06.20, 21:01) *
Ваш код разобрать это ещё то %;№№!";№%%:

Это обфускация кода. Автор решил не отдавать код кому попало smile.gif


Signature
#define private public
enum BOOL { FALSE, TRUE, FILENOTFOUND } is made my day

Petre Подменю пользователя
сообщение 09.06.20, 8:23
Сообщение #267

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2741
Из: Київ, Україна
Спасибо сказали: 821 раз
Рейтинг: 817.8

QUOTE (sergeyfit @ 08.06.20, 20:01) *
При создании Контрагента у меня почему-то кодировка дальше 999 не идет

Похоже, у вас нарушение порядка строковой кодировки. Найдите все коды с длиной меньше стандартной, исправьте, и примените метод ОбновитьНумерациюОбъектов.
QUOTE (sergeyfit @ 08.06.20, 20:01) *
Вам не икается?

Абсолютно...


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

budst Подменю пользователя
сообщение 20.06.20, 16:06
Сообщение #268

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Цитата(Petre @ 07.05.20, 16:30) *
Кожного разу є бажання додати багато нового функціоналу, але часу не вистачає.
Тому поки виправний реліз.

Версія 4.1

1С:Предприятие 8.3 (8.3.16.1063)
Бухгалтерія для України, редакція 2.0 (2.0.20.4)

Відкриваю файл обробки "ОбмінЗБанком (2.1) 4.1.epf"
Обираю формат "ОбмінЗБанком_ОбробкаФормату_iBank2 4.1.epf" (Файл рядку з розділювачами (CSV))
Завантажую виписку з UKRSIB business в форматі CSV

Результат:
Прочитати файл виписки - Помилка файлу обробки формату
Перевірити заповнення - Несоответствие типов (параметр номер '1')

Можливо, UrkSib змінив формат?

Petre Подменю пользователя
сообщение 22.06.20, 8:24
Сообщение #269

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2741
Из: Київ, Україна
Спасибо сказали: 821 раз
Рейтинг: 817.8

budst @ 20.06.20, 16:06 * ,
Можливо. Обробка формату "ОбмінЗБанком_ОбробкаФормату_iBank2 4.1.epf", хоч і називається "iBank2", нормально працює з Аваль. В УкрСиб начебто теж iBank2, але не зовсім коректний.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

rudnitskij Подменю пользователя
сообщение 22.06.20, 17:05
Сообщение #270

Молчаливый
*
Группа: Ахтунги
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ 09.06.20, 9:23 * ,
Скажите пожалуйста, у вас строки на русском и украинском сделаны одинаковыми. Это так задумано было?
ОБщЕгоНаЗНаЧЕНИЯкЛИеНТсЕрвеР.СооБщитьпОльзовАТЕЛю(nStR("ru = 'Сталася помилка пошуку формату'; uk = 'Сталася помилка пошуку формату'"));

Petre Подменю пользователя
сообщение 23.06.20, 8:39
Сообщение #271

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2741
Из: Київ, Україна
Спасибо сказали: 821 раз
Рейтинг: 817.8

rudnitskij @ Yesterday, 17:05 * ,
В соответствии с рекомендациями, для интерфейсных строк использую НСтр(). Но до перевода на росийский руки пока не дошли. Чтобы не оставлять пустыми, заполняю на украинском.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

rudnitskij Подменю пользователя
сообщение 23.06.20, 10:45
Сообщение #272

Молчаливый
*
Группа: Ахтунги
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ Сегодня, 9:39 * ,
Я об этом и говорю. Зачем вы используете НСтр, если всё на одном языке?
И что это за язык - "российский"? Русский же

Vofka Подменю пользователя
сообщение 23.06.20, 14:10
Сообщение #273

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13372
Из: Киев
Спасибо сказали: 4123 раз
Рейтинг: 3265.6

Цитата(rudnitskij @ 23.06.20, 11:45) *
Зачем вы используете НСтр

Цитата(Petre @ 23.06.20, 9:39) *
В соответствии с рекомендациями


Сообщение отредактировал Vofka - 24.06.20, 8:30

rudnitskij Подменю пользователя
сообщение 23.06.20, 18:41
Сообщение #274

Молчаливый
*
Группа: Ахтунги
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Vofka @ Сегодня, 15:10 * ,
"Зачем вы используете НСтр, если всё на одном языке?" - надо читать не по диагонали, а слева направо. Потом строку, которая находится ниже. Тогда от вас не ускользнет смысл, таящийся в буквах

Vofka Подменю пользователя
сообщение 24.06.20, 8:23
Сообщение #275

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13372
Из: Киев
Спасибо сказали: 4123 раз
Рейтинг: 3265.6

rudnitskij, для особо одаренных попробую донести свою мысль другими словами: не нравится обработка - не пользуйтесь.

Спасибо сказали: Eugen_aka, maxst22, mvo2008, olegbilas,

rudnitskij Подменю пользователя
сообщение 24.06.20, 8:41
Сообщение #276

Молчаливый
*
Группа: Ахтунги
Сообщений: 4
Спасибо сказали: 0 раз
Рейтинг: 0

Vofka @ Сегодня, 9:23 * ,
Для особо одаренных: я у автора уточнил, может он по ошибке или по запарке так написал. Он ответил что нет.
Каким боком эта ситуация вас касается?
И всё же, еще раз рекомендовал бы более внимательно читать сообщения, на которые вы отвечаете

allegro Подменю пользователя
сообщение 15.07.20, 11:42
Сообщение #277

Молчаливый
*
Группа: Пользователи
Сообщений: 5
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ 07.05.20, 16:30 * ,
Дякую за обработку. При вивантаженні платіжних доручень, не можу вказати поточний формат, що там має бути? Коли натискую Заповнити платіжні доручення, видає помилку не обрано формат. Завантажує нормально.

Petre Подменю пользователя
сообщение 15.07.20, 12:22
Сообщение #278

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2741
Из: Київ, Україна
Спасибо сказали: 821 раз
Рейтинг: 817.8

allegro @ Today, 11:42 * ,
Формати вивантаження беруться з підключених обробок формату. Можливо, налаштовані у вас обробки формату не містять функціоналу вивантаження, а лише завантаження.


Signature
Допрацьовую:
- "Бухгалтерія для України 2.1";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: allegro,

9992952 Подменю пользователя
сообщение 22.07.20, 12:45
Сообщение #279

Молчаливый
*
Группа: Пользователи
Сообщений: 1
Спасибо сказали: 0 раз
Рейтинг: 0

Petre @ 26.04.17, 9:57 * ,
файл защищен паролем, а где пароль?

Batchir Подменю пользователя
сообщение 23.07.20, 11:47
Сообщение #280

Живет на форуме
Иконка группы
Группа: Команда
Сообщений: 3502
Из: Одесса
Спасибо сказали: 1361 раз
Рейтинг: 1010.6

9992952, В правилах

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


16 страниц V  « < 12 13 14 15 16 >
Ответить Новая тема
2 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 1 AlexanderTiger

 

RSS Текстовая версия Сейчас: 30.10.20, 0:18
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!