Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Не могу выгрузить текстовый документ в файл на локальном диске          
lina1982 Подменю пользователя
сообщение 06.10.21, 11:17
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

Здравствуйте, Конфигурация:
1С:Предприятие 8.3 (8.3.16.1063)
Бухгалтерия предприятия, редакция 3.0 - (1.3.10.150)

При выгрузки текстового документа с сервисной базы выходит сообщение:


Ошибка доступа к файлу: D:\rrr.txt



АдресФайла = Объект.Файл;
    // Текст.Записать("D:\Оптима\гог.txt");
    Текст.Записать(АдресФайла);



Пробовала:
Код
&НаКлиенте
Процедура ФайлНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Режим                                     = РежимДиалогаВыбораФайла.Сохранение;
    ДиалогОткрытияФайла                     = Новый ДиалогВыбораФайла(Режим);
    //ДиалогОткрытияФайла.Каталог                = АдресФайла;    
    ДиалогОткрытияФайла.ПолноеИмяФайла         = "";
    Фильтр                                     = "Файл(*.txt;*)|*.txt";
    ДиалогОткрытияФайла.Фильтр                 = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор     = Ложь;
    ДиалогОткрытияФайла.Заголовок             = "Укажите имя файла txt и выберите папку, в которую необходимо записать этот файл";
    
    ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ПутьКФайлуНачалоВыбораЗавершение", ЭтотОбъект, Новый Структура("ДиалогОткрытияФайла", ДиалогОткрытияФайла)));

КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбораЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
    
    ДиалогОткрытияФайла = ДополнительныеПараметры.ДиалогОткрытияФайла;      
    
    Если (ВыбранныеФайлы <> Неопределено) Тогда
        Объект.Файл = ДиалогОткрытияФайла.ПолноеИмяФайла;
    КонецЕсли;
      
КонецПроцедуры


Не получается

Сообщение отредактировал Vofka - 07.10.21, 9:12


Vofka Подменю пользователя
сообщение 06.10.21, 19:59
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13607
Из: Киев
Спасибо сказали: 4255 раз
Рейтинг: 3411.8

lina1982, база клиент серверная и строчка
Текст.Записать(АдресФайла);

выполняется в процедуре с директивой &НаСервере?

lina1982 Подменю пользователя
сообщение 07.10.21, 3:23
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ Вчера, 20:59 * ,
да

Vofka Подменю пользователя
сообщение 07.10.21, 9:14
Сообщение #4

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13607
Из: Киев
Спасибо сказали: 4255 раз
Рейтинг: 3411.8

lina1982, код, который выполняется на сервере, физически выполняется на компьютере, где установлен сервер 1С. В вашем случае скорее всего диск D есть на вашем локальном компьютере, но нету на сервере.

lina1982 Подменю пользователя
сообщение 07.10.21, 10:06
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ Сегодня, 10:14 * ,
это понятно, я не знаю как написать, чтобы документ записывался на локальный компьютер, а не на сервер. Если база локальная, то записывает на диск без проблем.

Vofka Подменю пользователя
сообщение 07.10.21, 11:11
Сообщение #6

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13607
Из: Киев
Спасибо сказали: 4255 раз
Рейтинг: 3411.8

lina1982, делать запись в процедуре НаКлиенте.

lina1982 Подменю пользователя
сообщение 07.10.21, 11:26
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ Сегодня, 11:11 * ,
на клиенте я пробовала, код показала в данной теме, все равно не получается...

takefive Подменю пользователя
сообщение 08.10.21, 10:42
Сообщение #8

Говорящий
***
Группа: Пользователи
Сообщений: 53
Из: Днепропетровск
Спасибо сказали: 18 раз
Рейтинг: 18.9

Не пишите в корень диска. Настройте каталогу уровень безопасности и доступа. Учитывая, что Ваши права и права программы различны...


Signature
без свинга нет музыки...

lina1982 Подменю пользователя
сообщение 09.10.21, 7:18
Сообщение #9

Общительный
**
Группа: Пользователи
Сообщений: 14
Спасибо сказали: 1 раз
Рейтинг: 1

takefive @ Вчера, 10:42 * ,
я не знаю как это сделать

takefive Подменю пользователя
сообщение 11.10.21, 17:20
Сообщение #10

Говорящий
***
Группа: Пользователи
Сообщений: 53
Из: Днепропетровск
Спасибо сказали: 18 раз
Рейтинг: 18.9

lina1982 @ 09.10.21, 7:18 * ,
В свойствах папки на закладке Безопасность включите группе Пользователи флажки - разрешить...


Signature
без свинга нет музыки...

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.21, 20:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!