Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Не дотягивает до "ОбработкаВыбора" из ОповеститьОВыборе(АдресРезультата);          
Constantus Подменю пользователя
сообщение 15.11.19, 10:56
Сообщение #1

Ветеран
*******
Группа: Пользователи
Сообщений: 858
Спасибо сказали: 6 раз
Рейтинг: 5

Приветсьвую, Форумчане!
1с8.3.12, СП, самопис, СП

Есть некий механизм, который в одной из форм по кнопке открывает дополнительную форму для отора строк ТЧ по галке, Далее создается документ с выранные строками. Это работает...

Теперь по полному образу и подобию создал этот механизм в другом документе, т.е. со всеми кодами и т.д. Визуально всё срабатывает, выбор, создание документа и т.д., за исключением момента.

    АдресРезультата = "";
    СоздатьПеремещениеНаСервере();

    Если ЭтоАдресВременногоХранилища(АдресРезультата) Тогда
        ОповеститьОВыборе(АдресРезультата);    
    КонецЕсли;


Не срабатывает оповестить о выборе, т.е. не доходить до "Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)" и соответственно не сраатывает "ЗаполнитьПеремещения(ВыбранноеЗначение);" в последней процедуре:

&НаКлиенте
Процедура ПередачаВПроизводство(Команда)
    
    Адрес = ПолучитьАдресВоВременномХранилище();
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Адрес", Адрес);
    ПараметрыФормы.Вставить("Основание", Объект.Ссылка);

    
    ОткрытьФорму("Документ.ПроизводственноеЗадание.Форма.ФормаСозданияДокументаПередачи", ПараметрыФормы, ЭтотОбъект,,,,
        Новый ОписаниеОповещения("СоздатьПеремещениеЗавершение", ЭтотОбъект), РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);

КонецПроцедуры

&НаКлиенте
Процедура СоздатьПеремещениеЗавершение(Результат, ДополнительныеПараметры) Экспорт
        
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    //Вставить содержимое обработчика
    
    Если ТипЗнч(ИсточникВыбора) = Тип("УправляемаяФорма")
        И ИсточникВыбора.ИмяФормы = "Документ.ПроизводственноеЗадание.Форма.ФормаСозданияДокументаПередачи" Тогда
        ЗаполнитьПеремещения(ВыбранноеЗначение);
    КонецЕсли;
    
    
КонецПроцедуры


Где и что я недотянул? Из-за того, что не сраатывает обраотка выбора не заполняются данные по ЗаполнитьПеремещения...

pablo Подменю пользователя
сообщение 15.11.19, 11:47
Сообщение #2

Старейшина
********
Группа: Команда (модераторы)
Сообщений: 1069
Из: Одесса-Луганск
Спасибо сказали: 180 раз
Рейтинг: 138.9

АдресРезультата у Вас как объявлен? как реквизит формы был, но в новой форме забыли его добавить и он стал локальной переменной?


Signature
Правильно поставленный вопрос содержит до 90% ответа.

Constantus Подменю пользователя
сообщение 15.11.19, 16:53
Сообщение #3

Ветеран
*******
Группа: Пользователи
Сообщений: 858
Спасибо сказали: 6 раз
Рейтинг: 5

pablo @ Сегодня, 15:47 * ,

Поторопился с вопросом. Надо было просто сначала кофе выпить, а потом понять, что простое копирование кода не означает, что этот код удет прикреплен автоматически к событиям

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 14.12.19, 7:51
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!