Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как в СКД при сохранении отчета чтобы имя файла уже было заполненным?          
twilight_dream Подменю пользователя
сообщение 26.03.20, 15:29
Сообщение #1

Оратор
*****
Группа: Пользователи
Сообщений: 253
Спасибо сказали: 4 раз
Рейтинг: 4

Платформа: 1С:Предприятие 8.3 (8.3.16.1224)
Конфигурация: любая

САБЖ.



Signature

Aquarrius Подменю пользователя
сообщение 26.03.20, 16:31
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 11
Спасибо сказали: 3 раз
Рейтинг: 2.3

twilight_dream @ Сегодня, 15:29 * ,
Процедура КоманднаяПанельФормыСохранитьВExcel(Кнопка)

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
Диалог.ПолноеИмяФайла = ЭтаФорма.Заголовок+".xls"; // имя файла
Диалог.Фильтр = "(*.xls)|*.xls";
Если Диалог.Выбрать() Тогда
ЭлементыФормы.ПолеТабличногоДокумента.Записать(Диалог.ПолноеИмяФайла,ТипФайлаТабличногоДокумента.XLS);
КонецЕсли;

КонецПроцедуры



Скорее всего по аналогии smile.gif

Сообщение отредактировал Vofka - 27.03.20, 9:22

twilight_dream Подменю пользователя
сообщение 26.03.20, 16:42
Сообщение #3

Оратор
*****
Группа: Пользователи
Сообщений: 253
Спасибо сказали: 4 раз
Рейтинг: 4

Да, это хороший вариант. Но надо без отдельных кнопок через меню "Файл - сохранить". Вашу версию оставлю на-последок, если ничего не найду.


Signature

Vofka Подменю пользователя
сообщение 27.03.20, 9:22
Сообщение #4

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13247
Из: Киев
Спасибо сказали: 4044 раз
Рейтинг: 3180.6

twilight_dream, для спасибо есть специальная кнопочка.

Vladal Подменю пользователя
сообщение 29.03.20, 17:45
Сообщение #5

Оратор
Иконка группы
Группа: Местный
Сообщений: 356
Из: Украина
Спасибо сказали: 61 раз
Рейтинг: 47.5

Я сделал так:

&НаКлиенте
Процедура ПечатьСабжа(Команда)
    ТабДок = Новый ТабличныйДокумент();
    ТабДок.Область(1, 1).Текст = "САБЖ";
    ТабДок.Показать("Это заголовок окна", КаталогВременныхФайлов() + "НужноеИмяФайла.mxl");
КонецПроцедуры
По команде меню "Файл - Сохранить как" будет открыт диалог с нужным именем файла.

Сообщение отредактировал Vladal - 29.03.20, 17:46

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 08.04.20, 17:23
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!