Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )



> Как перенести элемент спр.ТМЦ в другую папку спр.ТМЦ , Можно ли в коде задать перенос элемента справочника в заданую ?папку          
TTT Подменю пользователя
сообщение 18.10.16, 10:22
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 1 раз
Рейтинг: 0

Здравствуйте! Бухгалтерия 7.7.
Неужели нельзя в коде перенести ТекущийЭлемент() справочника (напр. спр.ТМЦ) в другую указанную папку
справочника, т.е. поменять Родителя???

sava1 Подменю пользователя
сообщение 18.10.16, 10:29
Сообщение #2

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2384
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

А что, написано , что нельзя ?

Из КЖК:

Родитель
Значение родительской группы элемента справочника.

Синтаксис:

Родитель

Англоязычный синоним:

Parent

Описание:

Атрибут Родитель предоставляет доступ к значению родительской группы выбранного элемента справочника.

Данный атрибут может быть изменен только для объектов, созданных функцией СоздатьОбъект.

Пример:

Функция ДатьРодителя(Элем)

   // Справочник Товаров многоуровневый

   // Получая в параметре функции значение товара,

   // надо выдать имя группы товара

   Спр = СоздатьОбъект("Справочник.Товары");

   Спр.НайтиЭлемент(Элем);

   Если Спр.Уровень() > 1 Тогда

      Спр.НайтиЭлемент(Спр.Родитель);

      Возврат "Этот товар принадлежит группе " + Спр.Наименование;

   Иначе

      Возврат "Это товар первого уровня - нет родителя!";

   КонецЕсли;

КонецФункции



TTT Подменю пользователя
сообщение 18.10.16, 10:55
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 1 раз
Рейтинг: 0

sava1 @ Сегодня, 11:29 * ,
Я не увидела присвоения нового Родителя!
Старый и так известен!

sava1 Подменю пользователя
сообщение 18.10.16, 11:19
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2384
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

Спр = СоздатьОбъект("Справочник.Товары");
// НовыйРодитель = спр.Найти...   или из реквизита
// те = найти элемент
те.Родитель = НовыйРодитель
Спр.Записать();

TTT Подменю пользователя
сообщение 18.10.16, 11:22
Сообщение #5

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 1 раз
Рейтинг: 0

sava1 @ Сегодня, 12:19 * ,
И все???
Спасибо!!

Vofka Подменю пользователя
сообщение 18.10.16, 13:10
Сообщение #6

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13401
Из: Киев
Спасибо сказали: 4143 раз
Рейтинг: 3287.8

TTT, для "спасибо" есть специальная кнопочка.

TTT Подменю пользователя
сообщение 18.10.16, 13:30
Сообщение #7

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 1 раз
Рейтинг: 0

TTT @ Сегодня, 12:22 * ,
Попробовала!
Ошибка: Объект не может быть перепозиционирован!

sava1 Подменю пользователя
сообщение 18.10.16, 14:53
Сообщение #8

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2384
Из: Проскуров
Спасибо сказали: 575 раз
Рейтинг: 559

код покажите.

TipsyKID Подменю пользователя
сообщение 18.10.16, 15:43
Сообщение #9

Оратор
Иконка группы
Группа: Местный
Сообщений: 408
Из: Киев
Спасибо сказали: 160 раз
Рейтинг: 0

Проверено работает.

Процедура ИзменитьРодителяНоменклатуры(Номенклатура,НовыйРодитель)
    
    Если НовыйРодитель.ЭтоГруппа() = 0 тогда
        Предупреждение("Укажите группу в качестве родителя!");
        Возврат;
    КонецЕсли;
    
    Спр = СоздатьОбъект("Справочник.ТМЦ");
    Спр.НайтиЭлемент(Номенклатура);
    
    Спр.Родитель = НовыйРодитель;
    
    Попытка
        Спр.Записать();
        Сообщить("Для элемента " + Номенклатура + " был изменен родитель на " + НовыйРодитель);
    Исключение
        Сообщить("" + ОписаниеОшибки());
    КонецПопытки;
    
КонецПроцедуры
//*******************************************


[необходимо зарегистрироваться для просмотра ссылки]


Signature
Специалист : Технологическая платформа 8.х, Бухгалтерия для Украины, Управление торговлей для Украины, Зарплата и Управление Персоналом для Украины

Спасибо сказали: TTT,

TTT Подменю пользователя
сообщение 19.10.16, 9:58
Сообщение #10

Общительный
**
Группа: Пользователи
Сообщений: 30
Спасибо сказали: 1 раз
Рейтинг: 0

TipsyKID @ Вчера, 16:43 * ,
ДА!!! Спасибо большое, все работает у меня бестолковой!

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 26.11.20, 22:45
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!