Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )




>  Отключение объединения номенклатурных позиций
KIODAMAGE
Отправлено: 16.09.20, 15:32


Молчаливый
*

Группа: Пользователи
Сообщений: 3
Регистрация: 30.06.20
Пользователь №: 69837


Получилось сделать таким образом:

Процедура ПолучитьТаблицуДоступныхДействий(Отбор, АдресаВХранилище, НадписьОбеспечено)
    
    ...
            
            НайденныеСтроки = ТаблицаДоступныхДействий.НайтиСтроки(СтруктураПоиска);
            //Если НайденныеСтроки.Количество()>0 Тогда
            //    НайденныеСтроки[0].Доступно = НайденныеСтроки[0].Доступно + КоличествоОформлено;  - отключил проверку на количество;
            //Иначе
                НоваяСтрока = ТаблицаДоступныхДействий.Добавить();
                ЗаполнитьЗначенияСвойств(НоваяСтрока, ТаблицаДоступныхДействий[ТаблицаДоступныхДействий.Количество()-2]);
                НоваяСтрока.ВариантОбеспечения = СтруктураПоиска.ВариантОбеспечения;
                НоваяСтрока.Доступно = КоличествоОформлено;
            //КонецЕсли;
        КонецЕсли;
        
    ...
    
КонецПроцедуры


В процедуре отключил проверку на количество, при добавлении через подбор товаров работает нормально, но при выборе быстрых товаров по-прежнему объединяет строки.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #166487 · Ответов: 1 · Просмотров: 98
 

>  Отключение объединения номенклатурных позиций
KIODAMAGE
Отправлено: 16.09.20, 14:06


Молчаливый
*

Группа: Пользователи
Сообщений: 3
Регистрация: 30.06.20
Пользователь №: 69837


Добрый день. В Рознице 2.2 есть возможность в настройках РМК запретить объединение одинаковых номенклатурных позиций в одну строку(когда при добавлении не добавляется новая строка, а только возрастает количество). Подскажите, можно ли это каким-то образом сделать в УТ 3.2.16.3?
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #166485 · Ответов: 1 · Просмотров: 98
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 31.10.20, 13:29
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!