Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику ignsv ::: Спасибо сказали: 58 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
16.05.17, 19:55 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
mister-x @ Сегодня, 12:41 * ,
https://www.work.ua/jobs/2460459/
Pavlik1c,
31.03.17, 12:57 Як внести нову фізичну особу (Комплексний облік для бюджетних установ України.Редакція 2.1)
Юля @ Сегодня, 12:55 * ,
оновіться до останнього релізу - здається така помилка була в перших релізах 2.1 редакції
Юля,
21.10.16, 14:46 Добавить движение по новому регистру в РКО и ППИ
        // Движения по заказам покупателей.
        НаборДвижений = Движения.ЗаказыПокупателей;
        
        СтруктТаблицДокумента = Новый Структура;
        СтруктТаблицДокумента.Вставить("ТаблицаПоТоварам", ТаблицаПоТоварам);

            
        ТаблицыДанныхДокумента = ОбщегоНазначения.ЗагрузитьТаблицыДокументаВСтруктуру(НаборДвижений, СтруктТаблицДокумента);
        
        ОбщегоНазначения.УстановитьЗначениеВТаблицыДокумента(ТаблицыДанныхДокумента, "ЗаказПокупателя",    Ссылка);
        ОбщегоНазначения.УстановитьЗначениеВТаблицыДокумента(ТаблицыДанныхДокумента, "ДоговорКонтрагента", ДоговорКонтрагента);

        ОбщегоНазначения.ЗаписатьТаблицыДокументаВРегистр(НаборДвижений, ВидДвиженияНакопления.Приход, ТаблицыДанныхДокумента, Дата);


где ТаблицаПоТоварам - ваша подготовленная таблица
twilight_dream,
04.06.16, 11:34 помогите добавить колонку штрих-кода в форме Реализация товаров и услуг
ошибка из-за того, что вы добавили регистр "штрихкоды" и там так же само есть реквизит ЕдиницаИзмерения, а так как в запросе пишется "ЕдиницаИзмерения" - без указания от куда брать его, то 1с дает ошибку. Например Если заменить на
РеализацияТоваровУслуг.ЕдиницаИзмерения
тогда будет норм. а вообще предлагаю не изменять запрос, а в цикле вывода строки получать штрихкод :
УправлениеРозничнойТорговлей.ПолучитьШтрихКод(сюда передаем владельца, единицу характеристику и т.д.)
- меньше изменений в типовом коде, но может немного дольше формировать, потестируйте, как вам будет оптимальней
souvenirsplaster,
02.11.15, 14:35 Выбор контрагентов из конкретной группы
Например так
Constantus,
27.10.15, 12:38 Изменить счет в платежном поручение входящем (исходящем)
якби да, вище людина відповіла, скоріш за все у вас змінена...
1c ms,
12.09.15, 13:51 Пердача параметра из журнала в новый документ
Значения установленного отбора (ДокументСписок.Отбор) будет доступен в переменной "Основание" в обработчике ОбработкаЗаполнения, можно и там смотреть или передалась структура, или там есть рекв "Касса" далее заполнять. и список без изменений ))
vol235,
02.02.15, 12:28 Как заполнить "ДанныеЗаполнения"?
Цитата(SV71 @ 02.02.15, 11:19) *
как из события "ПередНачаломДобавления" в "Форма списка.Список" заполнить "ДанныеЗаполнения"

установить отбор по дате в списке
SV71,
05.12.14, 14:40 продажа покупка валюты деление на 0
РеестрОстатков=РегистрыБухгалтерии.Хозрасчетный;

        СтруктураОтбора = Новый Структура("Счет",ПланыСчетов.Хозрасчетный.ДенежныеСредстваВПутиВИностраннойВалюте);
        СтруктураОтбора.Вставить("Организация", Организация);
        СтруктураОтбора.Вставить("Валюта", Валюта);
        СтруктураОтбора.Вставить("Субконто1", Банк);
        
        Реквизиты = "Счет,Валюта,Субконто1";
        
        РеестрОстатков = РеестрОстатков.Остатки(Новый Граница(ДатаДвижений, ВидГраницы.Включая),,СтруктураОтбора,Реквизиты,"Сумма,ВалютнаяСумма");
        КурсПоСреднему =0;
        Для каждого Стр из РеестрОстатков цикл
            ОстатокВалРегУчета = Стр.СуммаОстатокДт-Стр.СуммаОстатокКт;
            ОстатокИнаяВал = Стр.ВалютнаяСуммаОстатокДт-Стр.ВалютнаяСуммаОстатокКт;
            КурсПоСреднему = ОстатокВалРегУчета/ОстатокИнаяВал;
        КонецЦикла;


Посмотрите остатки по счету такому то, с отборами: организация, валюта, банк, смотрите на СуммаОстатокДт, СуммаОстатокКт, ВалютнаяСуммаОстатокДт, ВалютнаяСуммаОстатокКт, подставляйте свои значения в расчеты



DatteBayo,
24.10.14, 8:21 Ведомость товаров на складах
Вы же сами "дошли" что необходим список номенклатуры, ну так заполните список номенклатурой с документа, например:
Процедура Кнопка1Нажатие(Элемент)
мНом = Товары.ВыгрузитьКолонку("Номенклатура"); // получили массив, по-моему нужен список
сНом = Новый СписокЗначений;

сНом .ЗагрузитьЗначения(мНом); // получили список
    Отбор["Номенклатура"].ВидСравнения = ВидСравнения.ВСписке;
    Отбор["Номенклатура"].Значение = сНом;
r1p88@mail.ru,
24.06.14, 18:41 Удаление строк в таблице по условиям
както так:
ВЫБРАТЬ
    "Стол" КАК Наименование,
    "А1" КАК Артикул,
    "А111" КАК Оригинал
ПОМЕСТИТЬ СписокНом

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "Стол",
    "А1",
    "НЕТ"

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "Стол",
    "А1",
    "НЕТ"

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "Кровать",
    "К5",
    "К321"

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    "Полка",
    "П4",
    "НЕТ"
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    СписокНом.Наименование,
    СписокНом.Артикул,
    СписокНом.Оригинал КАК Оригинал,
    КОЛИЧЕСТВО(СписокНом.Артикул) КАК АртикулКолво,
    КОЛИЧЕСТВО(СписокНом.Оригинал) КАК ОригиналКолво
ПОМЕСТИТЬ ПромежуточныеРасчеты
ИЗ
    СписокНом КАК СписокНом

СГРУППИРОВАТЬ ПО
    СписокНом.Наименование,
    СписокНом.Артикул,
    СписокНом.Оригинал
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ПромежуточныеРасчеты.Наименование,
    ПромежуточныеРасчеты.Артикул,
    ПромежуточныеРасчеты.Оригинал
ИЗ
    ПромежуточныеРасчеты КАК ПромежуточныеРасчеты
ГДЕ
    ПромежуточныеРасчеты.АртикулКолво = 1
    И ПромежуточныеРасчеты.ОригиналКолво = 1
    И ПромежуточныеРасчеты.Оригинал = "НЕТ"
Log1c,
22.04.14, 8:32 Как в форму выбора выводить только позиции с положительным количеством
Цитата(logist @ 22.04.14, 7:56) *
Не достаточно, надо еще и обработку результата подбора написать (или взять откуда-то, из той же формы ЧекККМ должна подойти, и адаптировать)


Если мы говорим про "ЧекККМ" и форму "ФормуРегистрацииПродаж" то там уже есть обработка результата подбора. А так то да: стандартно вызов подбора и обработка результата подбора
yur,
21.04.14, 12:04 Как в форму выбора выводить только позиции с положительным количеством
есть там путь: Попробуйте F12 или "перейти к определению" стоя на тексте "ДействиеПодбор" по-идее достаточно только вызов подбора сделать, а обработка уже есть там
yur,
04.04.14, 11:15 Планы выхода обновлений
Бухгалтерия для Украины

Номер версии 1.2.20
Ориентировочная дата выхода 09.04.14
Дата обновления плановых данных 04.04.14
В релизе планируется:
- согласно Приказу Миндоходов от 08.02.2014 № 48 внести изменения в план счетов;
- согласно Приказу Миндоходов от 08.02.2014 № 48 внести изменения в финансовые отчеты;
- согласно Приказу Миндоходов от 21.01.2014 № 49 реализовать новую форму отчета 1ДФ;
- согласно Закону Украины от 27.03.2014 № 1166-VII
- реализовать возможность оформления документов по ставке НДС 7%,
- установить ставку сбора в пенсионный фонд с покупки валюты 0,5%;
- исправить обнаруженные ошибки.
Ardi, Batchir, Rayne, sasha007, Vofka,
11.09.13, 12:24 Удаление строк из ТЗ по условию
вот так можно удалить сстроки ТабЗнач по условию:
Индекс = 0;
    Пока Индекс < Таблица.Количество() Цикл

        СтрокаТаблицы = Таблица.Получить(Индекс);

        Если Условие Тогда
            Индекс = Индекс + 1;
        Иначе
            Таблица.Удалить(СтрокаТаблицы);
        КонецЕсли;

         КонецЦикла;
bolobol,
15.08.13, 12:36 Печать штрих-кода
делал не давно такое. за основу взял УТ 3.0

1. выполняем подключение компоненты там функция взять от туда код
 
ВнешняяКомпонента = Обработки.ОбработкаГдеХранитсяКомпонента.ПодключитьВнешнююКомпонентуПечатиШтрихк
ода()

( в обработке в макете лежит компонента)

2, Преобразовать Свой уникальный код в ШК
наподобе
ШестнадчатиричноеЧисло = СтрЗаменить(Строка(Ссылка.УникальныйИдентификатор()),"-","");
    Возврат ПреобразоватьИзШестнадцатиричнойСистемыСчисленияВДесятичноеЧисло(ШестнадчатиричноеЧисло);


3. передать ШК в компоненту которая и сформирует картинку
наподобе:
ВнешняяКомпонента.ЗначениеКода = Штрихкод;
    
// Сформируем картинку
ДвоичныеДанныеКартинки = ВнешняяКомпонента.ПолучитьШтрихкод();
    
// Если картинка сформировалась
Если ДвоичныеДанныеКартинки <> Неопределено Тогда
    // Формируем из двоичных данных
    ОбластьМакета.Рисунки.КартинкаШтрихкода.Картинка = Новый Картинка(ДвоичныеДанныеКартинки);
КонецЕсли;


з.ы. компоненты лежат в УТ 3.0 в обработке печать ценников и этикеток

как то так
хакерок,
08.05.13, 9:21 Как отобразить в накладной разную цену товаров?
Цитата(Романова @ 08.05.13, 9:38) *
Прошу прощения, я только изучаю 1С и где искать флаг корректировки цены в документе? спасибо заранее


Сервис > Пользователи > Настройка доп. прав пользователей
Романова,
20.03.13, 19:52 Редактирование стандартного отчета
В универсальном отчете контактная информация реализована аналогично свойствам и категориям.
Посмотрите Процедуру универсального отчета:
УниверсальныйОтчет.ДобавитьВТекстЗапросаКонтактнуюИнформацию()

+ почитайте здесь

в итоге получите отчет вида:


1сНеЛюбитМеня,
20.03.13, 12:01 Нужно получить значение регистра ЗначенияСвойствОбъектов
Вместо Сообщить()
Если  Выб .Следующий() Тогда
    Сообщить(Строка(Выб .Свойство) + "    " +Строка(Выб .Значение));    
КонецЕсли;
abes,
15.03.13, 15:50 Получить ограниченное число документов по каждому покупателю запросом

Цитата
Пример реального использования:
Теперь немного о том, ради чего всё это делается, то-есть польза, которую можно извлечь из нумерации строк запроса.

Например, перед нами стоит задача получить для каждого контрагента пять последних документов поступления товаров и услуг:
...


Нумерация строк в запросе

alex040269, logist, Petre,
29.01.13, 13:08 язык печатных форм
Проверьте: Настройка пользователя >другие настройки > язык формирования печатных форм документов
Илья,
25.01.13, 16:04 Превышение остатка денежных средств....
Посмотрите отчет Ведомость по денежным средствам по вашему счету, добавьте группировку регистратор, проанализируйте данные
Если у вас специфика такая, то "Разрешить превышение свободного остатка денежных средств" - в дополнительных правах пользователя
iat,
23.01.13, 15:25 Преобразование полученного значения в Дату
Если вы сделаете Формат, вы потеряете тип Дата. Если вам дальше нужно работать с типом Дата, то 10.08.1983 0:00:00 = 10.08.1983.
vall-n-rol,
20.01.13, 19:29 Вопрос на ввод данных №2
Цитата
А как переместить товар между организациями? Списать с одной и оприходовать на другую?


Да, я делал Поступление от Поставщика на "ООО Опт" > Продаж Контрагенту "Розница" > Поступление на "ООО Розница"

Цитата
И что означает фраза "Внести данные о продажах непосредственно в "ООО Розница""?


Продать от Организации "ООО Розница" с розничного склада. Я делал док "Чеки ККМ", склад Розничный, Кассу ККМ добавил, товар там 10 шт. проводил > "обработка закрытия кассовой смены" > сформирует отчет о розничных продажах и удалит все чеки.
Vofka,
12.12.12, 16:20 Вопрос на конфигурирование №2
Мой вариант:
1. Изменяем спр. Личные контакты и спр КонтактныеЛица Добавляем Реквизиты, выводим на форму:
НапоминатьОПодарке - булево
КоличествоДнейДоПодарка - число 2,0
ОтветственныйЗаПодарок – спр.Пользователи

2.
МодульФормы (для двух справочников):
Процедура ДоступностьДанныхНапоминанияОДнеРождения()
    Если ДатаРождения = '00010101000000' Тогда    
        ЭлементыФормы.НапоминатьОДнеРождения.Доступность      = Ложь;
        ЭлементыФормы.КоличествоДнейДоНапоминания.Доступность = Ложь;
        ЭлементыФормы.НадписьДней.Доступность                 = Ложь;
    //УТСПЕЦИАЛИСТ +
        ЭлементыФормы.НапоминатьОПодарке.Доступность           = Ложь;      
        ЭлементыФормы.КоличествоДнейДоНапоминания1.Доступность = Ложь;
        ЭлементыФормы.ОтветственныйЗаПодарок.Доступность       = Ложь;
        //УТСпециалист -
    Иначе        
        ЭлементыФормы.НапоминатьОДнеРождения.Доступность      = Истина;
        ЭлементыФормы.КоличествоДнейДоНапоминания.Доступность = НапоминатьОДнеРождения;
        ЭлементыФормы.НадписьДней.Доступность                 = НапоминатьОДнеРождения;
        
    //УТСПЕЦИАЛИСТ +
        ЭлементыФормы.НапоминатьОПодарке.Доступность           = Истина;      
        ЭлементыФормы.КоличествоДнейДоНапоминания1.Доступность = НапоминатьОПодарке;
        ЭлементыФормы.ОтветственныйЗаПодарок.Доступность       = НапоминатьОПодарке;
        //УТСпециалист -
    КонецЕсли;
КонецПроцедуры // ДоступностьДанныхНапоминанияОДнеРождения()

(Если хватает времени то можно для справочника.КонтактныеЛицаКонтрагентов форма ФормаВводаНового проделать аналогичные действия (там реквизиты формы)

3. Находим ОбщийМодуль - МодульРегламентныхЗаданий:
    
//////////После всего добавляем
    ////УТ_Специалист +
//ПОДАРКИ
        
        
    Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
                   |    Контакты.КонтактноеЛицо КАК КонтактноеЛицо,
                   |    Контакты.КонтактноеЛицо.ОтветственныйЗаПодарок КАК Исполнитель,
                   |    Контакты.КонтактноеЛицо.КоличествоДнейДоПодарка КАК ИнтервалДней,
                   |    Контакты.КонтактноеЛицо.ДатаРождения КАК ДатаРождения,
                   |    Задачи.СрокИсполнения КАК Срок
                   |ИЗ
                   |    Справочник.КонтактныеЛицаКонтрагентов КАК Контакты
                   |        ЛЕВОЕ СОЕДИНЕНИЕ Задача.ЗадачиПользователя КАК Задачи
                   |        ПО (Задачи.Объект = Контакты.КонтактноеЛицо)
                   |            И (Задачи.Оповещение = ИСТИНА)
                   |            И (Задачи.ПамятнаяДата = ИСТИНА)
                   |            И (Задачи.СрокИсполнения > ДОБАВИТЬКДАТЕ(Контакты.КонтактноеЛицо.ДатаРождения, ГОД, РАЗНОСТЬДАТ(Контакты.КонтактноеЛицо.ДатаРождения, ДОБАВИТЬКДАТЕ(&ТекДата, ДЕНЬ, Контакты.КонтактноеЛицо.КоличествоДнейДоПодарка), МЕСЯЦ) / 12 - 1))
                   |ГДЕ
                   |    Контакты.КонтактноеЛицо.НапоминатьОПодарке = ИСТИНА
                   |    И Контакты.КонтактноеЛицо.ДатаРождения <> ДАТАВРЕМЯ(1, 1, 1)
                   |    И Контакты.Владелец ССЫЛКА Справочник.Контрагенты
                   |    И Контакты.Владелец <> ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
                   |    И Контакты.КонтактноеЛицо.ОтветственныйЗаПодарок <> ЗНАЧЕНИЕ(Справочник.Пользователи.ПустаяСсылка)
                   |    И (ДОБАВИТЬКДАТЕ(Контакты.КонтактноеЛицо.ДатаРождения, ГОД, ГОД(&ТекДата) - ГОД(Контакты.КонтактноеЛицо.ДатаРождения)) >= &ТекДата
                   |                И ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(Контакты.КонтактноеЛицо.ДатаРождения, ДЕНЬ, -Контакты.КонтактноеЛицо.КоличествоДнейДоПодарка), ГОД, ГОД(&ТекДата) - ГОД(Контакты.КонтактноеЛицо.ДатаРождения)) <= &ТекДата
                   |            ИЛИ ДОБАВИТЬКДАТЕ(Контакты.КонтактноеЛицо.ДатаРождения, ГОД, ГОД(&ТекДата) - ГОД(Контакты.КонтактноеЛицо.ДатаРождения)) >= ДОБАВИТЬКДАТЕ(&ТекДата, ГОД, -1)
                   |                И ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(Контакты.КонтактноеЛицо.ДатаРождения, ДЕНЬ, -Контакты.КонтактноеЛицо.КоличествоДнейДоПодарка), ГОД, ГОД(&ТекДата) - ГОД(Контакты.КонтактноеЛицо.ДатаРождения)) <= ДОБАВИТЬКДАТЕ(&ТекДата, ГОД, -1))
                   |    И Задачи.СрокИсполнения ЕСТЬ NULL
                   |
                   |ОБЪЕДИНИТЬ
                   |
                   |ВЫБРАТЬ
                   |    ЛичныеКонтакты.Ссылка,
                   |    ЛичныеКонтакты.ОтветственныйЗаПодарок,
                   |    ЛичныеКонтакты.КоличествоДнейДоПодарка,
                   |    ЛичныеКонтакты.ДатаРождения,
                   |    Задачи.СрокИсполнения
                   |ИЗ
                   |    Справочник.ЛичныеКонтакты КАК ЛичныеКонтакты
                   |        ЛЕВОЕ СОЕДИНЕНИЕ Задача.ЗадачиПользователя КАК Задачи
                   |        ПО (Задачи.Объект = ЛичныеКонтакты.Ссылка)
                   |            И (Задачи.Оповещение = ИСТИНА)
                   |            И (Задачи.ПамятнаяДата = ИСТИНА)
                   |            И (Задачи.СрокИсполнения > ДОБАВИТЬКДАТЕ(ЛичныеКонтакты.ДатаРождения, ГОД, РАЗНОСТЬДАТ(ЛичныеКонтакты.ДатаРождения, ДОБАВИТЬКДАТЕ(&ТекДата, ДЕНЬ, ЛичныеКонтакты.КоличествоДнейДоПодарка), МЕСЯЦ) / 12 - 1))
                   |ГДЕ
                   |    ЛичныеКонтакты.НапоминатьОПодарке = ИСТИНА
                   |    И ЛичныеКонтакты.ДатаРождения <> ДАТАВРЕМЯ(1, 1, 1)
                   |    И ЛичныеКонтакты.ОтветственныйЗаПодарок <> ЗНАЧЕНИЕ(Справочник.Пользователи.ПустаяСсылка)
                   |    И (ДОБАВИТЬКДАТЕ(ЛичныеКонтакты.ДатаРождения, ГОД, ГОД(&ТекДата) - ГОД(ЛичныеКонтакты.ДатаРождения)) >= &ТекДата
                   |                И ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ЛичныеКонтакты.ДатаРождения, ДЕНЬ, -ЛичныеКонтакты.КоличествоДнейДоПодарка), ГОД, ГОД(&ТекДата) - ГОД(ЛичныеКонтакты.ДатаРождения)) <= &ТекДата
                   |            ИЛИ ДОБАВИТЬКДАТЕ(ЛичныеКонтакты.ДатаРождения, ГОД, ГОД(&ТекДата) - ГОД(ЛичныеКонтакты.ДатаРождения)) >= ДОБАВИТЬКДАТЕ(&ТекДата, ГОД, -1)
                   |                И ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ЛичныеКонтакты.ДатаРождения, ДЕНЬ, -ЛичныеКонтакты.КоличествоДнейДоПодарка), ГОД, ГОД(&ТекДата) - ГОД(ЛичныеКонтакты.ДатаРождения)) <= ДОБАВИТЬКДАТЕ(&ТекДата, ГОД, -1))
                   |    И Задачи.СрокИсполнения ЕСТЬ NULL ";

    //УТ Специалист –


Запрос менялся «по аналогии».

Для проверки изменяем расписание регламентного задания ФормированиеПоздравленийСДнемРождения
Ставим каждые 60 сек например.

Из ошибок: идеально сделать пользователя, ответственного за подарки через регистр сведений. (я сдал и без этого, но правильно через регистр сведений)
TipsyKID,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 06.06.20, 17:16
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!