Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



6 страниц V   1 2 3 > » 

>  Сервис для журнала регистрации
AnryMc
Отправлено: 17.03.23, 18:33


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


python @ Сегодня, 12:21 * ,
RedCat77 @ Сегодня, 12:33 * ,

Создал и залил: https://pro1c.org.ua/topic/vneshnya-pechatn...ta-fonom-67202/

"Внешняя печатная форма "История объекта фоном"

Цитата
Предмодерация

В данном разделе все темы проходят предмодерацию. Поэтому после создания новой темы вы будете переадресованы в этот форум, но темы своей не увидите. Если с темой все в порядке, то она будет опубликована модератором после проверки.


Ждите когда отмодерируют...
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #176941 · Ответов: 5 · Просмотров: 438
 

>  Внешня печатная форма "История объекта фоном"
AnryMc
Отправлено: 17.03.23, 18:29


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Внешняя печатная форма "История объекта фоном"
История Документа / Справочника из журнала регистрации конфигурации по конкретному объекту / элементу...
Создал, изменил , провел,...

Опробована в конфигурации BAS Бухгалтерия Корп, но должна работать на всех конфигурациях с БСП

Добавляется во внешние отчеты и обработки - выбрать для каких объектов конфигурации использовать...

Выполняется в фоновом режиме - т.е. можно продолжать работать в других открытых в программе окнах...
  Форум: Отчеты / Обработки · Просмотр сообщения: #176940 · Ответов: 0 · Просмотров: 59
 

>  Сервис для журнала регистрации
AnryMc
Отправлено: 08.03.23, 17:40


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Делал внешнюю печатную форму для объектов (документы/Справочники) события: Создал, изменил, провел, отменил проведение, пометил на удаление.
Выполнение запроса к журналу регистрации в фоновом режиме...

Если интересно могу поискать...
  Форум: Администрирование и настройка 1С · Просмотр сообщения: #176911 · Ответов: 5 · Просмотров: 438
 

>  Сообщение пользователю без привязки к конкретному окну
AnryMc
Отправлено: 08.03.23, 10:07


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


denis84 @ Сегодня, 9:57 * ,

Это я видел до данной темы, но не понимаю:
1) // удаляем после получения
2) ПолучитьСообщенияПользователю(Истина)
3) // Код вывода сообщения (в серверных процедурах)
// ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Сообщение");

Т.е.:
1) как и где сформировать само сообщение?
2) Как и где его потом очистить?
3) Как и где заставить его вывести?
4) Какое фоновое задание?

Для: Business automation software for accounting CORP, edition 2.1 (2.1.13.1)

P.S. Метод через "Окно.Активировать()" - тоже не смог заставить работать...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176909 · Ответов: 6 · Просмотров: 217
 

>  Сообщение пользователю без привязки к конкретному окну
AnryMc
Отправлено: 08.03.23, 9:24


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(Petre @ 08.03.23, 8:11) *
Для вызова с сервера есть ОбщегоНазначения.СообщитьПользователю().
В форме есть событие на клиенте ПослеЗаписи.


БСП 3.0.1.418

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)

    ОбщегоНазначенияКлиентСервер.СообщитьПользователю("!!!!", Объект.Ссылка, ,,);

КонецПроцедуры



"Записать" - работает
"Провести" - работает
"Провести и закрыть! - НЕ РАБОТАЕТ!!!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176907 · Ответов: 6 · Просмотров: 217
 

>  Сообщение пользователю без привязки к конкретному окну
AnryMc
Отправлено: 08.03.23, 8:05


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Petre @ Вчера, 17:49 * ,


БСП есть но расположенное в модуле формы в процедуре ПослеЗаписиНаСервере - не срабатывает при "Провести и Закрыть"

З.Ы. Или я не знаю "волшебное" слово?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176905 · Ответов: 6 · Просмотров: 217
 

>  Сообщение пользователю без привязки к конкретному окну
AnryMc
Отправлено: 07.03.23, 14:13


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Добрый день!

Задача: При записи документа происходит некоторый анализ записываемого документа и его результат выводится как СообщениеПользователю....
Так как данное событие не критично то не влияет на Отмену (записи/Проведения) и просто несет некоторое информативное наполнение...
Т.Е. Открыто окно документа - пользователь может нажать "Провести и закрыть" - окна документа уже нет. чтобы вывести сообщение, Документ может быть открыт из: Списка, Отчета (расшибровка), Избранное и пр. - т.е Владелец окна тоже не подходит...

Как Вывести сообщениеПользователю в такой ситуации???
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176903 · Ответов: 6 · Просмотров: 217
 

>  Как перейти с ПРОФ на КОРП BAS бухгалтерии для Украины?
AnryMc
Отправлено: 06.03.23, 12:42


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


https://tqm.com.ua/likbez/bas/bas-buhgalter...#perenos-dannyh

Цитата
Перенос данных при переходе из других программ

Переход на решения "BAS Бухгалтерія КОРП" из программы "BAS Бухгалтерія ПРОФ", редакции 2.1 осуществляется обновлением актуальной версии конфигурации указанных программ (на момент выхода новости - версии 2.1.3), при этом накопленные бухгалтерские учетные данные полностью сохраняются (без изменений и потерь ).

Перенос данных

Переход на решения "BAS Бухгалтерія КОРП" из программы "Бухгалтерія ", редакция 1.2 или редакции 2.0, осуществляется в два этапа:

на первом этапе следует обновить "Бухгалтерія ", редакции 1.2 или редакции 2.0, до актуальной версии "BAS Бухгалтерія ПРОФ", редакция 2.1;
на втором этапе промежуточную базу "BAS Бухгалтерія ПРОФ", редакция 2.1, следует обновить до актуальной версии "BAS Бухгалтерія КОРП", редакция 2.1.

Существующие документы зарплатного и кадрового учета после перехода хранятся без возможности редактирования. Для использования новых возможностей "BAS Бухгалтерія КОРП" следует выполнить конвертацию данных специальной обработкой, которая входит в состав конфигурации. С помощью обработки переносятся:

кадровая история сотрудников;
остатки невыплаченной зарплаты и остатки расчетов с бюджетом по налогам и сборам;
данные для расчета среднего заработка за последние 12 месяцев;
актуальные способы отображения заработной платы, зарплатные проекты и личные счета сотрудников, налоговые социальные льготы сотрудников, базовые периоды индексации.

При переходе с программы "Управління торговим підприємством" решения "BAS Бухгалтерія КОРП" можно перенести справочники и остатки по бухгалтерским счетам, а также настройки, основные данные и остатки заработной платы и учета кадров. Соответствующие правила переноса включены в состав программы "BAS Бухгалтерія КОРП".

Реализована возможность перенести настройки, основные данные и остатки заработной платы и учета кадров по программе "Зарплата і Управління Персоналом", редакция 2.1 (перенос данных возможно начиная с версии 2.1.56). Соответствующие правила переноса также включены в состав программы "BAS Бухгалтерія КОРП".
  Форум: Платформа 8 · Просмотр сообщения: #176894 · Ответов: 3 · Просмотров: 181
 

>  Імпорт даних в довідник Номенклатура
AnryMc
Отправлено: 06.03.23, 12:35


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


andreydv87 @ Сегодня, 12:23 * ,
Цитата(andreydv87 @ 06.03.23, 12:23) *
Не одна обработка не переносит коды,



Стандартная - ПЕРЕНОСИТ. Нужно просто указать из какой колонки в какой реквизит...
Возможно потребуется в доп. настройках указать "Загрузка" для обхода стандартного механизма контроля кодов (например когда импортируемый код совпадает с уже существующим, но это другая история...)
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #176893 · Ответов: 4 · Просмотров: 207
 

>  Імпорт даних в довідник Номенклатура
AnryMc
Отправлено: 06.03.23, 8:17


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


ОбменДанными.Загрузка = ИСТИНА;
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #176889 · Ответов: 4 · Просмотров: 207
 

>  Строка шаблона для поиска регулярного выражения
AnryMc
Отправлено: 02.03.23, 17:01


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


zay @ Сегодня, 12:57 * ,


Полностью своя конфа...
В день до 1500 наименований с "оЧеПатками" как у поставщика...
а потом нужно во всём этом "мусоре" найти нужные типоразмеры...
так что только RegExp

Нужна строка патерна для такой ситуации:

ПервоеЧисло введенное пользователем
+ может быть разделитель дробной части «.» или «,» если есть разделитель, то должна быть ещё одна цифра
+ может быть (или не быть) один или два разделителя (пробел)
+ знак «х» укр., «x» eng. (возможно в верхнем регистре) или «*» или «/»
+ может быть (или не быть) один или два разделителя (пробел)
+ ВтороеЧисло введенное пользователем
+ может быть разделитель дробной части «.» или «,» если есть разделитель, то должна быть ещё одна цифра
+ может быть (или не быть) один или два разделителя (пробел)
+ текст «мм» (укр.) или «mm» (eng.) (возможно в верхнем регистре)





Для чисел (второе 1-но разрядное) без десятичных

\d{1,3}\s{0,2}[xх\*]\s{0,2}\d\s{0,2}[mм][mм

Решение:

&НаКлиенте
Процедура ВыполнитьПоиск(Команда)
    
    ВыполнитьПоискНаСервере();
    
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ЗаполнитьШаблоны();
    
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьШаблоны()
    
    Объект.СтрокаПоиска = "Болт 10,2 * 5.1 Mm. и прочее";
    Объект.ШаблонПоиска = "ЧЧЧ1\s{0,2}[xх\*\/]\s{0,2}ЧЧЧ2\s{0,2}[mм][mм].?";
    Объект.Число1 = "10.2";
    Объект.Число2 = "5,1";
    
КонецПроцедуры

&НаСервере
Процедура ВыполнитьПоискНаСервере()
    
    RegExp = Новый COMОбъект("VBScript.RegExp");
    RegExp.MultiLine = ЛОЖЬ; //Многострочный
    RegExp.Global = Истина;
    RegExp.IgnoreCase = Истина; //Регистр верхний/нижний или не учитывать
    
    Число1_1 = СтрНайти(СокрЛП(Объект.Число1), ".");
    Число1_2 = СтрНайти(СокрЛП(Объект.Число1), ",");
    Число1_Длина = СтрДлина(СокрЛП(Объект.Число1));
    Число2_1 = СтрНайти(СокрЛП(Объект.Число2), ".");
    Число2_2 = СтрНайти(СокрЛП(Объект.Число2), ",");
    Число2_Длина = СтрДлина(СокрЛП(Объект.Число2));
    
    Если Число1_1 <> 0 Тогда
        
        СтрокаЧЧЧ1 = Лев(СокрЛП(Объект.Число1), Число1_1-1)+"[\.,]"+Прав(СокрЛП(Объект.Число1),Число1_Длина - Число1_1);
        
    ИначеЕсли Число1_2 <> 0 Тогда
        
        СтрокаЧЧЧ1 = Лев(СокрЛП(Объект.Число1), Число1_2-1)+"[\.,]"+Прав(СокрЛП(Объект.Число1),Число1_Длина - Число1_2);
        
    Иначе
        
        СтрокаЧЧЧ1 = СокрЛП(Объект.Число1);
        
    КонецЕсли;
    
    Если Число2_1 <> 0 Тогда
        
        СтрокаЧЧЧ2 = Лев(СокрЛП(Объект.Число2), Число2_1-1)+"[\.,]"+Прав(СокрЛП(Объект.Число2),Число2_Длина - Число2_1);
        
    ИначеЕсли Число2_2 <> 0 Тогда
        
        СтрокаЧЧЧ2 = Лев(СокрЛП(Объект.Число2), Число2_2-1)+"[\.,]"+Прав(СокрЛП(Объект.Число2),Число2_Длина - Число2_2);
        
    Иначе
        
        СтрокаЧЧЧ2 = СокрЛП(Объект.Число2);
        
    КонецЕсли;
    
    СтрокаШаблона = СтрЗаменить(СтрЗаменить(Объект.ШаблонПоиска, "ЧЧЧ1", СтрокаЧЧЧ1), "ЧЧЧ2", СтрокаЧЧЧ2);
    
    RegExp.Pattern = СокрЛП(СтрокаШаблона);
    
    Matches=RegExp.Execute(СокрЛП(Объект.СтрокаПоиска));
    
    Если Matches.Count > 0 Тогда
        
        SubMatch = Matches.Item(0);
        //Получаем значение первой захваченной группы
        ЭтоНашли = SubMatch.Value;
        Объект.РезультатПоиска = ЭтоНашли;
        
    Иначе
        
        Объект.РезультатПоиска = "";
        
    КонецЕсли;
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176876 · Ответов: 2 · Просмотров: 177
 

>  Строка шаблона для поиска регулярного выражения
AnryMc
Отправлено: 02.03.23, 12:38


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Добрый день!

Не могу собрать в мозгах шаблон для RegExp.Pattern

Ситуация: есть куча номенклатуры (название вноситься как в накладной поставщика), поэтому куча элементов по сути одно и тоже, но с разными названиями...

Например:
Болт 10 * 5 мм.
Болт 10,0 х 5.0 mm
БОЛТ 10Х5,0мм
bolt 10/5 mm
...
И куча прочих вариантов...

Задача отбор динамического списка где ищется:

Два числа (могут быть дробными с разделителем . или ,)
Между ними укр. х eng. x (возможно в верхнем регистре), ещё возможны знаки * и / - этот "разделитель" может (или нет) отделятся от чисел пробелами...
После второго числа через пробел (или без пробела) следует "мм" или "mm" (возможно в верхнем регистре)

Помогите с созданием шаблона для поиска RegExp.Pattern

Спасибо


P.S. Предполагается, что пользователь вводит два числа, например: 10 и 5
Нужно отобрать всю номенклатуру с данными парамерами...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176874 · Ответов: 2 · Просмотров: 177
 

>  Открыть файл для загрузки Excel
AnryMc
Отправлено: 28.02.23, 13:33


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Если мне не изменяет память, то вроде должно работать

"VA-03671_*.xls|VA-03671_*.xls"

вроде так делал...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176861 · Ответов: 6 · Просмотров: 227
 

>  Открыть файл для загрузки Excel
AnryMc
Отправлено: 28.02.23, 9:14


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Не проще загружать по имени КАТАЛОГА? (перебор файлов в каталоге)...


&НаКлиенте
Процедура ВыбратьФайлExcel(Команда)
    
    Если ОбработатьВсеФайлыИзПапки Тогда
        
        Если НЕ ПроверитьСуществованиеКаталога(Объект.ПутьКФайлу) Тогда
            
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Не вибрано каталог для імпорту!";
            Сообщение.Поле = "Объект.ПутьКФайлу";
            Сообщение.Сообщить();
            
            Возврат;
            
        КонецЕсли;
        
    Иначе
        
        Если НЕ ПроверитьСуществованиеФайла(Объект.ПутьКФайлу) Тогда
            
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Не вибрано файл для імпорту!";
            Сообщение.Поле = "Объект.ПутьКФайлу";
            Сообщение.Сообщить();
            
            Возврат;
            
        КонецЕсли;
        
    КонецЕсли;
    
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Початок вибірки з файлу: "+СокрЛП(ТекущаяДата());
    Сообщение.Сообщить();
    
    Если ОбработатьВсеФайлыИзПапки Тогда
        //много файлов
        
        СписокФайлов = НайтиПутиФайлов(Объект.ПутьКФайлу);
        
        Если СписокФайлов.Количество() = 0 Тогда
            
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Немає файлів для імпорту в каталозі: "+СокрЛП(Объект.ПутьКФайлу);
            Сообщение.Сообщить();
            
            Возврат;    
            
        КонецЕсли;
        
        Для КАЖДОГО текФ ИЗ СписокФайлов Цикл
            
            Попытка
                
                Двоичное = Новый ДвоичныеДанные(текФ);
                
            Исключение
                
                Сообщение = Новый СообщениеПользователю;
                Сообщение.Текст = "Помилка відкриття файлу: "+СокрЛП(текФ)+ОписаниеОшибки();
                Сообщение.Сообщить();
                
            КонецПопытки;
            
            Адрес = НЕОПРЕДЕЛЕНО;
            
            Адрес = ПоместитьВоВременноеХранилище(Двоичное, ЭтаФорма.УникальныйИдентификатор);
            
            ЗагрузкаНаСервере(Адрес, текФ);
            
        КонецЦикла;
        
    Иначе
        //Один файл
        
        Попытка
            
            Двоичное = Новый ДвоичныеДанные(Объект.ПутьКФайлу);
            
        Исключение
            
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Помилка відкриття файлу! "+ОписаниеОшибки();
            Сообщение.Сообщить();
            
        КонецПопытки;
        
        Адрес = ПоместитьВоВременноеХранилище(Двоичное, ЭтаФорма.УникальныйИдентификатор);
        
        ЗагрузкаНаСервере(Адрес);
        
    КонецЕсли;
    
    //Пост обработка
    
    нТип = НужныйТип();
    
    текН = 1;
    
    Для КАЖДОГО текТип ИЗ нТип Цикл
        
        текНужныйТип = текТип;
        
        ОповеститьОбИзменении(текНужныйТип);
        
    КонецЦикла;
    
КонецПроцедуры

&НаСервере
Процедура ЗагрузкаНаСервере(Адрес, текФайл = "")
        
    темп_Путь = КаталогВременныхФайлов()+ "Import_KP_"+СтрЗаменить(СтрЗаменить(СтрЗаменить(Формат(ТекущаяДата(), "ЧГ=0"), ".", ""), ":", ""), "", "_")+".xlsx";
    
    темп_файл = ПолучитьИзВременногоХранилища(Адрес);
    темп_файл.Записать(темп_Путь);
    
    СписокКолонок = Новый СписокЗначений;
    СписокКолонок.Добавить("ВидЗапроса"); //1
    СписокКолонок.Добавить("РегНомер");     //2
    СписокКолонок.Добавить("ДатаДок");      //3
        
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Початок створення файлу переносу: "+СокрЛП(ТекущаяДата());
    Сообщение.Сообщить();
    
    ТабЗагрузки = НЕОПРЕДЕЛЕНО;
    
    ТабЗагрузки = ЗагрузитьЭксель(темп_Путь,СписокКолонок);
    
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Файл перенесення сформовано: "+СокрЛП(ТекущаяДата());
    Сообщение.Сообщить();
...

&НаСервере
Функция  ЗагрузитьЭксель(Путь, СписокКолонки)
    
    ТЗФайл = Новый ТаблицаЗначений;
    
    Попытка
        
        ex = ПолучитьCOMобъект("","Excel.Application");
        
    Исключение
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст ="Excel Application не створено!!";
        Сообщение.Сообщить();
        
        Возврат ТЗФайл;
        
    КонецПопытки;
    
    Попытка
        
        ex.workbooks.open(Путь,1);
        
    Исключение
        
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст ="Файл переміщено або видалено!";
        Сообщение.Сообщить();
        
        Возврат ТЗФайл;
        
    КонецПопытки;
    
    Для каждого Зн Из СписокКолонки Цикл
        
        ТЗФайл.Колонки.Добавить(Зн.Значение);
        
    КонецЦикла;    
    
    RCount = ex.Cells(1,1).SpecialCells(11).Row;
    CCount = ex.Cells(1,1).SpecialCells(11).Column;
    
        Для j = 6 по RCount цикл
        
        Новая = ТЗФайл.Добавить();
        
        Для i=1 По СписокКолонки.Количество() Цикл
            
            ТД = СокрЛП(ex.ActiveSheet.Cells(j,i).Value);
            ТД = СтрЗаменить(ТД,Символ(КодСимвола(Символы.ВК,1))," ");
    
            
            Новая.Установить(i-1, ТД);
            
        КонецЦикла;    
        
    КонецЦикла;    
    
    ex.workbooks.Close();
    ex.quit();
    
    Возврат ТЗФайл;
    
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176860 · Ответов: 6 · Просмотров: 227
 

>  Получение почты с Gmail
AnryMc
Отправлено: 27.02.23, 8:09


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Вроде, есть корпоративная подписка, там есть администрирование - в котором можно отключить...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176851 · Ответов: 4 · Просмотров: 242
 

>  Програміст 1С ERP + Альфа-Авто + BAS в м.Київ
AnryMc
Отправлено: 20.02.23, 14:38


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Цитата(DimiIvi @ 20.02.23, 12:14) *
вік від 30 до 45 років


В Закон Украины "О рекламе" ст. 24
за несоблюдение этих норм работодателю грозит штраф в десятикратном размере минимальной зарплаты.
= 67 000 грн.

Можно стукнуть в Гоструда - если не примете ;-)
  Форум: Предложения работы · Просмотр сообщения: #176835 · Ответов: 4 · Просмотров: 233
 

>  Поиск заказов по номенклатуре
AnryMc
Отправлено: 20.02.23, 14:30


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Все функции - стандартные (в конце /внизу) - Поиск ссылок на объекты
Потом в нем по клавише "Найти" - "Заказ клиентов" или как у вас этот документ называется...
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #176834 · Ответов: 3 · Просмотров: 288
 

>  Как определить что в стандартный поиск донамического списка введено значение
AnryMc
Отправлено: 16.02.23, 10:37


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Дано:
- Динамический список
- автозаполнение командной панели
- в стандартный Поиск вводится значение

Вопросы:
1) Как можно определить что в динамическом списке выполнен отбор? Причем отбор вызван вводом значения в стандартный реквизит "поиск" на командной панели данного динамического списка
2) Как программно можно удалить это значение из поиска (очистить поиск)?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176827 · Ответов: 0 · Просмотров: 385
 

>  Пользователь блокирует Полнотекстовый поиск
AnryMc
Отправлено: 13.02.23, 16:39


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Самописная конфигурация. Файловый вариант.
Если пользователь производит полнотекстовый поиск он становиться владельцем файла КаталогБазы\1Cv8FTxt\tableChanges.dat
И пока он не выйдет из программы регламентные задания Обновления и Слияния индекса не могут выполняться т.к. указанный файл заблокирован пользователем...

Как с этим бороться???
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176817 · Ответов: 0 · Просмотров: 166
 

>  BAS Бухгалтерия. Запрет доступа к ЗП. В частности к счету 66
AnryMc
Отправлено: 03.02.23, 14:11


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


sava1 @ Сегодня, 13:57 * ,

Делал такое на РЛС - в отчетах и полях со ссылкой на справочник "Сотрудники" показывалось: "Объект не обнаружен" и его ГУИД...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176789 · Ответов: 7 · Просмотров: 369
 

>  Определить по реквизиту формы объект которому он принадлежит
AnryMc
Отправлено: 26.01.23, 10:35


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Vofka @ Сегодня, 9:51 * ,

Есть несколько справочников у которых есть реквизит - динамический список РС. Все эти справочники являются измерением (составного типа) записей данного РС.

Если из элемента из этих справочников добавить в РС новую запись то в этой записи будет виден только реквизит (Имя) из которого создана эта запись.

Как из этого реквизита определить Тип / Ссылку объекта который "породил" данную запись???

З.Ы. РС независимый, одному элементу справочников "владельцев/регистраторов" может принадлежать много записей РС...

Нужно при открытии новой записи РС вызваной из реквизита справочника "владельца/регистратора" (тип "динамический список РС") определить какой справочник и его элемент его создает...

Определить надо именно из записи РС не трогая сами справочники...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176747 · Ответов: 5 · Просмотров: 703
 

>  Чудеса использования полнотекстового поиска
AnryMc
Отправлено: 26.01.23, 8:54


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


РЕШЕНО: Когда удалил индекс и построил заново - заработало...

Т.е. при добавлении словаря полнотекстового поиска он не индексируется работающими регламентными задания "обновления" и "слияния" - только новое полное построение...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176745 · Ответов: 2 · Просмотров: 245
 

>  Определить по реквизиту формы объект которому он принадлежит
AnryMc
Отправлено: 26.01.23, 8:50


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Ни у кого нет идей как решить?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176744 · Ответов: 5 · Просмотров: 703
 

>  Чудеса использования полнотекстового поиска
AnryMc
Отправлено: 20.01.23, 10:09


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Очень хочется подключить синонимы!!!

Кто может помочь?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176731 · Ответов: 2 · Просмотров: 245
 

>  Возможно ли что то тимпа накопительного вычитания в СКД?
AnryMc
Отправлено: 20.01.23, 8:35


Завсегдатай
Иконка группы

Группа: Местный
Сообщений: 143
Регистрация: 11.12.10
Пользователь №: 5718


Я бы обратил внимание на расширение языка запросов СКД, а именно: "ВычислитьВыражениеСГруппировкой..."
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176730 · Ответов: 1 · Просмотров: 246
 

6 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.03.23, 7:30
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!