Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



102 страниц V   1 2 3 > » 

>  не могу передать значение с таблицы
sava1
Отправлено: Вчера, 9:04


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(AnryMc @ 26.09.22, 9:44) *
Было бы неплохо узнать что такое rsMain?


таблица в Медке
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176363 · Ответов: 2 · Просмотров: 132
 

>  Заміна 1С
sava1
Отправлено: 14.09.22, 10:04


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


22 в Партнерском, крайняя 21 тоже,
21.1393 - качается
  Форум: Офф-топик · Просмотр сообщения: #176313 · Ответов: 22 · Просмотров: 702
 

>  FF день
sava1
Отправлено: 13.09.22, 8:45


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Всех с днюхой, ПОГРОММисты !!!
  Форум: Офф-топик · Просмотр сообщения: #176307 · Ответов: 2 · Просмотров: 340
 

>  Заміна 1С
sava1
Отправлено: 12.09.22, 7:09


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


andr_andrey @ Вчера, 20:52 * ,


22.1553 - спокойно есть. МОжет Вам ИТС купить?
  Форум: Офф-топик · Просмотр сообщения: #176305 · Ответов: 22 · Просмотров: 702
 

>  Підключення з 1с7 до 1с8 для запуску обробки
sava1
Отправлено: 06.09.22, 11:15


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Коннектор=Создать0бъект("V82.COMConnector");
v8 =Коннектор.Connect("File="""+СокрЛП(ПутьКБазе) + """; Usr="""СокрЛП(Логин) +"""; Pwd=""" +СокрЛП(Пароль)+""" ");

Выборка = v8.МояФункция(Параметр1, Параметр2, ......);


для обработки - сделайте глобальную функцию в 8ке, которая будет вызывать Вашу обработку
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176297 · Ответов: 3 · Просмотров: 237
 

>  Підключення з 1с7 до 1с8 для запуску обробки
sava1
Отправлено: 06.09.22, 10:55


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


можна. по ОЛЕ/СОМ
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176295 · Ответов: 3 · Просмотров: 237
 

>  Заміна 1С
sava1
Отправлено: 05.09.22, 14:49


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


1с - це не тільки простенька Бухгалтерія і Торгівля
  Форум: Офф-топик · Просмотр сообщения: #176280 · Ответов: 22 · Просмотров: 702
 

>  Динамический список и странное поведение
sava1
Отправлено: 01.09.22, 10:11


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Vofka @ Сегодня, 9:50 * ,
воощето да - ПриПолученииДанныхНаСервере
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176257 · Ответов: 11 · Просмотров: 782
 

>  Період в журналі відбору
sava1
Отправлено: 01.09.22, 8:49


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


из жкк

Цитата
ОткрытьФорму(<?>,)
Синтаксис:
ОткрытьФорму(<ОписательОбъекта>,<КонтекстФормы>)
Назначение:
Открывает визуальную форму журнала документов.
Возвращает: 1 - если действие выполнено, 0 - иначе.
Параметры:
<ОписательОбъекта> - строковое выражение. ''Журнал.ХХХХХ.YYYYY'', где ХХХХХ - идентификатор журнала документов, YYYYY - идентификатор формы журнала документов. Кроме того, в качестве идентификатора журнала можно указывать идентификатор конкретного вида документа, тогда откроется журнал просмотра документов именно указанного вида;
<КонтекстФормы> - имя переменной, куда можно задать значение любого типа для передачи в открываемую форму. Данное значение будет доступно в открытой форме как атрибут Форма.Параметр. После исполнения данного метода система вернет в данную переменную контекст открытой формы (необязателен).
Замечание:
Пока форма открыта, тип значения параметра <КонтекстФормы> равен 100, когда закрыта - 0.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176253 · Ответов: 2 · Просмотров: 276
 

>  Динамический список и странное поведение
sava1
Отправлено: 31.08.22, 20:21


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


а еще есть ПриПолученииДанных.......
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176252 · Ответов: 11 · Просмотров: 782
 

>  Не везде считать итоги в СКД
sava1
Отправлено: 19.08.22, 15:50


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


В рнсурсах указать по каким групптроакам рассчитывать. Там есть и Общие итоги
  Форум: Система компоновки данных · Просмотр сообщения: #176199 · Ответов: 2 · Просмотров: 222
 

>  Цикл по табличной части и результат пенерести в другую таблицу
sava1
Отправлено: 15.08.22, 14:28


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(burza @ 15.08.22, 15:02) *
таблЗначений.Свернуть(,);


специально написал ЗАПЯТУЮ - в хелпе подробнее
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176170 · Ответов: 4 · Просмотров: 307
 

>  Цикл по табличной части и результат пенерести в другую таблицу
sava1
Отправлено: 15.08.22, 13:35


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


burza @ Сегодня, 14:22 * ,

таблЗначений = таблЧасть.Выгрузить(,);
таблЗначений.Свернуть(,);

табЧасть2.Загрузить(таблЗначений);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176168 · Ответов: 4 · Просмотров: 307
 

>  Язык отчета на СКД
sava1
Отправлено: 08.08.22, 13:17


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(AnryMc @ 05.08.22, 11:55) *
Ячейка = 1;

Пока Ячейка <> Неопределено Цикл

Ячейка = ДокументРезультат.НайтиТекст("Итого");

Если Ячейка <> Неопределено Тогда

Ячейка.Текст = "Разом";

КонецЕсли;

КонецЦикла;



Уж если по-правильному , тогда

    Пока Истина Цикл
        
        Ячейка = ДокументРезультат.НайтиТекст("Итого");
        
        Если Ячейка = Неопределено Тогда
             Прервать;
        КонецЕсли;
            
        Ячейка.Текст = "Разом";            

        
    КонецЦикла;


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176133 · Ответов: 9 · Просмотров: 450
 

>  Оновлення BAS for AGRO. Accounting
sava1
Отправлено: 05.08.22, 11:14


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


наберіть ИнАгро - вони висилають інструкцію.
простіше через обробку початкового заповнення
  Форум: Вся 1С · Просмотр сообщения: #176113 · Ответов: 4 · Просмотров: 911
 

>  Язык отчета на СКД
sava1
Отправлено: 05.08.22, 9:36


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Vofka @ Сегодня, 9:57 * ,
Vofka @ Сегодня, 9:57 * ,

в ТабДокументе ищем ячейку со значением "Итого" и меняем на свое - так конкретно?

установка параметров - ПриКомпоновке....

    Настройки = КомпоновщикНастроек.ПолучитьНастройки();    
    Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Параметр", Значение);    
    КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);


далее выводим отчет....
а здесь меняем Итого

     ТекОбласть = Результат.НайтиТекст("Итого", ТекОбласть, Результат.Область(), Истина, Истина, Истина, Ложь);      

      Если ТекОбласть <> Неопределено Тогда
               ТекОбласть.Текст = "Загалом";
     КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176109 · Ответов: 9 · Просмотров: 450
 

>  Язык отчета на СКД
sava1
Отправлено: 04.08.22, 13:01


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


AnryMc,

найти Итого и заменить на свое.
Если, что - пишите в ЛС
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #176107 · Ответов: 9 · Просмотров: 450
 

>  Совет по запросу в целях оптимизации
sava1
Отправлено: 02.08.22, 9:13


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


helluinn @ Вчера, 16:12 * ,
так логика работы/обхода данных такая. Как по другому?
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #176085 · Ответов: 7 · Просмотров: 434
 

>  Проблемы при перемещении ОС между организациями
sava1
Отправлено: 01.08.22, 14:45


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(quicky @ 01.08.22, 14:49) *
закрытие месяца как минимум,


с чего бы это? при смене статуса снимаете птису "начислять амортизацию"
  Форум: Бухгалтерия 8, редакция 1 для Украины · Просмотр сообщения: #176079 · Ответов: 6 · Просмотров: 265
 

>  Проблемы при перемещении ОС между организациями
sava1
Отправлено: 01.08.22, 9:29


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


quicky @ 27.07.22, 16:18 * ,

тут надо определиться - или крестик или трусы...
продайте ОС - все будет нормально.
если Вы сдаете его внаем - вообще ничегоделать не надо.

вооще можно добавить еще один статус - типа "Ушел по бабам" - и с ним заворачивать движения
  Форум: Бухгалтерия 8, редакция 1 для Украины · Просмотр сообщения: #176075 · Ответов: 6 · Просмотров: 265
 

>  Совет по запросу в целях оптимизации
sava1
Отправлено: 01.08.22, 9:16


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


есть в запросах такая конструкция ИТОГИ...ПО...
прописываете агрегатные функции для полей и поля группирования

получаете выборку и обходите результат запроса по группировкам

смотрите Выбрать(...) для результата запроса
  Форум: Программирование в 1С Предприятие 8.1 (8.0) · Просмотр сообщения: #176074 · Ответов: 7 · Просмотров: 434
 

>  Как можно запретить отмену проведения докумена, если документ сделал проводку на 281 счет?
sava1
Отправлено: 27.07.22, 14:05


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


andreydv87 @ Сегодня, 12:49 * ,

это 77 - какая подписка?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176060 · Ответов: 5 · Просмотров: 537
 

>  Как можно запретить отмену проведения докумена, если документ сделал проводку на 281 счет?
sava1
Отправлено: 26.07.22, 8:05


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


типа так

// глобальный модуль

Процедура ПриОтменеПроведенияДокумента(Док)

    Если Док.СуществуетОперация()=1 Тогда

        Опер = Док.Операция;
        Опер.ВыбратьПроводки();  // тут можно проверить наличие проводок
        Пока Опер.ПолучитьПроводку()=1 Цикл

                        Если Опер.СчетДт = !нужныйСчет!  Тогда
                               СтатусВозврата(0);
                               Предупреждение("Низзя распроводить документ");
                               Возврат;
                        КонецЕсли;  
    
        КонецЦикла;
    КонецЕсли;


КонецПроцедуры
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #176048 · Ответов: 5 · Просмотров: 537
 

>  Чтений проводок при отмене проведения документа
sava1
Отправлено: 26.07.22, 7:41


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(kostya77 @ 26.07.22, 7:52) *
запрет отмены проведения докумена,


статучВозврата(0)
возврат
  Форум: Корзина · Просмотр сообщения: #176046 · Ответов: 4 · Просмотров: 192
 

>  Тонкая настройка обмена данными
sava1
Отправлено: 25.07.22, 13:58


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2581
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


так. желательно и метаданные загрузить
  Форум: Конфигурация "1С:Конвертация данных" · Просмотр сообщения: #176039 · Ответов: 11 · Просмотров: 530
 

102 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 27.09.22, 1:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!