Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



12 страниц V   1 2 3 > » 

>  Ошибка при вызове метода контекста (Заблокировать)
volodya1122
Отправлено: 18.11.20, 14:38


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


gololol @ Сегодня, 11:23 * ,

такого не должно быть. тут скорее всего что-то "держит" этот документ.
Что проверить:
1. Маловероятно но все же в ПриОткрытии() или в ПередОткрытием() не меняются никакие реквизиты документа?
2. Ваше регламентное задание выполняется не единожды, а крутится по кругу. И поэтому постоянно блокирует документ.
3. В регламентном задании в конце очистить объект документа где вы его меняете ((тот что ПолучитьОбъект()).
4. Возможно где-то в другом месте этот документ блкируете и держите постоянно его в каком то реквизите.

Цитата(gololol @ 18.11.20, 11:23) *
Проблема в том, что блокируется запись у которой

ВерсияДанных = "AAAAAABc4OoM"

а на самом деле

ВерсияДанных = "AAAAAABc4OoP"

т.е. программа пытается заблокировать запись с несуществующей ВерсиейДанных


Тут неверно понимаете поведение платформы 1С. 1С пытается заблокировать не реквизиты в вашем документе а сам документ (и неважно что внутри документа поменялись данные)
Поясню на примере. Например у Вас есть обычная паперовая папка с документами. Лежит у Вас на столе. Вы на ней написали (внутри лежит 10 документов. Другой человек взял эту папку и открыл (заблокировал, в терминологии 1С). Положил туда еще какие-то дукументы, закрыл и положил на место (папка опять доступна). Хотя содержимое внутри уже не соответствует описанию , вы всеравно можете взять эту папку и открыть (заблокировать уже от себя) и при открытии папки можете видеть новое содержимое..
А теперь представте. Другой человек взял эту папку, открыл (ПолучитьОбъект() - в терминологии 1С) положил в нее свои документы (или ничего не положил) и держит в руках. В таком случае Вы не можете взять и заблокировать свою папку. Это вам и сообщает 1С
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168375 · Ответов: 2 · Просмотров: 96
 

>  Как можно получить значение реквизита?
volodya1122
Отправлено: 06.11.20, 9:03


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(Evgeniux @ 06.11.20, 8:48) *
а работает в таком виде

Если ВРег (Выборка.ЦельСборки) = ВРег("некое значение") Тогда


Значит несовпадение Типов. Например одно - это строка, а второе это Справочник, или Перечисление
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167992 · Ответов: 7 · Просмотров: 233
 

>  Как можно получить значение реквизита?
volodya1122
Отправлено: 05.11.20, 10:31


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


denis84 @ Вчера, 16:58 * ,

Поправка
Если Выборка.ЦельСборки = "некое значение" тогда
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #167964 · Ответов: 7 · Просмотров: 233
 

>  Как запустить выполнение процедуры в отчете из документа РасходнаяНакладная? в 1С 7.70.003 торговля склад для Украины?
volodya1122
Отправлено: 28.10.20, 13:54


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Вчера, 0:30 * ,

У Вас что-то очень много нестандартных хотелок. Может лучше сделать как в стандартных отчетах реализовано (например Отчет По Партиях товара, или Отчет Продажи). Вверху в сформированном отчете есть кнопки "Оновить" Настроить". Суть тут такая: Сформировали отчет. Потом в каком-то документе поменяли данные, записали документ. Потом просто нажать "Оновить" и отчет перерисуется (с теми же параметрами которые пользователь выбрал для отчета). (сформированный отчет должен быть в Режиме ТолькоПросмотр(1)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #167753 · Ответов: 6 · Просмотров: 613
 

>  Добавление колонки Цена в Справочник/Номенклатура
volodya1122
Отправлено: 05.10.20, 10:07


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(sava1 @ 05.10.20, 9:11) *
не стОит. - тормоза будут

У меня очень древняя небольшая база ТИС, примерно 10000 елементов в спавочнике Номенклатуры. Подобным методом также показываю остатки. Тормоза не наблюдаются, (даже когда отключена Иерархия)
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #167046 · Ответов: 15 · Просмотров: 336
 

>  Намагаюсь отримати деяку інформацію для проекту
volodya1122
Отправлено: 02.10.20, 15:21


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


DuneH @ Сегодня, 13:59 * ,

не думаю що такий є у вільному доступі.
існує у вільному доступі довідник КОАТУУ - довідник всіх населених пунктів України з кодами (а це більше 40000 населених пунктів)
  Форум: Офф-топик · Просмотр сообщения: #166965 · Ответов: 4 · Просмотров: 148
 

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
volodya1122
Отправлено: 18.09.20, 15:12


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


svetas_l @ Сегодня, 15:09 * ,

а точно файл такой есть?
Проверте
    ВыбФайл = Новый Файл(Этаформа.ПутьЧтения+".json");
    Если НЕ ВыбФайл.Существует() Тогда
        Сообщить("Файл не существует!");
    КонецЕсли;


Ну или в файле есть какие-то недопустиміе символі
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166554 · Ответов: 10 · Просмотров: 232
 

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
volodya1122
Отправлено: 18.09.20, 9:42


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Думаю проблема в этом
Цитата
Чтение.УстановитьСтроку("{}");


Цитата
УстановитьСтроку (SetString)
Синтаксис:

УстановитьСтроку(<СтрокаJSON>)
Параметры:

<СтрокаJSON> (обязательный)

Тип: Строка.
Строка, содержащая текст в формате JSON.


а у Вас в качестве строки пустой массив. А туда нужно засунуть весть текст из Вашего файла
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166546 · Ответов: 10 · Просмотров: 232
 

>  как ПрочитатьJSON(Чтение) массив объектов (выборку запроса)
volodya1122
Отправлено: 18.09.20, 8:59


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


svetas_l @ Сегодня, 9:36 * ,

Может это поможет. Там я какраз делал чтение данных JSON
https://pro1c.org.ua/topic/post-zapros-do-s...atkovojy-61187/
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #166542 · Ответов: 10 · Просмотров: 232
 

>  Обработка позволяющая сохранить и загрузить сеанс работы
volodya1122
Отправлено: 14.09.20, 9:37


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


kiveda @ 12.09.20, 0:23 * ,

Ну с интервалами и отборами в журналах. просто. Можно это писать просто в отдельный справочник и при открытии журнала оттуда брати эти значения.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #166408 · Ответов: 4 · Просмотров: 233
 

>  Обработка позволяющая сохранить и загрузить сеанс работы
volodya1122
Отправлено: 11.09.20, 15:04


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


kiveda @ Сегодня, 12:44 * ,

Не думаю что такая существует, ибо практического смысла в этом нет. Представте, в процессе работы пользователь окрыл много журналов, , документов, отчетов, из них еще кучу печатных форм. В итоге на панеле окон у него 100 объектов окрыто. В итоге чтобы очистить этот мусор и не закрывать черех крестик все 100 закладок просто вышел из 1С.
По вашей хотелке пользователь выйдет. А когда захочет войти ему автоматом откроется эти все 100 закладок. И еще 1С при этом будет долго загружаться (пока отработают все эти формы).
незнаю возможно ли вообще реализовать вашу хотелку. Но можно посмотреть в сторону Formex . Может там есть за что зацепиться.

Если все же хочется такое, то можно пойти иным путем. Например при старте всегда открывать нужный список окон (для всех пользователей один список окон). Или Прописать каждому пользователю список окон которые он желает видеть при старте 1С
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #166355 · Ответов: 4 · Просмотров: 233
 

>  POST запрос до серверу податкової
volodya1122
Отправлено: 28.08.20, 17:36


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


нарешті добився результату.
1. Дійсно токен потрібно формувати в приватній частині електронного кабінету
https://cabinet.tax.gov.ua/news/A6CA47C3AB0...0530A5028078B00
2. Готовий код (поки корявий, але робочий), може кому пригодиться
    Соединение = Новый HTTPСоединение("cabinet.tax.gov.ua",443,,,,15,Новый ЗащищенноеСоединениеOpenSSL(), Ложь);
    Заголовки = Новый Соответствие;

       ЄДРПОУ="12345678";  // для тесту
       МойТокен="1111111111111111111111111111111";  // потрібно згенерувати в електроннім кабінеті податкової

    Заголовки.Вставить("Content-Type", "application/json");
    Кавычка=Прав("""",2);                        
    КодПриглашения = "{" +Кавычка+
    "tinList"+Кавычка+":" +Кавычка+ ЄДРПОУ+Кавычка+"," +
    Кавычка+"token"+Кавычка+":"+Кавычка +МойТокен+Кавычка+"}";
    
    //    {"kodPdvList":null,"tinList":"34554355 34554357",
    //    "name":null,"token":"03AOLTBLRIFo9xivFXYOrFqaLL6g0HKv"}
    Запрос = Новый HTTPЗапрос("/ws/api/public/registers/pdv_act/list",Заголовки);
    Запрос.УстановитьТелоИзСтроки(КодПриглашения);
    
    Ответ = Соединение.ОтправитьДляОбработки(Запрос);
    
    ЧтениеJSON = Новый ЧтениеJSON;
    ЧтениеJSON.УстановитьСтроку(Ответ.ПолучитьТелоКакСтроку());
    Данные = ПрочитатьJSON(ЧтениеJSON, Ложь);
    Для Каждого ЕлМассива ИЗ Данные цикл
        Для каждого Структур ИЗ ЕлМассива цикл
            Ключ = Структур.Ключ;
            Знч = Структур.Значение;
            Сообщить("Ключ= "+Ключ+"   Знач "+Знч);
        КонецЦикла;
    КонецЦикла;


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165999 · Ответов: 6 · Просмотров: 369
 

>  POST запрос до серверу податкової
volodya1122
Отправлено: 28.08.20, 13:32


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Крім того я думаю до такого популярного ресурсу, як сервер податкової, багато хто вже робив запити. Тому щоб не придумувати в черговий раз велосипед, думаю може хтось поділиться готовим рішенням
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165993 · Ответов: 6 · Просмотров: 369
 

>  POST запрос до серверу податкової
volodya1122
Отправлено: 28.08.20, 12:12


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


nik389 @ Сегодня, 12:10 * ,

Звичайно, перед тим як задавати питання я по різних форумах вивчав це питання
Щось получилось але всеодно нерозумію чому не працює так як потрібно
Ось що написав
    Соединение = Новый HTTPСоединение("cabinet.tax.gov.ua",443,,,,15,Новый ЗащищенноеСоединениеOpenSSL(), Ложь);
//Соединение = Новый HTTPСоединение("https://cabinet.tax.gov.ua",443,,,,15,Новый ЗащищенноеСоединениеOpenSSL(), Ложь);
// ось тут була проблема, нерозумів чому небачить цього хоста
    Заголовки = Новый Соответствие;
    Заголовки.Вставить("Content-Type", "application/json");
    Заголовки.Вставить("kodPdvList", "12345678");                            
    
    Заголовки.Вставить("token", "03AOLTBLRIFo9xivFXYOrFqaLL6g0HKv");
        
    Запрос = Новый HTTPЗапрос("/ws/api/public/registers/pdv_act/list",Заголовки);    

    // Ответ = Соединение.ОтправитьДляОбработки(Запрос);
    Ответ = Соединение.Получить(Запрос);
    Сообщить(Ответ);
    Сообщить(ТипЗнч(Ответ));
    Данные = Ответ.ПолучитьТелоКакСтроку();

    Сообщить(Данные);

але всеодно сайт вертає ось це по останньому Сообщить.
{"error":"Помилка","error_description":"Помилка обробки запиту"}
нерозумію чому....
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165991 · Ответов: 6 · Просмотров: 369
 

>  POST запрос до серверу податкової
volodya1122
Отправлено: 27.08.20, 15:32


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


https://cabinet.tax.gov.ua/help/api-registers.html Тут описано методи API для доступу до реєстрів відкритої частини ЕК.
З API ніколи не працював. Можливо хтось підкаже як реалізувати ці запити на 1С ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165963 · Ответов: 6 · Просмотров: 369
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 19.08.20, 10:39


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Ще добавлю, можливо не зрозуміли.
РеквизитДокумента, РеквизитФормы на формі не потрібно розміщувати взагалі. вини існують тільки в межах даної процедури
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165760 · Ответов: 14 · Просмотров: 800
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 19.08.20, 8:49


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Сегодня, 1:49 * ,
Зрозуміліше не стало від цього пояснення. Пропробую здогадатися.
І так і вас на формі обробки (чи де саме використовуєте даний код) є реквізити Имя_, Телефон, АдресаОбласть, АдресаНаселенийПункт, АдресаВулиця.
В залежності від нажатої кнопки потрібно зробити три різних пошуки.
1. по реквізиту форми Имя_
2. по реквізиту форми Телефон
3. одночасно по співпадінню зразу трьох реквізитів АдресаОбласть, АдресаНаселенийПункт, АдресаВулиця
Тоді потрібно ось так прописати

Если НомерВызова=1 тогда
РеквизитДокумента=Расх.Имя;
РеквизитФормы=Имя_;
ИначеЕсли НомерВызова=2 тогда
РеквизитДокумента=Расх.Телефон;
РеквизитФормы=Телефон_;
ИначеЕсли НомерВызова=3 тогда
РеквизитДокумента=Расх.АдресОбл+Расх.НасПункт+Расх.АдресВул;
РеквизитФормы=АдресаОбласть+АдресаНаселенийПункт+АдресаВулиця;
КонецЕсли;

Если ((Найти(РеквизитДокумента,РеквизитФормы)>0)и(Расх.ПометкаУдаления()=0)) Тогда  // замінити замість Вашої умови
// РеквизитДокумента, РеквизитФормы придумані довільні
// відповідно у Вашому докумеенті РасходнаяНакладная повинні бути ці реквізити (або вони називаються по іншому) Телефон, Имя, АдресОбл, НасПункт , АдресВул
// або можливо це реквізити контрагента який є на формі документа. Поді відповідно буде Расх.Контрагент.АдресОбл , ..........
// можливо для рексвізитів в даному коді потрібно буде застосувати СокрЛП

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165757 · Ответов: 14 · Просмотров: 800
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 18.08.20, 9:28


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(ZUBR @ 16.08.20, 18:28) *
Или, хотя бы, как сделать так, чтобы таблица значений и другие созданные объекты в одной процедуре, были видны в других процедурах?

Це робиться досить просто.
в самому верху модуля (до всіх процедур) робиться обявлення всіх реквізитів які повинні бути доступні у всіх процедурах і функціях даного модуля:
Перем: ТЗ, МояПерем1, МояПерем2;
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165733 · Ответов: 14 · Просмотров: 800
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 18.08.20, 8:21


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


ZUBR @ Сегодня, 1:30 * ,
Що значить не працює? Реквізит можете назвати хоч АбраКадабраАхалайМахалай.... це немає ніякого значення. Якщо на формі є такий реквізит то і в умові так само писати.
Я в прикладі нааписав змінну "РеквізитФорми" щоб в одній основній умові де йде перевірка, можна було використати різні реквізити форми (відповідно до нажатої кнопки).

Хоча я не зовсім зрозумів запитання що саме мається на увазі
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165731 · Ответов: 14 · Просмотров: 800
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
volodya1122
Отправлено: 17.08.20, 8:59


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Я так зрозумів, що ця процедура визивається різними кнопками. Тому щоби знати якою кнопкою визвана процедура на кожній кнопці визиваємо приблизно так:
ПоискПТФ(1) -на першій кнопці
ПоискПТФ(2) - на другій кнопці
......


В самому модулі навзву процедури пишемо так;
ПоискПТФ(НомерВызова)

І в тексті процедури, перед Вашою умовою пишем
Если НомерВызова=1 тогда
РеквизитСправочника=Расх.Имя;
РеквизитФормы=Имя_;
ИначеЕсли НомерВызова=2 тогда
РеквизитСправочника=Расх.Телефон;
РеквизитФормы=Телефон_;
Иначе..............
..........
КонецЕсли;

Если ((Найти(РеквизитСправочника,РеквизитФорми)>0)и(Расх.ПометкаУдаления()=0)) Тогда  // замінити замість Вашої умови
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165702 · Ответов: 14 · Просмотров: 800
 

>  Номенклатура и её родители
volodya1122
Отправлено: 05.08.20, 11:06


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Цитата(Bon Jovi @ 04.08.20, 16:59) *
Согласен. Уровень заранее известен, но нужно сделать универсально и не программно, а сразу запросом


Так это все и будет запросом (програмно)
Вот как-то так можно сформировать запрос (добавить до того что предложил Vofka

ВсегоУровней=99999;
Если Метаданные.Справочники.МойСправочник.ОграничиватьКоличествоУровней  тогда
ВсегоУровней= Метаданные.Справочники.МойСправочник.КоличествоУровней;
КонецЕсли;
// запрос
|ГДЕ
|   Номенклатура.Родитель.МойПризнак = 1";

ДобавкаЗапроса="|   ИЛИ Номенклатура.";
Суфикс="";
Если ВсегоУровней>1 тогда
    Для уровней=2 по ВсегоУровней цикл
        Суфикс=Суфикс+"Родитель.";
        Запрос.Текст = Запрос.Текст + Символы.ПС+"
        ДобавкаЗапроса+Суфикс+"МойПризнак = 1 ";
    КонецЦикла;
КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #165341 · Ответов: 5 · Просмотров: 373
 

>  Объеденение приходных накаладных
volodya1122
Отправлено: 28.07.20, 11:56


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


А зачем вообще бегать к компютеру, рассортировывать товары по накладным?. Распечатать эти 2 или сколько там накладных на бумаге. И потом считать (реальный приехавший товар) сколько "тарелок одного вида приехало". И отмечать в каждой накладной на бумаге (если один вид тарелок разбито по нескольким накладным). И не нужно никуда бегать.
  Форум: Платформа 8 · Просмотр сообщения: #165116 · Ответов: 4 · Просмотров: 303
 

>  Как определить в двух строковых типах большее число
volodya1122
Отправлено: 30.06.20, 9:07


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


Наприклад так можна

Функция СравнитьЧисла(МояСтрока1,МояСтрока2)
МассивЧисел1=СтрРазделить(МояСтрока1,".");
МассивЧисел2=СтрРазделить(МояСтрока2,".");
Для Индекс = 0 По МассивЧисел1.Количество() - 1 Цикл
    Если число(МассивЧисел1[Индекс])> число(МассивЧисел2[Индекс]) тогда
        Возврат "Перше число більше";
        //Прервать;
    ИначеЕсли число(МассивЧисел1[Индекс])< число(МассивЧисел2[Индекс]) тогда
        Возврат "Друге число більше";
        //Прервать;
    КонецЕсли;    
КонецЦикла;
Возврат "Числа однакові";
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #164302 · Ответов: 3 · Просмотров: 243
 

>  При работе с фаловой базой данных подтормаживает 1С 7.7
volodya1122
Отправлено: 19.06.20, 13:16


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


F.U.T.U. @ Сегодня, 14:03 *

Можно попробоапть грохнуть 1cv7.mlg или обрезать
Также грохуть файли пользователей (файлы пользователей и должны занимать несколько килобайт)
Это немного ускорит работу (может на несколько процентов).
Но оптимизировать тут больше нечего. Так что только Скуль

В папке SYSLOG только один файл журнала или есть ешще какие?
  Форум: Платформа 7.7 · Просмотр сообщения: #164020 · Ответов: 10 · Просмотров: 468
 

>  При работе с фаловой базой данных подтормаживает 1С 7.7
volodya1122
Отправлено: 19.06.20, 11:43


Оратор
Иконка группы

Группа: Местный
Сообщений: 299
Регистрация: 10.05.11
Из: Тернопіль
Пользователь №: 9111


F.U.T.U. @ Сегодня, 11:37 * ,

1. какие характеристики сервера на котором стоит 1С? и какая Ось?
2. Какой размер базы? Какой размер самого большого dbf ффайла?
3. Размер файла 1cv7.mlg в папке SYSLOG
4. Размер файлов в каталогах пользователя?
  Форум: Платформа 7.7 · Просмотр сообщения: #164014 · Ответов: 10 · Просмотров: 468
 

12 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 24.11.20, 5:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!