Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

84 страниц V   1 2 3 > » 

>  Как вывести значение булево(да или нет) в колонку Формы списка документа
sava1
Отправлено: 13.09.19, 16:33


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(jojojoba2 @ 13.09.19, 17:04) *
ОформлениеСтроки.Ячейки.Флаг = Истина;


стр.Ячейки.Флаг = Истина;

Цитата(jojojoba2 @ 13.09.19, 17:04) *
Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока);


Запрос.УстановитьПараметр("ЗначениеКритерияОтбора",масЗаказы);

соответственно выбирать в запросе с условием в (&ЗначениеКритерияОтбора)

а что получите - посмотрите в консоли запросов
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155610 · Ответов: 1 · Просмотров: 59
 

>  Настроить вывод в заголовки отчетов время и дата формирования отчета, как было в 1с77
sava1
Отправлено: 13.09.19, 11:32


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Там по-идее должно проходить в Выражении ТекущаяДата()
Попробуйте в Выражении прописать ДобавитьКДате(ТекущаяДата(),"СЕКУНДА",1)
  Форум: Система компоновки данных · Просмотр сообщения: #155599 · Ответов: 11 · Просмотров: 115
 

>  Вывести флажок в поле формы списка
sava1
Отправлено: 13.09.19, 11:29


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


в Список добавляем колонку "ЕстьДокументы" - тип Флаг, не выводить текст.....
вот вывод в списке состояния заказа

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    ЗаполнитьСостояниеЗаказа(ОформленияСтрок);
КонецПроцедуры

Процедура ЗаполнитьСостояниеЗаказа(ОформленияСтрок)    
    МасЗаказы = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        ДанныеСтроки = Стр.ДанныеСтроки;
        МасЗаказы.Добавить(ДанныеСтроки.Ссылка);
    КонецЦикла;
    //
    запрос = Новый Запрос;
    запрос.Текст = "
    |ВЫБРАТЬ
    |    рр.Заказ,
    |    IsNull(рр.Состояние,4) Состояние
    |ИЗ РегистрСведений.А_СостояниеЗаказа КАК рр
    |ГДЕ рр.Заказ В (&СпЗаказы)
    |";
    запрос.УстановитьПараметр("СпЗаказы", МасЗаказы);    
    Выборка = Запрос.Выполнить().Выбрать();
    //
    //тКартинка =;
    Для Каждого Стр Из ОформленияСтрок Цикл
        тд = Стр.ДанныеСтроки;        
        Выборка.Сбросить();
        Если Выборка.НайтиСледующий(тд.Ссылка, "Заказ") Тогда

   ВОТ ЗДЕСЬ УСТАНАВЛИВАЕМ ФЛАЖОК

        //    **ИндексКарт = Выборка.Состояние;
        //Иначе
        //    ИндексКарт = 4;
        КонецЕсли;

    КонецЦикла;
    
КонецПроцедуры


Вам вместо запроса к регистру надо делать запрос к КритериюОтбора СвязанныеДокументы
определять есть-ли документы и устанавливать флажок
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155598 · Ответов: 6 · Просмотров: 78
 

>  Вывести флажок в поле формы списка
sava1
Отправлено: 13.09.19, 10:12


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


УФ / оФ ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155593 · Ответов: 6 · Просмотров: 78
 

>  Настроить вывод в заголовки отчетов время и дата формирования отчета, как было в 1с77
sava1
Отправлено: 13.09.19, 7:22


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


ПриКомпоновке

Компоновщик.....Параметры.Установить()

варианты
тыц
  Форум: Система компоновки данных · Просмотр сообщения: #155589 · Ответов: 11 · Просмотров: 115
 

>  Настроить вывод в заголовки отчетов время и дата формирования отчета, как было в 1с77
sava1
Отправлено: 12.09.19, 14:49


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(andreykyiv@bigmir.net @ 12.09.19, 13:18) *
В разделе Параметры создаю новый параметр "Дата вывода отчета", тип параметра "Дата"

а дальше в Выражение пишем ТекущаяДата()
  Форум: Система компоновки данных · Просмотр сообщения: #155568 · Ответов: 11 · Просмотров: 115
 

>  Импорт из Аваль Банка
sava1
Отправлено: 06.09.19, 15:05


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(bezzil @ 06.09.19, 15:24) *
Это ничего не даст, так как старая выгрузка имела точно такой же формат.

это я о своем....

ВыбСчет.Номер - строка ? длина больше 29 ?

Тогда условие
Если Сред(стр,12,29) <> ВыбСчет.Номер


+ учесть смещение остальных значений (как минимум на 15 вправо)

+ добавить обработку счетов по старому формату
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155400 · Ответов: 16 · Просмотров: 299
 

>  Импорт из Аваль Банка
sava1
Отправлено: 06.09.19, 14:01


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


вот стандартная функция

Функция ЗаменитьСимволы(Стр)
    СтрВозврата = Стр;
    СтрВозврата = СтрЗаменить(СтрВозврата, "Ї", "Є");
    СтрВозврата = СтрЗаменить(СтрВозврата, "ї", "є");
    СтрВозврата = СтрЗаменить(СтрВозврата, "Ў", "І");
    СтрВозврата = СтрЗаменить(СтрВозврата, "ў", "і");
    СтрВозврата = СтрЗаменить(СтрВозврата, "•", "ї");
    СтрВозврата = СтрЗаменить(СтрВозврата, "°", "Ї");
    Возврат СтрВозврата;
КонецФункции
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155397 · Ответов: 16 · Просмотров: 299
 

>  Импорт из Аваль Банка
sava1
Отправлено: 06.09.19, 13:56


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


там проблема в кодовых страницах - у 77 - 866, а банк выдает 1251.
перекодировать надо.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #155395 · Ответов: 16 · Просмотров: 299
 

>  Перенос данных о зарплате из ЗУП в Бухгалтерию 2,0
sava1
Отправлено: 05.09.19, 11:06


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


зарплата и кадры- обмен данными с ЗУП
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #155352 · Ответов: 5 · Просмотров: 113
 

>  Перенос данных о зарплате из ЗУП в Бухгалтерию 2,0
sava1
Отправлено: 05.09.19, 9:59


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


в Главное - Зарплата поставить Учет ведется в сторонней программе. тогда появится кнопочка загрузки
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #155350 · Ответов: 5 · Просмотров: 113
 

>  Улыбнуло
sava1
Отправлено: 03.09.19, 10:19


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Google запретила популярные приложения для Android

сцылко

Потрясла фраза
Поскольку наркотические препараты становятся все более востребованными среди владельцев смартфонов на базе Android, компания Google приняла решение о том, что такие нужно запретить.
  Форум: Юмор · Просмотр сообщения: #155286 · Ответов: 839 · Просмотров: 181827
 

>  IBAN в 1С:Підприємство
sava1
Отправлено: 02.09.19, 14:56


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(Petre @ 02.09.19, 15:55) *
иллюстрация смены банковского счета на примере конфигурации «Бухгалтерія для України» редакции 2.0.


так эт только для примера
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #155238 · Ответов: 13 · Просмотров: 363
 

>  IBAN в 1С:Підприємство
sava1
Отправлено: 02.09.19, 14:53


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(RedCat77 @ 02.09.19, 15:48) *
Очень смешно haha.gif
1С 7.7 или 8 (1.2 или 2.0 или 2.1)?


А если во всех сразу !? смешного мало...
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #155236 · Ответов: 13 · Просмотров: 363
 

>  Проблемы после массового перепроведения документов
sava1
Отправлено: 02.09.19, 9:28


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Звать шамана с бубном
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155224 · Ответов: 2 · Просмотров: 100
 

>  отображение файла формата BOL на сервере и локальной машине по разному
sava1
Отправлено: 30.08.19, 14:35


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


в блокноте поменяйте (вроде Курьер) - запомнится.
  Форум: Администрирование и настройка компьютера, железо · Просмотр сообщения: #155170 · Ответов: 6 · Просмотров: 146
 

>  отображение файла формата BOL на сервере и локальной машине по разному
sava1
Отправлено: 30.08.19, 13:58


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(awp @ 30.08.19, 14:22) *
о есть ttf файл шрифта используемый системой по умолчанию различается?


в одном месте моноширинный, в другом - нет
  Форум: Администрирование и настройка компьютера, железо · Просмотр сообщения: #155168 · Ответов: 6 · Просмотров: 146
 

>  Вывод структуры подчиненности в заказах покупателя
sava1
Отправлено: 30.08.19, 11:08


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


деревоЗначений
ПриАктивизации запускать ОбработчикОжидания на 0.1 - 0.3 с (чтобы не срабатывало на простое движение) а вобработкеОжидания - формировать Структуру
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155160 · Ответов: 3 · Просмотров: 131
 

>  отображение файла формата BOL на сервере и локальной машине по разному
sava1
Отправлено: 30.08.19, 8:32


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


шрифт
  Форум: Администрирование и настройка компьютера, железо · Просмотр сообщения: #155154 · Ответов: 6 · Просмотров: 146
 

>  Заповнення в УТП регламентної 1ДФ в розрізі місцезнаходження працівників
sava1
Отправлено: 29.08.19, 13:27


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


вряд-ли. Я дописывал отбор по группам
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #155125 · Ответов: 3 · Просмотров: 123
 

>  Заповнення в УТП регламентної 1ДФ в розрізі місцезнаходження працівників
sava1
Отправлено: 29.08.19, 9:34


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


возьмите в спр Сотрудники Группы по нахождению и заполняйте с отбором по группам
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #155118 · Ответов: 3 · Просмотров: 123
 

>  Форма списка документа: отделить ряд документов по определенному признаку, разместить вверху
sava1
Отправлено: 27.08.19, 13:43


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(Constantus @ 27.08.19, 14:17) *
На какое событие ставить?

ПриОткрытии - открываем нужнуюФорму - ЭтаФорма.Закрыть();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155065 · Ответов: 10 · Просмотров: 186
 

>  Перемещения товара не
sava1
Отправлено: 27.08.19, 12:35


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Это Вы жалуетесь ? рассказываете как не надо делать ? хвастаетесь ?
и при чем здесь тема Программирование ?
  Форум: Корзина · Просмотр сообщения: #155061 · Ответов: 2 · Просмотров: 40
 

>  Форма списка документа: отделить ряд документов по определенному признаку, разместить вверху
sava1
Отправлено: 27.08.19, 12:08


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


Цитата(Vofka @ 27.08.19, 12:57) *
При открытии формы не указывается открыть её на редактирование или на просмотр

не надо...
ТолькоПросмотр - это параметр формы и его можно указать при открытии формы

написано же -

Цитата(pablo @ 27.08.19, 11:39) *
2. Можно при открытии формы по умолчанию проверять это признак, закрывать форму по умолчанию и открывать нужную форму. В таком случае можно не заморачиваться с кнопками в ДС.



как вариант - использовать ПриПолученииФормы
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #155059 · Ответов: 10 · Просмотров: 186
 

>  Программное копирование строки ТЧ (разбивка по кол-ву)
sava1
Отправлено: 22.08.19, 14:22


Живет на форуме
Иконка группы

Группа: Местный
Сообщений: 2115
Регистрация: 04.02.09
Из: Проскуров
Пользователь №: 8


тз = Товары.Выгрузить();
тв = Товары.ВыгрузитьКолонки();

Для каждого строка из тз Цикл
   Для сч=1 по строка.Количество Цикл
       новаястр = тв.Добавить();
       ЗаполнитьЗначенияСвойств(нс, строка);
       новаястр.Количество=1;
   КонецЦикла;
КонецЦикла;

Товарі.Загрузить(тв);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154931 · Ответов: 5 · Просмотров: 174
 

84 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 15.09.19, 10:05
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!