Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Гладильная доска          
Batchir Подменю пользователя
сообщение 17.09.09, 17:08
Сообщение #1

Живет на форуме
Иконка группы
Группа: Команда
Сообщений: 3483
Из: Одесса
Спасибо сказали: 1339 раз
Рейтинг: 986.3

Вобщем сижу я дома, срочная удаленная работа, голова кипит, весь в экране монитора.
Заходит в комнату жена и говорит "Руслан, достань гладильную доску".Я всегда её достаю, она лежит в неудобном месте, ну и автоматом не обращая внимания раскладывю(всё равно в руках держу, почему бы и нет). Жена заходит,  смотрит и спрашивает "Почему не разложил". И тут я задумался - вот они результаты работы программиста - ЭРОРР!!! УТОЧНИТЕ ВХОДЯЩИЕ ПАРАМЕТРЫ.



Процедура ОбработатьСловаЖеныПоПоводуГладильнойДоски()
    СтруктураВходящихПараметров = новый Структура;
    ЖенаСказалаДостатьДоску = Истина; // параметр меняется взависимости от слов жены
    ЖенаСказалаРазложитьДоску = Ложь; // параметр меняется взависимости от слов жены
    Если ЖенаСказалаДостатьДоску Тогда
        СтруктураВходящихПараметров.Вставить("ДостатьДоску",Истина);
    Иначе
        СтруктураВходящихПараметров.Вставить("ДостатьДоску",Ложь);  
    КонецЕсли;  

    Если ЖенаСказалаРазложитьДоску Тогда
        СтруктураВходящихПараметров.Вставить("РазложитьДоску",Истина);
    Иначе
        СтруктураВходящихПараметров.Вставить("РазложитьДоску",Ложь);  
    КонецЕсли; 

    Если ВыполнитьДействия(СтруктураВходящихПараметров) Тогда
        Предупреждение("Всё сделано, жена довольна.");
    Иначе
        Предупреждение("ЭРОРР!!! УТОЧНИТЕ ВХОДЯЩИЕ ПАРАМЕТРЫ.");
    КонецЕсли;

КонецПроцедуры

Функция ВыполнитьДействия(СтруктураВходящихПараметров)
    ПерегрузкаМоска = Ложь; // параметр меняется от загруженности работой или какими-то другими вещами
    ДостатьДоску = СтруктураВходящихПараметров.ДостатьДоску;
    РазложитьДоску = СтруктураВходящихПараметров.РазложитьДоску;

    Если Не ПерегрузкаМоска тогда
        Если ДостатьДоску и не РазложитьДоску Тогда
            РазложитьДоску = Истина;
        КонецЕсли;
        Если РазложитьДоску И не ДостатьДоску Тогда
            ДостатьДоску = Истина;
        КонецЕсли;
    КонецЕсли;

    Если ДостатьДоску И РазложитьДоску Тогда
        Возврат Истина;
    Иначе
        Возврат Ложь;
    КонецЕсли;

КонецФункции

Vofka Подменю пользователя
сообщение 17.09.09, 19:20
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13147
Из: Киев
Спасибо сказали: 3991 раз
Рейтинг: 3123.4

wacko.gif

Ardi Подменю пользователя
сообщение 17.09.09, 19:46
Сообщение #3

Живет на форуме
***********
Гений телепатии и социального моделирования
Группа: Пользователи
Сообщений: 4121
Из: Киев
Спасибо сказали: 955 раз
Рейтинг: 0

Некто Дима однажды шел с работы (Институт проблем вычислительной техники) и думал об оптимизации вообще и об оптимизации своего модуля в частности. Зашел он по пути в некое заведение с гардеробом и бабушкой-гардеробщицей. Встал в очередь. Перед ним стоял парень с номерком - получать пальто. Тут Дима подумал: «Если бабушка работает по оптимизированной схеме, то она возьмет номерок у парня, даст его мне, возьмет мое пальто, отнесет на место пальто парня, принесет парню его пальто». Успешно решив таким способом задачу оптимизации, Дима успокоился и стал ждать действий бабушки. Она же нашла более оптимальное решение - взяла у парня номерок, дала Диме, взяла у Димы пальто и отдала парню.


Signature
Услуги 1С программиста 8.2, 7.7 (Плохо, дорого, очередь). Киев.

Batchir Подменю пользователя
сообщение 17.09.09, 20:21
Сообщение #4

Живет на форуме
Иконка группы
Группа: Команда
Сообщений: 3483
Из: Одесса
Спасибо сказали: 1339 раз
Рейтинг: 986.3

Цитата(Vofka @ 17.09.09, 20:20) *
wacko.gif


Да это я к тому что то что сказала то и сделал и не грамма больше smile.gif  - строго по алгоритму

MATEVI Подменю пользователя
сообщение 17.09.09, 22:37
Сообщение #5

Отдыхающий
Иконка группы
Ветеран троянской войныМодератору Про1С (за заслуги в 2011 году)
Группа: Местный
Сообщений: 2174
Из: Одесса
Спасибо сказали: 912 раз
Рейтинг: 728.2

Цитата(Batchir @ 17.09.09, 22:21) *
Да это я к тому что то что сказала то и сделал и не грамма больше smile.gif  - строго по алгоритму

Буквально в субботу прикалывался...
Для Шпателя=1 По КоличествоОткосов Цикл
У кого что болит smile.gif
...
А с меня Жена прикалывается все время. От же ш программист все на 3 шага вперед просчитывает а если иначе... smile.gif

Vofka Подменю пользователя
сообщение 18.09.09, 8:31
Сообщение #6

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13147
Из: Киев
Спасибо сказали: 3991 раз
Рейтинг: 3123.4

Всё в нашей жизни по алгоритму идет

Batchir Подменю пользователя
сообщение 18.09.09, 8:57
Сообщение #7

Живет на форуме
Иконка группы
Группа: Команда
Сообщений: 3483
Из: Одесса
Спасибо сказали: 1339 раз
Рейтинг: 986.3

Цитата(Vofka @ 18.09.09, 9:31) *
Всё в нашей жизни по алгоритму идет

И как сказал Ardi, нет предела оптимизации этого алгоритма.

danie Подменю пользователя
сообщение 18.09.09, 13:21
Сообщение #8

Завсегдатай
****
Группа: Пользователи
Сообщений: 219
Из: Полтава
Спасибо сказали: 38 раз
Рейтинг: 0

Так вырвемся ж, братья, хоть на мгновение, из оков блок-схемной логики и алгоритмов, вдохнём воздух свободы и предадимся спонтанным движениям души и мыслей! Почувствуем себя живыми ЧЕЛОВЕКАМИ, а не программированными механизмами, и заживем как нам хочется!
...до первого бсода


Signature
Новый Орбит "Ай, бля!" со вкусом языка

Vofka Подменю пользователя
сообщение 18.09.09, 14:00
Сообщение #9

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13147
Из: Киев
Спасибо сказали: 3991 раз
Рейтинг: 3123.4



Пока Живой=1 Цикл
Если День = 1 Тогда
Жрать = 1;
Если ЧтоТоВГоловуСтукнуло=0 Тогда
Работа, Дом... =1;
Иначе
НовыеВпечатления = 1;
Сообщить("О, йа-йа");
Продолжить;
КонецЕсли;
ИначеЕсли Ночь = 1 Тогда
Если Пятница = 1 Тогда
ЧтоТоВГоловуСтукнуло = 1;
КонецЕсли;
КонецЕсли;
КонецЦикла;


ЗЫ. пока дописал запутался.

Цитата
нет предела оптимизации этого алгоритма.


+1

p333aa Подменю пользователя
сообщение 19.01.10, 19:59
Сообщение #10

Молчаливый
*
Группа: Пользователи
Сообщений: 2
Из: Россия
Спасибо сказали: 0 раз
Рейтинг: 0

Начальное сообщение супер. Не думал раньше что это может быть смешно. У самого при отладке или в ходе написания было иначе - отказ речевого аппарата и не понимание почему телепатический коннект плохой, снились регистры, ну и ночевал несколько раз на работе по запарке.

Zaval Подменю пользователя
сообщение 18.12.10, 2:24
Сообщение #11

Крутой
Иконка группы
Группа: Местный
Сообщений: 1993
Из: Киева и окрестностей
Спасибо сказали: 403 раз
Рейтинг: 0

Мне как-то дорабатываемая конфигурация приснилась )) Все объекты были живые и разговаривали со мной. Допиленные некорректно или "пока сойдет - потом поправлю" были обижены, но высказывались корректно. А регистры сведений - те ваще таки интересных идей накидали crazy.gif

igmig65 Подменю пользователя
сообщение 18.12.10, 2:46
Сообщение #12

Почти ветеран
Иконка группы
Группа: Местный
Сообщений: 578
Из: Донецкая обл
Спасибо сказали: 159 раз
Рейтинг: 130.8

Цитата
А регистры сведений - те ваще таки интересных идей накидали

Крута, а чо курим?

Vofka Подменю пользователя
сообщение 18.12.10, 12:58
Сообщение #13

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13147
Из: Киев
Спасибо сказали: 3991 раз
Рейтинг: 3123.4

Цитата
Мне как-то дорабатываемая конфигурация приснилась )) Все объекты были живые и разговаривали со мной. Допиленные некорректно или "пока сойдет - потом поправлю" были обижены, но высказывались корректно. А регистры сведений - те ваще таки интересных идей накидали

Круто laugh.gif

VasilyKushnir Подменю пользователя
сообщение 30.04.11, 22:53
Сообщение #14

Говорящий
***
Группа: Пользователи
Сообщений: 53
Из: Украина Черкассы
Спасибо сказали: 23 раз
Рейтинг: 0

Цитата(Zaval @ 18.12.10, 2:24) *
Мне как-то дорабатываемая конфигурация приснилась )) ...


А мне почему-то бабы и рыбалка снятся.... Впрочем рыбалка чаще.
- Как думаеш, к кому мужчина быстрее подбежит: к бабе или к бутылке водки?
- С бутылкой водки от бабы!


Signature
Никогда не говори Никогда, еще реже говори Всегда.

5_kopeek Подменю пользователя
сообщение 30.04.11, 23:34
Сообщение #15

Ветеран
*******
Женщине-одинэснику
Группа: Пользователи*
Сообщений: 940
Спасибо сказали: 285 раз
Рейтинг: 0

Пример программистских ассоциаций:
Цитата
... бабы и рыбалка...
Цитата
... к бабе или к бутылке водки...

Ardi Подменю пользователя
сообщение 01.05.11, 0:43
Сообщение #16

Живет на форуме
***********
Гений телепатии и социального моделирования
Группа: Пользователи
Сообщений: 4121
Из: Киев
Спасибо сказали: 955 раз
Рейтинг: 0

Мне работа лишь раз в жизни снилась.
Разбирал два дня учет в Excell основных средств, Локомотивы там всякие, здания. Полотно немеряного размера.
И в некоторых основных средствах ошибка в результате чего несколько лет амортизация шла В ОБРАТНУЮ СТОРНУ.
Всю ночь продолжал во сне в Excelle ковыряться.

Кроме этого никогда больше к счастью работа не снилась.

Сообщение отредактировал Ardi - 01.05.11, 1:40


Signature
Услуги 1С программиста 8.2, 7.7 (Плохо, дорого, очередь). Киев.

igmig65 Подменю пользователя
сообщение 01.05.11, 11:59
Сообщение #17

Почти ветеран
Иконка группы
Группа: Местный
Сообщений: 578
Из: Донецкая обл
Спасибо сказали: 159 раз
Рейтинг: 130.8

Цитата
Вобщем сижу я дома, срочная удаленная работа, голова кипит, весь в экране монитора.

Я када нахожусь в таком состоянии, ко мне уже никто необращается, говорят ушел в нирвану.
Пример: сижу в цикле в отладчике, а ухо уловило что ктото зовет, мозк в цикле, поэтому все посторонее игнорирует, выхожу с отладчика, приходит сигнал от уха, только кто звал?, че спрашивал?....

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 21.11.19, 2:38
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!