Версия для печати темы (https://pro1c.org.ua/index.php?s=f535ee979bfe290cd03c278d875d350c&showtopic=55439)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ ТЧ: настройка формы с отбором нужных строк с сохранением настроект отбора

Автор: Constantus 27.11.19, 16:34

Приветствую, Форумчане!
1с8.3.12, СП, самопис, УФ.

Имеется ТЧ:
Модель (справочник)
Размер (справочник)
Вес (число)
Цена (число)

Необходимо как-то провести визуальный отбор записей по модели, размеру и весу (открывается некая форма, где и производится отбор) и запомнить этот отбор для применения в дальнейшем этого отбора для другого документа.

Далее в этой форме для отбора проставить цену, чтобы эта цена заполнилась в ТЧ...

Основная задача: запомнить фильтр отбора, чтобы каждый раз не заполнять. Т.е. в одном документе нужно настроить 3-и и более отбора, т.к. установка цены различна для разных данных...

Подскажите правильный подход к решению задачи...

Вот в форме списка документа доступна кнопка "Настроить список" и вроде там можно сохранить настройки. А как вставить эту кнопку в список таличной части? Ну если я иду в правильном направлении...

Автор: Vladal 28.11.19, 11:56

Цитата(Constantus @ 27.11.19, 16:34) *
запомнить фильтр отбора, чтобы каждый раз не заполнять.

используйте ХранилищеСистемныхНастроек
Пример:

&НаСервере
Процедура СохранитьНастройкиВХранилище() Экспорт
    
    ТекущийПользователь = Пользователи.ТекущийПользователь();
    
    ХранилищеСистемныхНастроек.Сохранить("Период",, ЭтотОбъект.Период,, ТекущийПользователь);
...
КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройкиИзХранилища() Экспорт
    
    ТекущийПользователь = Пользователи.ТекущийПользователь();
    
    ЭтотОбъект.Период = ХранилищеСистемныхНастроек.Загрузить("Период",,, ТекущийПользователь);
...
КонецПроцедуры



В общих модуляъ нашел такую процедуру, которая сохраняет настройки форм:

// Сохраняет настройку в хранилище настроек данных форм.
//
// Параметры:
//   КлючОбъекта       - Строка - Ключ объекта настройки.
//   КлючНастроек      - Строка - Ключ сохраняемых настроек.
//   Значение          - Произвольный     - Настройки, которые нужно сохранить в хранилище.
//   ОписаниеНастроек  - ОписаниеНастроек - Вспомогательная информация о настройке.
//   ИмяПользователя   - Строка - Имя пользователя, настройки которого сохраняются.
//       Если не указано, то сохраняются настройки текущего пользователя.
//   НужноОбновитьПовторноИспользуемыеЗначения - Булево - Сбросить кэши модулей ПовтИсп.
//
// См. также:
//   "СтандартноеХранилищеНастроекМенеджер.Сохранить" в синтакс-помощнике.
//
Процедура ХранилищеНастроекДанныхФормСохранить(КлючОбъекта, КлючНастроек, Значение,
    ОписаниеНастроек = Неопределено, ИмяПользователя = Неопределено,
    НужноОбновитьПовторноИспользуемыеЗначения = Ложь) Экспорт
    
    ХранилищеСохранить(
        ХранилищеНастроекДанныхФорм,
        КлючОбъекта,
        КлючНастроек,
        Значение,
        ОписаниеНастроек,
        ИмяПользователя,
        НужноОбновитьПовторноИспользуемыеЗначения);
    
КонецПроцедуры


А посмотрите в отладчике, какие свойства есть у табличного поля?
Компоновщик настроек есть?
Или отборы?
Копайте туда.

Автор: Constantus 01.12.19, 11:34

Попробую по-другому пояснить

Имеется дополнительная форма документа "ФормаИзмененияПроцентаЦены"
На ней установлено софйство: Сохранение данных формы в настройках - использовать список

Тем самым у формы появляются 2- новых кнопки "Сохранить и восстановить ппараметры"

На форме также имеется кнопка "Пометить с отбором", которая открывает общую форму "Заполнение документа", где проводится отбор данных по определенным параметрам, а потом по отборам и происходит установка галок в дополнительной форме для дальнейших махинаций...

Претензий к работе к указанному нет, все работает, но вот никак не запоминаются параметры, т.е. после сохранения параметра отбора и его восстановления, форма "Заполнение документа" открывается свободной от параметровЮ т.е. требуется снова заполнения параметров выбора, а хотелось бы, чтобы отборы взялись из сохраненных параметров формы...

На форме сделал реквизит "НастройкиЗаполнения" с КомпоновщикНастроекКомпоновкиДанных. Отор в этом реквизите поставил как "сохранять"

Как правильно сохранить настройки, а главное как получить эти настройки отборов при открытии формы "Заполнение документов"?



Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua