Версия для печати темы (https://pro1c.org.ua/index.php?s=8a4797901373d43bf67141a097d5fad6&showtopic=55437)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Изменение длины символов реквизита НомерСчета

Автор: Colt23846 27.11.19, 10:52

Добрый день.
1С:Підприємство 8.3 (8.3.10.2299)
Управление небольшой фирмой для Украины, редакция 1.6 (1.6.5.1)

Столкнулся с проблемой, что при изменении количества символов реквизита НомерСчета, по факту количество символов в самой 1С не изменяется.
Нужно изменить номер счета организации
Возможно я ввожу что-то не то или не там?




Автор: fly 27.11.19, 12:08

Colt23846 @ Сегодня, 10:52 * ,
ОбщийМодуль.УправлениеНебольшойФирмойКлиентСервер
найдите

Функция ДлинаНомераСчета() Экспорт
    Возврат 14;
КонецФункции


необходимо поставить

Функция
ДлинаНомераСчета() Экспорт
    Возврат  29;
КонецФункции


или

Функция
ДлинаНомераСчета() Экспорт
    Возврат  Метаданные.Справочники.БанковскиеСчета.Реквизиты.НомерСчета.Тип.КвалификаторыСтроки.Длина;
КонецФункции


или другой код, который необходим


fly @ Сегодня, 11:21 * ,
там еще попроверять надо
выдавать ошибки может, и т.п.
&НаКлиенте
Процедура НомерСчетаОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, СтандартнаяОбработка)
    
    #Если ВебКлиент ИЛИ МобильныйКлиент Тогда
        
        Если ЯвляетсяБанкомРФ И СтрДлина(Текст) > 14 Тогда
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = НСтр("ru='Введенное значение превышает допустимую длину номера счета 14 символов!';uk='Введене значення перевищує припустиму довжину номера рахунку 14 символів!'");
            Сообщение.Сообщить();
            
            СтандартнаяОбработка = Ложь;
        КонецЕсли;
        
    #КонецЕсли
    
КонецПроцедуры


Автор: Colt23846 27.11.19, 12:43

Что-то все равно не работает.
При любом коде ограничение в 20 знаков остается

Автор: fly 27.11.19, 13:00

Colt23846 @ Сегодня, 12:43 * ,
какая у реквизита банка стоит страна?
потому как если <> Справочники.СтраныМира.Украина
тогда надо искать функцию

УправлениеНебольшойФирмойКлиентСервер.ТипМеждународныйНомерСчета()

Автор: Colt23846 27.11.19, 13:47

fly @ Сегодня, 13:00 * ,
Не стояла страна совсем. После того, как поставил Украина ничего не изменилось

Автор: fly 27.11.19, 14:10

Цитата(Colt23846 @ 27.11.19, 13:47) *
Не стояла страна совсем. После того, как поставил Украина ничего не изменилось

ну по ходу проверить все реквизиты всех Форм нужно(Организации, Контрагенты, Документы и т.п.), где используется Номера_Р/с

скорее всего тогда в Форме элемента Организации - реквизит вроде так назывался "ОсновнойСчет_Номер" - имеет длину 20.

Автор: Макс1С 27.11.19, 17:10

Цитата(fly @ 27.11.19, 14:10) *
в Форме элемента Организации - реквизит вроде так назывался "ОсновнойСчет_Номер" - имеет длину 20

Так и есть.
Помимо этого есть ограничение в общем модуле, которое не дает вводить номер счета длиннее 14 знаков в форме элемента Банковские счета
Функция УправлениеНебольшойФирмойКлиентСервер.ДлинаНомераСчета()
всегда возвращает 14

Автор: rinon 05.12.19, 18:18

Colt23846 @ 27.11.19, 13:43 * ,
Формы - ФормаЭлемента - Поле Номер счета - Свойства - Маска - добавить нужное количество восклицательных знаков))

Автор: Макс1С 06.12.19, 9:35

rinon @ Вчера, 18:18 * ,
Это в другой конфигурации видел, в УНФ нет маски.

Только заметил что и я невнимательно прочитал первый ответ и продублировал в своем посте. Правильный ответ уже дан выше

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua