Версия для печати темы (https://pro1c.org.ua/index.php?s=276b7bcce71b9b2ffb7df1d6f2f24502&showtopic=55490)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Обучающее видео _ Как загрузить номенклатуру из внешнего файла (Excel и др.) в 1С 8.3 штатными средствами?

Автор: glavkomnn 30.11.19, 23:23

Коллеги приветствую!

Подавляющее большинство не знает, что разработчики оставили лазейку - возможность загрузить справочники в базу самостоятельно. Но оставить-то оставили, да не совсем. Ряд справочников доступен для загрузки, а некоторые стратегически важные, такие, как, например, Номенклатура - недоступны. Но путем нехитрых действий с расширениями можно добиться того, чтобы типовая загрузка могла загрузить в базу также и справочник Номенклатура. В данном видео описан порядок действий, чтобы этого достичь.

Неожиданно для себя наткнулся на то, что оказывается МОЖНО загрузить номенклатуру штатными средствами, встроенной загрузкой из файла в конфигурации УТ 11. Если немного подпилить её расширением.

Может кому пригодится, делюсь лайфхаком, записал на видео, как это можно сделать

В модуле менеджера обработки "ЗагрузкаИзВнешнегоФайла" надо в функции "СправочникСодержитРеквизитИсключение" закомментировать код:

Для каждого Реквизит Из Справочник.ТабличныеЧасти Цикл
        Если Реквизит.Имя <> "КонтактнаяИнформация"
            И Реквизит.Имя <> "ДополнительныеРеквизиты"
            И Реквизит.Имя <> "СертификатыШифрования" Тогда
                Возврат Истина;
        КонецЕсли;
    КонецЦикла;
    
    Для каждого Реквизит Из Справочник.Реквизиты Цикл
        Для каждого ТипРеквизита Из Реквизит.Тип.Типы() Цикл
            Если ТипРеквизита = Тип("ХранилищеЗначения") Тогда
                Возврат Истина;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;


Тогда справочник "Номенклатура" будет доступен в списке загрузки
И собственно вопрос
Вы не разбирались, по какой причине разработчики зашили такое ограничение - не загружать "Доп. реквизиты" и "Хранилище значения". Это намеренный ход или случайное совпадение, что самый стратегически загружаемый справочник, содержащий такие реквизиты, оказался за пределами возможностей загрузки?

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua