Версия для печати темы (https://pro1c.org.ua/index.php?s=0811568bed21a2621cf9a222e7d340de&showtopic=67478)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Прочее 1С 7.7 _ При нажатии на кнопку программно заполнить реквизит Формы

Автор: url_2l 12.02.24, 13:14

Доброго дня!!! Потрібна допомога 1С 7.7 в Розхідній Накладній в формі є реквізит Чек (поле вибору з Списку Перечислення Да Ні) при натасканні на кнопку друк перевіряє щоб поле було не пусте. Чи можна зробити щоб при натискані на кнопку це поле заповнювалось автоматично із списку на "Да"?
Приклад перевірки


Если ПустоеЗначение(Чек) = 1 Тогда
            Предупреждение("Виберіть тип Чеку (Да)");        
        Возврат;
        КонецЕсли;

Автор: denis84 12.02.24, 13:42

url_2l @ Сегодня, 13:14 * ,
Доброго дня! Є такий приклад в моїй конфігурації. В документі списання на виробництво - при зміні реквизиту "підрозділ у шапці документу, заповнюємо підрозділ в рядках документу

    текОтвет = Вопрос("У документі змінено реквізит підрозділу. Заповнити підрозділ по рядкам документу?","Да+Нет");
    Если текОтвет = "Да" Тогда
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
            СтрУчасток = Подразделение;
        КонецЦикла;
    КонецЕсли;


//або ось так: якщо заповнено реквізит "разрешил" в документі "заказ", то ставимо "да" для "готов к получению"
    Если ПустоеЗначение(Разрешил)=0 Тогда
        ГотовКПолучению = Перечисление.ДаНет.Да;
    Иначе
        ГотовКПолучению = Перечисление.ДаНет.Нет;        
    КонецЕсли;

Автор: url_2l 12.02.24, 14:31

denis84 @ Сегодня, 13:42 * ,
Дякую величезне запрацювало

Если ПустоеЗначение(Чек) = 1 Тогда
            Чек = Перечисление.ДаНет.Да;
    КонецЕсли;

Автор: denis84 12.02.24, 14:35

url_2l @ Сегодня, 14:31 * ,
Для "дякую" там є спеціальна кнопочка.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua