Версия для печати темы (https://pro1c.org.ua/index.php?s=f8997fdbdf9282b637f7d1eeafee58af&showtopic=67540)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Как програмно установить шрифт в форматированом документе

Автор: kostya77 02.05.24, 13:34

Добрый день. Есть код который из текста делает HTML

Если Объект.ОписаниеВФорматеHTML Тогда 
        Если Найти(Объект.Описание, "</html>") = 0 Тогда
            _ОписаниеHTML = "<html>" + Объект.Описание + "</html>";    
        Иначе    
            _ОписаниеHTML = Объект.Описание;    
        КонецЕсли;
        ОписаниеHTML.УстановитьHTML(_ОписаниеHTML, Новый Структура);
    КонецЕсли;


Подскажите, как програмно установить шрифт?

Автор: denis84 02.05.24, 14:08

kostya77 @ Сегодня, 14:34 * ,

//Обработка элементов форматированного документа, входящего в состав параграфа, может оказаться полезной в том случае, 
//если нужно, например, убрать все оформление в виде курсива или полужирного шрифта.

//Пример:

Полужирный = Новый Шрифт(, , Истина);
Курсив = Новый Шрифт(, , , Истина);
Обычный = Новый Шрифт;
Для каждого Элемент Из Параграф.Элементы Цикл
     Если ТипЗнч(Элемент) = Тип("ПереводСтрокиФорматированногоДокумента") Тогда        
           Продолжить;
     КонецЕсли;
     Если Элемент.Шрифт = Полужирный Или Элемент.Шрифт = Курсив Тогда          
           Элемент.Шрифт = Обычный
     КонецЕсли;
КонецЦикла;

Автор: kostya77 02.05.24, 14:32

denis84 @ Сегодня, 15:08 * ,
Это помогло. А как еще установить свой шрифт, например roboto

Автор: denis84 02.05.24, 15:46

kostya77 @ Сегодня, 15:32 * ,

//Новый Шрифт(<ИмяШрифта>, <Размер>, <Полужирный>, <Наклонный>, <Подчеркнутый>, <Зачеркнутый>, <Масштаб>)

Шрифт = Новый Шрифт("robota", 11, Истина);

Элемент.Шрифт = Шрифт;

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua