Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику Sirius83 ::: Спасибо сказали: 3 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
22.03.21, 9:26 Печатные формы и экспорт налоговой накладной по схемам F/J1201х12.xsd
One @ 17.03.21, 13:59 * ,
Моя наработка. Там все просто, надо закинуть макеты в общие, заменнить отчеты, и по желанию в модуле соответственных документов поправить печать.
denis84,
12.02.20, 16:22 Управление ролями пользователей.
Цитата(george_smith @ 12.02.20, 15:36) *
Здравстуйте!
В документе "Реализация товаров и услуг" на вкладке "Доверенность"есть реквизиты "Отпуск разрешил" и "Отпуск произвел". Для зав скадом редактирование данного документа запрещено. Как можно ему дать возможность вносить данные только в эти два реквизита. Спасибо!


Ну на редактирование документа все-таки доступ надо дать ибо ето обэкт которим регистрирукеш изменения а обрезать доступ к данным по документу можна как-то так:

Если РольДоступна("ЗавСклад") Тогда 
        Для Каждого Стр из ЭлементыФормы Цикл
            Стр.Доступность = Ложь;    
        КонецЦикла;
        
        ЭлементыФормы.ОсновнаяПанель.Страницы.Довереность.ОтпускРазрешил.Доступность = Истина;
        ЭлементыФормы.ОсновнаяПанель.Страницы.Довереность.ОтпускПроизвел.Доступность = Истина;

КонецЕсли;
george_smith,
20.03.19, 10:48 Не відкривається Оборотно сальдова по рахунку
Цитата(alex1c @ 20.03.19, 10:26) *
Зберігаєте звіт як зовнішній, рядок в якому помилка, вставляєте в Попытка ... Исключение. Звіт відкриється, далі думаю проблем не буде.

Супер!!!
Зробив наступне:
1) Зберіг даний звіт як зовнішній
2) Вичислив що в процедурі "ПередОткрытием" якраз відбувається заповнення налаштувань
3) Закоментував частину відновлення налаштувань:
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    
    ТиповыеОтчеты.НазначитьФормеУникальныйКлючИдентификации(ЭтаФорма);
    
    СохранятьНастройкуОтчета = Не РежимРасшифровки;
    
    //Если Не СохранениеНастроек.ЗаполнитьНастройкиПриОткрытииОтчета(ОтчетОбъект) Тогда
    //    ИнициализацияОтчета();
    //КонецЕсли;
    
    
КонецПроцедуры

4) Запустив зовнішній звіт під "проблемним" користувачем.. Сформував.. Закрив (треба сформувати оскільки після цього йде зберігання налаштувань в історію)
5) Потім запускаємо звіт який раніше не запускався і ... вуаля..! Все працює!
VYem,

RSS Текстовая версия Сейчас: 25.09.21, 5:42
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!