Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



15 страниц V   1 2 3 > » 

>  Условия сохранения определенного документа (1с 7.7.27)
andrew76
Отправлено: Сегодня, 16:03


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


29a @ Сегодня, 14:40 * ,

Так и сделал.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168621 · Ответов: 6 · Просмотров: 105
 

>  Условия сохранения определенного документа (1с 7.7.27)
andrew76
Отправлено: Сегодня, 3:44


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(denis84 @ 25.11.20, 22:53) *
И вот тут полезно почитать


c 1c 8 проще конечно.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168608 · Ответов: 6 · Просмотров: 105
 

>  Условия сохранения определенного документа (1с 7.7.27)
andrew76
Отправлено: Вчера, 18:57


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


denis84 @ Сегодня, 20:54 * ,

У меня этот документ проводить не надо.
Проблема только при сохранении с условием заполнения реквизита.
Табличной части нет тоже,реквизит Сотрудник находится в шапке документа.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168586 · Ответов: 6 · Просмотров: 105
 

>  Условия сохранения определенного документа (1с 7.7.27)
andrew76
Отправлено: Вчера, 16:58


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Добрый вечер !

Имеется определённый документ с реквизитом Сотрудник.
Как сделать так ,чтобы документ не могли сохранить пользователи,
при условии если реквизит Сотрудники не заполнен ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #168579 · Ответов: 6 · Просмотров: 105
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 20.11.20, 16:18


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(Vofka @ 20.11.20, 13:19) *
т.е. написать целую обработку - это фигня, а взять готовую "ради одного документа" - это ОФИГЕТЬ ?


В этом уникальном случае,мне лучше было написать коротенькую обработку,потому что с момента
удаления документа прошло несколько дней (женшена хватилась не сразу),другие же бухгалтера
тоже с базой работали.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168462 · Ответов: 14 · Просмотров: 256
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 20.11.20, 3:46


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(sava1 @ 19.11.20, 21:15) *
В архиве Выгрузить - в рабочей - Загрузить

ради одного документа ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168449 · Ответов: 14 · Просмотров: 256
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 19.11.20, 16:40


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Vofka @ Вчера, 22:23 * ,
ПолучитьОбъект() - насколько я понимаю,просто открывает объект для записи.
Но в отладчике я же не вижу столбцов ТЧ (скриншот 2).Поэтому и открывать для записи нечего.
Ничего не понимаю.

andrew76 @ Сегодня, 19:12 * ,

ИскомыйДокументОбъект = ИскомыйДокумент.ПолучитьОбъект();
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.13.1690): Ошибка инициализации модуля: Документ.Командировочные.МодульОбъекта


Предыстория событий :
Одна бухгалтерша,«замриялась», и находясь в этом режиме, удалила документ Командировочные, в ТЧ которого было 400 записей.
После ,выйдя из нирваны, начались вопли и вопросы есть ли в 1с подобие
Корзины для удаленных объектов, как в MS Windows.
Моя задача была в следующем : найти этот документ в архивной базе,и оттуда
Перенести содержимое этого документа в рабочую базу.


Коннектор=Новый COMОбъект("V83.ComConnector");  

ИмяСервера="server";
ИмяБазы="buhg";
Логин="Администратор";
Пасворд="0101";


Попытка
    v8=Коннектор.Connect("Srvr="""+СокрЛП(ИмяСервера)+""";Ref="""+СокрЛП(ИмяБазы)+""";Usr="""+СокрЛП(Логин)+""";Pwd = """ + СокрЛП(Пасворд) + """;");
    сообщить("Соединение установлено !");
Исключение
    Предупреждение("База данных не открыта!!!");
    Возврат;
КонецПопытки;

ссылка_источник=Неопределено;

  Запрос = Новый Запрос;
  Запрос.Текст =
        "ВЫБРАТЬ
        |   Ссылка
        |ИЗ
        |   Документ.Командировочные КАК Командировочные
        |ГДЕ
        |   Дата МЕЖДУ &НачДата И &КонДата И
        |   Номер = &ВыбНомер";

    Запрос.УстановитьПараметр("НачДата", '20201001');
    Запрос.УстановитьПараметр("КонДата", '20201031');
    Запрос.УстановитьПараметр("ВыбНомер", "октяб");

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДокументов = РезультатЗапроса.Выбрать();

    Если ВыборкаДокументов.Следующий() Тогда
         ссылка_источник=ВыборкаДокументов.Ссылка;
         Сообщить(ВыборкаДокументов.Ссылка);        
    Иначе
         Сообщить("Документ с таким номером не существует!");
    КонецЕсли;



ВыборкаДокументов = v8.Документы.Командировочные.Выбрать(НачалоГода(ТекущаяДата()), КонецГода(ТекущаяДата()));
Пока ВыборкаДокументов.Следующий() Цикл
    
     Если СокрЛП(ВыборкаДокументов.Номер)="окт1" тогда
          ИскомыйДокумент=ВыборкаДокументов;         
     КонецЕсли;
      
КонецЦикла;


ИскомыйДокументОбъект = ИскомыйДокумент.ПолучитьОбъект();  //вот здесь и начинает гнать
Строка = ИскомыйДокументОбъект.ТабличнаяЧасть1.Добавить()
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168428 · Ответов: 14 · Просмотров: 256
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 18.11.20, 18:20


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Vofka @ Сегодня, 21:12 * ,

На методе Добавить и вылетает ошибка:
Произошла исключительная ситуация (1C:Enterprise 8.3.13.1690): Объект недоступен для изменения.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168394 · Ответов: 14 · Просмотров: 256
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 18.11.20, 17:13


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Vofka @ Сегодня, 20:07 * ,

Выложил пока скриншоты.Код завтра выложу.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168392 · Ответов: 14 · Просмотров: 256
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 18.11.20, 17:02


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


andrew76 @ Вчера, 19:39 * ,

В общем у всех документов с ТЧ при попытке чтения данных из этих ТЧ вываливается
следующая ошибка :
Произошла исключительная ситуация (1C:Enterprise 8.3.13.1690): Объект недоступен для изменения.
Реквизиты шапки документов читаются.

Где искать ? Что гонит ? Сервер (Windows Server 2012 Standard x 64) ? Сам компонент COMConnector ?



  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168387 · Ответов: 14 · Просмотров: 256
 

>  Проблема с перебросом данных через объект ComConnector (1с 8.3.1690)
andrew76
Отправлено: 17.11.20, 16:39


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Добрый вечер !

Имеется 2-sql базы.Соединение между базами идет через объект ComConnector.
Соединение происходит нормально.Только при попытке записать данные из табличной части
документа Командировочные из одной базы в другую (в аналогичный Документ Командировочные),
выскакивает ошибка.При просмотре отладчиком выясняется следующее: (таблица источникsmile.gif
ТабличнаяЧасть1 - Значение COMObject
Add - метод не найден.
Count - метод не найден и так далее...
Столбцов ТЧ тоже не видно в отладчике.
Реквизиты же шапки документа читаются нормально.

В чем может быть проблема ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #168351 · Ответов: 14 · Просмотров: 256
 

>  Как создать ссылку на определенную строку ТаблицыЗначений? 1с 7.7 конф 7.7.003
andrew76
Отправлено: 23.09.20, 4:33


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Посмотрите в отладчике значение переменной А.Может лучше эту переменную
вычислять принудительно : А=А+1 ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #166690 · Ответов: 6 · Просмотров: 215
 

>  Как создать ссылку на определенную строку ТаблицыЗначений? 1с 7.7 конф 7.7.003
andrew76
Отправлено: 22.09.20, 18:40


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(ZUBR @ 22.09.20, 20:12) *
Суть в том, что в определенном месте цикла мне надо запомнить строку ТЗ, чтобы потом ее вызвать без поиска и цикла и произвести в ней некоторые изменения.


ПолучитьСтрокуПоНомеру(<?>);
Синтаксис:
ПолучитьСтрокуПоНомеру(<НомерСтроки>)
Назначение:
Получить строку таблицы значений по номеру. Указанная строка становится текущей.
Параметры:
<НомерСтроки> - номер строки, на которую следует переместиться.

ТЗ.ПолучитьСтрокуПоНомеру(<?>);



Вдогонку :

ТЗ.ВыбратьСтроки();  //эта строчка лишняя скорее всего

ТЗ.ПолучитьСтрокуПоНомеру(А);                   //ПЫТАЕМСЯ ПОЛУЧИТЬ СТРОКУ А

Если (ТЗ.ЗАКАЗ=Расх.НомерЗаказа)и(ТЗ.СТАТУС=Перечисление.Статусы.АКС)  Тогда  
       ТЗ.К=К;
КонецЕсли;

  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #166660 · Ответов: 6 · Просмотров: 215
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 15.09.20, 16:44


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Похоже и в моем случае.Только у меня вместо регистра работал справочник.Связка Пользователь/Цех.
Пользователи тоже не жаловались.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166449 · Ответов: 16 · Просмотров: 439
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 15.09.20, 8:34


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(MATEVI @ 14.09.20, 21:53) *
Пишут, то много чего.

Цитата(RedCat77 @ 11.09.20, 13:42) *
Суть вопроса: необходимо ограничить пользователя в возможности работы только по ему разрешенным складам (кому-то один, кому-то несколько, кому-то все доступны)


Судя по названию темы ("Ограничение доступа с пользователей к складам"),Автора
интересовал только ограниченный доступ к складам.А если на всю конфу,то надо использовать RLS,
Или ролями манипулировать.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166441 · Ответов: 16 · Просмотров: 439
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 14.09.20, 16:09


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


RedCat77 @ Сегодня, 18:17 * ,

При создании и открытии документов по складу работает почти тот же код,что и при открытии формы списка
справочника.При создании нового документа на форме при выборе поля склад пишете в обработчиках код с условием
фильтра назначенных пользователю складов.При просмотре - при открытии формы документа код почти такой же.
С отчетами надо разбираться отдельно в каждом случае.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166417 · Ответов: 16 · Просмотров: 439
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 14.09.20, 14:48


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(RedCat77 @ 11.09.20, 13:42) *
Суть вопроса: необходимо ограничить пользователя в возможности работы только по ему разрешенным складам (кому-то один, кому-то несколько, кому-то все доступны)

Цитата(RedCat77 @ 14.09.20, 12:27) *
А как работа с документами (создание, открытие), как работа с отчетами (особенно с бухгалтерскими ОСВ)?


Не совсем понял,бухгалтер тоже будет работать с определенными складами ? Или внутри документа
при выборе склада накладывать ограничение ?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166413 · Ответов: 16 · Просмотров: 439
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 13.09.20, 13:06


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(sava1 @ 13.09.20, 14:25) *
а теперь прикиньте объем работ для


Не могу прикинуть пока,Автор ветки не сообщил ,сколько у него документов и отчетов в конфигурации.
И просил он вариант без использования RLS.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166384 · Ответов: 16 · Просмотров: 439
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 13.09.20, 9:41


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


...тишина в эфире- cловно все застыло в этом странном мире (с)

Цитата(RedCat77 @ 11.09.20, 13:42) *
Суть вопроса: необходимо ограничить пользователя в возможности работы только по ему разрешенным складам (кому-то один, кому-то несколько, кому-то все доступны). Это должно распространяться на справочники

Цитата(RedCat77 @ 11.09.20, 13:42) *
Возможно нужна какая-то матрица доступа

Цитата(RedCat77 @ 11.09.20, 13:42) *
Кто сталкивался с такими вопросами или видел подобное? Есть ли подходящие решения?


Занимался подобным делом в этом году.Ограничивал доступ пользователям к отдельным цехам(отделам).
Реализовано это было без RLS.В справочнике цехов открыл новый реквизит-ссылка Справочник Пользователей.
Каждому цеху сопоставил в справочнике имя пользователя.При открытии формы списка справочника
запросом проверял ,есть ли у текущего пользователя доступ к просмотру определенного цеха.
Если у пользователя был доступ к цеху-он включался в значение отбора на форме списка справочника.
Далее включался отбор по списку и открывалась форма списка справочника с включенным отбором разрешенных
цехов.Конфигурация была самописная , с нуля.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166382 · Ответов: 16 · Просмотров: 439
 

>  Ограничение доступа с пользователей к складам
andrew76
Отправлено: 12.09.20, 14:19


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


RedCat77 @ Вчера, 13:42 * ,
Цитата(RedCat77 @ 11.09.20, 13:42) *
необходимо ограничить пользователя в возможности работы только по ему разрешенным складам (кому-то один, кому-то несколько, кому-то все доступны). Это должно распространяться на справочники, документы и отчеты.


А сколько пользователей в БД ? Сколько справочников , документов и отчетов ?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #166369 · Ответов: 16 · Просмотров: 439
 

>  Как использовать один и тот же программный блок с небольшими изменениями несколько раз? 1с 7.7 конф 7.7.00
andrew76
Отправлено: 17.08.20, 18:30


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Pepe @ Сегодня, 13:32 * ,

1.Переносите на форму новый объект - "Флажок".
2.В свойствах объекта "Флажок" прописываете переменную -в поле Идентификатор.Например: ПоискПоТелефону.
3.В процедуре ниже пишете примерно следующее:

Расх = СоздатьОбъект("Документ.РасходнаяНакладная");
    ТЗ = СоздатьОбъект ("ТаблицаЗначений");    
    Телефон_=СокрЛП(Телефон);
    ......................................................................
Пока Расх.ПолучитьДокумент()=1 Цикл
                
Если ПоискПоТелефону=1  //в элементе управления флажок Включена галочка - выбран поиск по телефону //
       Если ((Найти(Расх.Телефон,Телефон_)>0)и(Расх.ПометкаУдаления()=0)) Тогда
      
       КонецЕсли;

ИначеЕсли ////


если еще 3 варианта поиска, то надо сделать как в пунктах 1,2 ,только меняйте имя переменных:
ПоискПоФамилии,поискПоПриметам и т.д.
и в процедуре добавляете условия,если выставлены флажки.


КонецЕсли;
..............................................................................
ТЗ.НоваяКолонка("Модель");
ТЗ.НоваяКолонка("СерийныйНомер");


Не видя всей процедуры,сложно посоветовать оптимальное решение.
Можно было бы попробовать отборами отобрать доки.
Такой вот псевдокод:

Расх = СоздатьОбъект("Документ.РасходнаяНакладная");

Если ПоискПоТелефону=1  //в элементе управления флажок Включена галочка - выбран поиск по телефону
       Расх.ВыбратьПоЗначению(НачДата,КонДата,"Телефон",Телефон_);
ИначеЕсли ПоискПоФамилии=1 //выбран 2-й флажок на форме
       Расх.ВыбратьПоЗначению(НачДата,КонДата,"Имя",Имя_);
ИначеЕсли.... //3 условие

ИначеЕсли ... //4 условие

КонецЕсли...
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #165708 · Ответов: 14 · Просмотров: 800
 

>  Как вытянуть значения измерений из регистра ? (1c 7.7.027)
andrew76
Отправлено: 14.07.20, 19:43


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


denis84 @ Сегодня, 22:18 * ,

Склад=Рег.Склад;


выводится пустая строка

andrew76 @ Сегодня, 22:33 * ,

наверное после применения метода СводныйОстаток,это не работает

ост=Рег.СводныйОстаток(СпТов.код,Склад,,,"Количество");
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164737 · Ответов: 5 · Просмотров: 431
 

>  Как вытянуть значения измерений из регистра ? (1c 7.7.027)
andrew76
Отправлено: 14.07.20, 18:50


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


denis84 @ Сегодня, 21:19 * ,

отчет не мной писан,времени особо нет разбираться,но нужно.Да,нужно получить остатки из регистра :
ост=Рег.СводныйОстаток(СпТов.код,Склад,,,"Количество");

Нужно в строчку вывести номенклатурный номер,цену,количество,сумму,наименование склада,мол(мат.отв.лицо)
Как можно это сделать запросом ?
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164735 · Ответов: 5 · Просмотров: 431
 

>  Как вытянуть значения измерений из регистра ? (1c 7.7.027)
andrew76
Отправлено: 14.07.20, 17:26


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Добрый вечер !

Имеется регистр ТовЗапас (товарный запас) со следующими измерениями и ресурсами :
Измерения : Товар,Склад,Мол,Контрагент.
Ресурсы : Количество,Стоимость.
Как в нижеуказанной процедуре вывести в секции "Cтрока" значение измерений Склад и Мол?


Процедура Сформировать()
СпТов=СоздатьОбъект("Справочник.Материалы");
Рег=СоздатьОбъект("Регистр.ТовЗапас");
Таб=СоздатьОбъект("Таблица");
ИтогСк=0;
ИтогГР=0;
колстр=1;
Сптов.ПорядокКодов();
Сптов.НайтиПоКоду(СокрЛП(Склад.Код));
ТС=Сптов.ТекущийЭлемент();
сптов.ИспользоватьДату(ДатаПер);
сптов.ИспользоватьРодителя(ТС);
Если ПустаяСтрока(Грмат.код)=0 Тогда
    СпТов.ВыбратьЭлементыПоРеквизиту("ГруппаМатериалов",Грмат);
иначе
    СпТов.ВыбратьЭлементы();
конецЕсли;    
Рег.ВременныйРасчет();
РассчитатьРегистрыНа(ДатаПер);
Таб.ВывестиСекцию("Шапка");
Если Сжато=2 тогда
        Таб.ВывестиСекцию("Графы");
иначе
        Таб.ВывестиСекцию("ШапкаГр");
КонецЕсли;    
СпТов.ПолучитьЭлемент();
Группа=СпТов.ГруппаМатериалов;
Таб.ВывестиСекцию("Группа");
ост=Рег.СводныйОстаток(СпТов.код,Склад,,,"Количество");    
ИтогГр=ИтогГр+ост*Сптов.цена;
ИтогСк=ИтогСк+ост*Сптов.цена;
Если Сжато=2 тогда
    если ост> спТов.нормазапдень тогда
           Таб.ВывестиСекцию("Строка");   //как здесь из регистра прочитать значения измерений Склад и МОЛ ?
    конецесли;
    колстр=колстр+1;
КонецЕсли;    
Пока СпТов.ПолучитьЭлемент()>0 Цикл
Если СпТов.ПометкаУдаления()=0 тогда
    Если Группа<>спТов.ГруппаМатериалов тогда
        если итоггр>0 тогда
            Таб.ВывестиСекцию("ИтогГР");
        конецесли;
        колстр=колстр+1;
        Если колстр>63 тогда
            таб.НоваяСтраница();
            Таб.ВывестиСекцию("Графы");
            колстр=0;
        конецесли;    
        ИтогГР=0;
        Таб.ВывестиСекцию("Группа");
    конецЕсли;
    ост=Рег.СводныйОстаток(СпТов.код,Склад,,,"Количество");    
    ИтогГр=ИтогГр+ост*Сптов.цена;
    ИтогСк=ИтогСк+ост*Сптов.цена;
    Если Сжато=2 тогда
        если ост> спТов.нормазапдень тогда
                Таб.ВывестиСекцию("Строка");  //как здесь из регистра прочитать значения измерений Склад и МОЛ ?
        конецесли;
        КонецЕсли;    
конецЕсли;    
    Группа=спТов.ГруппаМатериалов;
КонецЦикла;    
Таб.ВывестиСекцию("ИтогГР");
Если ПустаяСтрока(Грмат.код)=1  тогда
    Таб.ВывестиСекцию("ИтогСк");
КонецЕсли;    


Таб.ТолькоПросмотр(1);
    Таб.Опции(0, 0, 5,0 ,,"ОСВР");
    Таб.ОбластьПечати(2);
    Таб.ПовторятьПриПечатиСтроки(3,3);
    Таб.ПараметрыСтраницы(1,,,,,,,,, 1);
    Таб.Показать("", "");
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164733 · Ответов: 5 · Просмотров: 431
 

>  Выбор минимальной даты в ТаблицеЗначений 1С 7.70.003 торговля склад для Украины?
andrew76
Отправлено: 26.06.20, 18:53


Оратор
*****

Группа: Пользователи
Сообщений: 370
Регистрация: 11.03.14
Из: Узбекистан
Пользователь №: 34250


Цитата(ZUBR @ 25.06.20, 16:14) *
Отсортировать ТЗ по возрастанию и получить значение из первой строки.


Цикл строить не надо.

ТЗ.Сортировать("+ДатаПриема");
Сообщить(ТЗ.ПолучитьЗначение(1,"ДатаПриема")); //минимальное значение
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #164242 · Ответов: 5 · Просмотров: 423
 

15 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 26.11.20, 22:25
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!