Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику mut ::: Спасибо сказали: 46 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
23.04.20, 18:01 Обратиться к реквизиту формы справочника из модуля формы обработки
У таблицы есть событие ПриВыводеСтроки, для раскраски строк я использую его. У вас, наверное, будет работать что-то подобное:

Процедура МояТаблицаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
    Если ДанныеСтроки.Номенклатура.Наименование="Оригинальность" Тогда
    
        ОформлениеСтроки.ЦветФона = ЦветЗеленый;
        
    Иначе
    
        ОформлениеСтроки.ЦветФона = ЦветКрасный;
        
    КонецЕсли;
    
КонецПроцедуры


Переменные для раскраски:
ЦветКрасный = Новый Цвет(255, 200, 200);
ЦветЗеленый = Новый Цвет(200, 255, 200);
SemenYU,
16.04.20, 14:39 Подключение ФР MINI-ФП54.01 в УТ 3.1 для Украины
Цитата(shavulsky1 @ 16.04.20, 9:47) *
Можете скинуть ссылку на архив с драйвером и краткую инструкцию что правили в УНФ?

Пересмотрел, всё, что было сделано. С файлом то были эксперименты, а раз уж переделывали конфигурацию, то драйвер встроили тоже. По этому просто архив с сайта Юнисистем сохраняете в общий макет, чтобы пользователю можно было его достать и установить в систему. Для упрощения задачи процесс автоматической установки я не прописывал.
Кратко порядок такой - ищем, как привязан драйвер Артсофта и по аналогии добавляем поддержку Мини.
Там понадобятся:
общий макет с драйвером
свой модуль-обработчик команд регистратора (копируем модуль Артсофта и пишем команды для Мини)
предопределенный элемент справочника драйверов
элемент перечисления ОбработчикиДрайверовПодключаемогоОборудования
в модуле МенеджерОборудованияВызовСервераПереопределяемый можно прописать заполнение справочника драйверов
в модуле МенеджерОборудованияКлиентПереопределяемый добавить возврат нашего обработчика
в модуле МенеджерОборудованияКлиент добавить создание СОМ объекта

ну вроде всё smile.gif

mut @ Сегодня, 15:28 * ,

Если все-таки будете экспериментировать с внешним файлом, вот пример того что я пробовал. В архиве хмл с описанием и самораспаковывающийся архив, потому как 1с хочет запустить ехе-файл при установке.
Такой архив можно загружать в 1с как внешний драйвер.

ссылка
natkor,
28.02.20, 20:36 Картинки в табличной форме документа.
volodya1122 @ Сегодня, 13:06 * ,
можно программно сохранить таблицу в ексель, потом через оле вызвать ексель и пересохранить файл в формате хлсх
Talkman,
26.02.20, 11:43 Создание элементов справочника через СОМ соединение
Если связь между базами более-менее постоянная, я, обычно в базе-приемнике, в модуле Внешнего соединения, пишу необходимые методы для формирования данных и вызываю их из исходной базы. Получается проще - получили простые данные - названия или коды и пр., потом уже в контексте принимающей БД делаем поиск, создание и прочее.
bizisoft, stark,
25.02.20, 21:49 Создание элементов справочника через СОМ соединение
Попробуйте те поля, которые предопределены указывать в английском варианте, не "Наименование" а "Description" и т.п.
bizisoft,
27.01.20, 16:15 Как открыть форму элемента справочника Контрагенты из формы расходной накладной в 1С 7.70.003 торговля склад для Украины?
А почему не использовать сам реквизит из накладной, зачем поиск по наименованию?

Спр.НайтиЭлемент(Контрагент);
anatol1c, ZUBR,
16.01.20, 11:14 ПолеВвода СписокЗначения
bizisoft @ Сегодня, 8:19 * ,

Нужно на форму добавить реквизит с типом СписокЗначений, у самого реквизита - ТипЗначения - нужный справочник, а у элемента формы в свойствах - ВыборГруппИЭлементов - Группы.
bizisoft,
03.01.20, 10:59 1С Вакансии: хочется узнать ваше мнение
Vofka @ 01.01.20, 21:45 * ,

Нужно поправить слово в тексте

Цитата
Если с момента активации вакансии прошло 7 дней и больше, её можно обновить. Вакансии, у которых дата обновления позже, в списке на сайте будут показаны раньше. Обновлении бесплатно и доступно в течении всего активного периода, но не чаще 1 раза в неделю.
Vofka,
28.12.19, 18:47 Обробка "Обмін з банком" для БУ 2.0

Petre,
У некоторых клиентов в договоре указан учет взаиморасчетов "по расчетным документам", но при заполнении выписки они не всегда указывают ссылку на расчетный документ. Предлагаю добавить возможность отключить проверку заполнения реквизита "Угода".
mvo2008, Petre,
24.12.19, 15:52 Как осуществить поиск телефона по нескольким цифрам в 1С 7.70.003 торговля склад для Украины?
andrew76 @ Сегодня, 12:30 * ,
Ну тогда уж ни в коем случае не таким способом:

Телефон = СокрЛП(Телефон);


Если Телефон - реквизит формы, никакого удаления не произойдет. Нужна новая переменная.
ZUBR,
23.12.19, 17:37 Как при выборе в списке справочника открывать форму элемента?
Fasharama @ Сегодня, 17:28 * ,

В форме списка, в свойствах списка - СпособРедактирования - установить "В диалоге".
Fasharama,
22.12.19, 12:47 Как осуществить поиск телефона по нескольким цифрам в 1С 7.70.003 торговля склад для Украины?
Цитата(ZUBR @ 21.12.19, 11:09) *
Реквизит Расх. Телефон имеет тип строка 48 символов в расходной накладной.
Реквизит Телефон имеет такой же тип. Это реквизит поле ввода в диалоге созданного отчета Поиск.


У строковых реквизитов перед поиском нужно обрезать пробелы.

Если (Найти(Расх.Телефон,СокрЛП(Телефон))>0) и (Расх.СтатусЗаказа <> Перечисление.Статусы.Акс) Тогда
ZUBR,
21.12.19, 19:41 Как осуществить поиск телефона по нескольким цифрам в 1С 7.70.003 торговля склад для Украины?
ZUBR @ Сегодня, 11:09 * ,
Невнимательно смотрели пример
Не «равно единице», а «больше нуля»
ZUBR,
18.12.19, 17:47 Как осуществить поиск телефона по нескольким цифрам в 1С 7.70.003 торговля склад для Украины?
Ну или функцией Найти() если нужно по любой части строки

Если Найти(Клиент.Телефон, Цифры) > 0 Тогда
...
ZUBR,
17.12.19, 17:53 Подружить Бухгалтерию с Фискальным регистратором
В наших краях популярны Экселио, там все равно какая модель, драйвер один, документация есть, примеры вместе с ним есть.
Володька,
13.12.19, 14:40 Проблема при открытии порта ККM Екселио 550
Вместе с драйвером идет тестовая утилита, ей можно проверить, эта утилита работает через ту-же длл, что и 1с.
Pashaboston,
11.11.19, 16:22 Создание счета на сайте, средставми 1С
По идее всё возможно. Сервер на котором крутится сайт должен сформировать и отправить запрос, правильнее POST-запрос, со всеми нужными параметрами в 1С. Соответственно в 1С должен быть сконфигурирован хттп-сервис, который сделает всё остальное. При выполнении запроса сервер авторизуется в 1С, ну и т.к. это всё на стороне сервера, то вполне безопасно, покупатель который жмет кнопку никаких паролей не увидит и что там будет происходить не узнает.
awp,
13.10.19, 11:54 Помогите создать внешнею печатную форму
Видимо функция СформироватьПечатнуюФорму должна вернуть табличный документ, вставьте в конце
Возврат ТабличныйДокумент;
AzamatK,
03.10.19, 17:02 Как изменить дату на месяц? 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 17:53 * ,

Если сейчас у нас дата в переменной ТекДата, то гарантированно попасть на конец следующего месяца можно так:

СледующаяДата = КонМесяца(КонМесяца(ТекДата)+1);
ZUBR,
18.09.19, 12:26 Помогите понять принцип создания запросов в 1с 7.7 конф 7.7.00
ZUBR @ Сегодня, 0:28 * ,

Представь результат выборки запроса в виде таблицы, потом эту таблицу свернули по полям, указанным в Группировка а по формулам Функция вычислили значения для этих группировок. Потом оператором Запрос.Группировка() мы перемещаемся по значениям группировок.
"Без Групп" работает для значений типа "Справочник", исключает из выборки элементы - группы, потому как по умолчанию если группировка делается по справочнику, то система собирает в выборку все элементы с иерархией и вычисляет функции и для групп, т.е. при переборе Запрос.Группировка() будем получать группу, элемент и т.д. Если нам группы не нужны, пишем "Без групп".
ZUBR,
16.09.19, 11:07 В чем ошибка условия? 1С 7.70.003 торговля склад для Украины?
Подсчет делается внутри перебора элементов справочника, нет смысла писать сотрудника в таблицу и потом сравнивать с таблицей.
Нужно сделать выборку накладных по текущему элементу справочника, потом добавить все в строку таблицы.

Спр.ВыбратьЭлементы();
      Пока Спр.ПолучитьЭлемент()=1 Цикл
            
          К = 0;
           Расх.ВыбратьДокументы(НачДата,КонДата);
          
      Пока Расх.ПолучитьДокумент()=1 Цикл
          
          Если Спр.ТекущийЭлемент() = Расх.Инженер Тогда
                К=К+1;
              КонецЕсли;
              
            КонецЦикла;

         ТЗ.НоваяСтрока();
          ТЗ.Сотрудник = Спр.Наименование;
      ТЗ.КолСис = К;

    КонецЦикла;
ZUBR,
02.09.19, 20:03 Как создать отчет с суммой по отдельной позиции табличной части расходных накладных в 1С 7.70.003 торговля склад для Украины
Цитата(ZUBR @ 02.09.19, 19:55) *
Если подскажете пример запроса


ТекстЗапроса = 
    "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |Товар = Документ.РасходнаяНакладная.Товар;
    |СуммаСНДС = Документ.РасходнаяНакладная.СуммаСНДС;
    |Функция Сум = Сумма(СуммаСНДС);
    |Группировка Товар Без Групп;
    |Условие (Товар = НужныйТовар);";
    Запрос.Выполнить(ТекстЗапроса);
    Пока Запрос.Группировка(1) = 1 Цикл
        СуммаУслуг = Запрос.Сум;
    КонецЦикла;


ваши параметры - НачДата, КонДата, НужныйТовар (это элемент справочника, услуга, по которой нужно отобрать)

результат в переменной СуммаУслуг
ZUBR,
02.09.19, 10:43 Не подсвечивается цветом ТЗ в 1С 7.70.003 торговля склад для Украины?
Цитата(ZUBR @ 31.08.19, 22:13) *
раскрашивать цветом строки этой таблицы.

раскрашивать табличный документ нельзя
нужно в макете табличного документа сделать несколько секций, с одинаковым содержимым, но раскрашенные в разные цвета и при построении таблицы выводить нужные секции (с нужной раскраской)
ZUBR,
02.09.19, 10:39 Как создать отчет с суммой по отдельной позиции табличной части расходных накладных в 1С 7.70.003 торговля склад для Украины
Конечно запросом, что тут думать?! Запрос по документам за период с отбором по номенклатуре, отбор нужно делать по элементу справочника, а не по названию. Если покажете структуру документа, могу подсказать пример запроса smile.gif
ZUBR,
07.08.19, 13:06 Загрузка курсов валют НБУ для 1с 8
Цитата(Lyti @ 06.08.19, 16:55) *
Нажаль, доступа до модуля обробки немає

Доречі, отримати курси з сайта НБУ дуже просто, якщо трохи програмуєте в 1С, то зробіть самі smile.gif
Все що потрібно - зробити запит на адресу https://bank.gov.ua/NBUStatService/v1/statd...190807&json
Замість 20190807 вставляємо потрібну дату. У відповідь приходить JSON з масивом даних по валютах. Залишається тільки перебрати масив з отбором по нужних валютах.

Все просто smile.gif
Badger1C,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 29.05.20, 21:42
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!