Версия для печати темы (https://pro1c.org.ua/index.php?s=a301bf79968b44482e0271c0983590d3&showtopic=56857)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 7.7 _ Расшифровка - из отчета в табличную часть документа

Автор: DiMart 05.02.20, 10:58

Отчет формирует список документов по конкретному товару. При двойном нажатии мыши на ячейке отчета с конкретным документом - последний открывается. Вопрос: как сделать так, чтобы активировалась строка табличной части открытого документа с выбранным в отчете товаре?

Автор: sava1 05.02.20, 11:44

самому прописать обработку расшифровки

Автор: DiMart 05.02.20, 12:13

sava1 @ Сегодня, 11:44 * ,
Обработка прописана, документ открывается. Цель: нужно, чтобы в открытом документе активизировалась строка в табличной части с выбранным товаром

Автор: CobraS 05.02.20, 12:46

DiMart @ Сегодня, 12:13 * ,
1. Передать ссылку на товар через параметр в форму документа.
2. В процедуре ПриОткрытии() написать активизацию строки с переданным товаром.

Автор: denis84 05.02.20, 13:04

DiMart,

Что типа такого:
Процедура ОбработкаЯчейкиТаблицы(ЗначЯч, Флаг, ТекТаб, Адрес)
//--- переход на форму док -------------
Если ЗначЯч = "НомерДок" Тогда
Если ДокПП.НайтиПоНомеру(СокрЛП(ТабОтч.Область(Адрес).Текст), ДатаДок) = 1 Тогда
ОткрытьФорму(ДокПП.ТекущийДокумент());
///а тут уже обрабоатывать чере активизироватьстроку с переметром номенклатуры

Иначе
Предупреждение("Док с номером "+СокрЛП(ТабОтч.Область(Адрес).Текст)+" не найдено!");
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Автор: anatol1c 06.02.20, 19:07

Цитата(denis84 @ 05.02.20, 13:04) *
///а тут уже обрабоатывать чере активизироватьстроку с переметром номенклатуры

В процедуре ПриОткрытии:
Если ТипЗначенияСтр(Форма.Параметр) = "Число" Тогда  
        Если Число(Форма.Параметр) > 0 Тогда  
             АктивизироватьСтроку(Число(Форма.Параметр));
        КонецЕсли;
    КонецЕсли;

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua