Версия для печати темы (https://pro1c.org.ua/index.php?s=7be580aa540aa7e25816c43fa50fdf22&showtopic=57030)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Перезапонение выбранных документов

Автор: Constantus 13.02.20, 10:48

Приветствую, Форумчане!
1с8.3.12, самопис, УФ

Имеется некий документ. На форме документа имеется кнопка, которая заполняет табличную часть кодом

  ДокументОбъект = РеквизитФормыВЗначение("Объект");
    ДокументОбъект.ЗаполнитьЦены();
    ЗначениеВРеквизитФормы(ДокументОбъект, "Объект");
    
    Модифицированность = Истина;


ЗаполнитьЦены(); - заполняет ТЧ ценами и т.д.

Теперь в форме списка нужно расположить некую кнопку, которая этим же кодом перезаполняет ТЧ несколько выбранных документов.
Поставил кнопку на список с кодом:

&НаКлиенте
Процедура ПерезаполнитьЦены(Команда)
    
    ВыделенныеСтроки = Элементы.Список.ВыделенныеСтроки;
    ИзменитьЦены(ВыделенныеСтроки);    
    
КонецПроцедуры


&НаСервере //БезКонтекста
Процедура ИзменитьЦены(ВыделенныеСтроки);
    
       Для Каждого Строка Из ВыделенныеСтроки Цикл
                Об = Строка.ПолучитьОбъект();
        Об.ТабличнаяЧасть.Очистить();
    
        Сообщить(Объект.Ссылка);
            
    КонецЦикла;
    
КонецПроцедуры




Никак не могу сообразить как правильно, а главное оптимально в этот код установить срабатывание кода в модуле объекта

Процедура ЗаполнитьЦены() Экспорт


Посоветуйте...

Автор: sava1 13.02.20, 11:49

в модуле менеджера прописать процедуру заполнения

в форме списка

Для каждого строка из список.Выделенныестроки цикл
     док = строка.ссылка;
     документы.НекийДокумент.ЗаполнитьЦены(док);
Конеццикла

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
https://pro1c.org.ua