Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )



История благодарностей участнику gvatgor ::: Спасибо сказали: 5 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
07.07.21, 11:03 Загрузка курсов валют в конфигуации 7.7, 8.1 malexmen,
07.07.21, 10:48 Загрузка курсов валют НБУ XML для 1с 7.7
По быстрому дописал в обработку возможность загрузки курсов за период.
Alex729, aseriy, Vofka,
14.01.16, 16:33 Товаро-транспортна накладна для 7.7
XBrut @ 18.01.14, 17:43 *,

У меня работае в таком варианте, иначе не заполняет количество, а из цены еще раз вычитает НДС.

Процедура Печать2014_2()
    Таб = СоздатьОбъект("Таблица");    
    Таб.ИсходнаяТаблица("2014-2");
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
        Номер         = НомерСтроки;
        Товар         = Товар;      
        Ед            = Единица;
        КвоМест        = Количество;
    //    Кво           = КвоМест;
        Код           = Код;          
        Цена=ЦенаСНДС;
        
        
    //    Если ПустоеЗначение(ТМЦ)=1 Тогда
    //        Цена=ЦенаСНДС;
    //    Иначе
    //        Цена= ЦенаСНДС/(1+ТМЦ.СтавкаНДС.Ставка.Получить(ДатаДок));
    //    КонецЕсли;    
        
        
        ПечДокумент = Док;
        Таб.ВывестиСекцию("Строка");
    КонецЦикла;




XBrut @ 18.01.14, 17:43 *,
Поправил ошибки, не печатало количество и еще раз вычитало НДС из цены.
Процедура Печать2014_2()
    Таб = СоздатьОбъект("Таблица");    
    Таб.ИсходнаяТаблица("2014-2");
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
        Номер         = НомерСтроки;
        Товар         = Товар;      
        Ед            = Единица;
        КвоМест        = Количество;
    //    Кво           = КвоМест;
        Код           = Код;          
        Цена=ЦенаСНДС;
        
        
    //    Если ПустоеЗначение(ТМЦ)=1 Тогда
    //        Цена=ЦенаСНДС;
    //    Иначе
    //        Цена= ЦенаСНДС/(1+ТМЦ.СтавкаНДС.Ставка.Получить(ДатаДок));
    //    КонецЕсли;    
        
        
        ПечДокумент = Док;
        Таб.ВывестиСекцию("Строка");
    КонецЦикла;
XBrut,

RSS Текстовая версия Сейчас: 24.09.21, 8:47
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!